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                                                                 INTRODUTION 

 

 
Introduction 
 
 
 
 
 
 
 
Using ZwCAD is part of an integrated documentation set that includes this manual and a 
comprehensive collection of help resources to give you the information you need to create 
drawings in ZwCAD®. 
 
This manual is organized into chapters that parallel how you work in ZwCAD, according to 
the tasks you might perform. The tasks are divided and organized into the following work-
focused chapters: 
 
Introduction: Chapter 1  An overview of the key features of ZwCAD plus basic concepts of 
computer aided design (CAD) as they apply to ZwCAD. 
 

Getting started: Chapter 2  Installing ZwCAD, starting and exiting ZwCAD, working with 
toolbars, and selecting commands. 
 

Working with drawings: Chapter 3  Opening and saving an existing drawing and starting a new 
drawing. Using drawing settings to establish paper size, scale factors, and text height. 
Working with colors in your drawings. Using drawing aids such as entity snaps, orthogonal 
mode and auto tracking to draw accurately. 
 

Creating entities: Chapters 4–5  Working with simple entities such as lines, circles, and arcs and 
with complex entities such as polygons, spline curves, planes, wipeouts, boundary hatches, 
and more. 
 
Viewing your drawing: Chapter 6  Moving around in the drawing, changing its magnification, 
creating multiple views, and saving arrangements of windows of the drawing. 
 
 
 
Topics in this chapter 

About ZwCAD and other CAD software .......................................................................2 
Comparing ZwCAD and CAD to manual drafting ..........................................................4 
Working with other data and programs ............................................................... 11 
Using advanced CAD features ..................................................................................13 
Getting more information.........................................................................................13 
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Working with coordinates: Chapter 7  Working with Cartesian coordinate systems, specifying 
two dimensional and three dimensional coordinates, and defining your own user coordinate 
systems. 
 

Working with the ZwCAD Explorer: Chapter 8  Using the ZwCAD Explorer to manage your 
drawings: controlling layers, linetypes, text styles, coordinate systems, views, and blocks and 
copying information between drawings. 
 
Getting drawing information: Chapter 9  Working with the additional information in ZwCAD 
drawings, calculating areas and distances, and displaying other drawing information. 
 

Modifying entities: Chapter 10  Selecting, copying, rearranging, resizing, and editing entities. 
 

Annotating and dimensioning your drawing: Chapters 11–12  Using text to annotate drawings; 
using dimensions to annotate the measurement of entities. 
 

Working with blocks, attributes, and external references: Chapter 13  Using blocks and external 
references to combine entities and data for reuse; creating attribute information to extract for 
use in other programs. 
 

Formatting and printing drawings: Chapter 14  Combining drawings into finished layouts, 
custommizing print options, and printing copies. 
 

Drawing in three dimensions: Chapter 15  Creating and editing three dimensional entities. And 
visualizing them using hidden line removal, shading, and photo realistic rendering. 
 

Working with other programs: Chapter 16  Sharing drawings and data with other users, docu-
ments, and programs. 
 

Customizing ZwCAD: Chapter 17  Customizing the appearance and operation of the program to 
suit your needs. 
 

Understanding AutoCAD compatibility: Appendix  Describes similarities and differences between 
ZwCAD and AutoCAD. 
 
 
 

About ZwCAD and other CAD software 

 
 
ZwCAD is designed for anyone who wants a fast and efficient CAD program with all the power 
and versatility of standard programs such as AutoCAD® by Autodesk®, Inc., or MicroStation® 

by Bentley Systems, Inc., at an affordable price. Using today’s advanced technology, ZwCAD 
integrates the Microsoft® Windows® interface with a powerful CAD engine. 
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ZwCAD provides unparalleled compatibility with AutoCAD, using most of the same file for-
mats including those for drawings (.dwg files), commands, linetypes, hatch patterns, and text 
styles. You can also use AutoCAD menu files and run Autodesk® AutoLISP®  programs. If 
you have written your own ADS (Autodesk® AutoCAD Development System®) programs, 
simply recompile them to link with the ZwCAD libraries. Many third party ADS programs 
already support ZwCAD. If you have a program that is not already supported, ask your soft-
ware vendor to provide a ZwCAD compatible version of the program. 
 
ZwCAD is more compatible with the AutoCAD program than any other CAD product, de-
livers additional tools with advanced CAD features, and has a seamless Microsoft®  Windows 
integration. This powerful program provides a superb combination of features for CAD users 
like architects, engineers, and designers. 
 
ZwCAD incorporates standard features found in other CAD programs, along with features and 
capabilities you won’t find anywhere else. Its multiple document interface (MDI) lets you 
open and work with several drawings at the same time. You can easily copy drawing entities 
between drawings. In addition, the powerful ZwCAD Explorer lets you manage information 
and settings and quickly copy layers, linetypes, and other information between drawings. 
 
Using AutoCAD legacy drawings 
ZwCAD fully supports AutoCAD legacy drawings. ZwCAD reads and writes DWG files in 
their native format without any loss of data, from AutoCAD 2006 back to Version 11, includ-
ing AutoCAD LT®. Because ZwCAD uses DWG as its native file format, no translation is 
required. 
 

ZwCAD provides you with the appropriate tools for your experience level— whether you are 
a beginner, intermediate, or advanced CAD user. If you are just starting out with CAD, you 
may want to use the beginner level, which provides toolbars containing the basic tools such as 
lines, arcs, and circles. As you become more experienced, you can move to the intermediate 
level and then to the advanced level, which gives you access to more than 300 commands 
through toolbars, menus, and keyboard entries. You can change the experience level in the 
Options dialog box on the Tools menu. 
 

ZwCAD supports three-dimensional wireframes and surfaces. Three dimensional drawings can 
be displayed in wireframe, hidden line view, and surface shading. Professional version of 
ZwCAD also support creating and editing 3D solids; Standard version display 3D solids, along 
with limited editing features. 
 

ZwCAD supports displaying and working with raster images in your drawings. However, 
ZwCAD does not display images located inside of blocks and externally referenced drawings 
(xrefs). When a drawing containing proxy entities is loaded into ZwCAD, a message displays 
indicating that some entities will not display, however, the entities reappear when you open the 
drawing later in AutoCAD. 
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It’s easy to customize ZwCAD. You can modify menus and toolbars, create custom menus, 
dialog boxes, command aliases, and scripts, and add custom programs written in any of several 
programming languages, including LISP (the program’s Autodesk®  AutoLISP compatible 
language) and SDS™ (Solutions Development System™, the program’s Autodesk® ADS-
compatible language). There is also Microsoft®  Visual Basic for Applications (VBA). 
 
You can run existing Autodesk®  AutoLISP applications in ZwCAD with little or no 
modification. ZwCAD uses the Appload command so you can easily load LISP programs. 
ZwCAD reads files that contain dialog control language (DCL) statements as well, which 
makes ZwCAD compatible with dialog boxes created for AutoCAD. 
 
Using AutoCAD commands with ZwCAD 
Because ZwCAD supports hundreds of AutoCAD commands, you use the commands you 
already know. For example, to draw a circle, use the Circle command. To copy a circle, use 
the Copy command. 
 

When you press Enter or the spacebar, you activate the command—just like in AutoCAD. 
ZwCAD accepts the special characters used by AutoCAD, such as point filters (for exam-
ple, .xy), relative coordinates (the @ symbol), and the apostrophe (the ‘ prefix) for transparent 
commands. ZwCAD function keys are also similar to those used in AutoCAD. 
 

Because you do not need to learn a new set of commands, you are immediately productive 
with ZwCAD. 
 
 
 

Comparing ZwCAD and CAD to manual drafting 

 
 
ZwCAD greatly reduces the time and effort it takes to create and revise drawings. Not only 
can you produce accurate drawings faster, you can also reuse the information in your drawings. 
These are the primary reasons for making the transition to CAD from traditional, manual 
drafting on paper. 
 
As with any tool, however, to use it effectively, you need to be familiar with some of the 
special features, functions, and concepts of CAD. If you are familiar with manual drafting, 
you’ll find some conceptual similarities in CAD as well as some differences. 
 
Drawing to scale   
In traditional, manual drafting, you usually determine the scale of the drawing before you even 
start to draw, because you are working with a sheet of paper of a fixed size. You may have to 
reduce or enlarge the entity you are drawing to fit within the confines of the paper. 
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When you create a drawing in ZwCAD, you draw everything full size. You determine the type 
of units in which your drawing is measured. If you are drawing a building, 1 drawing unit 
might equal 1 inch. If you are drawing a map, 1 drawing unit might equal 1 mile. Your draw-
ing environment and the CAD drawing file itself are not limited to the size of a particular 
sheet of paper. 
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1 drawing unit equals 1 inch. 1 drawing unit equals 1 foot. 
 
As you draw, you can use commands such as Pan and Zoom to work on different part of the 
drawing and to magnify the display of the drawing to view small details. These commands 
have no effect on the actual size of the entities in your drawing; they affect only the way the 
drawing is displayed on your screen. Only when you print or plot your drawing do you need to 
set the scale so that the printed drawing fits within a specific paper size. 
 
Using tools 
In manual drafting, you use tools such as pencils, rulers, T squares, templates, erasers, and so 
on. When you create a drawing in ZwCAD, you use a mouse instead of a pencil, and you use 
the mouse to select other tools—commands you select from a menu or a toolbar. 
 

You use some tools to create basic entities, such as lines, circles, and arcs, and other tools to 
modify existing entities (for example, to copy or move them or to change properties such as 
color and linetype).
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Organizing information 
In traditional drafting, you often separate elements such as walls, dimensions, structural steel 
members, and electrical plans onto separate, translucent overlays. When you want to print the 
working drawings, you can create several different drawings by combining different overlays. 
 

When you create a drawing in ZwCAD, you use layers to organize elements in a similar man-
ner. However, the layers feature in CAD offers numerous advantages over physical trans-
parencies. The number of overlays you can combine to print a manually drafted drawing is 
limited by the printing process. There is no such limitation in CAD. With ZwCAD, you can 
define an unlimited number of layers, any of which can be visible or invisible at any time. 
You can name each layer and assign each its own color, linetype, lineweight, and print style. 
You can also lock individual layers to ensure that information on those layers isn’t altered 
accidentally. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Use layers to organize drawing information. 
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Drawing accurately 
When you create a manual drawing, ensuring accuracy typically requires a lot of manual cal-
culations and rechecking. By contrast, ZwCAD offers a number of drawing aids that ensure 
accuracy from the start. For example, you create and modify entities based on an underlying 
Cartesian coordinate system. Every location in the drawing has its own x,y,z coordinates. You 
can also display a grid as a visual reference to your coordinate system. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Every location in the drawing has its own x,y,z-coordinates within the underlying Cartesian coordinate system. Point 
5,2,0 is 5 units to the right (along the x axis), 2 units up (along the y axis), and 0 units (alongthe z axis) from the origin 
(the 0,0,0 point). 

 
Settings such as snap and entity snap allow you to draw accurately without specifying coordi-
nates. The snap setting forces the selected points to adhere to the grid increment or to any other 
increment you set. Entity snaps let you snap to precise geometric points on existing entities—
for example, the endpoint of a line or the center of a circle. Another setting, or thogonal, con-
strains lines so that they are drawn parallel to the vertical and horizontal axes. Polar tracking 
and object snap tracking help you draw objects at specific angles or in specific relationships to 
other objects. When you turn on polar tracking and object snap tracking, temporary alignment paths 
help you create objects at precise positions and angles. You will discover techniques that make 
specific design tasks easier. 
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Paper based drawings lack the high degree of accuracy possible when using CAD. Lines often overlap or fail to meet 
adjacent lines. 

 
 
 
 
 
 
 
 
 
 
 
 
 
Snap and entity snap force the cursor to adhere to a specified increment or attach to key geometric points on existing 
entities. You can also constrain lines to vertical and horizontal axes. 
 
Drawing efficiently 
In paper based, manual drafting, you often have to redraw the same entity several times at 
different scales or from different vantage points. You may also need to redraw the border and 
title block on each new sheet. 
 

One of the most powerful features of ZwCAD is that when you create a drawing, you can 
reuse individual entities, borders, and title blocks as often as you want. You need draw an 
entity only once; the final printed drawing can show the entity at several different scales and 
viewpoints. 
 

You usually begin drawing in model space on the Model tab, creating the drawing (a floor plan, 
a map, or a three dimensional part) without regard to the final layout on paper. When you are 
ready to print your drawing, you have the option to switch to paper space on a Layout tab, 
where you lay out the drawing as you want it to appear on a sheet of paper. For example, you 
can insert a drawing file that contains the standard border and title block that you created. You 
can define and arrange multiple views of the drawing at appropriate scales and with specific 
portions visible or invisible—again, without having to redraw the border and title block for 
each view. 
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You create the basic drawing in model space on the Model tab. 
 

 
 
When you’re ready to print or plot your drawing, you can switch to paper space on a Layout tab, where you provide a 
layout of the drawing as you want it to appear on a sheet of paper. 
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Reusing CAD drawings and entities 
When you create a paper drawing manually, you can draw repetitive symbols by tracing a 
plastic template. After you draw a symbol in ZwCAD, you can reuse that symbol without 
having to redraw it. You simply save the symbol as a block. You can then insert copies of that 
block anywhere in your drawing. You can also save the symbol as a separate drawing for use 
in other drawings. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
You can draw a symbol one time, save it as a block, and then insert multiple copies of that symbol anywhere in your 
drawing. 
 
In addition, you can reuse entire drawings and insert individual drawings into other drawings. 
You can also use an external reference, which acts as a pointer to another drawing rather than 
a copy of the entire drawing. Using an external reference has an added advantage: when you 
update the externally referenced drawing, each drawing that references it can be automatically 
updated. 
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Making changes 
To make changes to a paper drawing, you erase and then redraw. With ZwCAD, you use 
commands to modify entities in the drawing. You can move, rotate, stretch, or change the 
scale of entities. When you want to remove an entity, you can delete it with a single click 
of the mouse. If you make a mistake while creating or modifying your drawing, you can 
easily reverse your actions. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
You can easily change an entity using commands such as move, rotate, stretch, and scale instead of redrawing the 
entity. 
 

Working with other data and programs 

Traditional paper drawings serve only as a means of communicating information between the 
person who created the drawing and the person viewing the drawing. The drawings contain no 
more information than what is visually imparted by the creator and seen by the viewer. 
 

ZwCAD offers rich possibilities for analyzing drawings and attaching additional data to them. 
For instance, although it may be impractical to count entities in a complex paper drawing, this 
task is simple in CAD. ZwCAD can calculate the number of entities in a drawing and compute 
area and distance. 
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CAD drawings can also contain information in addition to visible entities. You can attach 
invisible database information to visible drawing entities and extract the information for 
analysis in a database or spreadsheet. (Working with information in a data base requires a 
program from a third party vendor, or you can create your own means of exporting the data in 
LISP or SDS. Or, you can also use VBA.) 
 

 
 
You can extract information stored in the drawing as …and use that data for analysis in a 

database or spreadsheet. visible or invisible attributes… 
. 

 
ZwCAD provides in-place editing of Microsoft® objects, such as those created in Microsoft® 

Word and Microsoft® Excel software programs. In place editing makes it easy to share data 
with other users and programs. For example, you can include ZwCAD drawings in files 
created using Microsoft® Word, and you can insert files created using Microsoft® Word into 
your ZwCAD drawings. 
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Using advanced CAD features 

 
In addition to being compatible with AutoCAD, ZwCAD goes several steps further by pro-
viding you with innovative features to increase your productivity. 
 
Using the ZwCAD Explorer 
The ZwCAD Explorer has an interface similar to the Windows Explorer, allowing you to view 
and manage the elements of multiple, open drawings, such as layers, blocks, linetypes, views, 
user coordinate systems, and text styles. 
 
Editing multiple documents simultaneously 
With ZwCAD, you can open and edit multiple drawings simultaneously. You can also copy 
and paste elements between open drawings. 
 
Editing multiple entities 
ZwCAD allows you to change most of the properties of all selected entities using a single, 
tabbed dialog box. 
 
Using the Customize dialog box 
ZwCAD has a single, tabbed dialog box for changing toolbars, menus, keyboard shortcuts, 
and command aliases. You can also use the drag and drop method to customize toolbars, 
including flyouts. The simple, point and click action lets you easily create new menu items 
and keyboard shortcuts—no programming or manual text editing required. 
 
Performing unlimited undo and redo 
ZwCAD increases your power with unlimited undo and redo of editing actions. 
 
 
 

Getting more information 

 
 
In addition to the ZwCAD documentation, much of the assistance you need as you use ZwCAD 
is specific to the commands you work with on the screen. To obtain immediate information as 
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you work, use these additional sources of information: 
 
Status bar To find out more detailed information about a tool when you pause the cursor over it, 
look on the status bar at the bottom of the screen. 
Online help ZwCAD online help is available on the screen when you press F1, choose a com-
mand from the Help menu, or click the question mark in a dialog box. The online help also 
presents information that does not appear in this manual, including a programming reference 
that describes how to program in LISP and SDS. The programming reference also describes 
programming in VBA. 
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Getting started 
 

 
 
 
 
This section helps you get started using ZwCAD software by explaining how to install it and 
providing basic information about how to use it. 
 

 
NOTE This guide assumes that you have used other Windows based programs and are 
familiar with Windows terminology and techniques. 
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System requirements 

You need the following software and hardware to install and run ZwCAD: 
 

•   Microsoft®Windows 98/Me/Nt, Windows 2000, or Windows XP 

•   Intel® Pentium (or faster) processor 

•   64 megabytes (MB) of RAM (minimum); 256 MB of RAM or more (recommended) 

•   150 MB of free hard disk space for a full installation, including sample files, electronic 
documentation, and online Help 

•   Super VGA (800x600) or higher resolution, video adapter, and monitor 

•   Mouse, or other pointing device 

•   CD-ROM drive for installation, if installing from a CD 
 
 
 

Installing ZwCAD 

A setup program guides you through the ZwCAD installation process. The program transfers 
files to a folder that it creates on your hard disk. The program also creates a menu item on the 
Start menu. 
 
 
To install ZwCAD from a compact disc 

1. Insert the ZwCAD compact disc into your CD ROM drive. 
2. Double click the installation file in the CD, Standard Edition or Professional Edition. 
3. Follow the instructions on your screen. 
 
 
NOTE If you did not receive an ZwCAD compact disc, for example, if you downloaded 
the program from the Internet, follow the instructions that came with the program. 
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Starting ZwCAD 

To start ZwCAD, choose Start > Programs > ZwCAD 2006 > ZwCAD 2006 (may vary, 
depending on your operating system). 
 
When you start ZwCAD, there are three options for choosing to draw. You can start from 
scratch using default settings, you can start from a template file with a preset environ-
ment, or you can use a wizard to step you through the process, in each case, you can 
choose the conventions and defaults you want to use. 
 
I. Start a Drawing from Scratch 
 
A quick way to begin a new drawing is to start from scratch, which starts a drawing 
that uses settings from a default drawing template file. 
                      
When you use Start from Scratch, you can specify either imperial or metric units for 
the new drawing. The setting you select determines default values used for many 
system variables controlling text, dimensions, grid, snap, and the default linetype and 
hatch pattern file. 
 
• Imperial: Creates a new drawing based on the imperial measurement system. The 
drawing uses internal default values, and the default grid display boundary, called the 
grid limits, is 12*9 inches. 
• Metric: Creates a new drawing based on the metric measurement system. The 
drawing uses internal default values, and the default grid display boundary is 429*297 
millimeters. 
 
To start a drawing from scratch with the Create Drawing dialog box 
1   On the File menu, click New. 
2   In the Create New Drawing dialog box, click Start from Scratch. 
3   Under Default Settings, click either Imperial or Metric. 

Standard toolbar   
Command line     NEW 
 
 
II. Use a Default Drawing Template File 
 
A drawing template file contains standard settings. Select one of the template files 
supplied, or create your own template files. Drawing template files have a .dwt file 
extension. 
 
When you create a new drawing based on an existing template file and make changes, 
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the changes in the new drawing do not affect the template file. You can use one of the 
template files supplied with ZwCAD, or you can create your own template files. 
 
To start a drawing by selecting a template file 
1   On the File menu, click New. 
2   In the Select Template dialog box, select a template from the list and click Open. 
ZwCAD opens the drawing as drawing1.dwg. The default drawing name changes to 
reflect the number of new drawings that have been opened. For example, if you open 
another drawing from a template, the default drawing name is drawing2.dwg. If you 
want to start a new drawing with no template file, click the arrow next to the Open 
button and then click one of the “no template” options from the list. 

Standard toolbar   
Command line     NEW 
 
 
III. Use a Setup Wizard 
 
A setup wizard establishes basic drawing settings step by step. You have two wizard 
options to help you set up a drawing: 
 
• Quick Setup Wizard: Sets units of measurement, precision of displayed units, and 
grid limits. 
• Advanced Setup Wizard: Sets units of measurement, precision of displayed units, 
and grid limits. Also establishes angle settings such as units of measurement style, 
precision, direction, and orientation. 
 
To begin a new drawing using a wizard 
 
1   On the File menu, click New. 
2   In the Create New Drawing dialog box, click Use a Wizard. 
3   Click Quick Setup or Advanced Setup. 
4   Complete the wizard pages using the Next and Back buttons to move forward and 

backward. 
5   On the last page, click Finish. 

Standard toolbar   
Command line     NEW 
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Working in ZwCAD 

You can work with the ZwCAD window and its elements in a variety of ways. For example, 
you can display and rearrange the toolbars, display the command bar, and enable the status bar. 
The toolbars and command bar can also be floated anywhere on the screen or docked to the 
edges of the main ZwCAD window. 
 

A 

B 

D 
F 

F 

C 
G 

H 

I 
A  You can customize the menu bar at the top of the 
window. 
B  You can customize the toolbars, changing the 
appearance and arrangement of tools and adding your 
own commands and macros. 
C  Your drawings are displayed in the drawing window. 
D  The user coordinate system (UCS) icon indicates the 
orientation of the drawing in two dimensional space 
(default setting). 
E  Click a tab to switch between the drawing of your 

model and a printed layout. 
F  You can type commands in the command bar. To 
reposition the command bar, drag it to another location 
on your screen. 
G  You can move and dock the toolbars to any location 
on your screen. 
H  Specialty editor. You can modify the value you 
wanted in each column. 
I  The status bar displays information such as the   
current cursor coordinates, and mode settings.
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Displaying commands on a shortcut menu 
Shortcut menus provide quick access to specific commands. A shortcut menu displays when 
you right click an object, toolbar, status bar, the Model tab name, or a Layout tab name. The 
selections presented in the shortcut menu depend on what you clicked. 
 

When you right click a toolbar, the program displays a shortcut menu that lets you toggle the 
command bar, status bar, and various toolbars on and off. If you select one or more objects 
and then right click, the program displays a shortcut menu from which you can choose a 
command to modify the selected objects. To display a short cut menu from which you can 
choose an object snap, press and hold down the Shift key, and then right click anywhere 
within the drawing window. 
 
Displaying and hiding toolbars 
When you start ZwCAD the first time, multiple toolbars are displayed. ZwCAD provides more 
than a dozen toolbars, which you can customize by adding and deleting tools. You can also 
move and resize toolbars, and you can create new toolbars. You can use a shortcut menu to 
display or hide toolbars. 
 
You can also choose whether toolbars are displayed large or small and in color. You can 
choose to display or hide ToolTips, which provide descriptions of tools that display when you 
pause the cursor over them. Go to View > Toolbars to make these selections. 
 

Toolbars are either docked or floating. A floating toolbar has a title bar and a Close box, can 
be located anywhere on the screen, and can be resized. A docked toolbar does not display a 
title or Close box, cannot be resized, and is attached along one of the edges of the drawing 
window. 

•   To dock a toolbar, drag it to the perimeter of your drawing; to undock it, drag it away 
from the perimeter. 

•   To position a toolbar in a docking area without docking it, press Ctrl while you drag it. 

•   To move a toolbar, drag it to a new location. 

•   To resize a toolbar, move your cursor to the edge until it changes to a resize arrow, and 
then drag. 
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To choose which toolbars to display 
1   Choose View > Toolbars. 
2   In the Select Toolbars dialog box, choose the toolbars you want displayed, and then click 

OK. 
 

 
 
Select the check boxes for the toolbars you want to display. 
 
 
TIP Right click anywhere on a docked toolbar to display the toolbar shortcut menu, and  
then choose Toolbars. You can also select the toolbars you want displayed directly on  
the shortcut menu. 
 
 
 
 
 
 
Using the command bar 
The command bar is a dockable window in which you type ZwCAD commands and view 
prompts and other program messages. To display the command bar, choose View >Display> 
Command Bar. The command bar displays the three most recent lines of prompts. You can 
move the command bar by dragging it. 
 

When the command bar is floating, you can drag the top or bottom of the window to change 
the number of lines of text it displays. You can dock the command bar at the top or bottom of 
the drawing. 
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Using the status bar 
If you elect not to use the command bar, the status bar displays information about the selected 
command or tool. It also displays the current cursor coordinates, mode settings, and other 
information about current settings. 
 

In addition to displaying information, the status bar is a quick way to access many features. 
You can click status bar items to make changes, and right click items to display short cut 
menus that allow you more choices. 
 

                                        
 

 

F A J I HB C D E G

 
A  Cursor coordinates (x,y,z). H  Lineweight display. Left click to 

toggle on or off. B  Snap setting. Left click to toggle on or off. 
C  Grid setting. Left click to toggle on or off. I  Model space or paper space. Left 

click to toggle   between model space 
and paper space. 

D  Orthogonal setting. Left click to toggle on or off 
E  Polar tracking. Left click to change colors. 

J  Digitizer mode. Left click to toggle 
on or off. F  Object snap setting. Left click to select object snaps. 

G  Object snap tracking. Left click to toggle on or off.  
  
To change the items that display on the status bar 
1   Right click an empty area of the status bar. 

2   Select an item to add or remove it. 
 
 
To change the setting of an item on the status bar 
Right click the status bar item you want to change, and then select the desired setting. 
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To display or hide the status bar 
Choose View >Display> Status Bar. 
Command line   STATBAR 
 
 
Using prompt boxes 
ZwCAD commands often provide several options. These options appear in the status bar or 
command bar and also in a prompt box (called a context menu in AutoCAD) initially dis-
played in the upper right corner of the screen. You can move the prompt box by dragging it; 
future prompt boxes will appear where you last placed it. The options appear as menu selec-
tions. Choose the appropriate option by selecting it in the prompt box. To close a prompt box, 
click the Close box. 

 
 
 
 
 
 
 
 
 
 
 

 
Command options appear in a prompt box. 
 
The prompt box is closed by default. To turn on the display of prompt boxes, choose Tools > 
Options, click the Display tab, and then click the Display screen menu check box to clear it. 
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The ZwCAD user interface. 
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Selecting commands 

Select commands using any of these methods: 
 

•   Choose a command from a menu. 

•   Click a tool in a toolbar. 

•   Type the command in the command bar. 
 
Some commands remain active until you end them, so you can repeat an action without having 
to select a command repeatedly. You can end a command by pressing Enter, or by right-
clicking to choose Enter menu.  
 
Using commands 
You can use most commands while another command is active. For example, while drawing a 
line, you may want to use the Pan command to move the drawing across the screen to select 
the endpoint of the line. You can also change the settings of drawing aids such as snap or grid 
while other commands are active. 
 
Starting commands using toolbars 
To start a command from a toolbar, click a tool and respond to the prompts. 
 
 
NOTE  The available toolbars depend on the experience level that is set. To change 
the current experience level, choose Tools > Options, and then click the Open and  
Save tab. 
 

 
Some tools, such as Line or Arc, contain flyouts, which are options either for using the 
basic tool with different methods or that contain other, related tools. Flyouts are 
indicated by a small triangle in the lower right corner of a tool. To display a flyout, click 
the tool and hold down the mouse button. To select a tool from a flyout, point to the tool 
you want and then release the mouse button. The tool you select on the flyout 
becomes the default tool on the toolbar. 
 
Starting commands using menus 
To start a command from a menu, choose it from the list of menu options available. 
 
The available menu options depend on the experience level that is set. To change the current 
experience level, choose Tools > Options, and then click the General tab. 
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Starting commands using the command bar 
Type a command, and then press Enter. If the command bar is displayed, the command you 
typed appears there. If the command bar is not displayed, the command you typed appears in 
the status bar. 
 

 
TIP Quickly start commands using the command bar by copying, cutting, and pasting text. 
In the command bar or Prompt History window, right click to select various cut, copy, and 
paste commands. 
 
Repeating a command 
You can repeat a command you used previously without having to reselect it. 
 
To repeat the command you just used 

1   Do one of the following: 

•   Press the spacebar. 

•   Press Enter. 

•   Click the right mouse button in the drawing. 
 
To repeat commands you used previously 

1   Do one of the following: 

•   In the command bar or Prompt History window, press Ctrl and double click the previous 
command text. 

•   In the command bar or Prompt History window, right click, choose Recent Commands, 
and then choose the desired command. 

•   Press Ctrl + K, repeat until you get back to the desired command, and then press Enter. 
Press Ctrl + L to move forward to the desired command, and then press Enter. 

•   Use the Up and Down arrows to display previously used commands, if Use Up/ Down 
Arrows for Command History Navigation is selected in Tools > Options. 

 
TIP  If you are using the command bar to type commands, you can type multiple before 
starting some commands (Circle, Arc, and Rectangle, for example) to repeat a command 
indefinitely. When you are done with a command, press Esc. 
 
Nesting a command 
If you are working in the command bar, you can use another command from within a com-
mand, called nesting. To use a command inside an active command, type an apostrophe before 
you type the command, such as ‘circle, ‘line, or ‘pyramid. You can nest commands indefinitely 
in ZwCAD. Many menu and toolbar macros work this way by default; for example, select 
color, reference grid, zoom, and snap. When you have finished with the nested command, the 
original command resumes. 
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Modifying a command 
If you are working in the command bar, there are special ways that you can modify a 
command as you work. You can modify the active command using any of the following 
options: 

•   Object snaps — Type an object snap command, such as nearest or midpoint, to enable a 
one time object snap for a single selection. You can also use a one time object snap to 
override a running object snap. 

•   Extension snaps — Type int after selecting a command, such as Line or Circle, to enable 
a one-time snap to the logical location where two objects would intersect if they were of 
infinite length. Type app to enable a similar one time snap if the extensions would not 
intersect in three dimensional space but would intersect in the current view. 

•   Midpoint snaps — Type m2p or mtp to enable a one time snap to the midpoint of two 
points that you specify. 

 
Using the Prompt History window 
The Prompt History window displays a history of the commands and prompts issued since you 
started the current session of ZwCAD. By default, the program tracks up to 256 command lines. 
There is no limit to the number of command lines you can track, but program performance 
may be degraded if you choose to track an excessively high number of lines. 
 
To display or close the Prompt History window 

•   Press F2. 
 
To view entries in the Prompt History window 

1   Do one of the following: 

•   Use the scroll bars. 

•   Press Ctrl + K to browse backward; press Ctrl + L to browse forward. 

•   Use the Up and Down arrows to display previously used commands, if Use Up/ Down 
Arrows for Command History Navigation is selected in Tools > Options. 

 
To copy or paste text in the Prompt History window 

1   If copying text, do one of the following: 

•   Highlight text using your mouse. 

•   Press Ctrl + Shift + arrow keys to highlight text. 
 

2   Right-click and choose whether to copy or paste. 
 
TIP  You can also copy the entire command history by choosing Copy History or copy the 
 last command line by choosing Copy Last Line. 
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To change the number of command lines to track 
1   Choose Tools > Options, and then click the Display tab. 
 

2   In the Command Lines To Track field, type the number of command lines you want to 
display, and then click OK. 

Command line   OPTION 
 
Using mouse shortcuts 
You can use your mouse, often combined with the keyboard, to start commands and perform 
other actions. 

 
Mouse shortcuts  
Shortcut Action 

Ctrl + Shift + Hold and drag left mouse button Real Time Sphere command 
 

Ctrl + Shift + Hold and drag right mouse button Real Time Z command 
 

Ctrl + Hold and drag left mouse button Real Time Zoom command 
 

Ctrl + Hold and drag right mouse button Real Time Pan command 
 

 
 
Using scripts 
The ZwCAD Script Recorder captures and saves many of your actions so you can play them 
back. After you enable the Script Recorder, all commands and options that you type in the 
command bar are recorded until you type a command to stop recording. When you run the 
script, the program carries out the recorded commands in succession. 
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Correcting mistakes 

 
ZwCAD tracks the commands you use and the changes you make. If you change your mind or 
make a mistake, you can undo, or reverse, the last action or several previous actions. You can 
also redo any actions that you reversed. 

 
  B A 
 
 
 
 

A  Click the Undo tool to reverse the last action. 
B  Click the Redo tool to reverse the previous undos.  
You can undo multiple actions by typing undo and specifying the number of actions to undo. 
 
 
 

Customizing ZwCAD 

 
You can tailor many aspects of ZwCAD to better suit your needs. For example, you can easily 
create and modify toolbars by simply dragging and dropping icons. If you want to restore any 
area of the user interface back to its default state, click Reset. ZwCAD stores your customized 
settings in the Windows registry; you can also store them in a separate file, called a profile. 
 
ZwCAD supports the most important AutoCAD customization files, including linetypes, hatch 
patterns, text fonts, the unit conversion file, menus, toolbars, and aliases. In addition, ZwCAD 
unifies four AutoCAD customization functions with a single customize command: command 
aliases, keyboard shortcuts, menus, and toolbars. 
 
You can also add custom programs written in any of several programming languages, including 
the following: 

•   LISP (the program’s Autodesk® AutoLISP compatible language) 

•   SDS (the program’s Autodesk® ADS compatible language) 

•   Microsoft® Visual Basic for Applications (VBA) 
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Getting online Help 

ZwCAD includes online Help, which contains task-oriented topics, a command reference, a 
system variables reference, and a programming language reference. You can display online 
Help in any of these ways: 
 
 
 
• Choose a command from the Help menu. 

• Click the question mark in a dialog box. 

• Type help in the command bar. 
 
 

Saving your drawing 

You can save your drawing at any time. 
 
To save a drawing, use one of the following methods: 
 

Choose File > Save.   

Standard toolbar   
Command line     SAVE 

 
TIP When you save a drawing the first time, the program displays the Save Drawing  
As dialog box so that you can choose a directory and type a name for the drawing. To  
save the drawing later using another name, choose File > Save As and type the new 
name. 
 
 

Exiting ZwCAD 

When you have finished working in ZwCAD, choose File > Exit. 
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Working with drawings 
 

 
 
 
 
 
CAD drawings help you organize information for greater efficiency. With ZwCAD, you can 
draw entities representing different types of information on various layers and use those layers 
to control color, linetype, and visibility. ZwCAD also includes drawing aids that help you 
draw accurately. 
 

This section explains setting up drawings and using built-in drawing aids, including how to: 

•   Create new drawings, open existing drawings, and save changes to drawings. 

•   Use aids such as the grid, snap, polar tracking, and orthogonal settings to draw accurately. 
                              
 
 
 
 
 
 
 
 
 
Topics in this chapter 
 

Creating a new drawing ...........................................................................................32 
Opening a drawing ..................................................................................................32 
Setting up a drawing ................................................................................................34 
Working with colors ................................................................................................42 
Setting and changing the grid and snap alignment ...........................................................46 
Using the Draw Orthogonal option..............................................................................50 
Using Object snaps ..................................................................................................51 
Use Polar Tracking and PolarSnap ..............................................................................58 
Saving your drawing ................................................................................................60 
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Creating a new drawing 
 
When you start ZwCAD, there are three options for choosing to draw.You can start from scratch 
using default settings, you can start from a template file with a preset environment, or 
you can use a wizard to step you through the process, in each case, you can choose 
the conventions and defaults you want to use. 
For more details about creating a new drawing, see “Starting ZwCAD” on page 17. 
                              
 
 

Opening a drawing 

You can open drawing (.dwg) files, Drawing Exchange Format (.dxf) files, Design Web 
Format™ (.dwf) files, and drawing template (.dwt) files. 
 
You can also open and check drawings that you suspect are damaged. 
 
Opening an existing drawing 
You can open any of these drawing files: 
 

•   Standard drawing files with a .dwg extension. 

In addition to your own drawing files, you can open and use one of the sample drawings 
that are included with ZwCAD. 

•   Drawing Exchange Format files with a .dxf file extension. 

•   Design Web Format files with a .dwf file extension. 

•   Drawing templates with a .dwt file extension. 
 
 
To open an existing drawing 

1   Choose File > Open.    
 

2   In Files of Type, choose the type of file you want to open. 

3   Choose the folder containing the desired file. 

4   Do one of the following: 

•   Choose the drawing you want to open, and then click Open. 

•   Double click the drawing you want to open. 
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If the drawing requires a password, enter the password, click OK to verify the password, and 
then click Open again. 

Standard toolbar   
Command line     OPEN 
 
 
TIP You can also open drawings while browsing files on your computer using pro- 
grams that came with your operating system, such as Windows File Explorer or My 
Computer. Simply double click the file to open it in ZwCAD. Easily find the draw- 
ing you want by viewing thumbnail images of the drawing files as you browse them. 
 
 
 

A 

B 

C 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

A  Defines how drawings display in the list, including file details and thumbnail images. 
B  If a thumbnail image exists in the selected drawing, displays an image of the drawing before you open it. 
C  Opens the drawing, and you can click to open as read only menu to prevent making changes to the file. 

 
 
TIP To quickly open a drawing file that you recently used, choose File > <file name>. 
The program tracks the last four drawings. 
 
 
 
Opening damaged files 
Files can become damaged for many reasons. For example, if you are working on a drawing 
during a power outage, a system crash, or a hardware failure, your drawing file may become 
damaged. ZwCAD allows you to open and check damaged files to attempt file recovery. 
 

 33 



CHAPTER 3 

Recovering a file attempts to open one of the following file types: 
 

•   Standard drawing files with a .dwg extension. 

•   Drawing Exchange Format files with a .dxf file extension. 

•   Design Web Format files with a .dwf file extension. 

•   Drawing templates with a .dwt file extension. 
 
You can also audit any open file to check it for errors. You specify whether you want ZwCAD 
to fix any errors that are found automatically. ZwCAD fixes as many errors as possible and 
any errors that cannot be fixed are reported as “Ignored” in the Prompt History window. 
 
 
 
To open a damaged file 

1   Choose File > Drawing Utilities>Recover.    
 

2   In Files of Type, choose the type of file you want to recover. 

3   Choose the directory containing the damaged file. 

4   Choose the damaged file you want to recover. 

5   Click Open. 

Command line   RECOVER 
 
 
 
To check a drawing file for errors 

1. With the drawing open that you want to check, choose File > Drawing Utilities > Audit. 
 

2. Choose whether you want ZwCAD to fix any found errors automatically, and then press 
Enter. 

Command line     AUDIT 
 
NOTE If the AUDITCTL system variable is set to On and errors are found during a file 
recovery or audit, an ASCII file is created that describes the audit. The ASCII file is saved 
in the same folder as the audited drawing and has the same name as the drawing file, but 
with an .adt extension. 
 
 

Setting up a drawing 
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You can specify individual settings when you create a new drawing or when you modify 
settings in a drawing created from a template. 
 
 
Setting the current layer 
Layers are like the overlays that you use in manual drafting. You use layers to organize differ-
rent types of drawing information. Every drawing has at least one layer, the default layer, 
named “0.” Your drawing can also contain an unlimited number of additional layers. When 
you create an entity, it is created on the current layer. 
 
To set the current layer 
1   Choose Format > Layer.  
 

2   Double click the layer name that you want to make current. 

3   Close the Layer property manager. 

Standard toolbar   
Command line   LAYER 

 
 

 
 
Left-click the layer name that you want to make current. 
 
 
 
Setting the current entity color 
An entity’s color determines how it is displayed and, if you are using a color printer, how it 
prints. Entities are created in the current color. 
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When you open a new drawing, entities are created in the color BYLAYER, which adopts the 
color of the current layer. Initially, layer 0 is both the only layer and the current layer. Its 
default color is white, so your entities appear as white. 
 

There are index colors, which contain two additional color properties that are often referred to 
as colors, true colors, and color book colors. The two additional color properties are BY-
LAYER and BYBLOCK. These color properties cause an entity to adopt the color either of 
the layer or of the block in which it is a member. 
 
To set the current entity color 
1   Choose Format > Color. 
 

2   Click the Entity Creation tab. 

3   Click Select Color. 

4   In the Color dialog box, click one of the following tabs and select a color: 

•   Index Color — Click BYBLOCK, BYLAYER, or one of the 255 index colors. You can 
also type the color number in the Index box. 

•   True Color — Click a basic color, click a color in the color palette, enter the Hue, Saturation, 
and Luminance (HSL) values, or enter the Red, Green, Blue (RGB) values. There are 
more than 16 million true colors from which you can choose. 

•   Color Books — Select a color book from the list, then click a color. You can select Show 
Only Color Book Colors Used in Drawing to limit the selection to only those color book 
colors that are used in the current drawing. 

5   Click OK. 

6   Click OK again. 

 
Command line   COLOR 

 
 
For more details about using color in the many aspects of your drawing, see “Working with 
colors” on page 42 in this chapter. 
 
 
Setting the current linetype 
Linetypes help convey information. You use different linetypes to differentiate the purpose of 
one line from another. A linetype consists of a repeating pattern of dots, dashes, or blank 
spaces. Linetypes determine the appearance of entities both on the screen and when printed. 
By default, every drawing has at least three linetypes: CONTINUOUS, BYLAYER, and 
BYBLOCK. Your drawing may also contain an unlimited number of additional linetypes. 
 
When you create an entity, it is created using the current linetype. By default, the current 
linetype is BYLAYER. ZwCAD indicates that the entity linetype is determined by the current 
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layer’s linetype by assigning the BYLAYER property as the default linetype setting. When 
you assign BYLAYER, changing a layer’s linetype changes the linetype of all the entities 
assigned that layer (if they were created using the linetype BYLAYER). 
 

You can also select a specific linetype as the current linetype, which overrides the layer’s 
linetype setting. Entities are then created using that linetype, and changing the layer linetype 
has no effect on them. 
 

As a third option, you can use the linetype BYBLOCK property, in which case new entities 
are drawn using the CONTINUOUS linetype until you group them into a block. The entities 
then inherit the block’s linetype setting when you insert the block into a drawing. 
 
To set the current linetype 

1   Choose Format > Linetype.   

2   In the Entity Linetype list, left click the linetype that you want to make current, then click 
the current button. 

3   Click OK. 
Command line   LINETYPE 
 
 
Setting the linetype scale 
You can specify the linetype scale. The smaller the scale, the more repetitions of the linetype 
pattern are generated per drawing unit. For example, a linetype pattern is defined as a se-
quence of dashed lines and open spaces, each 0.25 units long. The line type scale uses the 
drawing scale factor to determine the length. A scale factor of 0.5 would reduce the length of 
each line and space to 0.125 units; a scale factor of 2 would increase the length of each to 0.5 
units. 
 
 
 
NOTE  Setting the linetype scale too large or too small may result in a line pattern looking 
like a solid line, depending on what the scale view is or at what scale the drawing is printed. 
 
 

 
You can control a new entity’s individual linetype scale factor as well as the overall or global 
scale factor applied to all the entities in the drawing. 
 
To set the current individual linetype scale 
1   Choose Format > Linetype. 
 

2   Click the Show Details button. 

3   In the Current object scale field, type the linetype scale that you want to make current. 

4   Click OK. 
Command line   LINETYPE 
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To change the global linetype scale 
1    Choose Format > Linetype. 
 

2   Click the Show Details button. 

3   In the Global Scale factor, type the global linetype scale that you want to change. 

4   Click OK. 
Command line   LINETYPE 
 
 

Setting the current lineweight 
Lineweights help differentiate the purpose of one line from another. Lineweights determine 
how thick or thin entities appear both on the screen and when printed. Every drawing has these 
lineweights: DEFAULT, BYLAYER, BYBLOCK, and many additional lineweights in 
millimeters (or you can use inches). 
 

When you create an entity, it is created using the current lineweight. By default, the current 
lineweight for a new entity is BYLAYER. This means that the entity lineweight is deter-
mined by the current layer. When you assign BYLAYER, changing a layer’s lineweight 
changes the lineweight of all the entities assigned that layer (if they were created using the 
lineweight BYLAYER). 
 
You can also select a specific lineweight (or DEFAULT) as the current lineweight, which 
overrides the layer’s lineweight setting. Entities are then created using that lineweight (or the 
DEFAULT lineweight), and changing the layer lineweight has no effect on them. 
 
As a third option, you can use the lineweight BYBLOCK property, in which case new entities 
are drawn using the DEFAULT lineweight until you group them into a block. The entities then 
inherit the block’s lineweight setting when you insert the block into a drawing. 
 
If you choose a lineweight that is less than .025 millimeter, it displays as one pixel when you 
create your drawing. When you print your drawing, it prints at the thinnest lineweight that is 
available for your printer. 
 

You cannot assign lineweights to planes, points, TrueType fonts, or raster images (if support-
ed in your version of ZwCAD). 
 
To set the current lineweight 
1   Choose Format > Lineweight. 
 

2   In the Current Lineweight list, choose the lineweight that you want to make current. 

3   Click OK. 

Command line   linetype 

 38 



                                                W O R K I N G   W I T H   D R A W I N G S 

Status bar       right-click  choose settings 
 
 
TIP  On the status bar, right click the word LWT to toggle the display of lineweights  
on and off. 
 
 
 
NOTE To see lineweights in your drawing, you may need to turn on lineweights. For 
details, see “Controlling the display of lineweights” on page 121. 
 
 
Setting drawing units 
With ZwCAD, you typically draw at full size (1:1 scale), and then set a scale factor when you 
print or plot your drawing. Before you begin drawing, however, you need to determine the 
relationship between drawing units and real world units. 
 

For example, you can decide whether one linear drawing unit represents an inch, a foot, a 
meter, or a mile. In addition, you can specify the way the program measures angles. For both 
linear and angular units, you can also set the degree of display precision, such as the number 
of decimal places or smallest denominator used when displaying fractions. The precision 
settings affect only the display of distances, angles, and coordinates. ZwCAD always stores 
distances, angles, and coordinates using floating point accuracy. 
 
 
Open drawing units dialog 
Choose Format > Units. 

Command line   UNITS 
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A B

C 

D 

 
A  Specifies the current unit of measurement 
and the precision for the current units. 
B  Angle: Specifies the current angle format 
and the precision for the current angle display. 
C  Controls the unit of measurement for blocks 
that are dragged into the current drawing using 

a tool palette. 

E 

D   Sample Output: Displays an example of 
the current settings for units and angles. 
E   Displays the Direction Control dialog box. 
 

 
 

F 

G 

 
 
 
 
 
 
 
 
 
 
 

F   Sets the direction of the zero angle. 
G   Pick an Angle Button: Defines the zero angle in the graphics area based on the angle of an 

imaginary line that connects any two points you specify with the pointing device. Available only 
when Other is selected 

 
Understanding scale factors 
Instead of drawing to a particular scale, you draw everything in the program full size. Although 
it’s a good idea to keep your scale factor in mind when setting up a drawing, you don’t need to 
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set the scale until you print it. For example, when you draw a mechanical part 40 inches in 
length with ZwCAD, you actually draw it as 40 inches, rather than applying a scale factor as 
you draw. When you print your drawing, you can assign the scale at which the drawing is to 
print. 
 
Scale, however, does affect the way a few elements such as text, arrows, or linetypes print or 
plot in your drawing. For these, you can make adjustments when you first set up your drawing 
so that they print or plot at the correct size. For example, when you draw text, you need to 
determine the text size so that when you print it later at a particular scale, the text height is 
correct. 
 

After you determine the eventual scale of your finished drawing, you can calculate the scale 
factor for the drawing as a ratio of one drawing unit to the actual scale unit represented by 
each drawing unit. For example, if you plan to print your drawing at 1/8” = 1’-0”, your scale 
factor ratio is 1:96 (1/8” = 12” is the same as 1 = 96). If you want your printed scale to be 1 
inch = 100 feet, your scale factor ratio is 1:1200. 
 
The following table shows some standard architectural and engineering scale ratios and 
equivalent text heights required to create text that measures 1/8 inch high when you print the 
drawing at the specified scale. 
 
Standard scale ratios and equivalent text heights 
Scale Scale factor        Text height 
1/16” = 1’-0” 192 24” 
 

1/8” = 1’-0” 96 12” 
 

3/16” = 1’-0” 64 8” 
 

1/4” = 1’-0” 48 6” 
 

3/8” = 1’-0” 32 4” 
 

1/2” = 1’-0” 24 3” 
 

3/4” = 1’-0” 16 2” 
 

1” = 1’-0” 12 1.5” 
 

1 1/2” = 1’-0” 8 1” 
 

3” = 1’-0” 4 0.5” 
 

1” = 10’ 120 15” 
 

1” = 20’ 240 30” 
 

1” = 30’ 360 45” 
 

1” = 40’ 480 60” 
 

1” = 50’ 600 75” 
 

1” = 60’ 720 90” 
 

1” = 100’ 1200 150” 
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You can use these scale factors to predetermine the size of your drawing to make sure that it 
fits on a specific size paper when you print it. You control the size of your drawing by the 
drawing limits. To calculate the drawing limits to match the size of your paper, multiply the 
dimensions of your paper size by your scale factor. 
 
For example, if the paper you use to print measures 36 inches x 24 inches and you print your 
drawing at 1/8” = 1’-0” (in other words, using a scale factor of 96), the size of your drawing 
measured in drawing units is 36 x 96 (or 3,456 units) wide and 24 x 96 (or 2,304 units) high. 
 
Keep in mind that you can print the finished drawing at any scale, regardless of the scale 
factor you calculate. You can also print on paper of a different size and use the Layout tabs to 
create different views of your drawing and to position and scale those views differently. The 
scaling factor is not related to the size of the entities you draw; it simply provides a 
preliminary guide to help you establish the text height and drawing limits when you begin 
your drawing. You can change the text height and drawing limits at any time. 
 

Working with colors 

 
An entity’s color determines how it is displayed and, if you are using a color printer, how it 
prints. Entities are created in the current color specified for the drawing. 
 
Layers can also control the color of entities. When you open a new drawing, entities are 
created in the color BYLAYER, which adopts the color of the current layer. Initially, layer 0 
is both the only layer and the current layer. Its default color is white, so your entities appear as 
white. 
 

For entities and layers in ZwCAD, there are three different types of colors: 
 

•   Index colors 

•   True colors 

•   Color book colors 
 
You can choose colors by selecting them from the Color dialog box. In the command bar or in 
some dialog boxes, you specify a color either by name or by number. 
 
Using index colors 
There are 255 standard index colors and two additional color properties that are often referred 
to as colors (BYLAYER and BYBLOCK). You can use seven of the 255 standard index co-
lors by name: red, yellow, green, cyan, blue, magenta, and white. (Numbers eight and nine are 
not named.) Each index color has a unique number from 1 to 255. The two additional color 
properties are BYLAYER and BYBLOCK. These color properties cause an entity to adopt the 
color either of the layer or of the block in which it is a member. BYLAYER is color number 
256, and BYBLOCK is color number 0. In all commands for which you would use a color, you 
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can indicate BYLAYER and BYBLOCK as well as by numbers 256 and 0, respectively. 
 
To select an index color 
1   Click Select Color in the desired dialog box, such as Layers, Drawing Settings, Properties, 

or Multiline Text. The Color dialog box opens. 

2   Click the Index Color tab. 

3   Do one of the following: 

•   Click BYBLOCK. 

•   Click BYLAYER. 

•   Click the color of your choice, or type the color number in the Current box. 
 

4   Click OK. 
 
 

A 

B 

C 

D 

E 

F 

 
 
 
 
 
 
 
 
 
 
 
 

 
 
 

 
A  Click to select any one of the available index colors. 
B  Click to select one of the Standard shades. 
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C  Click to select one of the gray shades . 
D  Specifies a color name, the BYLAYER and 
BYBLOCK colors, or an ACI number of 1 

through 255. 
E  Click to set the color to BYLAYER. 
F  Click to set the color to   BYBLOCK. 

 
Using true colors 
There are more than 16 million true colors from which you can choose. True colors are de-
fined using 24 bit color. 
 

Even with so many colors available, you can quickly choose a color from the display of basic 
colors or by clicking the color palette. Alternatively, if you know the values used to define the 
desired color, you can enter the Hue, Saturation, and Luminance (HSL) values, or you can 
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enter the Red, Green, Blue (RGB) values. 
 
To select a true color 
1   Click Select Color in the desired dialog box, such as Layers, Drawing Settings, Properties, 

or Multiline Text. The Color dialog box opens. 

2   Click the True Color tab. 
3   There are two true color models. 
•   HSL color model 
 
 

                

C

B 

A 

 
 
 
 
 
 
 
 
 
 
 
 
 

A  Enter (or view) the amount of hue, saturation, and 
luminance of the desired true color. 
B   Enter (or view) the amount of red, green, and blue 

of the desired true color. 
C   Display the selected color and its RGB values. 
D   Slide or click to adjust the color luminance.

 
• RGB color model 
                                

                                             

C 

B 

A 

 
 
 
 
 
 
 
 
 
 
 
 

A  Enter, slide or click to adjust the desired true 
color of red, green, blue.                                        C   Display the selected color and its RGB values. 
B  Enter (or view) the amount of red, green, and blue 

of the desired true color. 
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 Using color books 
ZwCAD uses color books to store collections of colors. For example, you can store a unique 
color scheme for a client in a color book and then use colors only from that color book for the 
client’s drawings. 
 

You may have a color book given to you by a client, developed by a third party, or you can 
create your own. Each color book has an .acb extension and is saved in Extensible Markup 
Language (XML) format. By default, color books are stored in the same folder where you 
installed ZwCAD. To verify the folder location, choose Options from the Tools menu, click 
the Paths/Files tab, and find the Color Book folder in the Paths list. 
 
To create a color book 

1   Start an XML editor program. 

2   Create a new XML file using the format below as a guide. 
 
<colorBook> 

<bookName>Color book sample</bookName> 
<colorPage> 

<pageColor><RGB8><red>0</red><green>0</green><blue>0</blue></RGB8> 

</pageColor> 
<colorEntry> 

<colorName>Orange</colorName> 

<RGB8><red>255</red><green>128</green><blue>0</blue></RGB8> 

</colorEntry> 
<colorEntry> 

<colorName>Light Green</colorName> 

<RGB8><red>128</red><green>192</green><blue>128</blue></RGB8> 

</colorEntry> 
<colorEntry> 

<colorName>Gray</colorName> 

<RGB8><red>128</red><green>128</green><blue>128</blue></RGB8> 

</colorEntry> 
</colorPage> 
</colorBook> 

 
NOTE Your color book can contain an unlimited number of colors using the 
<colorEntry> and </colorEntry> tags. 
 
3   Save the color book in XML format and with an .acb extension. 
 
To load a color book 

1   Save the color book in the folder where ZwCAD searches for color books. By default, 
this is the same folder where you installed ZwCAD. To verify the folder location, choose 
Options from the Tools menu, click the Paths/Files tab, and find the Color Book folder in the 
Paths list. 
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To select a color book color 
1   Click Select Color in the desired dialog box, such as Layers, Drawing Settings, Properties, 

or Multiline Text. The Color dialog box opens. 

2   Click the Color Books tab. 

3   Select a color book from the list. 

4   If you want to narrow your color search, select Show Only Color Book Colors Used in 
Drawing. Only those color book colors that are used in the current drawing will display in 
the list. 

5   Click the desired color. 

6   Click OK. 
 

C 

B 

A 
D 

E 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
A  Select a color book. D  Slide to adjust the desired color 
B  Click to select an available color from the selected 
color book. 

E  Displays the selected color and its RGB values. 

C  Enter (or view) the amount of red, green, and blue of 
the desired color. 
 

Setting and changing the grid and snap alignment 

 
Grid and snap settings are effective tools to use in your drawing to ensure accuracy. Although 
many users find it convenient to match grid points to snap settings, they are independent of 
each other and should not be confused. Grid points are for visual reference only; they do not 
affect your drawing and they do not print. Snap points are, by themselves, not visible; 
however, when set, they constrain the creation of new entities. 
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Setting a reference grid 
A reference grid displays as a pattern of regularly spaced dots. You can turn the display on 
and off, and you can specify how far apart the dots are spaced. 
 

The reference grid extends only to the limits of the drawing, helping you to visualize the 
boundary of your drawing and to align entities and visualize distances between entities. You 
can turn the grid on and off as needed. You can also change the spacing of the grid at any time. 
 
To turn the grid on and set the grid spacing 

1   Choose Tools > Drafting Settings.  
2   Click the Snap and Grid tab. 

3   Click the Grid on box. 

4   Under Grid Spacing, in the X field, choose the horizontal grid spacing. 

5   Under Grid Spacing, in the Y field, choose the vertical grid spacing. 

6   Click OK. 

Status bar        right-click  choose settings 
 
 
TIP To toggle the grid display on and off at any time, left click the GRID setting on 
the status bar, or press F7. 
. 

 
 

I 

H

GA 

B 

C 

D 

E 

F 

 
 
 
 
 
 
 
 
 
 
 
 

A   Click the check box to enable snap mode. F  Controls the PolarSnap™ increment 
distance. B  Specify the x and y snap spacing. 
G  Click the check box to display the reference grid. C  Rotates the snap grid by the angle specified. 
H  Specify the x and y grid spacing. D  Specifies an X and Ybase coordinate point 

for the grid. I  Controls snap mode settings. 
E  Click the current isometric plane, 
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Setting snap spacing 
Another way to ensure drawing accuracy is to turn on and set snap spacing. When snap is 
turned on, the program restricts the selection points to predetermined snap intervals. Although 
it is often helpful to match the snap spacing to some interval of the grid spacing or another 
related setting, the settings do not have to match. 
 
To turn snap settings on and set snap spacing 

1   Choose Tools > Drafting Settings.  
2   Click the Snap and Grid tab. 

3   Click the Snap on box. 

4   Under Snap Spacing, in the X field, choose the horizontal Snap spacing. 

5   Under Snap Spacing, in the Y field, choose the vertical Snap spacing. 

6   Click OK. 

Status bar        right-click   choose settings 
 
 
TIP To toggle snap settings on and off at any time, left click the SNAP setting on 
the status bar, or press F9. 
 

 
In addition to setting the snap spacing, you can change the snap and grid orientation. You can 
also rotate the alignment of the grid or set it to create isometric drawings. 
 
Changing the snap and grid angle and base point 
The snap and grid are both normally based on the drawing origin, the 0,0 coordinate in the 
World Coordinate System (WCS). You can relocate the snap and grid origin, however, to help 
you draw entities in relation to a different location. You can also rotate the grid to a different 
angle to realign the crosshairs to the new grid angle. If the grid is on, and the grid spacing is 0,0, 
then the grid defaults to the snap spacing. 
 
To change the snap angle and base point 
1   Choose Tools > Drafting Settings.  
2   Click the Snap and Grid tab. 

3   Click the Snap on box. 

4   In the X base field, type the x coordinate of the new snap origin. 

5   In the Y Origin field, type the y coordinate of the new snap origin. 

6   In the Angle field, type the grid rotation angle. 

7   Click OK. 
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Default grid and snap alignment.                  Rotated grid and snap alignment. 
 
 

Using isometric snap  
You can use the Isometric Snap option to create two dimensional isometric drawings. With the 
isometric option, you are simply drawing a simulated three dimensional view on a two-
dimensional plane, much the same as you might draw on a piece of paper. Do not confuse 
isometric drawings with three dimensional drawings. You create three dimensional drawings 
in three dimensional space. 
 

The isometric option always uses three preset planes, which are denoted as left, right, and top. 
You cannot alter the arrangement of these planes. If the snap angle is 0, the three isometric 
axes are 30 degrees, 90 degrees, and 150 degrees. 
 

When you check the Isometric Snap option and select an isometric plane, the snap intervals, 
grid, and crosshairs align with the current plane. The grid is always shown as isometric and uses 
y coordinates to calculate the grid spacing. If you click the Draw Orthogonal check box, the 
program restricts the drawing of entities to the current isometric plane. 
 

 
TIP  To toggle between isometric planes, press F5. 
 
 
 
To turn the Isometric Snap And Grid option on 

1   Choose Tools > Drafting Settings.  

2   Click the Snap and Grid tab. 

3   In  sna p  ty pe  & s ty l e  t ab ,  select the Isometric Snap check box. 
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4   Under Isometric Crosshairs, click the option for the isometric plane you want (Top, Left, 
or Right). 

5   Click OK. 
 
 
 
 
 
 
 
 
 
  

 
Isometric planes left (A), right (B), top (C). 

 

Using the Draw Orthogonal option 

 
You can restrict cursor movement to the current horizontal and vertical axes so that you can 
draw at right angles, or orthogonally. For example, with the default 0 degree Orientation 
(angle 0 at the “three o’clock” or “east” position), when the Draw Orthogonal option is en-
abled, lines are restricted to 0 degrees, 90 degrees, 180 degrees, or 270 degrees. As you draw 
lines, the rubber banding line follows either the horizontal or vertical axis, depending on 
which axis is farthest from the cursor. When you enable the isometric snap and grid, cursor 
movement is restricted to orthogonal equivalents within the current isometric plane. 
 

 
NOTE  ZwCAD ignores orthogonal drawing when you type coordinates in the command bar or 
when you use entity snaps. 
 
 
To enable orthogonal drawing 
 
Press F8 

Status bar        click   
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Using Object snaps 

 
Object snaps enable you to quickly select exact geometric points on existing entities without 
having to know the exact coordinates of those points. With object snaps, you can select the 
endpoint of a line or arc, the center point of a circle, the intersection of any two entities, or any 
other geometrically significant position. You can also use object snaps to draw entities that are 
tangent or perpendicular to an existing entity. 
 

You can use object snaps any time the program prompts you to specify a point—for example, 
if you are drawing a line or other object. You can work with object snaps in one of two ways: 

•   Enable a running object snap that remains in effect until you turn it off by choosing an 
object snap when no other command is active. 

•   Enable a one time entity snap for a single selection by choosing an object snap when 
another command is active. You can also use a one time object snap to override a 
running object snap. 

 
 
TIP If you type the name of the object snap, you need to type only the first three letters. 
 

 
 
When using object snaps, the program recognizes only visible objects or visible portions of 
objects. You cannot snap to objects on layers that have been turned off or to the blank 
portions of dashed lines. 
 

When you specify one or more object snaps, an object snap target box is added to the 
crosshairs. In addition, an icon appears adjacent to the crosshairs indicating the active object 
snap. When you select an object, the program snaps to the snap point closest to the center of 
the target box. 
 

 
TIP  Type m2p or mtp to enable a one time snap to the midpoint of two points that you 
specify, such as two points selected using object snaps. 
 
 
 
To change the size of the object snap target box 

1   Choose Tools>Draft Settings > Options. 
 

2   Under Aperture Size, slide to adjust the desired size. 

3   Click OK. 
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A 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

A  Slide to select the object snap aperture size. 

 
Setting object snaps 
You can set object snaps using any of the following methods: 
 

•   Choose Tools>Draft Settings > Object Snap, then click one of the object snap tools. 
•   On the Entity Snaps toolbar, click one of the object snap tools. 
•   On the command line, type an object snap command. 
•   On the status bar, right click ESNAP, choose settings. 

•   Press and hold down the Shift key while right clicking anywhere within the drawing 
window to display the object snap shortcut menu, and then choose the object snap you 
want to set. 

 
 

 
TIP When you select an object snap, a check mark appears next to the object snap in the 
menu, the associated tool if the Object Snaps toolbar is active, and the corresponding 
box is checked in the Object Snap of the Draft Settings dialog box. 
 
 
Nearest Snap tool 
Use the Nearest Snap tool to snap to the nearest point of another entity. You can snap to the 
nearest point on an arc, circle, ellipse, elliptical arc, line, point, polyline segment, ray, spline, 
infinite line, or hatch pattern that is visually closest to the cursor. 
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To set the Nearest Snap 
1   Choose Tools>Draft Settings > Object Snap. 

2   On the Object Snap modes tab, click the Set Nearest Snap tool ( ). 

Command line   NEAREST 
 
Endpoint Snap tool 
Use the Endpoint Snap tool to snap to the endpoint of another entity. You can snap to the 
closest endpoint of an arc, line, polyline segment, ray, hatch pattern, plane, or three-
dimensional face. If an entity has thickness, the Endpoint Snap also snaps to the endpoints of 
the edges of the entity. 
To set the Endpoint Snap 
•   Choose Tools>Draft Settings > Object Snap. 

•   On the Object Snap modes tab, click the Set Endpoint Snap tool ( ). 
Command line   ENDPOINT 
 

 
 
 
 
 
 
 

To snap to the endpoint, select anywhere on the entity near its endpoint (A). 
 
Midpoint Snap tool 
Use the Midpoint Snap tool to snap to the midpoint of another entity. You can snap to the mid-
point of an arc, ellipse, line, polyline segment, plane, infinite line, spline, or hatch pattern. In 
the case of infinite lines, the midpoint snaps to the first defined point. If an entity has thickness, 
the midpoint entity snap also snaps to the midpoint of the edges of the entity. 
 
To set the Midpoint Snap 
1   Choose Tools>Draft Settings > Object Snap. 

2   On the Object Snap modes tab, click the Set Midpoint Snap tool ( ). 
Command line   MIDPOINT 
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To snap to the midpoint, select anywhere on the entity near its midpoint (A). 
 
Center Snap tool 
Use the Center Snap tool to snap to the center point of another entity. You can snap to the cen-
ter of an arc, circle, polygon, ellipse, or elliptical arc. To snap to the center, you must select a 
visible portion of the entity. 
 
To set the Center Snap 
1   Choose Tools>Draft Settings > Object Snap. 

2   On the Object Snap modes tab, click the Set Center Snap tool ( ). 

Command line   center 
 

 
 
 
 
 
 
 
 

To snap to the center, select anywhere on the visible portion of the entity (A). 
 
Perpendicular Snap tool 
Use the Perpendicular Snap tool to snap to the perpendicular point of another entity. You can 
snap to an arc, circle, ellipse, line, polyline, infinite line, ray, spline, hatch pattern, or edge of a 
plane to form a perpendicular alignment with that entity or with an imaginary extension of that 
entity. 
 
To set the Perpendicular Snap 
1   Choose Tools>Draft Settings > Object Snap. 

2   On the Object Snap modes tab, click the Set Perpendicular Snap tool ( ). 

Command line   PERPENDICULAR 
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To form a perpendicular angle (A) to an entity (B), select anywhere on 
the entity. 
 
Tangent Snap tool 
Use the Tangent Snap tool to snap to the tangent point of another entity. You can snap to the 
point on an arc, ellipse, spline, or circle that, when connected to the previous point, forms a line 
tangent to that entity. 
 
To set the Tangent Snap 
1   Choose Tools>Draft Settings > Object Snap. 

2   On the Object Snap modes tab, click the Set Tangent Snap tool ( ). 
Command line   TANGENT 
 

 
 
 
 
 
 
 
 

To snap to a tangent, select the entity near the tangent point (A). 
 
Quadrant Snap tool 
Use the Quadrant Snap tool to snap to the quadrant point of another entity. You can snap to 
the closest quadrant of an arc, circle, ellipse, or elliptical arc. 
 
To set the Quadrant Snap 
1   Choose Tools>Draft Settings > Object Snap. 

2   On the Object Snap modes tab, click the Set Quadrant Snap tool ( ). 
Command line   QUADRANT 
 
 
 
 
 

 55 



CHAPTER 3 

 
 
 
 
 
 
 
 
 
 

To snap to a quadrant, select the entity near the quadrant point (A). 
 
Insertion Snap tool 
Use the Insertion Point Snap tool to snap to the insertion point of an attribute, block, or text 
entity. 
 
To set the Insertion Snap 
1   Choose Tools>Draft Settings > Object Snap. 

2   On the Object Snap modes tab, click the Set Insertion Snap tool ( ). 
Command line   INSERTION 
 

 
 
 
 
 
 
 
 

 
  
 
 

To snap to an insertion point, select anywhere on the entity (A). 
 
 
Node Snap tool 
Use the node Snap tool to snap to a node entity. 
 
To set the node Snap 

Do one of the following: 
1   Choose Tools>Draft Settings > Object Snap. 

2   On the Object Snap modes tab, click the Set Node Snap tool ( ). 
Command line   NODE 
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To snap to a node entity, select the entity (A). 
 
Intersection Snap tool 
The Intersection Snap tool snaps to the actual intersection in three dimensional space of any 
combination of entities. You can snap to the combination of an arc, circle, line, infinite line, 
polyline, ray, ellipse, elliptical arc, spline, hatch pattern, polygon mesh, or polyface mesh. 
You can also snap to an intersection point within a single entity, including a polyline or spline. 
 

The Extended Intersection Snap option snaps to the logical location where two entities (lines, 
arcs, or elliptical segments) would intersect if they were of infinite length. ZwCAD auto-
matically uses the extension option only when you type int in the command bar (not the full 
intersection command name) after selecting a command, such as Line or Circle. Dashed ex-
tension lines are drawn to help show the extended intersection. 
 

 
NOTE There are two types of intersection snaps. You can set the Intersection Snap or 
Apparent Intersection Snap, but you cannot use both at the same time. 
 
 
To set the Intersection Snap 
1   Choose Tools>Draft Settings > Object Snap. 

2   On the Object Snap modes tab, click the Set Intersection Snap tool ( ). 

Command line   INTERSECTION 
 
 
 
 
 
 
 
 
 
 
 
 
 

To snap to an intersection, select the intersection (A). 
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To snap to an extended intersection point 
1   Choose a command, for example, line. 

2   Type int and then press Enter. 

3   Select an extended intersection point. 
 
The Extended Intersection Snap turns off automatically after you select a point. 
 
 

Use Polar Tracking and PolarSnap 

 
When you are creating or modifying objects, you can use polar tracking to display 
temporary alignment paths defined by the polar angles you specify. You can use 
PolarSnap™ to snap to specified distances along the alignment path. For example, in 
the following illustration you draw a two unit line from point 1 to point 2, and then 
draw a tw o unit line to point 3 at a 45 degree angle to the line. If you turn on the 45-
degree polar angle increment, AutoCAD displays an alignment path and tooltip when 
your cursor crosses the 0 or 45 degree angle. The alignment path and tooltip disappear 
when you move the cursor away from the angle. 
 
As you move your cursor, alignment paths and tooltips are displayed when you move 
the cursor near polar angles. The default angle measurement is 90 degrees. Use the 
alignment path and tooltip to draw your object. You can use polar tracking with Inter-
section and Apparent Intersection object snaps to find where a polar alignment path 
intersects another object 
   
Note  Ortho mode restricts the cursor to horizontal or vertical (orthogonal) axes. Because 
you cannot have Ortho mode and polar tracking turned on at the same time, AutoCAD turns  
polar tracking off when you turn on Ortho mode. If you turn polar tracking back on,ZwCAD  
turns Ortho mode off. Similarly, if you turn PolarSnap on, grid snap is turned off automatically. 
 
 
To turn on and turn off polar tracking 
 
Press F10. 

 Status bar   right click 
 
To set polar snap distance 
 
1   From the Tools menu, choose Drafting Settings. 
2   In the Drafting Settings dialog box, Snap and Grid tab, select Snap On. 
3   In Snap Type & Style, select PolarSnap. 
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4   Under Polar Spacing, enter the polar distance. 
5   Choose the Polar Tracking tab and select Polar Tracking On. 
6   Select the angle from the Increment Angle list. You can specify your own angles 

by choosing Additional Angles and then New. 
7   Choose OK. 
 
To draw objects using polar tracking 
 
1   Turn on polar tracking and start a drawing command, such as ARC, CIRCLE, or 
LINE. You can also use polar tracking with editing commands, such as COPY and MOVE. 
2   As you move your cursor to specify points, notice the dotted polar tracking line 
that appears at the tracking angles you specified. Points you specify while the line is 
displayed conform to the polar tracking angle. 
 
 
To draw objects using polar distance 
 
1   Turn on snap and polar tracking. Make sure Polar Snap is selected in the Drafting 
Settings dialog box, Snap & Grid tab. 
2   Start a drawing command, such as LINE. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

A   Turns polar tracking on and off.            E  Deletes selected additional angles. 
B   Sets the polar increment angle used to 
display polar tracking alignment paths. 

F   Sets options for object snap tracking, 
either track orthogonally only or using all 
polar angle settings. C   Makes any additional angles in the list 

available for polar tracking. G   Sets the basis by which polar tracking 
alignment angles are measured.D   Adds up to 10 additional polar tracking 

alignment angles. 
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To set polar tracking angles 
 
1   From the Tools menu, choose Drafting Settings. 
2   In the Drafting Settings dialog box, on the Polar Tracking tab, select Polar Tracking 

On. 
3   In the Increment Angle list, select the polar tracking angle. 
4   To set additional tracking angles, select Additional Angles. Then click New and en-

ter the angle value in the text box. 
5   Under Polar Angle Measurement, specify whether polar tracking increments are 

based on the UCS or relative to the last object you created. 
6   Choose OK. 
 

Saving your drawing 

 
When you save a drawing, your work is saved in a drawing (.dwg) file. 
 
After you have saved your drawing for the first time, you can save it with a new name. In 
addition to drawing (.dwg) files, you can also save a drawing in a Drawing Exchange Format 
(.dxf) file or a drawing template (.dwt) file. 
 
If you created your drawing using a template, saving the drawing does not alter the original 
template. 
 

 
Saving a drawing 
To save a drawing: 
 

Choose File > Save. 

Standard Toolbar    
Command line      SAVE 
                
 
 
TIP When you save a drawing the first time, the program displays the Save Drawing 
As dialog box so that you can choose a directory and type a name for the drawing. 
You can use any name when you first save the drawing. 
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Saving a drawing with a new name or file format 
You can save a drawing with a new name and in any of the following file formats: 
 

•   Standard drawing files with a .dwg extension. You can choose a .dwg file format that is 
compatible with various versions of AutoCAD. 

•   Drawing Exchange Format files with a .dxf file extension. You can choose a .dxf file 
format that is compatible with various versions of AutoCAD. 

•   Drawing templates with a .dwt file extension. Drawing templates allow you to easily 
create new drawings that reuse your drawing settings and entities. 

 
To save a drawing with a new name or file format 
1   Choose File > Save As. 
2   In the Save Drawing As dialog box, under Save As Type, choose the file format. 

3   Specify the name of the file you want to create. 

4   Click Save. 

Command line   SAVEAS 
 
TIP You can also export drawing files to various file formats. For more details, see 
“Exporting drawings” on page 403. 
 
 
Saving a drawing with a password 
Sometimes drawings may contain confidential information and you want to control who has 
access to that information. If you need an added level of security, you can save a drawing with 
a password so only you and those who know the password can open the drawing. 
             

To save a drawing with a password, you must also save it in the AutoCAD 2004 
drawing (.dwg) file format. 
 
 
NOTE If you forget a drawing’s password, the drawing cannot be opened or recovered .You 
may want to store all passwords in a safe place. 
 
 
To save a drawing with a password 
1   Choose File > Save As. 
 

2   In the Save Drawing As dialog box, under Save As Type, choose AutoCAD 2004 (dwg). 

3   Click Password Protect. 

4   Choose a folder where you want to save the drawing. 

5   In File Name, specify the name of the file you want to create. 

6   Click Save. 

7   In the Password dialog box, enter a password. 
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8   If desired, record and store the password in a safe place. If you forget the drawing’s pass-
word, the drawing cannot be opened or recovered. 

9   Click OK. 
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Creating simple objects 
 

 
 
 
With ZwCAD, simple objects include lines (both finite and infinite), circles, arcs, ellipses, 
elliptical arcs, points, and rays. In addition, ZwCAD includes a freehand sketch tool. Objects 
drawn freehand are also considered to be simple objects. 
 

This section explains several methods for creating simple objects, including how to: 
 

•   Use menu commands on the Draw menu. 

•   Use the tools on the Draw 2D toolbar. 

•   Type commands in the command line. 
 
In some cases, there are a number of different ways to create an object. For the most part, one 
or two are given here. Refer to the online Help to learn how to create objects using other 
methods. 
 

When you use a tool or a drawing command, the program prompts you to enter coordinate 
points, such as endpoints or Drawion points. You can enter the points or distances either using 
a mouse or by typing coordinate values in the command bar. As you draw, ZwCAD also dis-
plays a context sensitive prompt box with appropriate additional options for the type of object 
you are drawing. 
 

After you create objects, you can modify them using the object modification tools. 
 

 
Topics in this chapter 
 

Drawing lines ........................................................................................................64 
Drawing Multiple-line........................................................................................65 
Drawing circles ..................................................................................................65 
Drawing arcs ......................................................................................................67 
Drawing ellipses.................................................................................................69 
Creating point objects ..............................................................................................71 
Drawing rays .........................................................................................................73 
Drawing construction lines ................................................................................74 
Creating freehand sketches ................................................................................76 
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Drawing lines 

 
A line consists of two points: a start point and an endpoint. You can connect a series of lines, 
but each line segment is considered a separate line object. 
 
To draw a line 

1  Choose Draw > Line 
2 Specify the start point. 
3 Complete the first line segment by specifying the endpoint. To undo the previous 

line segment during the Line command, enter u or click Undo on the toolbar. Spe-
cify the endpoints of any additional line segments. 

4 Press Enter to complete the command. 
To start a new line at the endpoint of the last line drawn, start the Line command ag-
ain and press Enter at the Specify Start Point prompt. 

Draw toolbar     
Command line   LINE 

 
 
 
 
 
 
 
 

Start point (A) and endpoint (B). 
 
 

If the last object you drew was an arc, you can also draw a line tangent to and starting from the 
endpoint of the arc. 
 
To draw a line as a continuation from the end of an arc 

1   Choose Draw > Line 
 

2   Take the end of an arc as the start point of line. 

3   Specify the length of the line. 

Draw toolbar     
Command line   LINE 
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Endpoint of previous arc (A) and length of the line (B). 
 
 

Drawing Multiple-line 

 
You position the elements by specifying the desired offset of each element from the 
origin of the multi line. You can create and save multi line styles or use the default 
style, which has two elements. The multi line command has there parameters: justification, 
scale, style. 

 
To draw a multi-line 
 
1   On the command line, type mline. 
2   Specify the start point. 
3   Specify the endpoint. 
4   Press Enter to complete the command. 
 
 

Drawing circles 

 
The default method for drawing a circle is to specify a center point and radius. You 
can draw circles using any of the following methods: 
 

•   Center Radius 
•   Center Diameter  
•   Two points  
•   Three points  
•   Tangent Tangent Radius 
 
•   Tangent Tangent Tangent 
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To draw a circle by specifying its center and radius 

1   Choose Draw > Circle>Center, Radius.   
 

2   Specify the center point. 

3   Specify the radius of the circle. 

Draw toolbar      

Command line    CIRCLE 

 
 
 
 
 
 
 
 
 

Center point (A) and radius (B). 
 
 
To draw a circle tangent to existing objects 
1    Choose Draw > Circle>Tan, Tan, Radius. 

2   Specify the radius of the circle. 

3   Select the first object to which to draw the circle tangent. 

4   Select the second object to which to draw the circle tangent. 

Draw toolbar      

Command line    CIRCLE 
 

  
 
 
 
 

 
 
 
 

Radius of circle (A) and tangent lines (B) and (C). 
 
 
To convert an arc to a circle       
1   On the command line, enter circle > a. 
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2   Select the arc you want to convert to a circle. 

 
 
 
 
 
 
 
 

Select an arc (A) to convert to a circle. 
 
 

Drawing arcs 

 
An arc is a portion of a circle. The default method for drawing an arc is to specify three 
points—the start point, a second point, and the endpoint. You can draw arcs using any of the 
following methods: 
•    Three points on an arc  
•    Start point center point endpoint 
•    Start point center point included angle 
•    Start point center point chord length 
•    Start point endpoint included angle  
•    Start point endpoint starting direction  
•    Start point endpoint radius 
•    Center point start point endpoint 
•    Center point start point included angle 
•    Center point start point chord length  
•    As a tangent continuation of the previous arc or line  
 
To draw an arc by specifying three points 
1   Choose Draw > Arc> 3 Points 
 

2   Specify the start point. 

3   Specify a second point. 

4   Specify the endpoint. 

Draw toolbar      

Command line    ARC 
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Start point (A), second point (B), and endpoint (C). 
 
 

To draw an arc by specifying its start point, center point, and endpoint 
1   Choose Draw > Arc> Start, Center, End. 
 

2   Specify the start point. 

3   Specify the center point. 

4   Specify the endpoint. 

Draw toolbar      

Command line    ARC 
 
 
 

 
 
 
 
 
 
 

Start point (A), center point (B), and endpoint (C). 
 
To draw an arc by specifying two points and an included angle 
1   Choose Draw > Arc> Start End Angle. 
 

2   Specify the start point. 

3   Type angle. 

4   To draw an arc in a counterclockwise direction, enter a positive value for the included 
angle. To draw an arc in a clockwise direction, enter a negative value for the included 
angle. 

5   Specify the endpoint. 

Draw toolbar      

Command line    ARC 
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Start point (A), endpoint (B), and included angle (C). 
 

If the last object you drew was an arc or a line, you can also draw an arc tangent to and starting 
from the endpoint of the arc or line. 
 
To draw an arc tangent to an arc or line 
1 Choose Draw > Arc >Continue. 
 

2 Specify the endpoint of the tangent arc. 

Draw toolbar      

Command line    ARC 

 
 
 
 
 
 
 
 

Endpoint (A). 
 
TIP To convert an arc to a circle, firstly, on the command line, enter circle > a, then 
 select the arc you want to convert to a circle. 
 
 

Drawing ellipses 

 
The default method for drawing an ellipse is to specify the endpoints of one axis of the ellipse, 
and then specify a distance representing half the length of the second axis. The endpoints of the 
first axis determine the orientation of the ellipse. The longer axis of the ellipse is called the ma-
jor axis, and the shorter one is the minor axis. The order in which you define the axes does not 
matter. The program determines the major and minor axes based on their relative lengths. You 
can draw ellipses using any of the following methods: 
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•   Center 
•   Axis End 
 
 
To draw an ellipse by specifying the axis endpoints 
1   Choose Draw > Ellipse >Axis End. 
 

2   Specify the first endpoint. 

3   Specify the second endpoint. 

4   Drag the pointing device away from the midpoint, and click to specify a distance 
for half the length of the second axis. 

Draw toolbar      

Command line    ELLIPSE 

 
 
 
 
 
  
 
 
 
 

First axis endpoint (A), second axis endpoint (B), and half-length of other axis (C). 
 
 

Drawing elliptical arcs 
 
 
An elliptical arc is a portion of an ellipse. The default method for drawing an elliptical arc is 
to specify the endpoints of one axis of the ellipse, and then specify a distance representing half 
the length of the second axis. Then you specify the start and end angles for the arc, measured 
from the center of the ellipse in relation to its major axis.  
 
To draw an elliptical arc by specifying the axis endpoints 

1   Choose Draw > Ellipse > Arc  
 

2   Specify the first endpoint. 

3   Specify the second endpoint. 

4   Specify the half length of the other axis. 

5   Specify the start angle of the arc. 

6   Specify the end angle. 
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Draw toolbar      

Command line    ELLIPSE 

 
 
NOTE   ZwCAD draws elliptical arcs in the direction you specify. Go to Format > 
Drawing Units, under angle tab, the default setting is counterclockwise. 
 

 
 
 
 

  
 
 
 
 
 

First axis endpoint (A), second axis endpoint (B), half length of other axis (C), start angle of arc (D), and end angle (E). 
 
 

Creating point objects 

 
You can draw a point object formatted as either a single dot or as one of 19 other possible 
display styles. 
 
To draw a point 
1 Choose Draw > Point > Single Point. 
 

2 Specify the location of the point. 

Draw toolbar      

Command line    POINT 
 
 
To draw several points 
1 Choose Draw > Point > Multiple Point. 
 

2 Specify the location of each point. 

Draw toolbar      

Command line    POINT 
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Changing the size and appearance of point objects 
Changing the size and appearance of point objects affects all point objects already in the 
drawing, as well as all points that you subsequently draw. Positive values represent the 
absolute size of the point object measured in drawing units. Negative values represent a 
percentage relative to the drawing screen, so that points retain their visual size as you use the 
Zoom command to change the magnification of the drawing. 
 
To change the size and appearance of point objects 
1   Choose Format > Point Style. 

2   Under Point Display Type, select the style you want. 

3   Under Point Size, select the point size, or choose one of the options. 

4   Click OK. 

 
When you regenerate the drawing, all point objects change to reflect the new size and 
appearance settings. 
 

 

A 

B 

C 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
A  Select the button that you want. C  To use one of the preset point size options, click the 

one that you want. B  To increase or decrease the point size, type or 
select a value. 
 
. 
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Drawing rays 

 
A ray is a line in three dimensional space that starts at a point and extends to infinity. Because 
rays extend to infinity, they are not calculated as part of the drawing extents. The default 
method for drawing a ray is to select the start point of the ray and then specify its direction. 
You can draw a ray in any of the following ways: 

•   Horizontal draws the ray parallel to the x-axis of the current user coordinate system 
(UCS). 

•   Vertical draws the ray parallel to the y axis of the current UCS. 

•   Angle draws the ray parallel to a specified angle. 

•   Bisect draws the ray perpendicular to an existing object. 

•   Parallel draws the ray parallel to an existing object. 
 
To draw a ray 
1   Choose Draw > Ray. 
 

2   Specify the start point. 

3   Specify the direction. 

4   To complete the command, press Enter. 

Command line   RAY 

 
 
 
 
  
 
 
 

Start point (A) and direction (B). 
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Drawing construction lines 

An construction line is a line through a given point, oriented at a specified angle in three-
dimensional space and extending to infinity in both directions. Because construction lines 
extend to infinity, they are not calculated as part of the drawing extents. 
 

The default method for drawing an construction line is to select a point along the line and then 
specify the direction of the line. You can draw an construction line in any of the following 
ways: 

•   Horizontal draws the construction line parallel to the x axis of the current UCS. 

•   Vertical draws the construction line parallel to the y axis of the current UCS. 

•   Angle draws the construction line parallel to a specified angle. 

•   Bisect draws the construction line perpendicular to an existing object. 

•   Parallel draws the construction line parallel to an existing object. 
 
To draw an construction line 
1   Choose Draw > construction line. 
 

2   Specify a point along the line. 

3   Specify the direction. 

4   To complete the command, press Enter. 

Draw toolbar      

Command line    XLINE 

 
 
. 

 
 

 
 
 
 
 

Point along the infinite line (A) and the direction (B). 
 

You can also draw construction line at a specific angle or at an angle relative to an existing 
object. 
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To draw an construction line at a specified angle relative to another object 
1   Choose Draw > construction line. 
 

2   On the command line, type angle. 

3   On the command line, type reference. 

4   Select the reference object. 

5   Specify the angle of the infinite line in relation to the selected object. 

6   Specify the location of the infinite line. 

7   To complete the command, press Enter. 

Draw toolbar      

Command line    XLINE 

 

 
 
 
 
 
 
 

Reference object (A) and angle in relation to object (B). 
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Creating freehand sketches    

 
A freehand sketch consists of many straight line segments, created either as individual line 
objects or as a polyline. Before you begin creating a freehand sketch, you must set the length, 
or increment, of each segment. The smaller the segments, the more accurate your sketch, but 
segments that are too small can greatly increase the file size. 
 

After you specify the length of the sketch segments, the crosshairs change to a Pencil tool. 
Your freehand sketch is not added to the drawing until you “write” the sketch into your 
drawing. This means that you temporarily save the segment that you’ve drawn and the 
segment length, and you can continue sketching. 
 
To create a freehand sketch 
1   On the command line, enter sketch. 
2   At the length of segments prompt, enter the minimum line segment length. 
3   Click the start point to put the “pen” down. When you move the pointing device, 
ZwCAD draws temporary freehand line segments of the length you specified. Sketch 
doesn’t accept coordinate input. During the command, freehand lines are displayed in 
a different color. 
4   Click the endpoint to lift the “pen” up so that you can move the cursor around 
the screen without drawing. Click a new start point to resume drawing from the new 
cursor position. 
5   Enter r at any time to record (save) in the database the line you’re drawing and 
those already drawn. If the pen is down, you can continue drawing after recording. If 
the pen is up, click to resume drawing. The freehand line starts from wherever the cur-
sor is when you click. 
6   Press Enter to complete the sketch and record all unrecorded lines 
 
 
 
 
 
 
 
 
A freehand sketch consists of individual line objects or a polyline. 
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Erasing freehand sketch lines 
You can erase temporary freehand sketch lines that have not yet been written into the drawing 
by choosing the Delete On option in the prompt box. The pencil changes to an Eraser tool. 
You can erase portions of the line when you move the eraser over a temporary freehand line 
without clicking the mouse button. 
 
To erase freehand sketch lines 
1   While running the sketch command, with the pen up or down, enter e(Erase). If 
the pen was down, it moves up. 
2   Move the cursor to the end of the line you drew last and then move it back as far 
along the line as you want to erase. 
3   To end the erasure and return to the sketch Command prompt, enter p. To undo 
the erasure, enter e. If you want to change the current viewport while sketching, make 
sure the pen is up, all lines entered so far have been recorded, and Tablet mode is off. 
 

 
. 
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Creating complex objects 
 

 
 
 
 
With ZwCAD, complex objects include polylines (including rectangles and polygons), spline 
curves, donuts, and planes. In addition, ZwCAD includes tools for adding hatching to your 
drawings. 
 

This section explains several methods for creating complex objects, including how to: 

•   Use menu commands on the Draw menu. 

•   Use the tools on the Draw toolbar. 

•   Type commands in the command line. 
 
When you type a drawing command or select a tool, the program prompts you to enter coor-
dinate points, such as endpoints or insertion points. As you draw, the program displays a 
context sensitive prompt with appropriate additional options for the type of object you are 
drawing. 
 
After you create complex objects, you can modify them using the object modification tools. 
Several of these object types require special editing commands. 
 
 
 
Topics in this chapter 
 

Drawing rectangles .................................................................................................79 
Drawing polygons ..............................................................................................81 
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Drawing wipeouts ..............................................................................................91 
Creating boundary polylines ..............................................................................93 
Adding hatching.................................................................................................97 
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Drawing rectangles 

 
With ZwCAD, rectangles are closed polylines with four sides. You draw a rectangle by speci-
fying its opposite corners. The rectangle is normally aligned parallel to the current snap and 
grid alignment, but you can use the Rotated option to align the rectangle to any angle. 
 
To draw a rectangle 
1   Choose Draw > Rectangle. 
 

2   Specify one corner of the rectangle. 

3   Specify the opposite corner of the rectangle. 

 

Draw toolbar     
Command line   RECTANGLE 

 
 
 
 
 
 
 

 
Opposite corners (A and B).                               Resulting rectangle.  
 

You can edit each side of a rectangle individually using the Edit Polyline tool ( ) on the 
ModifyII toolbar. You can convert the sides into individual line objects using the Explode tool 

( ) on the Modify toolbar. You can control whether wide rectangle lines are shown filled or 
as outlines using the fill command typed in the command line. You can also use the Rectangle tool 
to draw a square. Instead of specifying the opposite corners, you specify the length of one side and 
the alignment of the square. 
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To draw a square 
1   Choose Draw > Rectangle. 
 

2   On the command line, type square. 

3   Specify one corner of the square. 

4   Specify the length of one side of the square by selecting its other end. 

The point you specify determines both the size and alignment of the square. 

Draw toolbar     
Command line   RECTANGLE 

 
 
 
 
 
 
 
 

 
Endpoints of one side of the square (A and B).                 Resulting square.  
 
 
TIP To control the line width of the rectangle, type w in the command line, then type the 
desired value of line width. After you change the width of the line, the new width setting 
remains in effect for subsequent rectangles until you change it again. 
.
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Drawing polygons 

 
Polygons are closed polylines composed of a minimum of three and a maximum of 1,024 
equal length sides. The default method for drawing a polygon is to specify the center of the 
polygon and the distance from the center to each vertex. You can draw a polygon using any of 
the following methods: 

•   Center - by vertex  
•   Center - by side 

•   Edge  
 
The vertex polygon drawing method creates an equal sided polygon defined by its center point 
and the distance to its vertices. You specify the number of sides, the center point, and the loca-
tion of one vertex, which determines both the size and orientation of the polygon. 
 
To draw a polygon by vertex 
1    Choose Draw > Polygon. 
 

2   Type 5 to specify five sides for the polygon. 

3   Specify the center of the polygon. 

4   Specify the vertex of the polygon. 

Draw toolbar     

Command line   POLYGON 

 

 
 
 
 

 
 
 
 
 

The center (A) and vertex (B).                  Resulting polygon. 
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Drawing polygons by side 
The side polygon drawing method creates an equal sided polygon defined by its center point 
and the distance to the midpoint of a side. You specify the number of sides, the center point, 
and the location of the midpoint of one side, which determines both the size and orientation of 
the polygon. 
 
To draw a polygon by side 
1   Choose Draw > Polygon. 
 

2   Type 3 to specify three sides for the polygon. 

3   Specify the center of the polygon. 

4   Enter e (Edge). 

5   Specify the midpoint of the side. 

Draw toolbar     

Command line   POLYGON 

 
 
 
 
 
 
 
 
 
 

 
The center (A) and midpoint of one side (B).             Resulting polygon.
  
 

You can edit each side of a polygon individually using the Edit Polyline tool ( ) on the 
Modify toolbar. You can convert the sides into individual line objects using the Explode tool 

( ) on the Modify toolbar. You can control whether wide polygon lines are shown filled or 
as outlines using the fill command typed in the command line. 
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Drawing polylines 

 
With ZwCAD, a polyline is a connected sequence of arcs and lines that is treated as a single 
object. You can draw a polyline with any linetype and using a width that either remains cons-
tant or tapers over the length of any segment. When editing a polyline, you can modify the 
entire polyline or change individual segments. 
 
After you specify the start point of a polyline, the command line prompt several options as you 
draw, such as Arc, Distance, Halfwidth, and Width. You can specify different starting and ending 
widths to create a tapered polyline segment. 
 
After you draw at least one polyline segment, you can use the undo tool in right click menu to 
remove the previous segment. After you draw two or more polyline segments, you can type 
close in the command line to complete the command by drawing a segment that ends at the 
start point of the first polyline segment you drew. Press Enter to complete the command 
without closing the polyline. 
 
 
 

 
 
 
 
 
Curved polyline with tapered width.         Polyline with straight segments.    Closed polyline. 
   
  
To draw a polyline with straight segments 
1   Choose Draw > Polyline. 
2   Specify the start point. 

3   Specify the endpoint of each segment. 

4   Press Enter to end, or enter c to close the polyline. 

Draw toolbar     
Command line   PLINE 
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Polyline start point (A) and segment endpoints (B). 
 
With the Draw Arcs option, you can continually draw arc segments until you select the Draw 
Lines option to go back to drawing line segments. When you draw arc segments, the first 
point of the arc is the endpoint of the previous segment. By default, you draw arc segments by 
specifying the endpoint of each segment. Each successive arc segment is drawn tangent to the 
previous arc or line segment. If you type close while in the Draw Arcs option, the closing 
segment is created as an arc. 
 
You can also specify the arc using any of the following methods: 
•   Start point, included angle, center point 

•   Start point, included angle, radius 

•   Start point, center point, endpoint 

•   Start point, included angle, endpoint 

•   Start point, center point, included angle 

•   Start point, center point, chord length 

•   Start point, direction, endpoint 

•   Start point, radius, included angle 

•   Start point, second point, endpoint 
 
To draw a line segment followed by an arc polyline segment 
1 
  

  Choose Draw > Polyline. 

2   Specify the start point. 

3   Specify the endpoint. 

4   On the command line, type arc. 

5   Specify the endpoint of the arc segment. 

6   Press Enter. 

Draw toolbar     

Command line   PLINE 
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Polyline start point (A), line endpoint/arc start point (B), and arc endpoint (C). 
 

You can edit entire polylines and individual segments using the Edit Polyline tool ( ) on 
the Modify II toolbar. You can convert polylines into arc and line objects using the Explode 

tool ( ) on the Modify toolbar. You can control whether wide polylines are shown filled or 
as outlines using the fill command typed in the command line. 
 
 

Drawing splines 

 
A spline is a smooth curve defined by a set of points. You can use splines to create sculptured 
shapes such as the cross section of a turbine blade or an airplane wing. 
 
To draw a spline 
1   Choose Draw > Spline. 
2   Specify the first point of the spline. 

3   Specify the second point of the spline. 

4   Specify as many more points as you want. 

5   When you have finished, press Enter. 

Draw toolbar     

Command line   SPLINE 
 
You can add tangents to the spline, which are lines that give it shape. 
 
To add tangents to a spline 

1. Specify the starting tangent point. 

2. Specify the ending tangent point. 
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Spline                                         Spline with starting tangent point (A) and ending  
                                                tangent point (B). 
 
 
 
Specifying fit tolerance 

By default, a spline passes through all of the control points. When you draw a spline, you can 
change this by specifying the fit tolerance. The fit tolerance value determines how closely the 
spline fits the set of points you specify. For example, a spline fit tolerance value of 0 causes 
the spline to pass through the control points. A value of 0.01 creates a spline that passes 
through the start and endpoints and within 0.01 units of the intermediate control points. 
 
To specify the fit tolerance 
1   Choose Draw > Spline. 
 

2   Specify the first point of the spline. 

3   Specify the second point of the spline. 

4   To accept the default of 0.0000, press Enter. To specify a different fit tolerance, type the 
number, and then press Enter. 

5   Specify the additional points you need to draw a spline or a closed spline. 

Draw toolbar     

Command line   SPLINE 

 
Drawing a closed spline 
You can draw a closed spline, which is a spline for which the start point and endpoint are the 
same. Because the spline is closed, you specify only one tangent. 
 
To draw a closed spline 
1   Choose Draw > Spline. 
 

2   Specify the first point of the spline. 

3   Specify the second point of the spline. 

4   Specify as many more points as you want. 

5   When you have finished, on the command line, type close. 
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6   To complete the command, specify the tangent point. 

Draw toolbar     

Command line   SPLINE 

 
 
 
 
 
 
 
 

The start point and endpoint (A) of a closed spline. 
 
 

Drawing donuts 

 
Donuts are solid, filled circles or rings created as closed, wide polylines. You can draw a 
donut using one of several methods. The default method is to specify the inside and outside 
diameters of the donut, and then specify its center. You can then create multiple copies of the 
same donut by specifying different center points until you press Enter to complete the 
command. 
 
To draw a donut 
1   Choose Draw > Donut. 
 

2   Specify the inside diameter of the donut. 

3   Specify the outside diameter of the donut. 

4   Specify the center of the donut. 

5   Specify the center point to draw another donut, or press enter to complete the command. 

Command line   DONUT 

 

 
 
 
 
 
 
 

 
Inside diameter (A) and outside diameter (B). 
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ZwCAD provides additional options for drawing donuts. For example, you can specify the 
width of the donut and two points on the diameter of the donut if you type 2p, or you can 
specify the width and three points on the donut if you type 3p. You can also draw a donut 
tangent to existing objects if you type rtt. 
 

 
TIP A donut can be a completely filled circle by specifying an inside diameter of zero. 
 
 
 
 
To draw a donut tangent to existing objects 
1   Choose Draw > Donut. 
 

2   On the command line, type rtt. 

3   Specify the width of the donut. 

4   Specify the diameter of the donut. 

5   Select the first tangent object to which to draw the donut. 

6   Select the second tangent object to which to draw the donut. 

Command line   DONUT 

 
 
 
 

 
 
 

 
 
 
 

Width (A) and diameter (B) of the donut and tangent objects (C). 
 

You can edit donuts using the Edit Polyline tool ( ) on the Modify II toolbar. You can 

convert donuts into arc objects using the Explode tool ( ) on the Modify toolbar. You can 
control whether donuts are shown filled or as outlines using the fill command typed in the com-
mand line. 
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Creating planes 

 
With the Plane tool, you can draw rectangular, triangular, or quadrilateral areas filled with a 
solid color. The default method is to specify the corners of the plane. After you specify the first 
two corners, the plane is displayed as you specify the remaining corners. Specify corner points 
in a triangular manner. The program prompts you for the third point and then the fourth point. 
If you continue specifying points, the third- and fourth-point prompts toggle until you press 
Enter to complete the command. 
 

Creating planes in ZwCAD is similar to the Solid command in AutoCAD. 
 
To draw a quadrilateral plane 
1   Choose Draw > Surfaces > 2D Solid. 
 

2   Specify the first point. 

3   Specify the second point. 

4   Specify the third point. 

5   Specify the fourth point. 

6   To complete the command, press Enter. 

Draw toolbar     

Command line   SOLID 
 

 
 
 
 
 
 
 
 
 

After you select the first two points (A) and (B), the sequence in which you select the third (C) 
and fourth (D) points determines the shape of the resulting quadrilateral plane. 
 
The command line provides additional options for drawing planes. For example, you can draw 
rectangular, square, or triangular planes. 
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To draw a rectangular plane 
1   Choose Draw > Surfaces > 2D Solid. 
 

2   On the command line, type r. 

3   Specify the first point. 

4   Specify the opposite corner. 

5   Specify the rotation angle. 

6   To complete the command, specify the opposite corner to draw another rectangle, or press 
Enter. 

Draw toolbar     

Command line   SOLID 
 
 
 
 
 
 
 

 
Opposite corners (A and B) and rotation angle (C).                 Resulting plane. 
         
 
You can control whether planes are shown filled or as outlines using the fill command typed in 
the command line. You can convert planes into individual line objects corresponding to the 

outline of the plane using the Explode tool ( ) on the Modify toolbar. 
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Drawing wipeouts 

 
Wipeouts are unique objects that can help you hide areas of your drawing. They display with 
the current background color, so the details behind the wipeout do not display or print. 
 

Wipeouts are similar to other objects — you can copy, mirror, array, erase, rotate, and scale 
them, and they can be used in both model space and paper space. 
 

If you want to print the wipeout objects located in a drawing, you must print to a raster-cap-
able printer. Note that in some cases you may have unexpected results when printing drawings 
that contain wipeout objects, for example, if printing on colored paper. 
 
Drawing wipeouts using polygons and polylines 
Wipeouts are created using existing polygons, closed zero-width polylines made up of 
only line segments, or new polylines that you draw while using the Wipeout command. 
 
To draw a wipeout 
1   On the command line, type wipeout. 
 

2   Specify the start point. 

3   Specify the endpoint of each segment. 

4   After specifying the last endpoint, press Enter. 
 

 
 
 
 
 
 
 
 
 
 
 
Drawing without wipeout                           Drawing with wipeout.
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To create a wipeout using an existing polygon or polyline 
1   On the command line, type wipeout. 
 

2   Type Polyline. 

3   Select the closed polyline to use for the wipeout. 

4   Choose one of the following: 

•   Yes — Creates the wipeout and deletes the polyline used to create the wipeout. 

•   No — Creates the wipeout and keeps the polyline used to create the wipeout. 
 
Turning wipeout frames on or off 
Each wipeout has a frame along its boundary. Wipeout frames can be turned on or off for any 
drawing. When wipeout frames are on, you can select and modify wipeouts. You may want to 
turn off wipeout frames when it’s time to print. 
 
To turn wipeout frames on or off 
1   On the command line, type wipeout. 
2   Type Frames. 

3   Type On or Off. 
 

 
 
 
 
 
 
 
 
 
 
Wipeout frames turned on.                        Wipeout frames turned off.
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Creating boundary polylines 

 
With the Boundary command, you can designate a specific area of a drawing for operations 
such as hatching and dimensioning. You create a boundary polyline by selecting an area inside 
a closed loop. The area you select can be bounded by a single closed object or by multiple 
objects that intersect. 
 

In cases where objects intersect, ZwCAD interprets the boundary as the closed loop closest to 
the point specifying the area. In the following figure, for example, the area point selected in 
the rectangle results in a boundary consisting of the closed loop nearest the point selection, as 
opposed to the closed loop formed by the rectangle itself. 
 

 
 
 
 
 
 
 
 
 
 

Selected point (A).                                Resulting boundary (B).  
 
To make boundaries more specific, you can create a boundary set. A boundary set specifies 
which objects are considered in determining the boundary path. This can make creating the 
boundary polyline faster if you are working with a complex drawing. 
 
In the following figure, the circle and triangle are the selected objects. If you select an area 
anywhere inside the circle or the triangle, the result is a polyline that bounds the shaded area. 
 

 
 
 
 
 
 
 
 
 
 
 

Selected objects (A and B).                          Point specified in the selected area (C), 
                                         which results in a new boundary 
                                                 around the shaded area. 
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Using islands and island detection 
Islands are closed loops that reside inside other closed loops. ZwCAD provides island-
detection options so that you can specify which islands, if any, should be considered in the 
area selection for a boundary. 
 

The following figure shows a rectangular polyline with two islands. The circle is referred to as 
the outer island, and the octagon is referred to as a nested island. 
 

 
  
 
 

 
 
 
 
 
 
 

Rectangular polyline (A) with outer island (B), with point (C) specifying the area selection, and nested island 
(D). 
 
You can choose from three island-detection methods. 
 

•   Nested Islands style hatches inward from the outer boundary. If the hatching process 
encounters an internal boundary, hatching is turned off until another boundary is en-
countered.. 
•   Outer Only style hatches inward form the outer boundary and stops at the next boundary. 
•   Ignore Islands style hatches the entire area, ignoring inside boundaries. 

 
 
 
 
 
 
 
 
 
 
 
 

Nested islands (A), with outer island (B), and with ignore islands (C). 
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To draw a boundary polyline 
Advanced experience level 
 

1   Choose Draw > Boundary. 
 

2   Specify the objects that you want made available for the boundary polyline by doing one 
of the following: 

•   All objects Select All Visible Objects to have all objects in the drawing considered when 
creating the boundary polyline. 

•   Custom selection Define only specific areas to be considered when creating the boundary 
polyline, which can improve system performance if you are working with a complex 
drawing. Click Select Boundary Set. In the drawing, select the objects individually or by 
choosing a selection method from the prompt box, and then press Enter. The Current 
Selection Set option becomes selected automatically, which indicates that the objects you 
selected with the Select Boundary Set button will be considered when creating the 
boundary polyline 

. 

 
NOTE You can alternate between All Visible Entities and Current Selection Set without having 
to select objects again using the Select Boundary Set button. The Current Selection Set option 
uses the last set of objects you selected with the Select Boundary Set button. 
 
 
3   Choose an island-detection option. 

4   Click Select Area. 

5   In the drawing, click inside the area whose closed perimeter forms the boundary, not on 
the polyline itself. If desired, continue clicking inside additional closed perimeters. 

6   To complete the selection, press Enter. 
7   In the Boundary dialog box, click OK. 

Command line   BOUNDARY 
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A 

B 
C 

E 

D 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

A  Opens the drawing area for selection of objects 
to be considered when creating the boundary polyline. 
B  Choose to consider all visible objects when creating 
the boundary polyline. 
C  Choose to use the objects you selected for the 

boundary set. (Becomes available after you click the 
Select Boundary Set button.) 
D  Select an island detection option. 
E  Opens the drawing area for selection of the 
enclosed areas used to create new boundary polylines. 
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Adding hatching 

 
When you add hatching to a drawing, ZwCAD fills objects or enclosed areas with a pattern. 
You can choose a predefined hatch pattern, or you can create your own hatch pattern. 
 

First you specify the hatch pattern and other options, and then you choose which entities or 
enclosed areas that you want to hatch. 
 

 
NOTE Hatch patterns are memory intensive and can take a considerable amount of 
time to draw and display. To improve performance, add hatching as one of the last  
steps when you create a drawing, or insert hatches on a separate layer that you can 
freeze as you continue to work on your drawing. 
 
 
 
To open the Boundary Hatch dialog box 
Choose Draw > Hatch. 

Draw toolbar     

Command line   BHATCH 
 
Specifying a hatch pattern 
A hatch pattern consists of a repeating pattern of lines, dashes, and dots. You can select a 
hatch pattern from a set of predefined patterns, or you can define a pattern of your own. The 
hatch pattern you used most recently is the default pattern the next 
time you add hatching. 
 
The program supplies predefined standard hatch patterns, which are stored in the ICAD.pat 
and ICADISO.pat hatch pattern library files.  
 

 
NOTE The ICAD.pat hatch pattern library files are ANSI (American National Standards 
Institute) compliant patterns; the ICADISO.pat hatch pattern library files are ISO 
(International Standards Organization) compliant. 
 
 
To specify a predefined hatch pattern 
1   Choose Draw > Hatch. 
 

2   From the Boundary Hatch dialog box, click the Pattern Properties tab. 

3   In the Pattern list, click Predefined. 
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With Predefined, you can apply a scale factor to make the pattern larger or smaller than 
the default size. 

4   For Scale, enter the scale factor as a percentage of the default. 

5   For Angle, enter the angle of the pattern in degrees (1-360). 

The default angle is clockwise; you can change the angle of any hatch pattern by entering 
a numerical value. 

6   For ISO Pen Width, enter the pen width. 

If you choose a predefined, ISO standard pattern, you can scale the pattern based on the 
ISO pen width. 

7   To copy the pattern properties from an existing hatch, choose Copy Hatch Properties and 
select the hatch. 

8   To associate the hatch pattern to its boundary objects, under Hatch Attributes, select the 
Associative check box. An associative hatch updates automatically if you move any of its 
boundaries. 

9   To continue, add a hatch by doing one of the following: 

•   Select the objects you want to add a hatch. For details, see “Selecting objects for hatch-
ing” in this chapter. Begin with step 2. 

•   Select an area or boundary you want to add a hatch. For details, see “Selecting areas for 
hatching” in this chapter. Begin with step 2. 

Draw toolbar     
Command line   BHATCH 
 
To specify a user-defined hatch pattern 

1   Choose Draw > Hatch.  
 

2   From the Boundary Hatch dialog box, click the Pattern Properties tab. 

3   In the Pattern list, click User Defined. 

4   For Spacing, enter the line spacing for the pattern. 

5   To crosshatch the pattern, select the Cross Hatched check box. 

You can choose to crosshatch the pattern. Cross hatching imposes a copy of the specified 
user defined pattern at a 90-degree angle over the first pattern you defined. 

6   To copy the pattern properties from an existing hatch, choose Copy Hatch Properties, and 
select a hatch pattern from a hatched object in the drawing. 

7   To associate the hatch pattern to its boundary objects, under Hatch Attributes, select the 
Associative check box. An associative hatch updates automatically if you move any of its 
boundaries. 
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8   To continue, add a hatch by doing one of the following: 

•   Select the objects you want to add a hatch. For details, see “Selecting objects for hatch-
ing” in this chapter. Begin with step 2. 

•   Select an area or boundary you want to add a hatch. For details, see “Selecting areas for 
hatching” in this chapter. Begin with step 2. 

Draw toolbar     

Command line   BHATCH 
 

A G 

B 

C 
H 

D 

E 
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I 

 
 
A  Determines how the hatch will be defined. 
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B  Determines density of hatching for Predefined hatch 
patterns.  

C  Sets angle of hatch in relation to object (User 
Defined only). 

D  Determines density of hatching for User Defined 
hatch patterns. 

E  Sets pen width for ISO standard pattern. 
F  Imposes another copy of the specified pattern at a 

90-degree angle over the first.  
G  Select to update the hatch automatically if you move 

any of its boundaries. 
H  Displays the tolerance that non touching objects 

can be within and still be used to create the hatch 
pattern boundary , 

I  Closes dialog to allow selection and copying of 
existing hatch pattern properties. 

 
 
To use a predefined library pattern 
1   Choose Draw > Hatch. 
 

2   From the Boundary Hatch dialog box, click the Pattern tab. 
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3   For Hatch File, select the ICAD.pat or ICADISO.pat hatch pattern library file. 

4   To select a predefined pattern, do one of the following: 

•   In the Patterns list, click the pattern name. 

•   Click the graphical representation of the hatch pattern. 
 

5   To continue, add a hatch by doing one of the following: 

•   Select the objects you want to add hatching. For details, see “Selecting objects for hatch-
ing” in this chapter. Begin with step 2. 

•   Select an area or boundary you want to add hatching. For details, see “Selecting areas for 
hatching” in this chapter. Begin with step 2. 

Draw toolbar     
Command line   BHATCH 
 

 

A 

B 

C

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
A  Hatch pattern library files. C  Hatch patterns shown graphically
B  Hatch patterns listed by name. 
. 
 
NOTE Hatch patterns are memory intensive and can take a considerable amount of 
time to draw and display. To improve performance, add hatching as one of the last  
steps when you create a drawing, or insert hatches on a separate layer that you can 
freeze as you continue to work on your drawing. 
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Selecting objects for hatching 
You can add hatching to any object that forms a closed boundary, for example, a circle or 
rectangle. You can assign hatching to a single object or several objects at the same time. 
 
To select objects for hatching 
1   Choose Draw > Hatch. 
2   From the Boundary Hatch dialog box, click the Boundary tab. 
3   Under Island Detection Options, choose one of the following: 
•   Nested Islands Areas separated from the outside of the hatched by an odd number of 
intersections are hatched. 
•   Outer Only Only the outer object and its outer island are considered for hatching. 
•   Ignore Islands The entire object is considered for hatching. 
 

 
 
 
 
 
 
 
 
 
 
 

Nested islands (A), with outer island (B), and with ignore islands (C). 
 
4   To keep any new objects that are created for drawing the boundary hatch, select the 
Retain Boundaries check box. Existing objects are always retained. 
5   Click Select Objects. 

6   In the drawing, click the objects to be hatched individually or by choosing a selection 
method from the prompt box, and then press Enter when done. 

7   In the Boundary Hatch dialog box, click OK. 

Draw toolbar     

Command line   BHATCH 
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A  Choose to consider all visible objects when creating 

the boundary hatch. 
B  Mark the check box to keep any new objects that are 

created to draw the boundary hatch. Existing objects 
are always retained. 

C  (Display only) Indicates the boundary is created as 

a polyline, 
D  Opens the drawing area for selection of objects to 
be hatched. 
E  Determines how hatching interacts with islands. 

 
Selecting areas for hatching 
You can add hatching to an area enclosed by selected objects to form the hatch boundary. The 
hatch is formed in the enclosed area, not the objects themselves. 
 

After ZwCAD draws the hatch, the entire hatch is treated as a single object and it is either 
associative or independent of the hatch boundary objects. 
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o select an area for hatching 
1. Choose Draw > Hatch. 
2. From the Boundary Hatch dialog box, click the Boundary tab. 
3. Under Island Detection Options, choose one of the following: 
•   Nested Islands Areas separated from the outside of the hatched by an odd number of 

intersections are hatched 
•   Outer Only Only the outer object and its outer island are considered for hatching. 
•   Ignore Islands Only the outer object is considered for hatching. 
 

 
 
 
 
 
 
 
 
 
 
 

 
Nested islands (A), with outer island (B), and with ignore islands (C). 
 
4   To keep any new objects that are created for drawing the boundary hatch, select the 

Retain Boundaries check box. Existing objects are always retained. 
5   Specify the objects that you want made available for boundary hatching by doing one of 

the following: 

•   All objects Select All Visible Objects to have all objects in the drawing considered when 
creating the boundary hatch. 

•   Custom selection Define only specific areas to be considered when creating the boundary 
hatch, which can improve system performance if you are workingwith a complex draw-
ing. Click Select Boundary Set. In the drawing, select the objects individually, and then 
press Enter. The Current Selection Set option becomes selected automatically, which 
indicates that the objects you selected with the Select Boundary Set button will be 
considered when creating the boundary hatch. 
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NOTE You can alternate between All Visible Objects and Current Selection Set without having 
to select objects again using the Select Boundary Set button. The Current Selection Set option 
uses the last set of objects you selected with the Select Boundary Set button. 
 
 
6   In the Boundary Hatch dialog box, click Select Area. 
7   In the drawing, click inside the closed perimeter of a boundary, not on the boundary itself. 

If desired, continue clicking inside additional closed perimeters. 
8   To complete the selection, press Enter. 
9   In the Boundary Hatch dialog box, click OK. 

Draw toolbar     

Command line   BHATCH 
 
 

 

G
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A  Opens the drawing area for selection of objects to 
be considered when creating the boundary hatch. 
B  Choose to consider all visible objects when creating 
the boundary hatch. 
C  Choose to use the objects you selected for the 
boundary set. (Becomes available after you click the 
Select Boundary Set button.) 
D  Mark the check box to keep any new objects that are 

created to draw the boundary hatch. Existing objects are 
always retained. 
E  (Display only) Indicates the boundary is created as 
a polyline. 
F  Opens the drawing area for selection of enclosed 
areas to be hatched. 
G  Determines how hatching interacts with islands.

 
 
 

 104 



                                                     V I E W I N G   Y O U R   D R A W I N G 

 
 
Viewing your drawing 
 

 
 
 
 
ZwCAD provides many ways to display and view your drawing. You can also change various 
display settings to speed up the display or printing of a drawing. This section explains how to: 

•   Navigate within a drawing by scrolling, panning, and rotating the view. 

•   Change the magnification of a drawing by zooming in and out. 

•   Work with multiple windows or views of a drawing. 

•   Control the display of elements to optimize performance when working with large or 
complex drawings. 

 
 
 
 
 
 
 
 
 
 
 
 
Topics in this chapter 
 

Redrawing and regenerating a drawing .....................................................................106 
Moving around within a drawing.....................................................................106 
Changing the magnification of your drawing ..................................................109 
Displaying multiple views................................................................................ 113 
Controlling visual elements.............................................................................. 118 
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Redrawing and regenerating a drawing 

 
As you work on a drawing, visual elements may remain after the completion of a command. 
You can remove these elements by refreshing, or redrawing, the display. 
 
To redraw (refresh) the current window display 
Choose View > Redraw. 
Command line   REDRAW 
 
Information about drawing entities is stored in a database as floating point values, ensuring a 
high level of precision. Sometimes a drawing must be recalculated, or regenerated, from the 
floating point database to convert those values to the appropriate screen coordinates. This 
occurs automatically. You can also manually initiate a regeneration. When the drawing is re-
generated, it is also redrawn. 
 
To regenerate the current window, type regen in the command line. If more than one window 
is displayed, type regenall to regenerate all the windows. 
 
 
 

Moving around within a drawing 

 
You can move the view of a drawing displayed in the current viewport by scrolling, panning, 
or rotating the view. Doing this changes the portion of the drawing you are viewing without 
changing the current magnification. Scrolling lets you move around in the drawing 
horizontally and vertically. Panning lets you move the drawing in any direction. Rotating lets 
you view your drawing from any angle. 
 

 
 
 
Using scroll bars 
To assist you in navigating within a drawing, horizontal and vertical scroll bars are available in 
each drawing window. The size of the scroll box in relation to the scroll bar indicates the 
current level of drawing magnification. The position of the scroll box in relation to the scroll 
bar indicates the location of the center of the drawing in relation to the extents of the drawing 
(the smallest rectangle containing all the entities in the drawing). 
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To turn scroll bars on or off 
 
Do one of the following: 
•   Choose View >Display > Scroll Bars. 

•   Choose Tools > Options > Display tab, and select Display Scroll Bars in drawing window. 
Command line   SCROLLBAR 
 
Using the Pan command 
You can move the drawing in any direction using the pan command. Panning shifts or slides 
the view of the drawing horizontally, vertically, or diagonally. The magnification of the draw-
ing remains the same, as does its orientation in space. The only change is the portion of the 
drawing displayed. 
 
To pan, you can use any of the following methods: 
 

•   For precise panning, specify two points defining the magnitude and direction of the pan. 
The first point, or base point, indicates the starting point of the pan. The second point 
indicates the amount of pan displacement relative to the first point. 

•   To pan in real time, press Ctrl + Hold and drag right mouse button, or use the Real-Time 

Pan tool ( ) on the standard toolbar. 
•   If you have a mouse with a wheel, press and hold the wheel, and then move the mouse. 
 
To pan in real time 
 
1    Choose View > Zoom > Realt
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ime. 
 
2   Move the cursor in the direction you want to pan. 

3   To stop panning, press Enter or right click the mouse to choose edit. 

Standard toolbar    

Command line      PAN 
 
 
TIP Hold down the right mouse button while simultaneously pressing and holding 
Ctrl to pan in real time. 
 
 
NOTE If you are working with a large drawing file, it may be helpful to set the 
RTSKIPCOUNT system variable to a higher number to reduce the number of entities 
that display. For example, if the value is set to 10, only the 10th entity will display 
when panning and rotating in real time. 
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To pan using a mouse with a wheel 

•   Press and hold the wheel, and then move the mouse in the direction you want to pan. 
(The MBUTTONPAN system variable controls this feature.) 

 
 
 
Rotating the view in real time 
ZwCAD allows you to rotate your view of a drawing in real time. This allows you to view 
your model from any angle while in model space. You cannot rotate the view while in paper 
space. 
 

If desired, you can continue the view rotation after you release your mouse. Choose Tools > 
Options to enable continuous motion. For more information, see “Changing the options on the 
Display tab” on page 413. 
 
To rotate the view in real time 
1   Choose View > 3D Orbit. 
 

2   The view rotates according to the movement of your mouse. 

3   To stop rotating, release the mouse button. 

4   If the view continues to rotate, press Enter or right-click the drawing when finished. 

Command line      RTROT 

 
 
 
TIP  You can open the rotate command quickly to use Ctrl + Shift + Hold and drag left 
mouse button You can also press Ctrl +Shift and use the right mouse button to rotate the  
view about the z axis. 
. 
 
 
NOTE If you are working with a large drawing file, it may be helpful to set the 
RTSKIPCOUNT system variable to a higher number to reduce the number of entities 
that display. For example, if the value is set to 10, only the 10th entity will display 
when panning and rotating in real time. 
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Changing the magnification of your drawing 

 
You can change the magnification of your drawing at any time by zooming. The cursor chang-
es to a magnifying glass when a zoom tool is active. Zoom out to reduce the magnification so 
you can see more of the drawing, or zoom in to increase the magnification so you can see a 
portion of the drawing in greater detail. Changing the magnification of the drawing affects 
only the way the drawing is displayed; it has no effect on the dimensions of the entities in your 
drawing. 
 
Zooming in and out 
One of the easiest ways to change the magnification of the drawing is to zoom in or out by a 

preset increment. On the Zoom toolbar, the Zoom In tool ( ) doubles the current 

magnification of the drawing. The Zoom Out tool ( ) reduces the magnification of the 
drawing by half. The portion of the drawing located at the center of the current viewport 
remains centered on the screen as you zoom in and out. 
 
 
 
 
 
 
 
 
 
 
Zoom in.                                    Zoom out 
                                    
Zooming methods 
To zoom, you can use any of the following methods: 
 

•   To define the portion of the drawing to zoom, create a window. 

•   To zoom in real time, press Ctrl +hold and drag the left mouse button, or use the Real-

Time Zoom tool ( ) on the standard toolbar. 

•   If you have a mouse with a wheel, rotate the wheel to zoom in and out. 
 
To zoom in to an area using a window 

1   Choose View > Zoom > Window.    
 

2   Select one corner of the window around the area you want to magnify. 

3   Specify the opposite corner of the window around the area you want to magnify. 
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Standard toolbar      

Command line       zoom 
 

 
 
 
 
 
 
 
 
 
 
 
 

To specify a rectangular window around the            Results 
area you want to magnify, select first one corner 
(A), and then select the opposite corner (B). 
 
 
To zoom in real time 
1 Choose View > Zoom > Realtime. 
 

2   Click and hold the left mouse button. 

3   To zoom in, move the cursor up the screen; to zoom out, move the cursor down the screen. 

4   To stop zooming, release the mouse button. 

Standard toolbar      
Command line       RTZOOM 
 
TIP Hold down the left mouse button while simultaneously pressing and holding 
Ctrl to zoom in real time. 
 
 
 
To zoom using a mouse with a wheel 

•   Rotate the wheel away from you to zoom in or toward you to zoom out. 
 
Each rotation of the wheel away from you zooms out .8 times; each rotation toward you zooms 
in 1.25 times. 
 
Displaying the previous view of a drawing 
After you zoom in or pan to view a portion of your drawing in greater detail, you may want to 

zoom back out to see the entire drawing. On the Zoom menu, the Zoom Previous tool ( ) 
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lets you restore the previous view. Selecting this tool repeatedly steps back through up to 25 
successive zoomed or panned views. 
 
Zooming to a specific scale 
You can increase or decrease the magnification of your view by a precise scale factor measured 
relative to the overall size of the drawing or in relation to the current display. When you change 
the magnification factor, the portion of the drawing located at the center of the current viewport 
remains centered on the screen. 
 
To change the magnification of the view relative to the overall size of the drawing, type a 
number representing the magnification scale factor. For example, if you type a scale factor of 
2, the drawing appears at twice its original size. If you type a magnification factor of .5, the 
drawing appears at half its original size. 
 

You can also change the magnification of the drawing relative to its current magnification by 
adding an x after the magnification scale factor. For example, if you type a scale factor of 2x, 
the drawing changes to twice its current size. If you type a magnification factor of .5x, the 
drawing changes to half its current size. 
 
To zoom to a specific scale relative to the current display 
1   On the command line, type zoom. 
 
2   Type the scale factor, followed by an x (such as 2x). 

3   Press Enter. 

Zoom toolbar      

Command line    ZOOM    
 
Combining zooming and panning 
You can specify the point you want at the center of the view when you change the drawing 
magnification. You can specify the point you want at the lower left of the view when you 
change the magnification of the drawing with the Zoom Left tool ( ) on the View toolbar. 
With the exception of the Zoom Window tool, the other zoom tools zoom in or out from the 
center of the current view. 
 
To change the center of the current view 
1   Choose View > Zoom > Center. 
 

2   Select the point you want located at the center of the new view. 

3   Specify the zoom scale factor or the height of the drawing in drawing units. 

Zoom toolbar         
Command line       ZOOM 
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Current view showing the point to be centered in the new view (A), and the new view zoomed using a scale 
factor of 2x. 
 
 
 
Displaying the entire drawing 

You can use the Zoom All tool ( ) on the zoom toolbar to display an entire drawing. If you 
have drawn any entities outside the defined limits of the drawing, the extents of the drawing 
are displayed. If you drew all entities within the limits of the drawing, the drawing is displayed 
all the way to the drawing limits. 
 

The Zoom Extents tool ( ) on the zoom toolbar displays the drawing to its extents, making 
the image fill the display to the greatest possible magnification. 
 
 

 
 
 
 
 
 
 
 
 
 

 
Zoom extents (displays all entities).             Zoom all (displays to drawing limits).  
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Displaying multiple views 

 
When you begin a new drawing, it is displayed in a single window. You can view the drawing 
in a second window, or you can divide one window into multiple windows. You can also open 
and display multiple drawings. 
 
Working with multiple views of a single drawing 
You can open and work with several views of the same drawing simultaneously. There are 
two methods for dividing the current drawing into multiple views: 

•   Open a new window of the open drawing. 

•   Divide the current window into multiple views. 
 
After you divide a single window into multiple windows, you can control each window sepa-
rately. For example, you can zoom or pan in one window without affecting the display in any 
of the other windows. You can control the grid, snap, and view orientation separately for each 
window. You can restore named views in individual windows, draw from one window to ano-
ther, and name window configurations individually so you can reuse them later. 
 

As you draw, any changes you make in one window are immediately visible in the others. 
You can switch from one window to another at any time, even in the middle of a command, by 
clicking the window’s title bar. 
 
Opening a new window of the same drawing 
You can open additional windows to create more than one view of a drawing. To open a new 
window, choose Window > New Window. After you open a new window, you can change its 
display without affecting any of the other windows. 
 

When you open more than one window for a single drawing, each window is assigned a unique 
number (for example, mydrawing:1, mydrawing:2, and so on). If your current window is max-
imized, you can switch to another open window by selecting its name from the bottom of the 
Window menu. 
 

The names of other open drawings appear at the bottom of the Window menu. You can also 
use the Cascade, Tile Horizontally, and Tile Vertically commands to arrange all the open win-
dows and drawings. To arrange all the windows and drawings into a stack of identically sized 
windows, choose Window > Cascade. Arranging windows and drawings in this way makes it 
easy to see the title bar for each window. 
 
To arrange all the windows and drawings horizontally so they are placed in order from top to 
bottom, choose Window > Tile Horizontally. Arranging windows and drawings in this way 
displays each open window. The windows are resized to fit within the available space. 
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To arrange all the windows and drawings vertically so they are placed side by side, choose 
Window > Tile Vertically. Arranging windows and drawings in this way displays each open 
window. The windows are resized to fit within the available space. 
ZwCAD uses the commands in the following table to control its windows. 
 
ZwCAD window-control commands 

Command Result 
vports Splits the current window into two, three, or four 
tiled windows. 
 

wcascade Cascades (overlaps) all open windows. 
 

wclose Closes the current window. 
 

wcloseall Closes all windows; also closes all drawings. 
 

whtile Tiles all windows horizontally. 
 

wiarrange Arranges window icons. 
 

wopen Opens another window of the current drawing. 
 

wvtile Tiles all windows vertically. 
 
 
Dividing the current window into multiple views 
You can divide a single drawing window into multiple tiled windows (called viewports) on 
the Model tab. You can control the number of windows created and the arrangement of the 
windows. You can also save and restore named window configurations and display a list of 
the current and saved window configurations. 
 
To create multiple views 
1   Choose View > Viewports 
 

2   In viewports menu, choose 1, 2, 3, or 4 viewports. 

3   Type h if you want the horizontal orientation, or type v if you want the vertical 
orientation.   

Command line       VPORT 
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You can divide a drawing window into two windows arranged vertically (A) or horizontally (B); three windows 
arranged left (C), right (D), above (E), below (F), vertically (G), or horizontally (H); or four tiled windows (I). 
 

 
To join two views 
1   Choose View > Viewports > Join. 
 

2   Click anywhere inside the window you want to keep. 

3   Click anywhere inside the adjacent window you want to join to the first window. 

4   Press Enter. 

Command line       VPORT 
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Saving window configurations 
If you have divided the drawing window into multiple views, you can save the current window 
arrangement so that you can recall it to the screen later. The number and placement of the 
windows are saved exactly as they are currently displayed. The set tings for each window are 
also saved. 
 
To name and save a window configuration 
1   Choose View > Viewports > Save Viewports. 
 

2   Type a configuration name, and then press Enter. 

The name can be up to 31 characters in length and can contain letters, numbers, the dollar 
sign ($), hyphen (-), and underscore (_), or any combination. 

Command line       VPORT 

 
 
To restore a named window configuration 
1   Choose View > Viewports  
 

2   On the command line, type restore. 

3   Type the name of the window configuration you want to restore. 
 
Working with multiple drawings 
With the multiple document interface (MDI) feature, you can open more than one drawing 
inside of ZwCAD. Because you can open and work on several drawings at one time, you can 
copy, cut, or paste an entity from one drawing to another. 
 

Each drawing appears in a drawing window, which has the following advantages: 
 

•   You can see two or more drawings side by side. 

•   You can easily copy entities from one drawing to another. 

•   Using the ZwCAD Explorer, you can copy such elements as layers, linetypes, and text 
styles from one drawing to another. 

•   Like viewports on the Model tab, you can tile or overlap drawing windows; unlike 
viewports on the Model tab, drawing windows maximize or reduce to an icon. 
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One session of ZwCAD with four drawings open. 
 
Each drawing window that you open and work on retains in the Prompt History log all the 
commands that you perform, but the command line does not indicate when you have switched 
windows. 
 

When you work with more than one drawing open in its own window, you can easily move, 
cut, copy, and paste in between drawings. If you move an entity from one window to another 
and then want to undo this action, you must undo it in both drawings for it to take effect. If 
you copy an entity from one window to another and then want to undo that action, you must 
undo it from the drawing into which you copied the entity. If you cut and paste an entity and 
then want to undo that action, you must undo it in both drawings. 
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Controlling visual elements 

 
The number of entities in your drawing and the complexity of the drawing affect how quickly 
ZwCAD can process commands and display your drawing. You can improve overall program 
performance by turning off the display of certain visual elements, such as solid fills and text, 
while you work on the drawing. When you are ready to print your drawing, turn on the display 
of these elements so your drawing prints the way you want. 
 

You can also improve performance by turning off entity selection highlighting, turning off the 
display of marker blips created when you select locations in the drawing, and by turning off 
the display of lineweights. 
 
Turning Fill on and off 
You can reduce the time it takes to display or print a drawing by turning off the display of 
solid fill. When Fill is turned off, all filled entities, such as wide polylines and planes, display 
and print as outlines. When you turn Fill on or off, you must redraw the drawing before the 
change is displayed. 
 
To turn Fill on or off 
1   Choose Tools > Options. 
 

2   Click the Display tab. 

3   Under Display performance, select or clear the Apply solid fill check box. 

4   Choose View > Redraw. 

Command line      FILL 

 

 
 
 
  
 
 
 
 
Fill on                              Fill off 
.  
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Turning Quick Text on and off 
Text entities require a considerable amount of time to display and print. You can reduce the 
time it takes to display or print a drawing by enabling Quick Text. For example, if you’re 
doing a preliminary check print of a drawing, you may want to turn Quick Text on to speed up 
printing. When Quick Text is enabled, text entities are replaced by rectangular boxes that 
indicate the outline of the area occupied by the text. When you turn Quick Text on or off, you 
must regenerate the drawing before the change is displayed. 
 
To turn Quick Text on and off 
1   Choose Tools > Options. 
 

2   Click the Display tab. 

3   Under Display performance,select or clear the Show text boundary frame only check box. 

4   Click OK. 

5   To regenerate your drawing, do one of the following: 

•   Choose View > Regen. 

•   Type regen and then press Enter. 
Command line      QTEXT 
 
 
 
 
 
 
 
 
 
 
 
 
Quick Text off.                                      Quick Text on.  
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Turning highlighting on and off 
You can improve overall program performance by turning highlighting off. When you select 
entities to modify, the program highlights them using a dashed linetype. This highlight dis-
appears when you finish modifying the entities or when the entities are cleared. Sometimes 
highlighting entities can take a considerable amount of time. 
 
To turn highlighting on and off 
1   Choose Tools > Options. 
 

2   Click the Display tab. 

3   Under Display performance, select or clear highlight raster image frame only box. 

4   Click OK. 
Command line      HIGHLIGHT 

 
 
Turning Blips on and off 
You can turn Blips off. They are the temporary markers that appear on the screen when you 
select an entity or location. Blips are visible only until you redraw the drawing. You cannot 
select Blips; they are used only for reference and never print. 
 
To turn Blips on and off 
1   On the command line, type blipmode. 
 

2   Type on or off. 

5   Press Enter. 
 
 
 
 
 
 
 
 
 
Blips on.                                              Blips off. 

 120 



                                                     V I E W I N G   Y O U R   D R A W I N G 

Controlling the display of lineweights 
You can reduce the time it takes to display a drawing by turning off the display of lineweights. 
When you turn off lineweights, all entities display as outlines. 
 

You can also specify a lineweight scale. Specify a smaller scale to display thinner lines; speci-
fy a larger scale to display thicker lines. For example, a scale factor of 0.5 would display a .80 
millimeter lineweight as .40 millimeter; a scale factor of 2 would increase the same lineweight 
to display at 1.6 millimeters. This can help you differentiate various lineweights that display in 
a drawing. Adjusting the lineweight display scale affects how the lineweights appear on your 
screen, not how they appear when printed. 
 

 
NOTE  Setting the lineweight scale too high may result in slower system performance. 
 

 
You can also adjust the units for measuring lineweights, and the default lineweight. 
 
To control the display of lineweights 
1   Choose Format > Lineweight. 

2   In Units for Listing, choose Millimeters or Inches. 

3   In Default, select the lineweight assigned to layers and entities that use the Default line-
weight. 

4   In Adjust Display Scale, move the slider to the scale you want. By default, the slider 
begins at 1.00. 

5   Click OK. 
Command line      LW 
 
 
TIP  On the status bar ,left-click the word LWT to turn the display of lineweights 
on or off. 
 

 
You can turn lineweights on or off when you print. For details, see “Choosing how lineweights 
print” on page 327. 
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Working with coordinates 
 

 
 
 
 
For accuracy in a drawing, you can locate specific points by entering coordinates as you draw 
or modify entities. When you create two dimensional entities, you enter two dimensional co-
ordinates; for three dimensional entities, you specify three dimensional coordinates. 
 

You can also specify coordinates in relation to other known locations or entities in a drawing. 
In particular, when you work in three dimensional drawings, it is often easier to specify 
coordinates in relation to a two dimensional working plane, called a user coordinate system 
(UCS). 
 
This section explains how to work with coordinates, including how to: 
 

•   Use two dimensional and three dimensional coordinate systems. 

•   Specify absolute and relative coordinates. 

•   Specify polar, spherical, and cylindrical coordinates. 

•   Define and manipulate user coordinate systems. 
 

 
 
 
 
 
 
 
 
Topics in this chapter 
 

Using Cartesian coordinates....................................................................................123 
Using two dimensional coordinates............................................................................125 
Using three dimensional coordinates ..........................................................................128 
Using xyz point filters............................................................................................131 
Defining user coordinate systems...............................................................................133 
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Using Cartesian coordinates 

 
Many commands in ZwCAD require that you specify points as you draw or modify entities. 
You can do so by selecting points with the mouse or by typing coordinate values in the com-
mand bar. The program locates points in a drawing using a Cartesian coordinate system. 
 
Understanding how coordinate systems work 
The Cartesian coordinate system uses three perpendicular axes—x, y, and z—to specify 
points in three dimensional space. Every location in a drawing can be represented as a 
point relative to a 0,0,0 coordinate point, referred to as the origin. To draw a two-
dimensional entity, you specify horizontal coordinate positions along the x axis and 
vertical coordinate positions along the y axis. Thus, every point on a plane can be 
represented as a coordinate pair composed of an x coordinate and a y coordinate. Positive 
coordinates are located above and to the right of the origin; negative coordinates are 
located to the left and below the origin. 

 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  
 The three perpendicular axes of the Cartesian 

coordinate system  
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When you work in two dimensions, you need enter only the x and y coordinates; the program 
assumes that the z axis value is always the current elevation. When you work in three dimen-
sions, however, you must also specify the z axis value. When you look at a plan view of your 
drawing (a view from above, looking down), the z axis extends straight up out of the screen at 
a 90 degree angle to the xy plane. Positive coordinates are located above the xy plane, and 
negative coordinates are below the plane. 
 
All ZwCAD drawings use a fixed coordinate system, called the World Coordinate System 
(WCS), and every point in a drawing has a specific x,y,z coordinate in the WCS. You can also 
define arbitrary coordinate systems located anywhere in three dimensional space. These are 
called user coordinate systems and can be located anywhere in the WCS and oriented in any 
direction. 
 

You can create as many user coordinate systems as you want, saving or redefining them to 
help you construct three dimensional entities. By defining a UCS within the WCS, you can 
simplify the creation of most three dimensional entities into combinations of two dimensional 
entities. 
 

To help you keep your bearings in the current coordinate system, the program displays a 
coordinate system icon. When you begin a new drawing, you are automatically in the WCS, 
indicated by the letter W in the icon. When you display a drawing in plan view, you see the 
coordinate system icon from the top, with the z axis directed straight toward you. When you 
display a three dimensional drawing in a view other than plan view, the coordinate system icon 
changes to reflect your new viewpoint. 
 
TIP The visible portions of the axes are the positive directions. 
 
 
 
 
 
 
 
 
 
WCS icon.                    Plan UCS icon 3D View WCS icon.  
 
 
Understanding how coordinates are displayed 
The current position of the cursor is displayed as x,y,z coordinates in the status bar and, by 
default, updates dynamically as you move the cursor. You can toggle the coordinate display to 
static mode by pressing F6, so that it updates only when you select a point in the drawing. 
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Finding the coordinates of a point 
To find the x,y,z coordinates for a point on an entity, such as the endpoint of a line, select an 
appropriate entity snap (such as Endpoint) before selecting the entity. If you have no entity 
snaps set, the x,y coordinates of the point you specified is displayed, with the z coordinate 
equal to the current elevation. 
 
To find the coordinate of a point in the drawing 
1   Choose Tools > Inquiry > ID Point. 
 

2   Select the point for which you want to find the coordinates. 

If the command bar is activated, the x, y, z-coordinates for the point you selected display in 
the command bar. 

If the command bar is not activated, the Command Text Tab will show the x, y, z-coordinates 
for the point you selected. 

Inquiry toolbar      

Command line      IDPOINT 
 
 

 

Using two dimensional coordinates 

 
When working in two dimensions, you specify points on the xy plane. You can specify any 
point as an absolute coordinate (or Cartesian coordinate), using the exact x coordinate and y-
coordinate locations in relation to the origin (the 0,0 coordinate point at which the two axes 
intersect), or as a relative coordinate in relation to the previous point. You can also specify 
points using relative or absolute polar coordinates, which locate a point using a distance and 
an angle. 
 
Entering absolute Cartesian coordinates 
To enter absolute Cartesian coordinates, type the coordinate location of the point in the 
command bar. For example, to use absolute Cartesian coordinates to draw a line from the 
origin (0,0) to a point 3 units to the right and 1 unit above the origin, start the Line 
command and respond to the prompts as follows: 
    
Start of line: 0,0 
 
Angle/Length/<Endpoint>: 3,1 
 

 



CHAPTER 7 

  
 

 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
Drawing a line using the absolute Cartesian coordinate method. 
 
When using absolute Cartesian coordinates, you need to know the exact point locations for 
anything you draw. For instance, to use absolute Cartesian coordinates to draw an 8.5 unit 
square with its lower left corner at 4,5, you must determine that the upper left corner is at 
coordinate 4,13.5, the upper right corner at 12.5,13.5, and the lower right corner at 12.5,5. 
 
Entering relative Cartesian coordinates 
Another, simpler method is to use relative Cartesian coordinates: you specify a location in the 
drawing by determining its position relative to the last coordinate you specified. To use rela-
tive Cartesian coordinates, type the coordinate values in the command bar, preceded by the at 
symbol (@). The coordinate pair following the @ symbol represents the distance along the x-
axis and the y axis to the next point. For example, to draw an 8.5 unit square with its lower left 
corner at 4,5 using relative Cartesian coordinates, start the Line command, and then res-pond 
to the prompts as follows: 
 
Start of line: 4,5 
 
Angle/Length/<Endpoint>: @8.5,0 
 
Angle/Length/Follow/Undo/<Endpoint>: @0,8.5 
 
Angle/Length/Follow/Close/Undo/<Endpoint>: @-8.5,0 
 
Angle/Length/Follow/Close/Undo/<Endpoint>: C 
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Drawing a square using the relative Cartesian coordinates method; enter C to close。 
 
The first relative coordinate (@8.5,0) locates the new point 8.5 units to the right (along the x 
axis) from the previous point of 4,5; the second relative coordinate (@0,8.5) locates the next 
point 8.5 units above (along the y axis) the previous point, and so on. Entering C (for Close) 
draws the final line segment back to the first point specified when you started the Line 
command. 
 
    
Entering polar coordinates 
Using relative polar coordinates makes drawing a square tilted at a 45 degree angle a simple 
task. Polar coordinates base the location of a point on a distance and angle from either the 
origin (absolute coordinate) or from the previous point (relative coordinate). 
 

To specify polar coordinates, type a distance and an angle, separated by the open angle brac-
ket (<). For example, to use relative polar coordinates to specify a point 1 unit away from the 
previous point and at an angle of 45 degrees, type @1<45. 
 

To draw the square from the example in the previous section, “Entering relative Cartesian 
coordinates,” this time tilted at a 45 degree angle, start the Line command, and then respond to 
the prompts as follows: 
 
Start of line: 4,5 
 
Angle/Length/<Endpoint>: @8.5<45 
 
Angle/Length/Follow/Undo/<Endpoint>: @8.5<315 
 
Angle/Length/Follow/Close/Und/<Endpoint>: @8.5<225 
 
Angle/Length/Follow/Close/Undo/<Endpoint>: C 
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Drawing a tilted square using the relative polar coordinates method; enter C to close. 
 
 
NOTE  This example, like all examples in this guide, assumes the program’s default 
settings: Angles increase counterclockwise and decrease clockwise. Thus, an angle of 
315 degrees is the same as 45 degrees. 
 
 
 
 

Using three-dimensional coordinates 

 
Specifying coordinates in three dimensional space is similar to working in two dimensions, 
except that you also use the z axis to locate coordinates. Three dimensional coordinates are 
represented in the format x,y,z (for example, 2,3,6). 
 
Using the right hand rule 
To visualize how ZwCAD works with three dimensional space, use a technique known as the 
right hand rule. Hold up your right hand in a loose fist with your palm facing you. Extend 
your thumb in the direction of the positive x axis and your index finger upward in the direct-
ion of the positive y axis. Then extend your middle finger straight toward you in the direction 
of the z axis. These three fingers are now pointing in the positive x, y, and z directions, 
respectively. 
 
You can also use the right hand rule to determine the positive rotation direction. Point your 
thumb in the positive direction of the axis about which you want to rotate, and then curl the 
rest of your fingers toward your palm. These fingers are curling in the positive rotation direct-
ion. 
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The right hand rule helps you determine the positive direction of the x, y, and z axes and the 
positive rotation direction. 
 
Entering x,y,z coordinates 
When working in three dimensions, you can specify x,y,z coordinates as absolute distances in 
relation to the origin (the 0,0,0 coordinate point at which the three axes intersect) or as relative 
coordinates based on the last point selected. For example, to specify a point 3 units along the 
positive x axis, 4 units along the positive y axis, and 2 units along the positive z axis, specify 
the coordinate 3,4,2. 
 
 
Entering spherical coordinates 
When working in three dimensional space, you can use spherical coordinates to specify a 
three dimensional point by entering its distance from either the origin (absolute distance) 
or the last point (relative distance), along with its angle in the xy plane and its angle up 
from the xy plane. In spherical format, you separate each angle with the open angle 
bracket (<).You can enter the coordinate values using the following format: 
X < [angle from X axis] < [angle from XY plane] 
 
Thus, to draw a line from the origin to a point 10.2500 drawing units away, at an angle of 45 
degrees from the x axis and 35 degrees from the xy plane, start the Line command, and then 
respond to the prompts as follows: 
 
Start of line: 0,0,0 
 
Angle/Length/<Endpoint>: 10.2500<45<35 
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When you draw a line from a start point (A) to an endpoint (B) using spherical coordinates, you 
specify its length (C, in this case 10.2500 units), the angle in the xy plane (D, in this case 45 
degrees), and the angle from the xy plane (E, in this case 35 degrees) 
  
. 
Entering cylindrical coordinates 
When working in three dimensional space, you can also use cylindrical coordinates to specify 
a three dimensional point. You specify a point by entering its distance from either the origin 
(absolute distance) or the last point (relative distance), its angle in the xy plane, and its z-
coordinate value. 
 

In cylindrical format, you separate the distance and angle with the open angle bracket (<) and 
separate the angle and z value with a comma. You can enter the coordinate values using the 
following format X < [angle from X axis],Z 
 
For example, to draw a line from the last point to a point 7.4750 units away, at an angle of 27 
degrees from the x axis in the xy plane and 3 units up in the z direction, start the Line 
command, and then respond to the prompts as follows: 
 
Start of line: (select point A) 
 
Angle/Length/<Endpoint>: @7.4750<27,3 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

When you draw a line from a start point (A) to an endpoint (B) using cylindrical coordinates, 
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you specify its length (C, in this case 7.4750), the angle in the xy plane (D, in this case 27 
degrees), and the distance in the z direction (E, in this case 3 units). 
 
 
 

Using xyz point filters 

 
Point filters provide a method of locating a point in a drawing relative to another point without 
specifying the entire coordinate. Using a point filter, you can enter partial coordinates, and 
then the program prompts you for the remaining coordinate information. To use xyz point 
filters, respond to the prompt for a coordinate with a filter in the following form: 
 

.coordinate 
 
where coordinate is one or more of the letters x, y, and z. The program then prompts you for 
the filtered coordinate(s). For example, if you type .xy, the program prompts you to select a 
point whose xy coordinate you want, and then prompts you for the z coordinate. The 
filters .x, .y, .z, .xy, .xz, and .yz are all valid filters. 
 
Using point filters in two dimensions 
You can use point filters when you work in two dimensions to locate points in relation to exis-
ting entities. For example, to draw a circle centered in a rectangle, start the Circle command, 
and then respond to the prompts as follows: 
 
2Point/3Point/Ttr(tan tan radius)/Arc/Multiple/<Center of circle>: .y 
 
Select Y of: mid 
 
Snap to midpoint of: (select the left side of the rectangle) Still need XZ of: mid 

Snap to midpoint of: (select top of the rectangle) Diameter/<Radius>: (specify radius 

of circle) 

 
 
 
 
 
 
 
 
 

You can use point filters to center the circle by separately selecting the midpoints of 
two sides of the rectangle (A and B) and then specifying its radius. 
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Using point filters in three dimensions 
You can use point filters when you work in three dimensional space to locate points in two 
dimensions and then specify the z coordinate as the elevation above the xy plane. For example, 
to begin drawing a line from a point with a z coordinate 3 units above the center of a circle, 
insert the circle, and then start the Line command and respond to the prompts as follows: 
 
ENTER to use last point/Follow/<Start of line>: .xy 
 
Select XY of: cen 
 
Snap to centerpoint of: (select a point on the circle) 
 
Still need Z of: 3 (locates the starting point 3 units above the center of the circle) 

Length of line: (specify the length of the line) 
 

 
 
 
 

 
 
 
 
 
 
 

You can use point filters to draw a line by first selecting a point in the xy plane (A), 
specifying the z coordinate (B), and then specifying the length of the line (C). 
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Defining user coordinate systems 

 
When working in three dimensional space, you can define a UCS with its own 0,0,0 origin 
and orientation separate from the WCS. You can create as many user coordinate systems as 
you want, and then save and recall them as you need them to simplify construction of three-
dimensional entities. 
 

For example, you can create a separate UCS for each side of a building. Then, by switching to 
the UCS for the east side of the building, you can draw the windows on that side by specifying 
only their x and y coordinates. When you create one or more user coordinate systems, the 
coordinate entry is based on the current UCS. 
 

 
 
 
 
 
 
 
 
 
 
 
UCS aligned with the front wall of the house. 
 
Defining a user coordinate system 
To define a UCS, you can use any of the following methods: 
 

•   Specify a new origin and points on the positive x and y axes. 

•   Specify a new origin and point on the positive z axis. 

•   Align the UCS with an existing entity. 

•   Rotate the current UCS around any of its axes. 

•   Align the UCS with its z axis parallel to the current viewing direction. 

•   Align the UCS xy plane perpendicular to the current view. 
 
When you define a new UCS, the UCS icon changes to indicate the origin and orientation of 
the new UCS. 
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To define a UCS by specifying a new origin and points on the positive x and y axes 
1   On the command line, type dducsp 
 

2   In the User Coordinate Systems dialog box, click Explore UCSs. 

3   In the ZwCAD Explorer, be sure that Coordinate Systems is selected, and click the New 

Item tool ( ). 
4   On the command line, type 3. 

5   Select the new origin. 

6   Select a point on the positive x-axis. 

7   Select a point in the positive y direction. 

8   In the ZwCAD Explorer  Coordinate Systems dialog box, type the name for the new UCS, 
and then close the dialog box. 
 

 
 
 
 
 
 
 
 
 

 
Define the new UCS by selecting the origin (A), a point on the positive x-axis 
(B), and a point in the positive y direction (C). 
 
Using a preset user coordinate system 
ZwCAD lets you select a preset UCS. The six planes defined by looking along the x,y,z axes 
align the UCS with the top, left, front, bottom, right, or back, based on either the WCS or the 
current UCS in effect when you select the tool. You can also select the previous UCS, align 
the UCS to the current view, or select the WCS. 
 
When you select a UCS, the cursor orientation and UCS icon change to reflect the new UCS. 
The display does not change, however, unless you select the Change View To Plan View Of 
The Selected UCS check box. 
 
After you align the UCS to a preset UCS, you can use the ZwCAD Explorer to save the UCS. 
To do this, in the ZwCAD Explorer window, choose Edit > New > UCS, and then select Cur-
rent. 
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To select a preset UCS 
1   On the command line, type dducsp. 
 

2   Under Set the Selected UCS Relative To, select either Current UCS to change to the new 
UCS by reorienting relative to the current UCS or World Coordinate System (WCS) to 
base the new UCS orientation on the WCS. 

3   Under Select UCS, click the button corresponding to the UCS you want as the new current 
UCS. 

 
 
 

A 

B 

C 

D 

E 

F 

G

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
A  Specify whether to define the new UCS relative to the 

current UCS or to the World Coordinate System 
(WCS). 

D  Click one of these buttons to select the view you want 
of a preset UCS。 

E  Click to display the ZwCAD Explorer. 
B  Select to change the display to the plan view of the 

new UCS. F  Click to align the UCS with the current view. 
G  Click to select the WCS.C  Click to select the previous UCS. 
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Working with the ZwCAD 

Explorer 
 

 
 
 
 
The ZwCAD Explorer provides a powerful and convenient way to maintain and manage many 
of the features and settings of your drawings. You can use the ZwCAD Explorer to work with 
layers, linetypes, text styles, coordinate systems, named views, blocks, and dimension styles 
within the current drawing or to copy this information between drawings. 
 

This section explains how to use the ZwCAD Explorer to: 
 

•   Manage elements related to settings and objects in your drawings. 

•   Organize information on layers and manage layers. 

•   Create and use linetypes. 

•   Load text fonts and create text styles. 

•   Select and control coordinate systems. 

•   Save and restore named views. 

•   Save, insert, and manage blocks. 

•   Copy, cut, and paste dimension styles between DWG files. 
 
 
Topics in this chapter 
 

Using the ZwCAD Explorer ...................................................................................137 
Organizing information on layers ............................................................................141 
Working with linetypes...........................................................................................152 
Working with text fonts and styles.............................................................................160 
Working with coordinate systems .............................................................................165 
Using named views................................................................................................168 
Working with blocks and external references...............................................................171 
Working with dimension styles.................................................................................177 

 

 136 



CHAPTER 8 

Using the ZwCAD Explorer 

 
The ZwCAD Explorer opens in its own, separate window, which you can move or resize. The 
ZwCAD Explorer window has its own menu and tools. 
 
To display the ZwCAD Explorer 
Choose Tools > Design Center. 

Standard toolbar    
Command line    EXPLORER  
 
The ZwCAD Explorer window has two panes, a left pane and a right pane. The elements are 
listed in the left pane, and the drawing settings are listed and described in the right pane. 
 

     
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

E

D 

C 

B 

A 

 
A  Tools on the Standard toolbar provide controls 

common to all elements. 
B  The Elements pane shows an outline view 

containing the name of every drawing currently 
open and lists the elements you can control in 

each drawing. 
C  Other toolbars appear, depending on the selection 

in the Elements pane. 
D  The named settings for the selected element. 
E  Click on a setting to change it. 

 165

 137 



WORKING WITH THE ZwCAD EXPLORER 

Using the ZwCAD Explorer, you can create, delete, or modify any of the settings for the 
currently selected element for a given drawing. You can also copy the contents of any element 
from one drawing to another. The tools and menu items on the ZwCAD Explorer provide the 
following functions: 
 
ZwCAD Explorer tools 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
Copying settings 
A particularly powerful feature of the ZwCAD Explorer is its capability of copying many of the 
settings—layers, linetypes, text styles, coordinate systems, views, blocks, or dimension styles—
from one drawing to another. If you have more than one drawing open, the ZwCAD Explorer 
makes it easy to reuse information. For example, when you copy layers from one drawing to 
another, the layer names as well as their linetypes, colors, and other settings are also copied, 
but not the objects on those layers. 
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To copy layers from one open drawing to another open drawing 
1   Choose Tools > Design Center. 
 

2   In the Elements pane, select the drawing from which you want to copy layers. 

3   If necessary, click the plus (+) symbol to expand the Elements list for the drawing, and 
then click Layers. 

4   In the Layers Settings In Drawing list (right pane), select the layers you want to copy. 

5   Choose Edit > Copy, or click the Copy tool (  ). 
6   In the Elements pane, select the drawing to which you want to copy the layers. 

7   If necessary, click the plus (+) symbol to expand the Elements list for the drawing, and 
then click Layers. 

8   Choose Edit > Paste, or click the Paste tool ( ). 

Standard toolbar    
Command line    EXPLORER 
 
 
Deleting settings 
You can use the ZwCAD Explorer to delete many of the items that appear in the Elements list. 
You can delete a layer, linetype, text style, coordinate system, view, block, or dimension style. 
 

Because you may have already created objects on a particular layer or using a particular 
linetype or text style, deleting one of these elements requires that you make certain choices 
from options the program presents. For example, if you attempt to delete a layer, the program 
prompts you to specify whether you want to move any objects from that layer to another layer. 
Every drawing has at least one layer, the default layer, named “0.” You cannot delete or 
rename this layer. Your drawing can also contain an unlimited number of additional layers, 
each of which you assign a unique name. 
 
If you try to delete a linetype, the program prompts you to specify whether you want to con-
vert all objects drawn using that linetype to a different linetype. If you attempt to delete a text 
style, the program prompts you to specify whether you want to convert all text objects created 
using that style to a different style.
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To delete a layer and relocate its objects to another layer 
1   Choose Tools > Design Center.  

2   In the elements tab，left click Layers 
 

3   From the Layer Name list, select the layer that you want to delete. 

If that layer is the current layer, layer 0 automatically becomes the current layer. 

4   Choose Edit > Delete, or click the Delete tool ( ). 

5   From the dialog box, click Change. 

6   In the drop down list, double-click the layer to which you want to relocate objects. 

Standard toolbar    
Command line    EXPLORER 
 
       
 
Purging elements 
From within the ZwCAD Explorer, you can eliminate unused blocks, layers, line types, text 
styles, or dimension styles from your drawing file. Purging unused elements can significantly 
reduce the drawing file size. 
 
To purge an element 
1   Choose Tools > Design Center. 
  

2   Select the element from which you want to purge unreferenced elements. 

3   From the Standard toolbar, select the Pruge tool ( ).  
The main drawing window appears 

4   In the command bar, do one of the following: 

•   Enter the name of the element to purge, and then press Enter. 

•   Press Enter to purge all unused elements of the selected type without confirming the 
removal of each element. 

Standard toolbar    
Command line    EXPLORER 
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Organizing information on layers 

 
Layers in ZwCAD are like the transparent overlays you use in manual drafting. You use 
layers to organize different types of drawing information. In ZwCAD, each object in a drawing 
exists on a layer. When you draw an object, it is created on the current layer. 
 

You can control the visibility of layers in individual viewports. When you turn a layer off, ob-
jects drawn on that layer are no longer visible, and they do not print. Although a layer may be 
invisible, you can still select it as the current layer, in which case new objects are also invisi-
ble until you turn the layer back on. Objects on invisible layers can also affect the display and 
printing of objects on other layers. For example, entities on invisible layers can hide other ob-
jects when you use the Hide command to remove hidden lines. 
 

You can also freeze and thaw layers. Objects drawn on frozen layers do not display, do not 
print, and do not regenerate. When you freeze a layer, its objects do not affect the display or 
printing of other objects. For example, objects on frozen layers do not hide other objects when 
you use the Hide command to remove hidden lines. In addition, you cannot draw on a frozen 
layer until you thaw it, and you cannot make a frozen layer current. 
 
You cannot freeze the current layer. If you attempt to freeze the current layer, a dialog box 
appears prompting you to specify a different layer. You also cannot freeze or thaw a viewport 
layer unless you are working in a Layout tab. 
 

You can lock or unlock layers. The objects on a locked layer are still visible and will print, but 
you cannot edit them. Locking a layer prevents you from accidentally modifying objects. 
 

Each layer has its own color, linetype, and lineweight. For drawings that use named print 
styles, layers can also have their own print style. Objects you draw on a particular layer are 
displayed in the color, linetype, and lineweight associated with that layer unless you override 
these settings. You control all of the associated settings for layers using the Layers elements in 
the ZwCAD Explorer. 
 
To display layers in the ZwCAD Explorer 
Choose Tools > Design Center. 

Standard toolbar    
Command line    EXPLORER
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A  Select Layers to display the Layers settings. 
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B  Lists named layers in the current drawing. A check 
mark indicates the current layer. 

C  Displays the color assigned to each layer. 
D  Displays the linetype assigned to each layer. 
E  Indicates the visibility status of each layer. 
F  Indicates the locked or unlocked status of each 

layer. 
G  Indicates the frozen or thawed status of each layer 

for all viewports. 
H  Indicates the lineweight assigned to each layer. 
I   Indicates the print status of each layer.. 
J  Indicates the frozen or thawed status of the layer in 

the current viewport. 
K  Indicates the frozen or thawed status of the layer for 

new viewports on a Layout tab. 
L  Sorts the layers by that property when you click a 

column head. 
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When Layers are displayed, three tools on the Layer toolbar provide the following functions: 

 
 
 Layer On/Off toggles the selected layers on and off. 
 
 

Freeze/Thaw freezes or thaws the selected layers. 
 

 
Lock/Unlock locks or unlocks the selected layers. 
 

You can change any of these settings by clicking either the tool or its current condition. You 
can edit the color, linetype, lineweight, and other properties of a layer by clicking the corres-
ponding name and selecting the values you want in the dialog box.  
 
Creating and naming layers 
You can create an unlimited number of layers in every drawing and use those layers for orga-
nizing information. When you create a new layer, it is initially assigned the color white (or 
black, depending on your system settings) and the linetype CONTINUOUS. By default, a new 
layer is also visible. After you create and name a layer, you can change its color, linetype, visi-
bility, and other properties. 
 
 
NOTE  Layer names created or renamed in ZwCAD can have up to 31 characters and  
cannot include spaces. ZwCAD will, however, display longer layer names and names 
containing spaces, such as layers created in AutoCAD 2000. 
 
 
To create a new layer 
1   Choose Tools > Design Center. 
 

2   Choose Edit > New > Layer. 

The program adds a new layer to the Layer Name list, with the default name NewLayer1. 

3   Type a name for the new layer over the highlighted default name, and then press Enter. 

4   To complete the command and return to your drawing, close the window. 

Standard toolbar    
Command line    EXPLORER 
 
 
TIP You can also create a new layer by selecting the Layers element for a drawing 

and clicking the New Item tool( ). 
 
 
To change a layer name in the current drawing 
1   Choose Tools > Design Center. 
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2   In the elements tab，click Layers. 
 

3   In the Layer Name list, select the layer you want to make current. 

4   Do one of the following: 

•   Choose Edit > Rename, type a new name, and then press Enter. 

•   Highlight the layer name you want to change, type a new name, and then press Enter. 

•   Right-click the layer name you want to change, and from the shortcut menu, select 
Rename, type a new name, and then press Enter. 

5 To complete the command and return to your drawing, close the window. 

Standard toolbar    
Command line    EXPLORER 
 
 
NOTE  You cannot rename the 0 layer. 
 
 
 
Setting the current layer 
When you create new objects, they are drawn on the current layer. To draw new objects on a 
different layer, you must first make that layer the current layer. 
 
To make a layer current 
1   Choose Tools > Design Center. 
2   In the elements tab, click Layers 
 

3   In the Layer Name list, select the layer you want to make current. 

4   Do one of the following: 

•   Choose Edit > Current. 

•   In the Layer Name list, select the name you want to make current, and then click the 
Current tool ( ). 

•   Double-click the layer name in the Layer Name list. 

•   Right-click the layer name you want to change, and from the shortcut menu select 
Current. 

5  To complete the command and return to your drawing, close the window. 

Standard toolbar    
Command line    EXPLORER 
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Controlling layer visibility 
A layer can be visible or invisible. Objects on invisible layers are not displayed and do not 
print. By controlling layer visibility, you can turn off unnecessary information, such as con-
struction lines or notes. By changing layer visibility, you can put the same drawing to multiple 
uses. 
 
For example, if you are drawing a floor plan, you can draw the layout of light fixtures on one 
layer and the location of plumbing lines on another. By selectively turning layers on and off, 
you can print the electrical engineering drawings and the plumbing drawings from the same 
drawing file. For even more convenience, you can control the visibility of layers within indi-
vidual viewports, so that layers that display in one viewport are invisible in other viewports in 
the same drawing. 
 

When you turn a layer off, objects drawn on that layer are no longer visible. When you turn 
the layer back on, the objects on that layer are redisplayed. 
 
To turn layers on or off 
1   Choose Tools > Design Center. 
2   In the elements tab，click Layers 
 

3   In the Layer Name list, select the layer you want to turn on or off. 

4   Do one of the following: 

•   Choose View > On/Off. 

•   Right-click the layer you want to change, and from the shortcut menu, select Properties 
and turn the layer on or off. 

•   Click the setting in the On/Off column. The On/Off column shows the new setting. 

5   To complete the command and return to your drawing, close the window. 

Standard toolbar    
Command line    EXPLORER 
 
You can also freeze layers to improve the performance of operations such as zooming and pan-
ning or producing hidden lines or shaded images. When a layer is frozen, objects drawn on 
that layer are no longer visible. 
 

To control the visibility of external reference layers and save any changes made to them in the 
current drawing, turn on Xref Layer Visibility. 
 
To turn on Xref Layer Visibility 
1. Choose Tools > Design Center. 
2. In the elements tab，click Layers 
 

3. Choose View > Xref Layer Visibility. 
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Standard toolbar    
Command line    EXPLORER 
 
 
TIP  You can also turn on this variable by typing visretain. 
 
 
 
To freeze or thaw layers 
1   Choose Tools > Design Center. 
2   In the elements tab，click Layers 
 

3   In the Layer Name list, select the layers you want to freeze or thaw. 

4   Do one of the following: 

•   Choose View > Freeze/Thaw. 

•   Right click the layer you want to change, and from the shortcut menu, select Properties 
and freeze or thaw the layer. 

•   Click the setting in the All Viewports column. The All Viewports column shows the new 

setting. 

5   To complete the command and return to your drawing, close the window. 

Standard toolbar    
Command line   EXPLORER 
 
 
Locking and unlocking layers 
Locking a layer makes it easy to refer to information contained on the layer, but prevents you 
from accidentally modifying its objects. When a layer is locked (but visible and thawed), its 
objects remain visible, but you cannot edit them. If you lock the current layer, you can still add 
new objects to it. You can also change the linetype and color associated with a locked layer. 
Unlocking a layer restores full editing capabilities. 
 
To lock or unlock layers 
1   Choose Tools > Design Center. 
2   In the elements tab，click Layers 
 

3   In the Layer Name list, select the layers you want to lock or unlock. 

4   Do one of the following: 

•   Choose View > Lock/Unlock. 

•   Right click the layer name you want to change, and from the shortcut menu, select 
Properties and lock or unlock the layer. 

•   Click the setting in the Locked column. The Locked column shows the new setting. 
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5   To complete the command and return to your drawing, close the window. 

Standard toolbar    
Command line    EXPLORER 
 
 
Controlling layer printing 
Controlling layer printing is another way you can specify which objects print in your drawing. 
 

By controlling layer printing, you can turn off unnecessary information during printing. For 
example, if you are drawing a floor plan, you can draw the layout of light fixtures on one layer 
and the location of plumbing lines on another. By selectively turning layers on and off when 
you print, you can print the electrical engineering drawings and the plumbing drawings from 
the same drawing file. By changing layer printing, you can put the same drawing to multiple 
uses. 
 

When you turn off printing for a layer, objects drawn on that layer are still visible, but they do 
not print. If you turn off a layer’s visibility, objects drawn on that layer do not display or print. 
Controlling layer printing can be especially helpful if you want layer visibility on, but do not 
want to print objects on that layer. 
 

Layer visibility must be turned on in order to print objects drawn on that layer. 
 
To turn layer printing on or off 
1   Choose Tools > Design Center. 
2   In the elements tab，click Layers 
 

3   In the right pane, click the setting in the Print column for the layer you want to change. 
Choose Yes to print objects assigned to the layer. Choose No to omit entities assigned to 
the layer during printing. 

You can also right-click the layer you want to change, and from the shortcut menu, select Pro-
perties and change the print setting for a layer. 

Standard toolbar    
Command line    EXPLORER 
 
 
Setting the layer color 
Each layer in a drawing is assigned a color. ZwCAD uses the BYLAYER color as the default 
color setting for object creation so that new objects are drawn in the color of the layer on 
which they are inserted (set in the Drawing Settings dialog box). 
 

Using the ZwCAD Explorer, you can set or change the color assigned to a layer. With the 
direct editing feature, you can click on the color you want to change, and then select a new 
color from the dialog box that appears. Changing a layer’s color automatically changes the 
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color of all objects on that layer with the BYLAYER color. 
 
To change the layer color 
1   Choose Tools > Design Center. 
2   In the elements tab，click Layers 
 

3   In the right pane, click the color swatch for the layer you want to change. 

Standard toolbar    
Command line    EXPLORER 
 
TIP Right-click the name of the layer you want to change, and from the shortcut menu, 
select Properties and change the layer color. 
 

 
3   In the Color dialog box, select a color on one of the following tabs: 

•   Index Color — Click BYBLOCK, BYLAYER, or one of the 255 index colors. You can 
also type the color number in the Index box. 

•   True Color — Click a basic color, click a color in the color palette, enter the Hue, Saturation, 
and Luminance (HSL) values, or enter the Red, Green, Blue (RGB) values. There are 
more than 16 million true colors from which you can choose. 

•   Color Books — Select a color book from the list, then click a color. You can select Show 
Only Color Book Colors Used in Drawing to limit the selection to only those color book 
colors that are used in the current drawing. 

4   Click OK. 
 
NOTE You can also assign a specific color to an object, which overrides the layer’s color 
setting. When you create a new object, use the Format > Color command to change the 
current color. For an existing object, select the object, right click for the shortcut menu, 
and choose Properties. You can then change the object’s color in the Object Properties 
dialog box. 

 
For more details about using color in the many aspects of your drawing, see “Working with 
colors” on page 42. 
 
Setting a layer’s linetype 
Each layer uses a default linetype (a repeating pattern of dashes, dots, or blank spaces). Linetype 
determines the appearance of objects both on the screen and when printed. 
 

It’s a good idea to assign the BYLAYER linetype to any objects that you draw on that layer. 
ZwCAD uses the BYLAYER linetype as the default linetype setting for Object Creation (in 
the Drawing Settings dialog box). 
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Using the ZwCAD Explorer, you can set or change the linetype assigned to a layer. With the 
direct editing feature, you can click on the linetype you want to change, and then select a new 
linetype from the dialog box that appears. Changing the linetype assigned to a layer changes 
the linetype of all objects drawn on that layer with the BYLAYER linetype. 
 
 
NOTE  Only those linetypes already set in the drawing can be assigned to layers. For 
more information about setting additional linetypes, see “Working with linetypes” on 
page 152 in this chapter. 
 
 
To change the linetype assigned to one or more layers 
1   Choose Tools > Design Center. 
2   In the elements tab，click Layers. 
 

3   In the right pane, click the linetype for the layer you want to change. 

4   In the Linetype dialog box, select a new linetype for the layer, or click Browse to select 
your linetype file. 

You can also right click the layer you want to change, and from the shortcut menu, select 
Properties and change the linetype assigned to a layer. 

Standard toolbar    
Command line    EXPLORER 
 
 
NOTE  You can also assign a specific linetype to an object, which overrides the layer’s 
linetype setting. When you create a new object, use the Format > Linetype command to 
change the current linetype through the ZwCAD Explorer. For an existing object, sel-  
ect the object, right click for the shortcut menu, and choose Properties. You can then 
modify the object’s linetype in the Object Properties dialog box. 
 
 
Setting a layer’s lineweight 
Each layer uses a default lineweight. Lineweights determine the thickness of objects both on the 
screen and when printed. 
 

All new layers are assigned the DEFAULT lineweight, which is .25 millimeters or .01 inches. 
If you want a different lineweight assigned to a layer, you can easily change it using ZwCAD 
Explorer. For example, you may want different lineweights on each layer of your drawing to 
show separate elements, such as walls, dimensions, structural steel, and electrical plans. Chan-
ging the lineweight assigned to a layer changes the lineweight of all objects drawn on that 
layer with the BYLAYER lineweight. 
 
When you create new objects, it’s a good idea to assign the BYLAYER lineweight to any ob-
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jects that you draw on that layer, unless you want to override the layer lineweight. ZwCAD 
uses the BYLAYER lineweight as the default lineweight setting when you create objects (in 
the Drawing Settings dialog box). 
 

 
TIP  To change the DEFAULT lineweight, choose Settings > Drawing Settings, click 
the Display tab, select Lineweights in Change Settings For, and then select a new 
default. 
 
 
To change the lineweight assigned to one or more layers 
1   Choose Tools > Design Center. 

2   In the elements tab，click Layers. 
 

3   In the right pane, click the lineweight for the layer you want to change. 

4   In the Lineweight list, click the arrow to scroll the lineweights, and then select a new 
lineweight for the layer. 

You can also right click the layer you want to change, and from the shortcut menu, select 
Properties and change the lineweight assigned to a layer. 

Standard toolbar    
Command line   EXPLORER 
 
 
 
NOTE  You can also assign a specific lineweight to an object, which overrides the lay- 
er’s lineweight setting. When you create a new object, use the Format > Lineweight to 
change the current lineweight. For an existing object, select the object, right click for the 
shortcut menu, and choose Properties. You can then modify the object’s lineweight in the 
Object Properties tab. 
 
 
Setting a layer’s print style 
If your drawing uses named print style tables, you can specify a print style for each layer. 
Named print style tables contain print styles that you set up to control what objects look like 
when they print, without actually changing the objects in the drawing. 
 

If your drawing uses color-dependent print style tables, you cannot specify a print style for a 
layer. These types of print style tables automatically determine printing requirements by the 
color assigned to a layer or an object. For details about converting a drawing that uses color-
dependent print style table to use named print style tables, see “Changing a drawing’s print 
style table type” on page 336. 
 

In drawings that use named print style tables, the default print style is Normal for all new 
layers. If desired, you can assign a print style using ZwCAD Explorer. Changing the print style 
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assigned to a layer changes the print style of all objects drawn on that layer with the 
BYLAYER print style. 
 
When you create new objects, it’s a good idea to assign the BYLAYER print style to any ob-
jects that you draw on that layer, unless you want to override the layer print style. ZwCAD 
uses the BYLAYER print style as the default print style setting when you create objects (in the 
Drawing Settings dialog box). 
 
 
To change the print style assigned to one or more layers (only in a drawing that uses 
named print style tables) 
1   Choose Tools > Design Center. 
 

2   In the right pane, click the print style for the layer you want to change. 

3   If necessary, select a different print style table in the Active Print Style Table list. 

4   In Print Styles, select a print style. 

5   Click OK. 

You can also right click the layer you want to change, and from the shortcut menu, select 
Properties and change the print style assigned to a layer. 
 
NOTE  For drawings that use named print style tables, you can also assign a specific 
print style to an object, which overrides the layer’s print style setting. When you create 
a new object, use the Settings > Drawing Settings > Object Creation tab to change the 
current print style. For an existing object, select the object, right click for the shortcut  
menu, and choose Properties. You can then modify the object’s print style in the Ob-  
ject Properties dialog box. 
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Working with linetypes 

 
ZwCAD provides simple and complex linetypes: 
 

•   A simple linetype consists of a repeating pattern of dots, dashes, or blank spaces. 

•   A complex linetype contains embedded shape and text objects along with dots, dashes, 
and spaces. 

You can use different linetypes to represent specific kinds of information. For example, if you 
are drawing a site plan, you can draw roads using a continuous linetype, a fence using a using 
a linetype of dashes with square posts, or a gas line using a complex linetype showing the text 
“GAS”. 
 
By default, every drawing has at least three linetypes: CONTINUOUS, BYLAYER, and 
BYBLOCK. You cannot rename or delete these linetypes. Your drawing may also contain an 
unlimited number of additional linetypes. You can load more linetypes into the program from 
a linetype library file or create and save linetypes you define. 
 
 
To display the ZwCAD Explorer Linetypes element 
Choose Tools > Design Center. 

Standard toolbar    
Command line    EXPLORER 
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A

B C D

E 

 

 
A  Select Linetypes to display the Linetypes settings. D  Shows how linetypes will appear in the drawing. 

E  Sorts the linetypes by that property when you click a 
column head. 

B  Lists names of linetypes loaded in the current 
drawing. A check mark indicates the current linetype. 

C  Describes linetypes loaded in the current drawing. 
 
 
 
Setting the current linetype 
You normally draw an object using the linetype assigned to the current layer, indicated as 
BYLAYER. You can also assign linetypes on a per object basis, which over rides the layer’s 
linetype setting. A third option is to assign the BYBLOCK linetype, whereby you draw new 
objects using the default linetype until you group them into a block. The objects inherit the 
current linetype setting when you insert the block into 
the drawing. 
 
To make the linetype current 
1   Choose Tools > Design Center. 
2   In the elements tab，click Linetype.  
 

3   In the Linetype Name list, select the linetype you want to make current. 

4   Do one of the following: 

•   Choose Edit > Current. 

•   Select it in the Linetype Name list and click the Current tool ( ). 

•   Double click the linetype name. 
 

5   To complete the command and return to your drawing, close the window. 
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Standard toolbar    
Command line   EXPLORER 
 
 
Loading additional linetypes 
Before you can select a new linetype to use in a drawing, you must either create the linetype 
definition or load a predefined linetype from a linetype library file (*.lin). ZwCAD includes a 
linetype library file, icad.lin, which contains more than 100 predefined linetypes. 
 
To load a new linetype from a linetype library 
1   Choose Tools > Design Center. 
2   In the elements tab，click Linetype. 
 

3   Using one of the following methods, open the New Linetype dialog box: 

•   Choose Edit > New > Linetype. 

•   Click the New Item tool ( ). 

•   With the cursor in the right pane of the window, right click to display the shortcut menu, 
and then choose New > Linetype. 

4   Click Choose From File. 

5   Click Browse. 

6   Select the linetype library file, and then click Open. 

7   Select the linetype you want to load. 

8   Click OK, and then close the window. 

Standard toolbar    
Command line   EXPLORER 
 
 
Creating and naming linetypes 
In addition to loading predefined linetypes from a linetype library file, you can create new line-
types. You can save new linetypes you create to a linetype library file for use in other drawings. 
 
 
NOTE  Linetype names created or renamed in ZwCAD can have up to 31 characters 
and cannot include spaces. ZwCAD will, however, display longer linetype names 
and names containing spaces, such as linetypes created in AutoCAD 2000. 
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To create a new simple linetype 
1   Choose Tools > Design Center. 

2   In the elements tab，click Linetype. 
 

3   Using one of the following methods, open the New Linetype dialog box: 

•   Choose Edit > New > Linetype. 

•   Click the New Item tool ( ). 

•   With your cursor in the right pane of the window, right click to display the shortcut 
menu, and choose New > Linetype. 

4   In the Linetype Description field, type the linetype description. 

You can type anything in this field that will help you remember the purpose or appearance of 
this linetype. For example, it is helpful to type text or symbols such as __..__.. that approxi-
mate the appearance of the linetype. 

5   In the Linetype Definition field, type the linetype definition. 

The definition consists of positive and negative numbers separated by commas. A positive 
number draws a solid line segment for the specified number of drawing units; a negative 
number creates a gap for the specified number of units; a zero creates a dot. 

6   Click OK. 

The program adds the new linetype to the linetypes list with the default name, NewLinetype1. 

7   To enter a name for the new linetype, type over the highlighted default text, and press 
Enter. Do not use spaces between words in the new linetype name. 

7   To complete the command and return to your drawing, close the window. 

Standard toolbar    
Command line   EXPLORER
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A 

B 

C 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
A  Click to select a predefined linetype from a linetype 

library file. C  Type the definition of the linetype, consisting of 
positive and negative numbers separated by 
commas. B  Type any description in this box that helps you 

remember the purpose or appearance of the 
linetype. 

  
  

A complex linetype can denote utilities, boundaries, contours, and so on. As with simple line-
types, complex lines are dynamically drawn as the user specifies vertices. Shapes and text ob-
jects embedded in lines are always displayed completely; they are never trimmed. 

1   Choose Tools > Design Center. 
2   In the elements tab, click Linetype. 
3   Using one of the following methods, open the New Linetype dialog box: 

•   Choose Edit > New > Linetype. 

•   Click the New Item tool ( ). 

•   With your cursor in the right pane of the window, right click to display the shortcut menu, and 
choose New > Linetype. 

4   In the Linetype Description field, type the linetype description. 

You can type anything in this field that will help you remember the purpose or appearance of 
this linetype. For complex linetypes, it is helpful to type a text description of the linetype. 
5   In the Linetype Definition field, type the linetype definition. 

As for the simple linetypes, the syntax for a complex linetype is a comma deliminated list of 
pattern descriptors. For more details, see “Syntax for a complex linetype definition” on page 
157 in this chapter. 

Standard toolbar    
Command line   EXPLORER
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6   Click OK. 
The program adds the new linetype to the linetypes list with the default name, NewLinetype1. 

7   To enter a name for the new linetype, type over the highlighted default text, and press 
Enter. Do not use spaces between words in the new linetype name. 

8   To complete the command and return to your drawing, close the window. 
 
Syntax for a complex linetype definition 
Complex linetypes can include shape and text objects as pattern descriptors, as well as the 
dash and dot descriptors of simple linetypes. 
 
The shape descriptor syntax 

You can add a shape object to a complex linetype using the following syntax: 
 
[shape_name, shape_filename] or [shape_name, shape_filename, transform] The definitions 

of the fields in the syntax are as follows. 

shape_name The name of the shape to add to the linetype. The shape name must exist in the 
specified shape file (shape_filename). 
 

shape_filename The name of a compiled shape definition file (extension *.shx). If no path is 
defined for the shape file name, the library path is searched for the file. 
 

transform The transform argument is optional and can be any series of the following (each 
preceded by a comma):  
R=value    Relative rotation  
A=value    Absolute rotation  
S=value    Scale 
X=value    X offset 
Y=value    Y offset 
 
In this syntax, value represents a signed decimal number. The rotation is expressed in degrees 
while the other options are in linetype scaled drawing units. 
 

rotation R=value or A=value. 
R= determines a relative or tangential rotation with respect to the line’s elaboration. A= deter-
mines an absolute rotation of the shape with respect to the origin. All shapes have the same 
rotation regardless of their relative position to the line. The value can be appended with a d for 
degrees (default), r for radians, or g for grads. If rotation is omitted, 0 relative rotation is used. 
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scale S=value. 
 
Determines a factor by which the shape's internal scale is multiplied. If the shape's internal 
scale is 0, the scale value is used as the scale. 
 

X offset X=value. 
 
Determines a shift of the shape along the X axis of the linetype computed from the end of the 
linetype definition vertex. If X offset is omitted or is 0, the shape is elaborated with no offset. 
Include this field if you want a continuous line with shapes. This value is not scaled by the 
scale factor defined by S. 
 

Y offset Y=value. 
 
Determines a shift of the shape along the Y axis of the linetype computed from the end of the 
linetype definition vertex. If Y offset is omitted or 0, the shape is elaborated with no offset. 
This value is not scaled by the scale factor defined by S. 
 
The text descriptor syntax 

You can add a text object to a complex linetype using the following syntax: 
 
["string", style_name] or ["string", style_name, transform] The definitions of the fields in the 

syntax are as follows. 

string The text to be used in the complex linetype. You cannot use the ` or the " characters in 
the text string. To use these characters, enter a control code (%%) with the ASCII value for the 
character instead. 
 

style_name The name of the text style to be elaborated. The specified text style must be 
included. If it is omitted, use the currently defined style. 
 

transform The transform argument is optional and can be any series of the following 
(each preceded by a comma):  

R=value    Relative rotation  

A=value    Absolute rotation  

S=value    Scale 

X=value    X offset 
 
Y=value    Y offset 
 
In this syntax, value represents a signed decimal number. The rotation is expressed in degrees 
while the other options are in linetype scaled drawing units. 
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rotation R=value or A=value. 

R= determines a relative or tangential rotation with respect to the line’s elaboration.  

A= determines an absolute rotation of the text with respect to the origin.  

All text has the same rotation regardless of its relative position to the line. The value can be 

appended with a d for degrees (default), r for radians, or g for grads. If rotation is omitted, 0 

relative rotation is used. 
 

Rotation is centered between the baseline and the nominal cap heights box. 
 
scale S=value. 
 
Determines a factor by which the style's height is multiplied. If the style's height is 0, the scale 
value is used as the scale. 
 

Because the final height of the text is defined by both the scale value and the height assigned 
to the text style, you will achieve more predictable results by setting the text style height to 0. 
It is recommended that you create separate text styles for text in complex linetypes to avoid 
conflicts with other text in your drawing. 
 
X offset X=value. 
 
Determines a shift of the text along the X axis of the linetype computed from the end of the 
linetype definition vertex. If X offset is omitted or is 0, the text is elaborated by using the lower 
left corner of the text as the offset. Include this field if you want a continuous line with text. 
This value is not scaled by the scale factor that is defined by S. 
 

Y offset Y=value. 
 
Determines a shift of the text along the Y axis of the linetype computed from the end of the 
linetype definition vertex. If Y offset is omitted or is 0, the text is elaborated by using the lower 
left corner of the text as the offset. This value is not scaled by the scale factor that is defined 
by S. 
 
Editing linetypes 
 
To change a linetype name 
1   Choose Tools > Design Center. 

2   In the elements tab，click Linetype. 
 

3   Do one of the following: 

•   Select the linetype, and then choose Edit > Rename. 

•   Click the linetype name you want to change, and then type the new name. 

•   Right click the linetype name you want to change, and from the shortcut menu, select 
Rename. 
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4   To complete the command and return to your drawing, close the window. 

Standard toolbar    

Command line    EXPLORER 

 
To change a linetype definition 
1   Choose Tools > Design Center. 
2   In the elements tab，click Linetype. 
 

3   Right click on the linetype name for which you want to change the definition. 

4   From the shortcut menu, select Properties. 

5   In the Linetype Definition field, define the linetype using positive and negative numbers 
and zeros. 

A positive number draws a solid line segment for the specified number of drawing units. A 
negative number creates a gap for the specified number of drawing units. A zero creates a dot. 

6   To complete the command and return to your drawing, close the Linetypes dialog box 
and the ZwCAD Explorer window. 

Standard toolbar    
Command line    EXPLORER 
 
 
NOTE  You cannot rename the CONTINUOUS, BYBLOCK, or BYLAYER linetypes. 
 
 
 
 

Working with text fonts and styles 

 
When you add text to a drawing, it is created using the current text style. The text style 
determines the font, size, angle, orientation, and other text characteristics. 
 

Every drawing has at least one text style, named Standard, which initially uses the txt font. 
You cannot delete the Standard style, but you can rename it or modify it. For example, you 
can change the font or the oblique angle applied to the font. You also can use an unlimited 
number of additional text styles in your drawing. 
 
From the ZwCAD Explorer, you can directly edit any setting associated with a text style by 
using the single click editing method to change the setting. 
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To display the ZwCAD Explorer Text Styles element 
Choose Tools > Design Center. 

Standard toolbar    
Command line   EXPLORER 
 
 

 

A

B C D E F G H I J K L 

M 

A  Select Text Styles to display the text style settings. G  Displays the font style, such as bold or italic. 
H  Displays the language on which the text style is based. B  Lists names of text styles defined in the current 

drawing.  I   Displays whether Asian language big font files are 
used (for .shx file fonts only). C  Displays the height assigned to the text style. 

J  Indicates whether text will appear backward. D  Displays the width factor assigned to the text style. 
E  Displays the oblique angle assigned to the text style. K  Indicates whether text will appear upside down. 
F  Displays the font on which the style is based. L  Indicates whether text will appear vertically. 

M  Click any column head to sort the styles by that 
property. 
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Creating and naming text styles 
Fonts are character sets that consist of letters, numbers, punctuation marks, and symbols. Each 
font is stored in its own font file. Text styles apply additional formatting to fonts. You can 
create multiple text styles based on the same font, changing the various characteristics to alter 
the appearance of the font. To create a new text style, you assign formatting characteristics to 
a font. 
 

ZwCAD uses *.shx font files and provides a selection of fonts. These fonts are located in the 
ZwCAD/Fonts directory. You can also use any font designed to work with AutoCAD. Many 
fonts are available from third party vendors. 
 

 
NOTE  Text style names created or renamed in ZwCAD can have up to 31 characters and 
cannot include spaces. ZwCAD will, however, display longer text style names and names 
containing spaces, such as text styles created in AutoCAD. 
 
 
To create a new text style 
1   Choose Tools > Design Center. 
 

2   Choose Edit > New > Style. 

3   Select the font on which you want to base the new style, and then click Open. The 

program adds a new style to the text styles list with the default name, NewStyle1. 

4   Type the name for the new style by typing over the highlighted default text, and then 
press Enter. 

5   To complete the command, close the window. 

Standard toolbar    
Command line   EXPLORER  
 
 
TIP You can also create a new text style by selecting the Text Styles element and click- 

ing the New Item tool( ). 
 
 
To change a text style name in the current drawing 
1   Choose Tools > Design Center. 
2   In the elements tab，click Text Styles.. 
 

3   Do one of the following: 

•   Select the text style, choose Edit > Rename, type a new name, and then press Enter. 

•   Click the text style name you want to change, type a new name, and then press Enter. 
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•   Right click the text style name you want to change, and from the shortcut menu, select  
Rename, type a new name, and then press Enter. 

4 To complete the command and return to your drawing, close the window. 

Standard toolbar    
Command line    EXPLORER 

 
Modifying text styles 
A new text style is initially assigned default values for height, width factor, oblique angle, and 
other characteristics. You can change these values for both new and existing text styles. You 
can also change the font assigned to the text style. If you change the font or orientation pro-
perties of a text style assigned to text previously inserted in the drawing, all text using that 
style is regenerated to reflect the changes. Oblique angle and height, if specified, are given by 
the style definition when text is created, but are not updated for existing text when the style is 
changed. 

 
A fixed text height value of 0 allows you to specify the text height at the time you insert text 
into the drawing. Any other value sets height of the text to that value; the program does not 
prompt for the text height when you insert text into the drawing. The width factor determines 
the horizontal scaling of text. A value less than 1 compresses the text (for example, 0.75 
compresses the text 25 percent); a value greater than 1 expands the text (for example, 1.50 
expands the text 50 percent). The oblique angle determines the forward or backward slant of 
text as an angle offset from 90 degrees. Negative values slant text to the left; positive values 
slant text to the right. 
 
To modify a text style 
1   Choose Tools > Design Center. 
 

2   Select the text characteristic of a style that you want to modify. 
The text characteristic either toggles its value or a dialog box appears, allowing you to make 
the modifications you want. 

3 To complete the command, close the ZwCAD Explorer window. 

Standard toolbar    
Command line    EXPLORER 
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Setting the current text style 
When you insert text in a drawing, the text is created using the current text style. You can also 
select a different text style when you create text. 
 
To make the text style current 
1   Choose Tools > Design Center. 
2   In the elements tab，click Text styles. 
 

3   In the Text Style Name list, click the style you want to make current. 

4   Use one of the following methods to make the style the current style: 

•   Choose Edit > Current. 

•   Click the Current tool ( ). 

•   With the cursor in the right pane of the window, right-click to display the shortcut menu, 
and choose Current. 

5   To complete the command and return to your drawing, close the ZwCAD Explorer 
window. 

Standard toolbar    

Command line    EXPLORER 

 
 
TIP You can also make a text style current by selecting it in the Text Style Name list 
and clicking the Current tool ( ) or by double clicking the text style name in the 
Text Style Name list. 
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Working with coordinate systems 

 
When you create objects in a drawing, they are located in relation to the drawing’s underlying 
Cartesian coordinate system. Every drawing has a fixed coordinate system called the World 
Coordinate System (WCS). You cannot delete or modify the WCS. 
 

Your drawing may contain additional coordinate systems, however, each with its own 0,0,0 
origin and orientation. You can create as many user coordinate systems as you want, and then 
save and recall them as you need them. You can edit the origin of a coordinate system from 
within the ZwCAD Explorer by single clicking the origin coordinates and then typing new 
coordinates. 
 

For example, you can create a separate user coordinate system (UCS) for each side of a 
building. Then, by switching to the UCS for the east side of the building, you can draw the 
windows on that side by specifying only their x and y coordinates. 
 

You can create and then switch between various user coordinate systems by selecting 
Coordinate Systems in the ZwCAD Explorer. 
 
 
To display the Coordinate Systems element 
. Choose Tools > Design Center. 

Standard toolbar    
Command line   EXPLORER 
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A  Select Coordinate Systems to display the 

Coordinate Systems settings. 
B  Lists names of coordinate systems defined in the current drawing.  

E  Displays the y axis direction of the coordinate 
system in relation to the WCS. 

C  Displays the origin of the coordinate system in 
relation to the WCS. 

D  Displays the x axis direction of the coordinate 

system in relation to the WCS. 

F  Click any column head to sort the coordinate 
systems by that property. 

 
 
Defining and naming user coordinate systems 
A drawing can contain as many coordinate systems as you want and can be named appropriate 
names so you can remember how they are used in your drawing for recalling them later. 
 

 
NOTE  Coordinate system names created or renamed in ZwCAD can have up to 31 
characters and cannot include spaces. ZwCAD will, however, display longer coordinate  
system names and names containing spaces, such as coordinate systems created 
in AutoCAD 2000. 
 
 
To define new user coordinate systems in the ZwCAD Explorer 
1   Choose Tools > Design Center. 
2   In the elements tab，click Coordinate Systems. 
 

3   Do one of the following: 

•   Choose Edit > New > UCS. 

•   Click the New Item tool ( ). 

•   With your cursor in the right pane of the window, right click to display the shortcut 
menu, and choose New > UCS. 

B C D E

F 

A 
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4   Select a method from command bar by which to define the UCS in the drawing window. 

For example, select 3 Point and then specify three points in the drawing window to 
define the x, y, and z axes for your coordinate system. 

5   Type the name for the new user coordinate system by typing over the highlighted default 
text, and then press Enter. 

6   To complete the command, close the window. 

Standard toolbar    

Command line   EXPLORER 

 

To change a user coordinate system name in the current drawing 

1   Choose Tools > Design Center. 

2    In the elements tab，click Coordinate Systems. 
 

3   Do one of the following: 

•   Select the user coordinate system, and then choose Edit > Rename, type a new name, and 
then press Enter. 

•   Click the user coordinate system name you want to change, type a new name, and then 
press Enter. 

•   Right-click the user coordinate system name you want to change, and from the shortcut  
menu, select Rename, type a new name, and then press Enter. 

4   Type the new user coordinate system name, and then press Enter. 

5   To complete the command and return to your drawing, close the window. 

Standard toolbar    
Command line    EXPLORER 
 
Setting the current user coordinate system 
When you draw new objects, they are created in relation to the current coordinate system. You 
can set the current UCS from the ZwCAD Explorer. 
 
To set the current UCS from the ZwCAD Explorer 
Do one of the following: 
•   Double-click the UCS name in the UCS Name list. 

•   Select the UCS in the UCS Name list, and then choose Edit > Current. 

•   Select the UCS in the UCS Name list, and then click the Current tool. 
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Using named views 

 
As you work on a drawing, you may find that you frequently switch among different portions 
of it. For example, if you are drawing the floor plan of a house, you may zoom in to particular 
rooms of the house and then zoom out to display the entire house. Although you can repeat the 
Pan and Zoom commands to do this, it is much easier to save various views of the drawing as 
named views. You can then quickly switch among these views. You can save and later restore 
named views using either the View command or the Views element in the ZwCAD Explorer. 
 
To display Views in the ZwCAD Explorer 
Choose Tools > Design Center. 

Standard toolbar    

Command line    EXPLORER 

A 

B C D E

F 

 
 
 
 
A  To display the Views settings, select Views. E  Displays the direction of the view, expressed as a 

three- dimensional coordinate in the WCS. B  Lists names of views defined in the current drawing.  
F  Click any column head to sort the views by that 

property.
C  Displays the height of the view in drawing units. 
D  Displays the width of the view in drawing units. 

 

 168 



CHAPTER 8 

 
Saving and naming views 
You can save the view displayed in the current window as a named view. After you save a 
named view, you can restore that view in the current window at any time. 
 

 
NOTE  View names created or renamed in ZwCAD can have up to 31 characters 
and cannot include spaces. ZwCAD will, however, display longer view names and 
names containing spaces, such as views created in AutoCAD 2000. 
 
 
To save the current view as a named view 
1   Choose View > Named Views. 
 

2   On the command line, type save. 

3   Type a name for the view, and then press Enter. 

4   To complete the command and return to your drawing, close the window. 

Standard toolbar    
Command line     VIEW 
 
To save a portion of the current view as a named view 
1. Choose Tools > Design Center. 
 

2. Choose Edit > New > View. 
 

3. On the command line, type Window. 

4. Specify the first corner of the view window. 

5. Specify the opposite corner of the view window. 

6. Rename the new view, and then press Enter. 

Do not use spaces between words in the new view name. 

7. To complete the command and return to your drawing, close the window. 

Standard toolbar    
Command line   EXPLORER 

 
 
TIP You can also create a new view by selecting the Views element in the ZwCAD 

Explorer and clicking the New Item tool( ). 
 
 
To change a saved view name in the current drawing 
1   Choose Tools > Design Center. 
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2   Do one of the following: 

•   Select the view, choose Edit > Rename, type a new name, and then press Enter. 

•   Click the view name you want to change, type a new name, and then press Enter. 

•   Right click the view name you want to change, and from the shortcut menu, select 
Rename, type a new name, and then press Enter. 

3   Type the new view name, and then press Enter. 

4   To complete the command and return to your drawing, close the window. 

Standard toolbar    
Command line   EXPLORER 
 
 
Restoring named views 
After you save one or more named views, you can restore any of those views in the current 
window using either the View command or the ZwCAD Explorer. 
 
 
 
To restore a named view using the View command 
1   Choose View > Named Views. 
 

2   On the command line, type restore. 

3   Type the name of the view you want to restore, and then press Enter. 

Standard toolbar    

Command line      VIEW 
 
To restore a named view from the ZwCAD Explorer 
Do one of the following: 

•   Select the view name in the list of View settings, and then choose Edit > Current. 

•    Select the view name in the list of View settings, and then click the Current tool( ).  

•   Double-click the view name in the View list. 
 
 
Changing named view properties 
Once you create a named view you can modify its properties, such as the target direction and 
twist angle. This gives you access to many of the view settings after a view has been defined. 
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To change the view options 
1   Choose Tools > Design Center. 
 

2   Select the view whose properties you want to change. 

3   Choose Edit > Properties. 

You can also right click the view you want to change, and from the shortcut menu, select 
Properties. 

4   Change the values of the settings on any of the tabs and close the dialog box. 

5   To complete the command and return to your drawing, close the window. 

Standard toolbar    
Command line    EXPLORER 
 
 
 

Working with blocks and external references 

 
Blocks represent a special type of object that, once saved, can be inserted and manipulated in 
the drawing as a single object. A block can consist of visible objects such as lines, arcs, and 
circles as well as visible or invisible data called attributes. You can use attributes to track 
things such as part numbers and prices and to export attribute information to an external 
database. You can also track the number of parts by counting the number of times a block has 
been inserted into the drawing. Blocks are stored as part of the drawing file. 
 
External references have similar uses to blocks. Using external references, you can attach en-
tire drawings to your current drawing. Unlike a block, however, an external reference does not 
become part of the current drawing. 
 

You can save blocks in the ZwCAD Explorer. You can also use the ZwCAD Explorer to 
manage and insert copies of blocks. The ZwCAD Explorer lists the names of all blocks 
contained in the current drawing, along with other information about each block or external 
reference. 
 
You can also rename a block, modify its insertion point, and change the path of an externally 
referenced drawing by single-clicking on the property and making your edits within the 
ZwCAD Explorer. 
 
To display blocks in the ZwCAD Explorer 
Choose Tools > Design Center. 
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Standard toolbar    

Command line   EXPLORER 

The Blocks element in the ZwCAD Explorer defaults with images on. The Images view shows 
you a small image of each block or external reference. 

 
 
 
 
 
 
 
 
 
 
 
 

The Images view shows an image of each block in the selected drawing. Click an image to select it. 
 
 
When blocks are displayed, additional tools on the Block toolbar provide the functions 
described in the following table: 
 
Additional tools on the Block toolbar 

 

 

 
 
 
 
 

 
Additional tools on the Block toolbar 

 
 
 
 
 
 
 
 
 

 
To see more information about each block, click the Details tool (   ). In the Details view, you 
can edit the path and the insertion point by clicking the setting and typing your changes. 
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F 

A

B C D E
 
  
A  To display the Blocks settings, select Blocks. 
B  Lists names of blocks and external references 

defined in the current drawing. 
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C  Displays the number of occurrences of the block in 
the current drawing. 

D  Displays the insertion point of the block in the 

current drawing. 
E  Displays the name and path for externally 

referenced drawings. 
F  Click any column head to sort the blocks by that 

property.

 
 
Creating and naming blocks 
You can combine any number of objects into a single block. After you create a block, you can 
insert copies of it into a drawing. Each block insertion is treated as a single object; for example, 
you can rotate or scale each block when you insert it. The program adds the name of the new 
block you insert to the Block Name list in the ZwCAD Explorer. 
 

 
NOTE  Block names created or renamed in ZwCAD can have up to 31 characters 
and cannot include spaces. ZwCAD will, however, display longer block names and 
names containing spaces, such as blocks created in AutoCAD 2000. 
 
 
To create a block 
1   Choose Tools > Design Center. 
 

2   Choose Edit > New > Block. 
 

3   Enter a name for the new block. 

4   Specify the insertion point for the block. 

5   Select the objects to be combined into the block, and then press Enter. 

The program adds a new block to the blocks list, with the name you entered for it. 

6   To complete the command and return to your drawing, close the window. 
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Standard toolbar    

Command line    EXPLORER 
 
To change a block name in the current drawing 
1   Choose Tools > Design Center. 
 

2   Do one of the following: 

•   Select the block, choose Edit > Rename, type a new name, and then press Enter. 

•   Click the block name you want to change, type a new name, and then press Enter. 

•   Right click the block name you want to change, and from the shortcut menu, select 
Rename, type a new name, and then press Enter. 

3   To complete the command and return to your drawing, close the window. 

Standard toolbar    

Command line    EXPLORER 

 
Inserting a block 
You can insert into a drawing any block listed in the Block Name list in the IntelliCAD 
Explorer. This includes blocks contained within any open drawing. 
 
To insert a block 
1   Choose Tools > Design Center. 
 

2   If you want to insert a block from another open drawing, select the drawing in the 
Elements pane. (If the block is contained within the same drawing, you can skip this 
step.) 

3   In either the Details or Images view, select the block to be inserted. 

4   On the ZwCAD Explorer toolbar, click the Insert tool (.    ) 
5   In the drawing, specify the insertion point. 

6   Specify the x, y, and z scale factor and the rotation angle, or in the prompt box, select 
Done. 

7   To complete the command and return to your drawing, close the window. 

Standard toolbar    
Command line   EXPLORER 
 
TIP  You can also insert a block by choosing Tools > ZwCAD Explorer, and then 
Double clicking the name of the block you want to insert in the Block Name list. 
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TIP  You can also insert a block from the Insert menu. see Chapter 13, “Working with 
blocks, attributes, and external references.” 
 
 
Inserting a drawing as a block 
You can insert as a block another drawing into the current drawing. After you do this, the block 
name is added to the Block Name list in the ZwCAD Explorer. Changes made later to the 
inserted drawing will not be reflected in this drawing. 

 
To insert a drawing as a block 
1   Choose Tools > Design Center. 
 

2   On the ZwCAD Explorer toolbar, click the Insert External File Blocks tool (     ). 
3   In the Insert Block dialog box, select the drawing you want to insert, and then click Open. 

4   In the drawing, specify the insertion point. 

5   Specify the x, y, and z scale factor and the rotation angle, or in the prompt box, select 
Done. 

6   To complete the command and return to your drawing, close the window. 

Standard toolbar    
Command line    EXPLORER 
 
 
Attaching a drawing as an external reference 
You can attach another drawing to the current drawing as an external reference and insert a 
copy of the drawing into the current drawing. The name of the external reference drawing is 
added to the Block Name list. Changes made later to the referenced drawing will appear in 
this drawing when you reload the external reference. 
 
To attach an external reference 
1   Choose Tools > Design Center. 

2   On the ZwCAD Explorer toolbar, click the Attach Drawing tool (    ). 

3   In the Select File To Attach dialog box, select the drawing you want to attach, and then 
click Open. 

4   In the drawing, specify the insertion point. 

5   Specify the x, y, and z scale factor and the rotation angle, or in the prompt box, select 
Done. 
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6   To complete the command and return to your drawing, close the window. 

Standard toolbar    
Command line   EXPLORER 
 
To edit the path of an external reference 
1   Choose Tools > Design Center. 
 

2   Click the path you want to change. 

3   From the Insert Block dialog box, select the new drawing you want as the external 
reference. 

4   Click Open. 

5   To complete the command and return to your drawing, close the window. 

Standard toolbar    
Command line    EXPLORER 

 
 
 
Saving a block as a separate drawing 

You can save a block as a separate drawing, and then you can open and modify that drawing 
as you would any other drawing. 
 
To save a block as a separate drawing file 
1   Choose Tools > Design Center. 
 

2   In either the Details or Images view, select the block you want to save. 

3   On the ZwCAD Explorer toolbar, click the Save Block To Disk tool (    ). 
4   In the Save Block dialog box, select the folder in which you want to save the block. 

5   In the File Name field, type a name for the new drawing file (or accept the default, in 
which case the new drawing name is the same as the name of the block), and then click 
Save. 

Standard toolbar    
Command line   EXPLORER 
 
 
NOTE You can also work with external references using the Xref Manager. For 
details, see “Working with external references” on page 297. 
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Working with dimension styles 

 
From the ZwCAD Explorer, you can use the Dimension Styles element to cut, copy, and paste 
dimension styles from one drawing to another. 
 

 
TIP You can select the dimension style and use the Windows shortcut keys (Ctrl+A to 
select all, Ctrl+X to cut, Ctrl+C to copy, Ctrl+V to paste) to accomplish the same re- 
sults. You can use these shortcut keys with all other ZwCAD Explorer elements as well. 
 

 
A dimension style contains the settings that control the appearance of a dimension. Although 
you cannot control these settings from within the ZwCAD Explorer, you can use the Dimension 
Settings dialog box to control settings related to the appearance of arrows, lines, text, units, 
and other formatting characteristics. 
 
To display the ZwCAD Explorer Dimension Styles element 
Choose Tools > Design Center. 

Standard toolbar    
Command line   EXPLORER 

  

A 

B 

C 

C  Click the Dimension Style Name column head 
to sort by name. 

A  To display the Dimension Styles settings, select Dimension 
Styles. 
B  Lists the names of dimension styles defined in the current 
drawing. 
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Creating and naming dimension styles 
By using the Dimension Styles element in combination with the Dimension Settings dialog 
box, you can create new dimension styles, modify them, and copy them into a different 
drawing. 
 

 
NOTE  Dimension style names created or renamed in ZwCAD can have up to 31 cha-  
racters and cannot include spaces. ZwCAD will, however, display longer dimension  
style names and names containing spaces, such as dimension styles created in Auto- 
CAD 2000. 
 
 
To create a dimension style 
1   Choose Dimension > Style. 
 

2   In the Dimension Style dialog box, click New. 

3   Type the name of the new dimension style. 

4   Click Continue. 

5   In the Dimension Settings dialog box, click one of the other tabs, and then change the 
dimension settings as necessary. Repeat this step for each tab, as needed. 

6 To end the command, click OK. 

Dimension toolbar    

Command line    DIMSTYLE 
 
To change a dimension style name in the current drawing 
1   Choose Dimension > Style. 
 

2   Do one of the following: 

•   Select the dimension style, choose Edit > Rename, type a new name, and then press 
Enter. 

•   Click the dimension style name you want to change, type a new name, and then press 
Enter. 

•   Right click the dimension style name you want to change, and from the shortcut menu, 
select Rename, type a new name, and then press Enter. 

3   To complete the command and return to your drawing, close the window. 

Dimension toolbar    
Command line    DIMSTYLE 
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To copy a dimension style from one drawing to another 
1   Choose Tools > Design Center 
 

2   Right click the dimension style name you want to copy. 

3   From the shortcut menu, select Copy. 

4   In the left pane, select the drawing to which you want to copy the dimension style. 

5   Click the Dimension Styles element for that drawing. 

6   In the right pane, right click, and then from the shortcut menu, select Paste. 

Standard toolbar    
Command line    EXPLORER 

 
 
NOTE  Each drawing contains a dimension style named Standard. You cannot delete 
this dimension style, but you can rename it from within the ZwCAD Explorer or 
modify its properties in the Dimension Settings dialog box. 
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Getting drawing information 
 

 
 
 
 
ZwCAD stores accurate, detailed information about all the objects in a drawing. You can get 
details about an existing drawing and its objects using the tools for measuring distances and 
calculating areas. You can also track the amount of time you spend editing a drawing. This 
section explains how to: 

•   Measure distances along an object. 

•   Measure distances and angles. 

•   Divide an object into a number of equal segments. 

•   Calculate areas. 

•   Display information about objects in a drawing. 

•   Track the amount of time spent editing a drawing. 
 
Many of the functions described in this section require that you set ZwCAD to the Advanced 
experience level. 
 
 
 
 
 
 
 
 
 
 
Topics in this chapter 
 

Specifying measurements and divisions.....................................................................181 
Calculating areas...................................................................................................183 
Calculating distances and angles...............................................................................187 
Displaying information about your drawing................................................................188 
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Specifying measurements and divisions 

 
You can divide a line, arc, circle, polyline, ellipse, or spline into a number of equal segments 
or mark off intervals of a specific length along an object. (Note that divide is not the same as 
break.) For example, you may want to place station-point markers every 50 feet along the 
centerline of a roadway or divide the plan view of a window into three equal width sections of 
glass, placing a mullion at each division point. 
 

To specify measurements and divisions, use these commands: 
 

•   For the length of the segments, use the Measure command. 

•   For the number of equal length segments, use the Divide command. 
 
You can measure or divide arcs, circles, lines, polylines, ellipses, and splines. With either 
command, you can identify the segments by placing either a block or point object at the end of 
each interval. If you use points, you can snap to the ends of intervals using the point object 
snap. The appearance of the point objects is determined by the current point display type, 
which you control in the Point Style dialog box of Format menu. 
 
To use a block as the marker, the block must already be defined in the current drawing. You 
can further indicate whether to rotate the block to align perpendicularly to the object you are 
measuring or dividing. 
 
 
 
 
 
 
 
 
 
Block not aligned with object. Block aligned with object. 
 
ZwCAD begins measuring or dividing based on the point at which you select the object and 
the type of object with which you are working. For most objects, measuring starts from the 
endpoint closest to the point you used to select the object. If you select the object to be mea-
sured or divided using a method other than pointing (for example, using a window or fence 
selection), the program prompts you to specify the end from which you want to begin mea-
sureing. 
 
Measuring intervals on objects 
You can mark specified length increments along a selected object using either a point object 
or a block. 
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To measure intervals along an object and mark them using point objects 
Advanced experience level 
 

1   Choose Draw > Point > Measure. 
 

2   Select the object. 

3   Specify the segment length, and then press Enter. 

Command line   MEASURE 

 
 
 
 
 

 
When you select the object by pointing, intervals are measured from the end 
closest to the point at which you select the object (A). Blocks or point objects (B) 
are placed along the object at the specified interval. 
 
To measure intervals along an object and mark them using blocks 
Advanced experience level 
 

1   Choose Draw > Point > Measure. 
 

2   Select the object. 

3   On the command line, type block. 

4   Type the name of the block you want to insert as the marker. 

5   Enter y to align the blocks with the measured object. Enter n to use a rotation angle of 0 
degrees. 

6   Specify the segment length, and then press Enter 
Command line   MEASURE 
 

Dividing objects into segments 
You can place markers along a selected object, dividing that object into a specified number of 
equal length segments. You can use either a point object or a block to mark the segments. 
 
To divide an object into segments and mark them using point objects 
Advanced experience level 
 

1   Choose Draw > Point > Divide. 
 

2   Select the object. 

3   Specify the number of segments, and then press Enter. 
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Command line   DIVIDE 
 

 
 
 
 
 

 
When you select the object by pointing, divisions are marked beginning from the end closest to the 
point at which you select the object (A). Blocks or point objects (B) are placed along the object to 
mark it in equal intervals. 
 
To divide an object into segments and mark them using blocks 
Advanced experience level 
 

1   Choose Draw > Point > divide. 
 

2   Select the object. 

3   On the command line, type block. 

4   Type the name of the block you want to insert as the marker. 

5   Enter y to align the blocks with the measured object. Enter n to use a rotation angle of 0 
degrees. 

6   Specify the number of segments, and then press Enter. 

Command line   DIVIDE 

 

 

Calculating areas 

 
You can calculate the area and perimeter of a polygon based on a series of points you specify 
or enclose with a circle or closed polyline. You can also determine the area of several com-
bined objects and add or subtract the area of one or more objects from a total combined area. 
 
Calculating areas defined by points 
You can find the area and perimeter of any closed region by specifying a series of points. The 
program calculates the area and perimeter of the space that is enclosed by an imaginary poly-
gon consisting of straight line segments connecting each point. 
 
To calculate the area defined by points you specify 
1   Choose Tools > Inquiry > Area. 
 

 183 



CHAPTER 9 

2   Specify the first point. 

3   Specify the second point. 

4   Continue specifying points in sequence to define the perimeter of the area you want to 
measure. 

As you select each successive point, the resulting polygon is displayed on the screen. 

5   To complete the calculation, press Enter. 

The area and perimeter of the region you defined are displayed. For example, the following 
type of information is displayed: 
Area = 11.0583, Perimeter = 15.3092 

 Inquiry toolbar    
 Command line   AREA 
 

 
 
 
 
 
 
 
 

 
Select the points (A, B, C) that form a polygon. The area and 
perimeter of the region are then calculated. 
 
 
Calculating areas of closed objects 
You can find the area of any closed object. In addition, the program calculates either the 
circumference or the perimeter of the object, depending on the type of object you select. 
 
To calculate the area of a closed object 
1   Choose Tools > Inquiry > Area. 
 

2   On the command line, type e (entity). 

3   Select the closed entity. 

The following type of information is displayed: 
 
Area = 62.3837, Circumference = 27.9989 

Inquiry toolbar    
Command line   AREA 
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Calculating combined areas 
You can find the total area of several combined regions by specifying points or by selecting 
objects. You can also subtract the areas of objects or polygons from a running total. 
 
To add areas to calculate a combined area 
1   Choose Tools > Inquiry > Area. 
 

2   On the command line, type a (add). 

3   Using one of the following methods, identify the first area: 

•   Specify points defining a polygon, and then press Enter. 

•   Type e (entity), select the entities you want to add, and then press Enter to complete the 
calculations. 

4   To complete the command, press Enter. 

Inquiry toolbar    
Command line   AREA 
 
To subtract areas when calculating a combined area 
1   Choose Tools > Inquiry > Area. 
 

2   On the command line, type a (add). 

3   Using one of the following methods, identify the first area: 
•   Specify points defining a polygon, and then press Enter. 

•   Type e (entity), select the entities you want to add, and then press Enter to complete the 
calculations. 

4   On the command line, type s (subtract). 

5   Using one of the following methods, identify the area to be subtracted: 
•   Specify points defining a polygon, and then press Enter. 

•   Type e (entity), select the entities you want to subtract, and then press Enter to complete 
the calculations. 

6 To complete the command, press Enter. 

Inquiry toolbar    

Command line   AREA 
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To calculate the area of the gasket using the Area command, first add 
the area of the entire gasket (A), and then subtract the areas of the two circles (B and C). 
 
As you select objects, the program displays the calculations. If the command bar is displayed, 
the information appears there. If the command bar is not displayed, the program opens the 
Prompt History window and displays the calculations. The following type of information is an 
example of what is displayed: 
 
Entity/Add/Subtract/<First point>: Choose Add Areas Together Adding: 

Entity/Subtract/<First point>: Choose Add Entities to Area Adding area: <Select 

entities>: Select the first entity 

Area = 64.6259, Perimeter = 33.3049 
 
Total length = 33.3049 
 
Total area = 64.6259 
 
Adding area: <Select entities>: press Enter 
 
Adding: Entity/Subtract/<First point>: Choose Subtract Areas 
 
Subtracting: Entity/Add/<First point>: Choose Subtract Entities from 

Area 
 
Subtracting area: <Select entities>: Select the first entity to subtract 
 
Area = 3.1597, Circumference = 6.3012 
 
Total length = 27.0036 
 
Total area = 61.4662 
 
Subtracting area: <Select entities>: Select the second entity to subtract 
 
Area = 3.1597, Circumference = 6.3012 
 
Total length = 20.7024 
 
Total area = 58.3066 
 
Subtracting area: <Select entities>: Press Enter 
 
Subtracting/ Entity/Add/<First point>: Choose Done 

 186 



GETTING DRAWING INFORMATION 

Calculating distances and angles 

 
You can calculate the distance between any two points you select. The following information 
is displayed: 

•   The distance between the points, measured in drawing units. 

•   Their angle in the xy plane. 

•   Their angle measured from the xy plane. 

•   The change (delta) in the x, y, and z distances between the two points. 
 
To calculate the distance between two points and their angle 
1   Choose Tools > Inquiry > Distance. 
 

2   Specify the first point. 

3   Specify the second point. 

Inquiry toolbar    
Command line   DIST 
 
The following type of information is displayed: 
 
Distance = 13.2850, Angle in XY Plane = 31º, Angle from XY Plane = 0º Delta X = 

11.3878, Delta Y = 6.8418, Delta Z = 0.0000 

 

 
 
 
 
 
 
  
 

 
 
Use the Distance command to calculate the distance (A) between two points (B 
and C), the angle in the xy plane (D), the angle from the xy plane, and the delta 
x (E), delta y (F), and delta z distances between the two points. 
 
 
TIP  To use specific points on selected objects, use object snaps to select the precise 
points on the objects. 
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Displaying information about your drawing 

 
You can display a variety of information about a drawing and the objects it contains, including: 

•   Information in the drawing database about selected objects. 

•   The current drawing status. 

•   The time spent working on the drawing. 
 
This information is displayed in the Prompt History window and in the command bar. 
 
Displaying information about objects 
You can display information about the selected objects. The information varies, depending on 
the type of objects you select. All of the listings display the following information: 

•   Object type. 

•   Layer. 

•   Color. 

•   Linetype. 

•   The location of the object (its xyz coordinates relative to the current user coordinate 
system [UCS]). 

•   The current space (model space on the Model tab or paper space on a Layout tab). 

•   The size of the object (the information varies, depending on the object type). 
 
To display information about an object 
Advanced experience level 
 

1   Choose Tools > Inquiry > List. 
 

2   Select one or more objects. 

3   Press Enter. 

Inquiry toolbar    
Command line   LIST 
 
 
TIP   To return to the drawing window, press F2. 
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The following type of information is displayed: 
 
------ Circle --------------------------------------------------- Handle: 2C 

Current space: Model 
 
Layer: 0 
 
Color: BYLAYER Linetype: CONTINUOUS Handle: 4C 

Current space: Model 
 
Center point: X= -5.8583 Y= 7.2752 Z= 0.0000 
 
Radius: 4.4562 
 
Circumference: 27.9989 
 
Ar

 
ea: 62.3837 

Displaying the drawing status 
You can display information about the current status of a drawing, including: 

•   Drawing name. 

•   Limits. 

•   Insertion base point. 

•   Snap and grid settings. 

•   Current layer, color, and linetype. 

•   Current settings for various modes (fill, grid, orthogonal, snap, blips, and so on). 
 
To display the drawing status 

Advanced experience level 
 

Choose Tools > Inquiry > Status. 

Command line   STATUS 

 
The following type of information is displayed: 
 
Current drawing name: Site Plan 
 
Drawing limits are: X=0.0000 Y=0.0000 Z=0.0000 
 
X=12.0000 Y=9.0000 Z=0.0000 
 
Paper space limits are: X=0.0000 Y=0.0000 Z=0.0000 
 
X=12.0000 Y=9.0000 Z=0.0000 
 
Screen width (pixels): 971 
 
Screen height (pixels): 569 
 
Insertion base is: X=0.0000 Y=0.0000 Z=0.0000 
 
Snap resolution is: X=0.5000 Y=0.5000 Z=0.0000 
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Grid spacing is: X:0.5000 Y:0.5000 Z=0.0000 
 
Current layer: 0 
 
Current color: BYLAYER Current linetype: BYLAYER Current elevation: 0.0000 

Current thickness: 0.0000 
 
Fill: on Grid: off Ortho: off Snap: off Blips: off Drag: on 

Command echo: on 
 
Positive angle direction: Counterclockwise 
 
Angular units: Decimal degrees 
 
Dimension units: Decimal 
 
Pick box height: 3 
 
Ob

 
jects in drawing: 288 

Tracking time spent working on a drawing 
You can display information about the amount of time you have spent working on a drawing, 
including: 

•   The date and time the drawing was created. 

•   The date and time the drawing was most recently saved. 

•   The total amount of time spent working on the drawing. 

•   The time spent working on the drawing during the current editing session. You can turn 

the elapsed time timer on and off or reset it to zero. 

 

To display the timer information 
Advanced experience level 
 

1   Choose Tools > Inquiry > Time. 
 

2   You can do following commands: 

•   Type on to turn the elapsed timer on. 

•   Type off to turn the elapsed timer off. 

•   Type display to redisplay the timer information. 

•   Type reset to reset the elapsed timer to zero. 
 

3 Press Enter to exit the command. 

Command line   TIME 
 
Each time you display the timer information, the following type of information is displayed: 
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The current time is Fri Dec 19 09:58:43 1997 
 
Drawing was created on: Wed 17 Dec 1997 at 16:17:59.8090 
 
Drawing was last updated on: Thur 18 Dec 1997 at 09:58:43.3040 
 
Total editing time: 1  2: 35:4.2345 
 
Elapsed timer (on): 0  1: 21:5.6324 
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Modifying objects 
 

 
 
 
 
ZwCAD provides many editing tools for modifying a drawing. You can easily move, rotate, or 
stretch drawing objects, or change their scale. When you want to remove an object, you can 
delete it with a few clicks of the mouse. You can also make multiple copies of any object and 
copy objects from one drawing to another. 
 

You can modify most objects using general purpose editing commands, many of which are 
located on the Modify toolbar and the Modify menu. Some complex entities require special 
commands. This section explains how to: 

•   Select objects using object selection methods and grips. 

•   Change the properties of objects. 

•   Rearrange objects by moving, rotating, or changing the display order. 

•   Resize objects by stretching, scaling, extending, trimming, or editing their lengths. 

•   Break and join objects. 

•   Group objects. 

•   Edit polylines. 

•   Explode objects. 

•   Create chamfers and fillets. 
 
 
Topics in this chapter 
 

Selecting objects ..................................................................................................193 
Modifying the properties of objects.........................................................................197 
Deleting objects ...................................................................................................199 
Copying objects ...................................................................................................199 
Rearranging objects ..............................................................................................207 
Resizing objects ...................................................................................................210 
Breaking and joining objects..................................................................................219 
Grouping objects..................................................................................................222 
Editing polylines ..................................................................................................225 
Exploding objects.................................................................................................231 
Chamfering and filleting objects .............................................................................232 
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Selecting objects 

 
You can create a selection set that consists of one or more objects before you modify them. 
Use any of the following methods to create a selection set: 
 

•   Choose a command or tool first, and then select objects. 

•   Select objects first, and then choose a command or tool (most objects). 

•   Select objects by pointing, and then use grips to modify them. 

 
 
To create a Window Inside 
1   Click to select a point in the drawing. 

2   Click to the right of the first point to select a second point in the drawing. 
 
 
 
 
 
 
 
 
 
 
 

   Window-Inside by selecting the first (A) and second (B) points.  Resulting selection. 
 
This method is most commonly referred to as simply a window or selection window. 
 
To create a Crossing Window 
1   Click to select a point in the drawing. 

2   Click to the left of the first point to select a second point in the drawing. 
 

 
 
 
 
 
 
 
 
 

Crossing Window by selecting the first (A) and              Resulting selection. 
second (B) points. 
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In addition to a rectangular window, you can define a selection window using other shapes 
such as a polygon, circle, or fence (a multisegmented line that selects objects it crosses). 
 
 
To select objects using Window Polygon 

1   Activate an object modification command. 

2   On the command line, type wpolygon. 

3   Specify the vertices of the polygon. 

4   To complete the selection polygon, press Enter. 

 
 
 
 
 
 
 
 
 
 
 

Window Polygon by specifying the vertices of the          Resulting selection.  
polygon (A, B, and C). 
 
To select objects using Fence 
1   Activate an object modification command. 

2   On the command line, type fence. 

3   Specify the endpoints of the Fence segments. 

4   To complete the Fence, press Enter. 
 
 
 
 
 

 
 
 
 
 

Fence by specifying the endpoints of the fence                 Resulting selection. 
  segments (A, B, and C) .        
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Choosing the command first 
When you choose an object modification tool or command, the program prompts you to select 
objects. If you type ? on the command line, it will display some methods for selecting. You can 
select individual objects or use other techniques such as selection windows to select multiple 
objects. 
 

When you select objects, you add them to the selection set. After you select at least one object, 
you can remove objects from the selection set. To finish adding objects to the selection set, 
press Enter. Most object-modification commands then act on the entire selection set. 
 
Selecting objects first 
You can select objects first and then choose how to modify them. As you select each object, it 
is highlighted with small squares called grips, which appear at strategic points on the object. 
 
The locations of the grips depend on the type of object selected. For example, grips appear at 
the endpoints and midpoint of a line, at the quadrant points and center point of a circle, and at 
the endpoints, midpoint, and center of an arc. 
 
 
 
 
 
 
 
 
 
Examples of grip locations. 
 
After you select one or more objects, you can choose an object modification command, such as 
Copy or Move, from the Modify menu or toolbar. You can also click the right mouse button to 
display a shortcut menu containing the object modification commands appropriate for the sel-
ected objects, and then choose the command from the menu. 
 

When you select objects and then issue a command, the program immediately acts on the 
objects you’ve selected. In many cases, a command specific prompt box provides additional 
options for that editing operation. If you want to modify the selection set at that point, right-
click to display the prompt box with the selection options and choose the option you want. To 
redisplay the command specific prompt box, right click again. 
 
Deselecting objects 
If an object is no longer needed in a selection set, you can deselect it to remove it from the 
selection set. 
 
To remove an object from the selection set 
Press Shift, and then select the object again. 
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NOTE Pressing Shift while selecting objects using a crossing window removes all 
objects from the specified selection set. 
 
 
To remove all objects from the selection set 
Press Escape. 
 
Turning grips on and off 
You can turn the use of grips on and off and control the size and color of grips. 
 
To change grip settings 

1   Choose Tools > Options. 
 

2   In the Options dialog box, click the Selection tab. 

3   Under the Grips tab, change the desired settings, and then click OK. 

Command line   OPTIONS 
 
 

A 

B 
C 
D 
E 
F 

G 

 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
A  Display and select the grip size. E  Click to activate grip tips. 
B  Click to assign the color for grips. F  Click to activate grip attraction 

field and choose the points. C  Click to activate grips for all selected objects. 
G  Type the number of objects 
selection limit for display of grip. 

D  Click to activate grips in block. 
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Editing with grips 
To use grips for editing, you select an object to display the grips, and then click a grip to make 
it active. The grip you select depends on the type of object you’re modifying and the editing 
operation you’re performing. For example, to move a line object, drag it by its midpoint grip. 
To stretch the line, drag one of the endpoint grips. You do not need to enter a command when 
using grips. 
 

Modifying the properties of objects 

 
You can change the layer, thickness, linetype, color, and linetype scale of one or more objects. 
Depending on the type of object or objects you select, you can also change other properties, 
such as the start point and endpoint of lines, the center point and radius of circles, and the 
vertices of polylines. 
 

You can modify all the properties of all objects simultaneously. For example, using the ent-
prop command, select all objects on a particular layer, and then move the entities to another 
layer by simply selecting a name from the Layer text box. 
 

In the Object Properties dialog box, changes that you make in the Layer, Color, Thickness, 
Lineweight, Linetype, Linetype Scale, and Print Style (if using named print style tables) fields 
affect all selected objects. If you select several objects that all have different properties, the 
default value initially is Varies. Changes that you make in the object tabs, such as Circle, Line, 
and Arc, affect all selected objects of that type. You can select the objects to be changed using 
any object selection method. 
 
To modify properties of objects 

1   Choose Modify > Properties. 
2   Select the objects, and then press Enter. 

3   Make changes to the desired properties, and then click OK. 

Modify toolbar      
Command line      PROPERTIES 

 
 
TIP Use the Object Properties toolbar to change the properties of selected objects. 
Note that the Object Properties toolbar settings that display when no objects are 
selected determine the properties of new objects when you draw them. 
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The Object Properties dialog box, is also called tool palettes. Tool palettes are tabbed areas 
within the Tool Palettes window that provide an efficient method for organizing, shar-
ing, and placing blocks and hatches. Tool palettes can also contain custom tools pro-
vided by third party developers. 
 
Tool palettes are tabbed areas within the Tool Palettes window. The items you add to a 
tool palette are called tools. You can create a tool by dragging any of the following, 
one at a time, onto your tool palette: 
 
■    Geometric objects such as lines, circles, and polylines 
■    Dimensions 
■    Blocks 
■    Hatches 
■    Gradient fills 
■    Raster images 
■    External references (xrefs). 
 

. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

The ZwCAD Object Properties dialog box. 
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Deleting objects 

 
You can remove objects from a drawing. You can delete objects using any of the object-
selection methods. 
 
To delete a selection set 
1   Choose Edit > Erase. 
 

2   Select the objects, and then press Enter. 

Modify toolbar       
 Command line      ERASE 
 
 
TIP  Typing the Undelete command restores the most recently deleted selection set. If 
you have made additional modifications since deleting the objects, use Undelete 
rather than Undo to restore those objects without reversing those modifications. 
 
 
 
 

Copying objects 

 
You can copy one or more objects, making one copy or multiple copies within the current 
drawing. You can also copy objects between drawings. 
 
Use any of the following methods to copy objects within the current drawing: 
 

•   Create a copy at a location referenced from the original. 

•   Create a copy aligned parallel to the original. 

•   Create a copy as a mirror image of the original. 

•   Create several copies in a rectangular or circular pattern. 
 
Copying objects within a drawing 
You can duplicate objects within the current drawing. The default method is to create a selec-
tion set and then specify a starting point, or base point, and an endpoint, or displacement point, 
for the copy. You can also make multiple copies or copy the selection set to a location you 
specify, using a direction vector. 
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To copy a selection set once 
1   Choose Modify > Copy. 
 

2   Select the objects, and then press Enter. 

3   Specify the base point. 

4   Specify the displacement point. 

Modify toolbar       
Command line       COPY 

 
 
 
 
 
 
 
 
 
 
 

Object to copy (A), base point (B), and                Result.  
displacement point (C). 
 
To make multiple copies of a selection set 
1   Choose Modify > Copy. 
 

2   Select the objects, and then press Enter. 

3   On the command line, type multiple. 

4   Specify the base point. 

5   Specify the displacement point of the first copy. 

6   Specify the displacement point of the next copy. 

7   Continue specifying displacement points to place additional copies. 
8   To complete the command, press Enter. 

Modify toolbar       
Command line       COPY 
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To make multiple copies of an object, select the Result. 
object to copy (A), specify the base point (B),  
and then specify the displacement points (C, D, and E). 
 
Copying between drawings 
You can use the Clipboard to cut or copy objects from one drawing to another. Cutting re-
moves the selected objects from a drawing and stores them on the Clipboard. Copying dup-
licates the selected objects from a drawing and places them on the Clipboard. 
 
To cut objects to the Clipboard 

1   Select the objects you want to cut. 
2   Choose Edit > Cut. 

Standard toolbar       
Command line       CUTCLIP 
 
To copy objects to the Clipboard 

1   Select the objects you want to copy. 

2   Choose Edit > Copy. 

Standard toolbar       
Command line       COPYCLIP 
 

Anything that you can copy to the Clipboard can be pasted into a drawing. The format in which 
the program adds the Clipboard contents to the drawing depends on the type of information in 
the Clipboard. For example, if you copy ZwCAD drawing objects to the Clipboard, the pro-
gram pastes them into the drawing as ZwCAD objects. If you copy items to the Clipboard 
from other programs, they are pasted into the current drawing as embedded ActiveX® objects. 
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To paste objects from the Clipboard 
Choose Edit > Paste. 

Standard toolbar       
Command line       PASTECLIP 
 
Making offset copies 
You can use the offset feature to copy selected objects and align them offset to the original 
objects at a specified distance. You can make offset objects using arcs, circles, ellipses, 
elliptical arcs, lines, two dimensional polylines, rays, and infinite lines. 
 

Making offset copies of curved objects creates larger or smaller curves, depending on which 
side of the original object you place the copy. For example, placing a offset l copy of a circle 
outside the circle creates a larger concentric circle; positioning the copy inside the circle cre-
ates a smaller concentric circle. 
 
To make a offset copy by specifying the distance 
1   Choose Modify > offset. 
 

2   Specify the distance by selecting two points or by entering a distance. 

3   Select the object to copy. 

4   Specify on which side of the object to place the parallel copy. 

5   Select another object to copy, or press Enter to complete the command. 

Modify toolbar       

Command line       OFFSET 
 

 
 
 
 
 
 

 
 

 
To make a parallel copy, specify the distance between copies              Result. 
by entering a distance or selecting two points (A and B), select  
the object to copy (C), and specify on which side to place the copy (D). 
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To make a offset copy passing through a point 
1   Choose Modify > offset. 
 

2   On the command line, type through (Through Point). 

3   Select the object to copy. 

4   Specify the point for the object to pass through. 

5   Repeat steps 3 and 4, or press Enter to complete the command. 

Modify toolbar       

Command line       OFFSET 
 
 
 

 
 
 
 
 

To make a parallel copy passing through a point, select the object to copy (A) and then specify the through 
point (B). 
 
Mirroring objects 
You can create a mirror image of an object. You mirror the object about a mirror line, which 
you define by specifying two points in a drawing. You can delete or retain the original objects. 
 
To mirror objects 
1   Choose Modify > Mirror. 
 

2   Select the object, and then press Enter. 

3   Specify the first point of the mirror line. 

4   Specify the second point of the mirror line. 

5   On the command line, if you want to retain the original objects, type yes; if you want to 
delete the original objects, type no. 

Modify toolbar       

Command line       MIRROR 
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To mirror an object, select it (A), and then specify the           Result.  
first point (B) and second point (C) of the mirror line. 
 
Arraying objects 
You can copy an object in a rectangular or polar (circular) pattern, creating an array. For a 
rectangular array, you control the number of copies in the array by specifying the number of 
rows and columns. You also specify the distance between each row and column. For a polar 
array, you control the number of copies that compose the array and whether to rotate the 
copies. 
 
To create a polar array 
1   Choose Modify > Array. 
 

2   In the array tab, click Polar Array. 

3   Click the select objects button, select entities to array in your drawing. 

4   In the array tab, choose method and values you desired. 

5   Click OK. 

 Modify toolbar      
Command line       ARRAY 
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A 

B C 

D 
E 
F 
G 
H 

I 

J 
K 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
A  Type the x,y coordinate value of center point. H  Type or pick up the total number of items. 

I   Click to activate rotated items as copied. B  Click the button to pick up the center point. 
C  Click to activate polar array. J  Click to activate the base point as default. 
D  Click the button to select objects that you want to 

array. 
K  Type the x,y coordinate of base point.

E  Choose one of the three methods to polar array. 
F  Type the total number of items. 
G  Type or pick up the angle to fill.. 
  
 

 
 
 
 
 
 
 
 
 
 

 
To create a polar array, select the object to copy (A), specify the center point of the array (B), and then 
specify the number of items to array, the angle the array is to fill, and whether to rotate the items. 
 
To create a rectangular array 
1   Choose Modify > Array. 
 

2   In the array tab, click Rectangular Array. 

3   Click the select objects button, select entities to array in your drawing. 

4   In the array tab, choose method and values you desired. 
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5   Click OK. 

Modify toolbar       

Command line       ARRAY 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

A 

B 

C 

D 

E 

F G

H

I

J

K

 
 

G  Click the button to specify the row distance. A  Type the rows distance. 
H  Click the button to select objects that you want to 

array. 
B  Type the columns distance. 
C  Type the rows offset. 
D  Type the column offset. I   Click to activate rectangular array. 
E  Type the angle of array. J  Click the button to specify the column distance. 
F  Click the button to specify the row and column 

distance. 
K  Click the button to specify the angle of array.

. 
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To create a rectangular array, select the object to copy (A), type the number of rows and columns, and then 
specify the distance between each row (B) and column (C). 
 

Rearranging objects 

 
You can move one or more objects, and you can also rotate objects about a specified point. If you 
have objects that overlap, you can also change the display order. 
 
Moving objects 
You can move objects around within the current drawing or from one drawing to another. The 
default method is to create a selection set and then specify a starting point, or base point, and 
an endpoint, or displacement point, to define the relocation of the objects. You can also 
relocate the objects using a direction vector. 
 
To move a selection set 
1   Choose Modify > Move. 
 

2   Select the objects, and then press Enter. 

3   Specify the base point. 

4   Specify the displacement point. 

Modify toolbar        

Command line       MOVE 
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To move an object, select it (A), and then specify the       Result 
base point (B) and the displacement point (C). 
 
 
You can also move objects using grips. To move an object using grips, select the object to 
display its grips, and then click a grip and drag it. The grip you select depends on the type of 
object you’re modifying. For example, to move a line object, select the midpoint grip. To 
move a curved object, such as an arc, circle, or ellipse, select the center point grip. Not all 
objects can be moved using grips. 
 
 
To move an object using grips 

1   Select the object. 

2   Click a grip to select it. 

3   Drag the object to where you want to relocate it. 

4   Click to release. 
 
 
Rotating objects 
You can rotate objects about a specified point at a specified rotation angle or by an angle 
referenced to a base angle. The default method rotates the objects using a relative rotation 
angle from their current orientation. 
 
To rotate a selection set 
1   Choose Modify > Rotate. 
 

2   Select the objects, and then press Enter. 

3   Specify the rotation point. 

4   Specify the rotation angle. 

Modify toolbar        

Command line       ROTATE 
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To rotate an object, select the object to rotate (A), and then specify the rotation point (B) and the rotation 
angle (C). 
 
To rotate a selection set in reference to a base angle 
1   Choose Modify > Rotate. 
 

2   Select the objects, and then press Enter. 

3   Specify the rotation point. 

4   On the command line, type base. 

5   Specify the base angle. 

6   Specify the new angle. 

Modify toolbar        

Command line       ROTATE 
 

 
 
 
 
 
 
 
 
 
 

To rotate an entity in reference to a base angle, select the entity (A), specify the rotation point (B), select the 
base angle and pick point (B) again (or type the @ symbol), specify the second point (C), and then specify 
the point representing the new angle (D). 
 
  
Reordering objects 
When multiple objects overlap, you can change the order in which they are displayed and 
printed. You can move objects to the front, back, or on top or below of another object. 
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To reorder objects: 
1   Choose Tools > Display Order. 
 

2   Choose a desired order from the four orders. 

3   Select the object you want to reorder, and then press Enter. 

Command line       ROTATE 
 
NOTE  The SORTENTS system variable automatically turns on, which may affect sys- 
tem performance. 
 
 

Resizing objects 

 
You can change the size of an object or set of objects by stretching, scaling, extending, trim-
ming, or editing their lengths. 
 
Stretching objects 
You can change the size of objects by stretching them. When you stretch objects, you must 
select the objects using either a crossing window or a crossing polygon. You then specify a 
displacement distance or select a base point and a displacement point. Objects that cross the 
window or polygon boundary are stretched; those completely within the crossing window or 
crossing polygon are simply moved. 
 
To stretch an object 
1   Choose Modify > Stretch. 
 

2   On the command line, choose Crossing Window or Crossing Polygon. 

3   Select the objects, and then press Enter. 

4   Specify the base point. 

5   Specify the second point of displacement. 

Modify toolbar        

Command line       STRETCH 
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To stretch objects, select them using a crossing window (A) or crossing polygon, and then specify the base 
point (B) and displacement point (C). 
 
To stretch an object using grips, you select it to display its grips and then select a grip to make 
it the active grip. This becomes the base point. Then you move the active grip to a new location. 
The grip you select depends on the type of object you’re modifying. For example, to stretch 
one corner of a rectangle, select the corner point grip. 
To stretch a line, select an endpoint grip. Not all objects can be stretched using grips. 
 
To stretch an object using grips 
1   Select the object. 

2   Click a grip to activate it. 

3   Drag the grip. 

4   Click to release. 
 
 
 
 

 
 
 
 
 
 
 
 

To stretch an object using grips, select the object Result. 
(A), select a grip (B), and drag the grip to its new location (C). 
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Scaling objects 
You can change the size of a selected object by scaling it in relation to a base point. You can 
change the size of an object by specifying a base point and a length, which is used as a scale 
factor based on the current drawing units, or by specifying a scale factor. You can also use a 
scale factor referenced to a base scale factor, for example, by specifying the current length and 
a new length for the object. 
 
To scale a selection set by a scale factor 
1   Choose Modify > Scale. 
 

2   Select the objects, and then press Enter. 

3   Specify the base point. 

4   Specify the scale factor. 

Modify toolbar        

Command line       SCALE 

 

 
 
 
 
 
 

 
To scale an object by a scale factor, select the object (A),                Result. 
and then specify the base point (B) and the scale factor. 
 
You can also scale some objects using grips. To scale an object, you select the object, and then 
click a grip. You then change the size of the object by moving the grip. The grip you select 
depends on the type of object you’re modifying. For example, to scale a circle, select a quad-
rant point grip. 
 
To scale an object using grips 

1   Select the object. 

2   Click a grip to select it. 

3   Drag the grip. 

4   Click to release. 
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To scale using grips, select the object (A), click a grip (B), and         Result.  
scale the object by dragging the grip to its new location (C). 

 
 
Extending objects 
You can extend objects so that they end at a boundary defined by other objects. You can also 
extend objects to the point at which they would intersect an implied boundary edge. When 
extending objects, you first select the boundary edges, and then specify the objects to extend, 
selecting them either one at a time or using the fence selection method. 
 
You can extend arcs, lines, two-dimensional polylines, and rays. Arcs, circles, ellipses, lines, 
splines, polylines, rays, infinite lines, and viewports on a Layout tab can act as boundary 
edges. 
 
To extend an object 
1   Choose Modify > Extend. 
 

2   Select one or more objects as boundary edges, and then press Enter. 

3   Select the object to extend. 

4   Select another object to extend, or press Enter to complete the command. 

Modify toolbar        

Command line       EXTEND 
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To extend objects, select the boundary edge (A), and then                  Result.  
select the objects to extend (B). 
 
To extend an object to an implied boundary 
1   Choose Modify > Extend. 
 

2   Select one or more boundary edges, and then press Enter. 

3   On the command line, type edge. 

4   On the command line, type extend. 

5   Select the object to extend. 

6   Select another object to extend, or press Enter to complete the command. 

Modify toolbar        
Command line       EXTEND 
 

 
 
 
 
 
 
 
 
 

Select the boundary edge (A), and then select the objects to    Result. 
extend (B). 
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To extend several objects using the fence selection method 
1   Choose Modify > Extend. 
 

2   Select one or more boundary edges, and then press Enter. 

3   On the command line, type fence. 

4   Specify the first point of the fence. 

5   Specify the second point of the fence. 

6   Specify the next fence point, or press Enter to complete the command. 

Modify toolbar        
Command line       EXTEND 
 
 

 
 
 
 
 
 
 
 
 

Select the boundary edge (A), and then specify the                        Result. 
first point (B) and second point (C) of the fence. 
 
When you extend a wide polyline, its centerline intersects the boundary edge. Because the end 
of the polyline is always cut at a 90-degree angle, part of the polyline may extend past the bou-
ndary edge. A tapered polyline continues to taper until it intersects the boundary edge. If this 
would result in a negative polyline width, the ending width changes to 0. 
 
 

 
 
 
 
 
 
 
 
 

A tapered polyline (A) continues to taper until                          Result. 
it intersects the boundary edge (B). 
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Trimming objects 
You can clip, or trim, objects so they end at one or more implied cutting edges defined by 
other objects. You can also trim objects to the point at which they would intersect an implied 
cutting edge. When trimming objects, you first select the cutting edges and then specify the 
objects to trim, selecting them either one at a time or using the fence selection method. 
 

You can trim arcs, circles, lines, open two-dimensional and three dimensional polylines, and 
rays. Arcs, circles, lines, polylines, rays, infinite lines, and viewports on a Layout tab can act 
as cutting edges. An object can be both a cutting edge and one of the objects being trimmed. 
 
To trim an object 
1   Choose Modify > Trim. 
 

2   Select one or more cutting edges, and then press Enter. 

3   Select the object to trim. 

4   Select another object to trim, or press Enter to complete the command. 

Modify toolbar        

Command line       TRIM 

 
 
 
 
 
 
 
 
 

 
To trim objects, select the cutting edge (A), and then select                  Result.  
the objects to trim (B). 
 
To trim an object to an implied boundary 
1   Choose Modify > Trim. 
 

2   Select one or more cutting edges, and then press Enter. 

3   On the command line, type edge. 

4   On the command line, type extend. 

5   Select the object to trim. 
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6   Select another object to trim, or press Enter to complete the command. 

Modify toolbar        

Command line       TRIM 
 

 

 
 
 
 
 
 
 

Select the implied boundary edge (A), and then select                        Result.  
the objects to trim (B). 
 
To trim several objects using the fence selection method 
1   Choose Modify > Trim. 
 

2   Select one or more cutting edges, and then press Enter. 

3   On the command line, type fence. 

4   Specify the first point of the fence. 

5   Specify the second point of the fence. 

6   Specify the next fence point, or press Enter to complete the command. 

Modify toolbar        
Command line       TRIM 

 
 
 
 
 
 
 
 
 
 
 

Select the boundary edge (A), and then specify the first      Result. 
point (B) and second point (C) of the fence. 
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Editing the length of objects 
You can change the length of objects or the included angle of arcs. Use any of the following 
methods to change the length of an object: 

•   Dynamically drag the endpoint or angle. 

•   Specify an incremental length or angle measured from an endpoint. 

•   Specify the new length as a percentage of the total length or angle. 

•   Specify a new length or included angle. 
 
You can change the length of arcs, lines, and open polylines. 
 
To change the length of an object by dragging 
1   Choose Modify > Lengthen. 
 

2   On the command line, type dynamic. 

3   Select the object you want to change. 

4   Specify the new endpoint or included angle. 

Modify toolbar        

Command line       LENGTHEN 

 
 
 
 
 
 
 
 
 
 
 
 
 

Select the object (A), and then select the new               Result.  
endpoint (B). 
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Breaking and joining objects 

 
You can break an object into two parts, removing a portion of the object in the process. You 
can also join two objects into a single object. 
 
Breaking objects 
You can break arcs, circles, ellipses, lines, polylines, rays, and infinite lines. When breaking 
objects, you must specify two points for the break. By default, the point you use to select the 
object becomes the first break point; however, you can use the First option to select a break 
point different from the one that selects the object. 
 
To break an object 
1   Choose Modify > Break. 
 

2   Select the object. 

3   Specify the second break point. 

Modify toolbar        
Command line       BREAK 

 
 
 

 
 
 
 
 
 
 

Select the object (A), and then specify the second break       Result. 
point (B). 
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To select an object and then specify the two break points 
1   Choose Modify > Break 
 

2   Select the object. 

3   On the command line, type first. 

4   Specify the first break point. 

5   Specify the second break point. 

Modify toolbar        
Command line       BREAK 

 
 
 
 
 
 

 
 
 
 

 
Select the object (A), and then specify the first (B) and             Result. 
second (C) break points. 
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TIP  To break an object in two without removing a portion of the object, specify the 
same point for the first and second break points by typing the at sign (@) and press- 
ing Enter instead of specifying the second break point. 
 
 
Joining objects 
You can join two objects into a single object. You can join either two lines or two arcs. The two 
lines must be parallel; the two arcs must share the same center point and radius. 
 

When you join two lines, the farthest endpoints remain at their existing locations; the program 
draws a new line between these points. Arcs are joined counterclockwise, from the first arc 
you select to the second. 
 
To join two objects 

1   On the command line, type join.  
 

2   Select the first arc or line. 

3   Select the second arc or line. 

 
 

 
 
 
 
 
 
 
 
 
 
 
 

Select the first arc or line (A), and then select the        Result. 
second arc or line (B). 
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Grouping objects 

 
A group is a collection of objects saved together as one unit. After you select the entities that 
belong in the group, you can later add more objects, remove objects, and reorder the objects. If 
necessary, you can also ungroup the objects at any time to work with the objects separately. 
 

The Group dialog box controls the settings for all groups in a drawing. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Creating groups 
When you create a group, you enter a group name and description, and then select the objects 
for the group. 
 
To create a group 
1   On the command line, type group. 
 

2   Under Create New Group, enter the name and description of the group. 

3   Click Selectable if you want all entites in the group to be selected when you select one 
entity of the group in the drawing. 
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4   Click Select entities and Create Group. 
5   Select the objects for the group, and then press Enter. 

6   In the Group dialog box, click OK. 
 
TIP You can enter the name of a group in the command bar when selecting objects. 
 
 
Modifying groups 
 
To modify a group and its objects 
1   On the command line, type group 
 

2   Select the group you want to modify. 

3   Under Modify Selected Group, do one or more of the following: 

•   Enter a new name, and then click Rename Group. 

•   Enter a new description, and then click Change Group Description. 

•   Select whether you want the group to be selectable in the drawing. 

•   Click Add Objects to Group, select the objects to add to the group, and then press Enter. 

•   Click Remove Objects from Group, select the objects to remove from the group, and then 
press Enter. 

4   In the Group dialog box, click OK. 
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To change the order of objects in a group 
1   On the command line, type group 
 

2   Under Modify Selected Group, click Reorder Objects. 

3   In the Reorder Grouped Objects dialog box, select the group you want to reorder. 

4   To see the order of objects in the group, click Highlight. Follow the prompts that display 
to view the objects one by one. 

5   To reverse the order of all objects in the group, click Reverse Order. 

6   To change the order of specific objects or a range of objects: 

•   In Remove from Position, enter the current position of the object. 

•   In Place to Position, enter the new position of the object. 

•   In Number of Objects, enter the number of objects or range of objects to reorder. For 
example, if you are changing the order of only one object, enter 1. 

•   Click Reorder. 
 
NOTE The objects in a group are numbered 0, 1, 2, 3, and so on. 
 

 
7   Click OK, and then click OK again. 
 
Ungrouping objects 
When you ungroup objects, the objects remain in the drawing but the group is deleted from the 
drawing. 
 
To ungroup objects 
1   On the command line, type group 
 

2   Select the group to delete. 

3   Under Modify Selected Group, click Ungroup Objects. 

4   Click OK. 
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Editing polylines 

 
You can modify any type of two dimensional or three dimensional polyline. Objects such as 
rectangles, polygons, and donuts, as well as three dimensional objects such as pyramids, cy-
linders, and spheres, are all variations of polylines that you can edit. 
 

You can edit a polyline by opening or closing it, by changing its overall width or the widths of 
individual segments, and by converting a polyline with straight line segments into a flowing 
curve or an approximation of a spline. In addition, you can use the Edit Polyline tool to edit 
individual vertices, adding, removing, or moving vertices. You can also add new segments to 
an existing polyline, change the linetypes of a polyline, and reverse the direction or order of 
the vertices. 
 
To modify a polyline, you first select the polyline, and then select a polyline editing option. 
The available options vary depending on whether the selected polyline is a two dimensional or 
three dimensional object. If the selected object is not a polyline, the Edit Polyline tool pro-
vides the option of turning it into one. You can convert only arcs and lines into polylines. If 
several arcs or lines are joined endpoint to endpoint, they can all be selected and turned into 
one polyline. 
 
To convert an object into a polyline 
1   Choose Modify > Object > Polyline. 
 

2   Select the object. 

3   On the command line, type yes. 

4   On the command line, type another option, or press Enter to complete the command. 

Command line       PEDIT 
 
Opening and closing polylines 
When you close a polyline, the program draws a straight polyline segment from the last vertex 
of the polyline to the first vertex. Opening a polyline removes the closing segment. When you 
select a polyline for editing, the prompt box displays either the Open or Close option, 
depending on whether the polyline you select is closed or open. 
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To close an open polyline 
1   Choose Modify > Object > Polyline. 
 

2   Select the polyline. 

3   On the command line, type close. 

4   On the command line, type another option, or press Enter to complete the command. 

Command line       PEDIT 
 
 
 
 
 
 
 
 

 
 

Closing an open polyline adds a straight                 Result.  
 polyline segment between the first (A) and last 

(B) vertices. 
 
 
Curving and decurving polylines 
You can convert a multisegment polyline into a smooth curve using either the Fit or Spline 
option. The Fit option creates a smooth curve connecting all the vertices. The Spline option 
computes a smooth curve that is pulled toward the vertices but passes through only the first 
and last vertices. The Decurve option removes Fit or Spline curves and arcs, leaving straight 
segments between the vertices. 
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To fit a curve to a polyline 
1   Choose Modify > Object > Polyline. 
 

2   Select the polyline. 

3   On the command line, type fit. 

4   On the command line, type another option, or press Enter to complete the command. 

Command line       PEDIT 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Original polyline                        After applying Fit curve.                After applying Spline. 
 
 
Joining polylines 
You can add an arc, line, or polyline object to an existing open polyline, forming one contin-
uous polyline object. To join an object to a polyline, that object must already share an end-
point with an end vertex of the selected polyline. 
 

When you join an object to a polyline, the width of the new polyline segment depends on the 
width of the original polyline and the type of object you are joining to it: 

•   A line or an arc assumes the same width as the polyline segment for the end vertex 
to which it is joined. 

•   A polyline joined to a tapered polyline retains its own width values. 

•   A polyline joined to a uniform-width polyline assumes the width of the polyline to which 
it is joined. 
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To join an arc, line, or polyline to an existing polyline 
1   Choose Modify > Object > Polyline. 
 

2   Select the polyline. 

3   On the command line, type join. 

4   Select the arc, line, or polyline to join. 

5   On the command line, type another option, or press Enter to complete the command. 

Command line       PEDIT 
 
Changing the polyline width 
You can change the width of an entire polyline, applying a uniform width to the entire object or 
tapering the polyline uniformly along its entire length. 
 
To apply a uniform width to an entire polyline 
1   Choose Modify > Object > Polyline. 
 

2   Select the polyline. 

3   On the command line, type width. 

4   Specify the new polyline width. 

5   On the command line, type another option, or press Enter to complete the command. 

Command line       PEDIT 
 
To taper a polyline uniformly along its length 
1   Choose Modify > Object > Polyline. 
 

2   Select the polyline. 

3   On the command line, type taper. 

4   Specify the starting width. 

5   Specify the ending width. 

6   On the command line, type another option, or press Enter to complete the command. 

Command line       PEDIT
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Editing polyline vertices 
You can use the Edit Vertices option to modify individual polyline vertices. When you select 
this option, the program switches into a special vertex editing mode and places an x on the 
first vertex. The x indicates the vertex you are editing. The Next and Previous options move 
the x to the next or previous vertex. You can edit only one vertex at a time. 
 

When editing vertices, you can modify the polyline in the following ways: 
 

•   Convert a polyline segment into a curve by specifying a new tangent angle. 

•   Break a polyline into two separate polylines. 

•   Insert a new vertex after the current vertex. 

•   Move the current vertex. 

•   Straighten the polyline segment between two vertices. 

•   Change the width of the polyline segment between two vertices. 
 
To move a polyline vertex 
1   Choose Modify > Object > Polyline. 
 

2   Select the polyline. 

3   On the command line, type edit. 

4   On the command line, type next. 

Repeat until the x reaches the vertex you want to move. 

5   On the command line, type move. 

6   Specify the new location for the vertex. 

7   On the command line, type another option, or type exit to complete the command. 

8   On the command line, type another option, or press Enter to complete the command. 

Command line       PEDIT 
 

 
 
 
 

 
 
 
 

 
 

Select the polyline (A), move the current vertex Result. 
marker to the vertex you want to move (B), and then 
specify the new vertex location (C). 
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To taper the width of an individual polyline segment 
1   Choose Modify > Object > Polyline. 
 

2   Select the polyline. 

3   On the command line, type edit 

4   On the command line, type next. 

Repeat until the x reaches the first vertex of the segment you want to taper. 

5   On the command line, type width. 

6   Specify the starting width. 

7   Specify the ending width. 

8   On the command line, type another option, or type exit to complete the command. 

9   On the command line, type another option, or press Enter to complete the command. 

Command line       PEDIT 
 
 

 
 
 
 
 
 
 
 
 

Select the polyline (A), move the current vertex                 Result. 
marker to the first vertex of the segment you want 
 to taper (B), and then specify the new starting and 
 ending widths for that segment. 
.
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Exploding objects 

 
You can convert a complex object, such as a block or polyline, from a single object into its 
component parts. Exploding a polyline, rectangle, donut, polygon, dimension, or leader re-
duces it to a collection of individual line and arc objects that you can then modify individually. 
Blocks are converted to the individual objects, possibly including other, nested blocks that 
composed the original object. 
 

With the following exceptions, exploding an object usually has no visible effect on a drawing: 

•   If the original polyline had a width, the width information is lost when you explode it. The 
resulting lines and arcs follow the centerline of the original polyline. 

•   If you explode a block containing attributes, the attributes are lost, but the original attri-
bute definitions remain. 

•   Colors, linetypes, lineweights, and print styles assigned BYBLOCK may be different 
after exploding an object, because they will adopt the default color, linetype, lineweight, 
and print style until inserted into another block. 

 
To explode an object 
1   Choose Modify > Explode. 
 

2   Select the objects to explode. 

3   Press Enter. 

Modify toolbar        
Command line       EXPLODE 
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Chamfering and filleting objects 

 
You can chamfer or fillet objects. A chamfer connects two nonparallel objects with a line to 
create a beveled edge. A fillet connects two objects with an arc of a specified radius to create a 
rounded edge. If both objects you are working with are on the same layer, the chamfer or fillet 
is drawn on that layer. If they are on different layers, the chamfer or fillet is drawn on the 
current layer. 
 

The Chamfer/Fillet settings in the Drawing Settings dialog box control the chamfer and fillet 
settings. The portions of the objects that extend beyond the chamfer or fillet are normally 
deleted when you create the chamfer or fillet. You can retain these original objects, however, 
by changing the settings in the dialog box. 
 
 

A 

B 

C D 

E 

F 

G 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
A  Click to remove or retain portions of objects that D  Specify the chamfer length and 

angle when extend beyond the chamfer or fillet. 
using the distance angle method. B  Click to create a chamfer using two chamfer distances (distance-distance 

method). E  Click to create a chamfer using 
the chamfer length and angle (distance 
angle method). C  Specify the first and second chamfer distances when using the distance-

distance method. 
F  Click to specify the fillet radius by 
selecting two points in the drawing. 
G  Specify the fillet radius. 

 232 



CHAPTER 10 

Chamfering objects 
You can connect two nonparallel objects by extending or trimming them and then joining 
them with a line to create a beveled edge. You can chamfer lines, polylines, rays, and infinite 
lines. When creating a chamfer, you can specify how far to trim the objects back from their 
intersection (distance distance method), or you can specify the length of the chamfer and the 
angle it forms along the first object (distance angle method). 
 
When chamfering a polyline, you can chamfer multiple segments between two selected 
polyline segments, or you can chamfer the entire polyline. 
 
To chamfer two objects using the distance-distance method 
1   Choose Modify > Chamfer. 
 

2   On the command line, type s. 

3   In the Drawing Settings dialog box, click the Entity Modification tab. 

4   Under Chamfer Distances And Angles, click Distance Distance. 

5   Under Chamfer Distances And Angles, specify the first and second chamfer distances. 

6   Click OK. 

7   Select the first object. 

8   Select the second object. 

Modify toolbar        

Command line       CHAMFER 

 

 
 
 
 
 
 
 
 
 
 

 
Select the first (A) and second (B) objects. The chamfer is drawn, based on the first (C) and second (D) 
chamfer distances. 
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To chamfer two objects using the distance-angle method 
1   Choose Modify > Chamfer. 
 

2   On the command line, type s. 

3   In the Drawing Settings dialog box, click the Entity Modification tab. 

4   Under Chamfer Distances And Angles, click Distance Angle. 

5   Under Chamfer Distances And Angles, specify the chamfer distance and angle. 

6   Click OK. 

7   Select the first object. 

8   Select the second object. 

Modify toolbar        
Command line       CHAMFER 

 
 
 

 
 
 

 
 

 
 
 

Select the first (A) and second (B) objects. The chamfer is drawn, based on the distance measured along 
the first object (C) and the angle (D) formed with the first object. 
 
To chamfer all vertices in a polyline 
1   Choose Modify > Chamfer. 
 

2   On the command line, type polyline. 

3   Select the polyline. 

Modify toolbar        

Command line       CHAMFER 
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Original polyline.                             Result after chamfering.  
 
 
To chamfer selected vertices in a polyline 
1   Choose Modify > Chamfer. 
 

2   Select the polyline along the segment where you want to begin the chamfer. 

3   Select the polyline along the segment where you want to end the chamfer. 

Modify toolbar        

Command line       CHAMFER 

 
 
 
 
 
 
 
 

 
Select the polyline along the (A) and (B)              Result after chamfering. 
segments. 
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Filleting objects 
You can connect two objects with an arc of a specified radius to create a rounded edge. You 
can fillet pairs of line segments, straight polyline segments, arcs, circles, rays, and infinite 
lines. You can also fillet parallel lines, rays, and infinite lines. When filleting a polyline, you 
can fillet multiple segments between two selected segments, or you can fillet the entire 
polyline. 
 
To fillet two objects 
1   Choose Modify > Fillet. 
 

2   On the command line, type s. 

3   In the Drawing Settings dialog box, specify the fillet radius. 

4   Click OK. 

5   Select the first object. 

6   Select the second object. 

Modify toolbar        

Command line       FILLET 

 

 
 
 
 
 
 
 
 

 
Select the first (A) and second (B) objects.           Result after filleting. 
 
 
To fillet an entire polyline 
1   Choose Modify > Fillet. 
 

2   On the command line, type polyline. 

3   Select the polyline. 

Modify toolbar        

Command line       FILLET 
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Select the polyline (A).                               Result after filleting.  
 
To fillet selected vertices in a polyline 
1   Choose Modify > Fillet 
 

2   Select the polyline along the segment where you want to begin the fillet. 

3   Select the polyline along the segment where you want to end the fillet. 

Modify toolbar        

Command line       FILLET 

 
 
 
 
 
 
 

Select the polyline along the (A) and (B)         Result after filleting. 
segments. 
 
When you fillet circles and arcs, more than one fillet can exist between the objects. The point 
at which you select the objects determines the fillet. 

 
 
 
 
 

 
 
 
 
 
 
 
 

 
 
 
 
 
 

Select objects (A and B).                Results after filleting.  
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You can fillet parallel lines, rays, and infinite lines. The first object must be a line or ray; the 
second object can be a line, ray, or infinite line. The diameter of the fillet arc is always equal to 
the distance between the parallel objects. The current fillet radius is ignored. 
 
 
 
 
 
 
 
 
 
Original objects.                          Result after filleting.  

 238 



WORKING WITH TEXT 

 
 
Working with text 
 

 
 
 
 
You can insert text into your drawing and control its appearance, allowing you to provide 
additional information for your ZwCAD drawings. This section explains how to: 
 

•   Create line text. 

•   Create paragraphs. 

•   Create text styles. 

•   Format text. 

•   Change text. 

•   Change paragraph text. 

•   Use an alternate text editor. 
 

 
 
 
 
 
 
 
 
 
 
 
Topics in this chapter 
 

Creating line text....................................................................................................240 
Creating paragraph text............................................................................................240 
Working with text styles ..........................................................................................242 
Formatting text......................................................................................................243 
Changing text........................................................................................................246 
Using an alternate text editor .....................................................................................250 
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Creating line text 

 
When you create text, you end each line of text by pressing Enter. Each line of text is created 
as a separate entity that you can modify. 
 
To create text 
1 Choose Draw> Text > Single Line Text. 
2   Specify the insertion point for the first character. 

3   Specify the height of the text. 

4   Specify the text rotation angle. 

5   Type the text, and then press Enter at the end of each new line. 

6   To complete the command, press Enter again. 

Text toolbar      

Command line   TEXT 
 
 
TIP  If you’ve already created text and want new text to appear immediately below the 
previous text, Choose Draw> Text > Single Line Text. When prompted for an insertion 
point, press Enter. The new text will keep the same height and rotation angle as the 
previous text. 
 
 

Creating paragraph text 

 
Paragraph text consists of one or more lines of text or paragraphs that fit within a boundary 
width that you specify. Each paragraph text entity you create is treated as a single entity 
regardless of the number of individual paragraphs or lines of text it contains. 
 

When you create paragraph text, you first determine the paragraph’s boundary width by spe-
cifying the opposite corners of a rectangle. The paragraph text automatically wraps so that it 
fits within this rectangle. The first corner of the rectangle determines the default attachment 
point of the paragraph text. You can change the location of the attachment point in reference to 
the rectangle, and you can determine the direction in which text flows within the rectangle. 
You can also select the text and paragraph format, text style, text height, and the rotation angle 
of the entire paragraph text entity. 
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To create paragraph text 
1   Choose Draw> Text > Multiline Line Text. 
 

2   Select the first corner of the text area. 

3   Select the second corner of the text area. 

4   In the Multiline Text window, type the text you want. 

To create paragraphs, press Enter and continue typing. 

5   On the toolbar, make format changes as follows: 

•   To change the font of the selected text, select a font from the list. 
•   To change the height of the selected text, enter a new value in the 

Height box 

•   To format text in a TrueType font with boldface or italics, or to create underlined 
text for any font, click the corresponding button on the toolbar. SHX fonts do not 
support boldface or italics. 

•   To apply color to selected text, choose a color from the Color list. Click Other to 
display the Select Color dialog box。 

6   To save your changes and exit the Multiline Text Editor, use one of the following 
methods: 

  •     Click Save on the toolbar. 
  •    Press Ctrl + Enter. 

Text toolbar      
Command line   MTEXT 
 
 
TIP You can paste text from the Clipboard into the Multiline Text dialog box. 
 

 G

A 

B 

C D E F H I
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A  Click to view and select text style and text box 

properties. 
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B  Type and select text. 
C  Select the text font. 
D  Select BYBLOCK, BYLAYER, the color of your 

choice, or choose Select Color to select from 

additional colors. 
E   Select or type the text height. 
G   Undo and Redo button. 
H  Set the overlapped style of text. 
I   Save your changes and exit the MText Edito

  

Working with text styles 

 
When you add text to a drawing, it uses the current text style. Text style determines the font, 
size, angle, orientation, and other characteristics. 
 

Every drawing has a default text style, named Standard, which initially uses the Txt.shx font. 
You cannot delete the Standard style, but you can rename it or modify it. You can change the 
font, the size of the font, and the obliquing angle applied to it. If you change the font or ori-
entation of an existing style, all existing text entities created using that style are automatically 
updated to reflect the new font or orientation. Changing any other characteristic has no effect 
on existing text. You also can create and use an unlimited number of additional text styles. 
 
The text style determines the characteristics shown in the following table. 
 
Style characteristics 

 
To create a text style 
1   Choose Format > Text Styles. 

2   Click New, type a new text style name, then click OK.  

3   Under Text Measurements, enter the Fixed Text Height, Width Factor, and 

Oblique Angle measurement 
4   Under Text Font, select the name, style, language, and Bigfont of the font you want to use. 



WORKING WITH TEXT 

5   Under Text Generation, select the check boxes you want to indicate the direction for 
printed text to appear. 

6   Click Apply. 

7   To begin using the new style, type text. 

8   Type s (Use Defined Style). 

Text toolbar      
Command line   STYLE 
 
 
 

Formatting text 

 
When you create text, you choose the text style and set the alignment. The style determines the 
font characteristics for the text. For line text, the alignment determines how the text aligns with 
the text insertion point. For paragraph text, the alignment deter mines the location of the 
attachment point in relation to the paragraph text boundary and the direction in which text 
flows within the boundary. 
 
 
Setting the line text style 
You can set the text style before you specify the insertion point. You select the text style by 
typing the name of a previously defined style. 
 
To specify a line text style 
1   Choose Draw> Text > Single Line Text. 
 

2   On the command line, type s (Use Defined Style). 

3   Type the name of a previously defined text style, and then press Enter. 

To display a list of available text styles, type a question mark (?), and then press Enter. 

4   Specify the text insertion point. 

5   Specify the text height. 

6   Specify the rotation angle. 

7   Type the text line, and then press Enter. 

8   To complete the command, press Enter again. 

Text toolbar      
Command line   TEXT 
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Setting the paragraph text style 
You can set the paragraph text style before you specify the insertion point. You select the text 
style by typing the name of a previously defined style. 
 
To specify a paragraph text style 
1   Choose Draw> Text > Multiline Line Text. 
 

2   Specify the first point of the Multiline Text box. 

3   On the command line, type s (Use Defined Style). 

4   Type the name of a previously defined text style, and then press Enter. 

5   Specify the text height. 

6   Specify the rotation angle. 

7   Specify the opposite corner of the Multiline Text box. 

8   Type the text, and then press Enter. 

9   To complete the command, press Enter again. 

Text toolbar      
Command line   MTEXT 
 
 
Setting the line text alignment 
When you create text, you can set the text alignment before you specify the insertion point. 
You set the alignment by choosing it in the prompt box. By default, text is left justified. You 
can align text at the left, center, or right and at the top, middle, or base line of the text or at the 
bottom of descending letters. 
 

 
 
 
 
 
 
 

 

    
 
A  Top left D  Bottom left 
B  Middle left E  Center 
C  Left F  Bottom center 
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G  Bottom right L  Middle 
M  Middle center H  Baseline 
N  Top center 

I   Right 
J  Middle right 
K  Top right 
 
 
You can also align text so that it fits or aligns between two points. The Align option creates 
text that scales up or down while maintaining a constant height/width ratio; the Fit option 
expands or compresses the text to fit between the two points. 
 

 
 
 
 
 
 

Text aligned between two points maintains a         Text fit between two points expands or compresses 

constant height/width ratio。                        to fit. 
 
 
To specify the line text alignment 
1   Choose Draw> Text > Single Line Text. 
 

2   On the command line, type J (Justification).  

3   Type an alignment option. For example, enter br to align text at its bottom-right 
corner. 

4    Continue creating text 

Text toolbar      

Command line   TEXT 
 
Setting the paragraph text alignment 
When you create paragraph text, you can set the text alignment by specifying the attachment 
point location in relation to the paragraph text boundary and the direction in which text flows 
within the boundary. You can set the paragraph text alignment either in the prompt box dis-
played after you specify the first corner of the paragraph text boundary or from the Multiline 
Text dialog box. You can specify the attachment point at the top left, top center, top right, 
middle left, middle center, middle right, bottom left, bottom center, or bottom right. The para-
graph text can flow left to right, right to left, top to bottom, or bottom to top. 
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Including special text characters 
You can use control codes to overscore or underscore text or to include special characters. 
Both overscore and underscore can be active at the same time. To include control codes, as 
you type text, type two percent symbols (%%) followed by the special control code or charac-
ter. A single percent sign is treated as a normal text character. A triple percent control code is 
provided for those instances where a control code sequence must follow a percent sign in the 
text. 
Special text characters 
Control code                                          Function 
%%o                                                 Toggles overscore mode on and off. 
 

%%u                                                 Toggles underscore mode on and off. 
 

%%d                                                 Draws a degree symbol (º). 
 

%%p                                                 Draws the plus or minus symbol (±). 
 

%%c                                                 Draws the circle diameter symbol (Ø). 
 

%%%                                                Forces a single percent sign. 
 

%%nnn                                               Draws special character number nnn. 
 
 

 
 
Text created using special text characters: Ut wisi %%uenim%%d ad%%p%%u minim %%c %%oveniam. 
 
 
 

Changing text 

 
Changing line text 
You can edit and modify the text as you would any other drawing entity. That is, you can 
delete, move, rotate, and scale text. 
 
To edit text 
1   Choose Modify > Object >Edit. 
 

2   Select the text entity. 

3   In the Text field, edit the text, and then click Save. 

Text toolbar      

Command line   DDTEXT 
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To change text properties 

1   Select a single line text object. 

2   Right-click the selected object and click Properties on the shortcut menu. 
3   In the Properties palette, enter any new text, and then change formatting and 

other properties as needed. 

Standard toolbar      
Command line       PROPERTIES 
 
 

A 

B 

C 

D 

E 
F 

G
H 

I
J 

K
L 

M 

 
 
 

 
 
 

  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  

  
  

A  Click to change layer. I  Specify text rotation angle. 
B  Click to change color. J  Specify the width factor. 

K  Specify the obliquing angle. C  Specify the x,y,z coordinate of the position point of the text. 
D  Specify new text insertion point. L  Select to insert backward text. 
E  Click to change text justification. M  Select to insert upside down text. 
F  Edit the existing text. 
G  Click to change text style. 
H  Specify text height. 
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Changing paragraph text 
You can modify the text as you would any other drawing entity. That is, you can delete, move, 
rotate, and scale text. 
 
To edit paragraph text 
1   Choose Modify > Object >Edit. 

2   Select the text entity. 

3   Edit the text in the Contents field of the Multiline dialog box. 

4   Click OK. 

Text toolbar      
Command line   DDTEXT 
 
To change paragraph text properties 
1   Select a multiline text object. 
2   Right click the selected object and click Properties on the shortcut menu. 
3   In the Properties palette, enter any new text and change formatting and other 

settings as needed. 

Standard toolbar      
Command line       PROPERTIES 
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A 

B 

C 

D 
E

F 

H 
G

I
J 

K 
L

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
A  Click to change layer. H  Specify text rotation angle. 
B  Click to change color. I   Specify the line space factor of Mtext. 

J  Specify the line space style of Mtext. C  Specify the x,y,z coordinate of the position point of the text. 
D  Edit the existing text. K  Click to change attachment point in 

relation to text  boundary rectangle. E  Click to change text style. 
L  Click to change direction in which text 
flows. 

F  Specify text height. 
G  Specify width of text boundary rectangle. 
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Using an alternate text editor 

 
ZwCAD includes a built in text editor for creating paragraph text using the Multiline Text 
command. You can also specify an alternate text editor for the Multiline Text command. 
 
Selecting an alternate text editor 
Before you can use an alternate text editor, you must specify the editor by setting the 
MTEXTED system variable. 
 
To select an alternate text editor 
1   Type mtexted and then press Enter. 
 
2   Enter the path and name of the executable file for the text editor you want to use to create 

or edit multiline text. For example, to use Microsoft® Wordpad, you would type 
something similar to the following (adjusting the path name as necessary): C:\Program 
Files\Windows NT\Accessories\Wordpad.exe 

 
Creating paragraph text in an alternate text editor 
After you set up ZwCAD to use an alternate text editor, you can start using it to include text in 
your drawings. 
 
To use an alternate text editor 
1   Choose Draw> Text > Multiline Line Text. 
2   Select the first and second corners of the text area. 

3   In the window, type the text you want, using the special characters from the table shown 
next to achieve special formatting. Enter \P to end a paragraph and start a new paragraph 
on the next line. For example, to use an alignment value of 1 and stack two numbers to 
display them as a fraction: 

 

{\A1;\S1/2;}\P 

4   When your text is complete, save the changes and exit the text editor. 

Text toolbar      
Command line   MTEXT
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Special formatting characters 
Format characters Function 
\0...\o Toggles overscore mode on and off. 
 

\L...\l Toggles underscore mode on and off. 
 

\~ Inserts a nonbreaking space. 
 

\\ Inserts a backslash. 
 

\{...\} Inserts an opening and closing brace. 
 

\Cvalue; Sets the color to a specified value. 
 

\File name; Sets the font based on a specified font file name. 

\Hvalue; Sets the text height to a specified value. 
 

\Hvaluex; Sets the text height to a multiple of the current text height. 
 

\S...^...; Stacks the subsequent text at the /, #, or ^ symbol. 
 

\Tvalue; Adjusts the space between characters, from 0.75 to 4 times. 
\Qangle; Changes obliquing angle. 
 

\Wvalue; Changes width factor to produce wide text. 
 

\A Sets the alignment value. 
 

\P Ends paragraph. 
 
\p[i],[l],[tX1,X2,...,X32] Formats paragraph: i = first line indent; l = paragraph offset;. 
                                         t = tab positions 
 
 
 
Using Unicode characters 
ZwCAD supports the Unicode character encoding standard, which enables you to display and 
write text in different languages using different letters. Unicode fonts contain many more cha-
racters than typically defined in a system. 
 
Special Unicode characters 
Control code Function 
\U+00B0 Draws a degree symbol (º). 
 

\U+00B1 Draws the plus or minus symbol (±). 
 

\U+2205 Draws the circle diameter symbol (Ø). 
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Dimensioning your drawing 
 

 
 
 
 
The ZwCAD dimensioning tools let you add measurements to a drawing. You can quickly add 
dimensions by simply pointing to entities. You can also add tolerance symbols to your draw-
ings. 
 

The program’s many dimensioning variables let you control the appearance of the dimensions. 
With dimension styles, you can save dimension variable settings so you can reuse them with-
out having to recreate them. 
 

This section explains how to: 
 

•   Create dimensions as linear, angular, diametral, radial, and ordinate. 

•   Create leaders and annotations. 

•   Edit dimensions. 

•   Use dimension styles and variables. 

•   Add geometric tolerances. 

•   Control dimension tolerance. 

•   Control alternate dimension units. 
 
 
 
 
 
 
Topics in this chapter 
 

Understanding dimensioning concepts ......................................................................253 
Creating dimensions...............................................................................................255 
Editing dimensions ................................................................................................264 
Understanding dimension styles and variables..............................................................267 
Adding geometric tolerances....................................................................................278 
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Understanding dimensioning concepts 

 
You can create five basic types of dimensions: linear, angular, radial, diametral, and ordinate. 
You can create dimensions for existing entities by selecting them, or you can create dimen-
sions by selecting points within a drawing. For example, you can create a linear dimension 
either by selecting the entity to be dimensioned or by specifying the first and second extension 
line origins. 
 

 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
A  Radial dimension. 
B  Vertical linear dimension. 
C  Angular dimension. 
D  Linear continued dimensions. 
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E  Aligned dimension. 
F  Diametral dimension. 
G  Horizontal linear dimension. 
H  Linear baseline dimension. 
 
When you create a dimension, the program draws it on the current layer, using the current 
dimension style. Each dimension has an associated dimension style, which controls the app-
earance of the dimension, such as the types of arrowheads, text style, and colors of various 
components. You can modify existing dimension styles by changing one of the dimension 
variable settings and then updating the dimension style to reflect the new settings. 
 
Each dimension you create consists of several parts. A dimension line shows where a dimen-
sion begins and ends. When you create an angular dimension, the dimension line is a dimen-
sion line arc that subtends the measured angle. 
Extension lines, also called projection lines, are lines that extend away from the entity for 
which you are creating a dimension, so that you can place the dimension line away from the 
entity. Arrowheads form the termination at each end of the dimension line. 
 

Dimension text contains the measured dimension and can also include prefixes, suffixes, 
tolerances, and other optional text. As you insert dimensions, you can control the dimension 
text and specify its position and orientation. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 

 
A  Extension line. 
B  Arrowhead. 
 
C  Dimension line. 
D  Dimension text. 
 
 
Dimensions can also contain other optional components. A leader is a line leading from a 
feature of the drawing to an annotation. Leaders begin with an arrowhead, and you can use 
them to place a dimension away from the dimension line or to add notes. When you create a 
radial dimension, you can add a center mark, which is a small cross that marks the center of a 
circle or an arc, or you can add centerlines, which are crossing lines that extend out from the 
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center of a circle or an arc. 
 

 
 
 
 
 
 
 
 
. 

Leader                              Center mark. Centerlines. 

Creating dimensions 

 
You can create dimensions by: 
 

•   Selecting the entity to dimension and specifying the dimension line location. 

•   Specifying the extension line origins and the dimension line location. 
 
When you create dimensions by selecting an entity, the program automatically places the ex-
tension line origins at the appropriate definition points based on the type of entity you select. 
For example, the definition points are located at the endpoints of arcs, lines, and polyline 
segments. When you create dimensions by specifying the extension line origins, the points 
you specify determine the definition points. To establish these points precisely, use entity 
snaps. 
 
 
To create a quick dimension 
1 Choose Dimensions > Quick Dimension. 
2 Select the entity to dimension, then press Enter 
3 On the command line, it will display 
[Continuous/Staggered/Baseline/Ordinate/Radius/Diameter/datumPoint/Edit] 
You can type the command what you want. The default command is continuous. 

Dimension toolbar    
Command line      QDIM 
 
 
Creating linear dimensions 
Linear dimensions annotate linear distances or lengths and can be oriented horizontally, verti-
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cally, or aligned parallel to an existing entity or to the selected extension origin points. After 
you create a linear dimension, you can add a baseline dimension or a continued dimension. A 
linear baseline dimension inserts an additional dimension from a common first extension line 
origin of a previous linear dimension. A linear continued dimension continues a linear dimen-
sion from the second extension line of a previous linear dimension. 
 
 
TIP  To select precise ordinate points, use entity snaps. 
 
 
 
To create a horizontal or vertical dimension 
1 Choose Dimensions > Linear. 
 

2 Press Enter, and then select the entity to dimension. 

Or, you can insert the dimension by specifying the first and second extension line origins. 

3 Specify the dimension line location. 

Dimension toolbar    
Command line     DIMLINEAR 
 

 
 
 
 
 
 
 
 
 

 
To insert a linear dimension by selecting the entity,           Result 
 select the entity (A) to dimension, and then specify 
 the dimension line location (B). 
. 
 

 
 

 

 
 
 
 

 
To insert a linear dimension by selecting the extension        Result.  
 Line origins, select the first extension origin (A), select  
the second extension origin (B), and then specify the  
dimension line location (C). 
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To create an aligned dimension 
1   Choose Dimensions > Aligned. 
 

2   Press Enter, and then select the entity to dimension. 

Or, you can insert the dimension by specifying the first and second extension line origins. 

3 Specify the dimension line location. 

Dimension toolbar    
Command line      DIMALIGNED 
 

 
 
 
 
 
 
 
 
 

To insert an aligned dimension by selecting the                 Result. 
entity, select the entity (A) to dimension, and then  
select the dimension line location (B). 
 
 

 
 
 

 
 
 
 
 

To insert an aligned dimension by selecting                   Result. 
 the extension line origins, select the first  
extension origin (A), select the second 
extension origin (B), and then specify the 
 dimension line location (C). 
 
 
 
To create a linear baseline dimension 
 
NOTE  Before you can use this procedure, you must first create a dimension. 
 

 
1   Choose Dimensions > Baseline. 
 

2   To select a starting dimension, press Enter. 

3   Select the next extension line origin, and then press Enter. 
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Or press Enter, and then select an existing dimension for the baseline. Select the origin of the 
next extension line, and then press Enter. 

Dimension toolbar    
Command line      DIMBASELINE 

 

The program automatically places the new baseline dimension above or below the previous 
dimension line. The distance between the two dimension lines is determined by the Baseline 
Spacing value in the Dimension Style Manager dialog box. 
 

 
  
 
 
 
 
 
 
 
 
 
 
 
 
 
 

To add a baseline dimension to an existing linear dimension, select the existing dimension (A), select the 
next extension line origin (B), and select as many additional points as you want (C). 
 

 
 
 
 
 
 
 

Result. 
 
 
To create a linear continued dimension 
 
NOTE  Before you can use this procedure, you must first create a dimension. 
 

 
1   Choose Dimensions > Baseline. 
2   To select a starting dimension, press Enter. 

3   Select the next extension line origin, and then press Enter. 
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Or press Enter, and then select an existing dimension to continue. 

4   To add continued dimensions, continue selecting extension line origins. 

5   To end the command, press Enter twice. 

Dimension toolbar    
Command line      DIMCONTINUE 

 
 
 
 
 
 
 
 
 
  
 
 
 

To add a continued dimension to an existing linear dimension, select the existing dimension (A), select the 
next extension line origin (B), and select another extension line origin (C). 
 

 
 
 
 
 
 
 

Result. 
 
 
Creating angular dimensions 
Angular dimensions annotate the angle measured between two lines. You can also dimension 
an angle by selecting an angle vertex and two endpoints. After you create an angular dimen-
sion, you can add a baseline dimension or a continued dimension. An angular baseline dimen-
sion inserts an additional dimension from a common first extension line origin of a previous 
angular dimension. An angular continued dimension continues an angular dimension from the 
second extension line of a previous angular dimension. 
 
 
To dimension an angle encompassed by an arc 
1   Choose Dimensions > Angular. 
 

2   Select the arc. 

3   Specify the dimension arc location. 
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Dimension toolbar    
Command line      DIMANGULAR 
 

 
 
 
 
 
 
 
 
 

 
To dimension the angle subtended by an arc,               Result. 
Select the arc (A), and then specify the dimension 
 arc location (B). 
 
 
To dimension an angle between two lines 
1   Choose Dimensions > Angular. 
 

2   Select one line. 

3   Select the other line. 

4   Specify the dimension line location. 

Dimension toolbar    
Command line      DIMANGULAR 
 

 
 
 
 
 
 

 
 

 
Select one line (A), select the other line (B),                     Result. 
and then specify the dimension line location (C). 
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Creating diametral and radial dimensions 
Diameter and radius dimensions annotate the radii and diameters of arcs and circles. You can 
optionally include centerlines or center marks. 
 
 
To create a diametral dimension 
1   Choose Dimensions > Diameter. 
 

2   Select the arc or circle. 

3   Specify the dimension line location. 

Dimension toolbar    
Command line     DIMDIAMETER 
 
 

 
 
 
 
 
 
 

Select the circle (A), and then specify the                  Result. 
dimension line location (B). 

 
 
To create a radial dimension 
1   Choose Dimensions > Radius. 
 

2   Select the arc or circle. 

3   Specify the dimension line location. 

Dimension toolbar    
Command line     DIMRADIUS 
 

 
 
 
 
 
 
 
 

Select the circle (A), and then specify the                 Results. 
dimension line location (B). 
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Creating ordinate dimensions 
An ordinate dimension annotates the perpendicular distance from an origin or base point (the 
origin of the current user coordinate system [UCS]). Ordinate dimensions consist of an x or y 
coordinate and a leader. An x ordinate dimension measures distances along the x axis; a y 
ordinate dimension measures distances along the y axis. 
 

As you select ordinate points, the program automatically determines whether the point is an x  
or y ordinate based on which direction you drag the second point. You can also specify whe-
ther the ordinate represents an x or y ordinate. Ordinate dimension text is always aligned with 
the ordinate leader lines, regardless of the text orientation specified by the current dimension 
style. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Ordinate dimensions measure the distance along the x or y axis from an origin to a selected ordinate point. 
 
 
To create an ordinate dimension 
1   Choose Dimensions > Ordinate. 
 

2   Select the point for ordinate dimension. 

3   Specify the ordinate leader endpoint. 

Dimension toolbar    
Command line      DIMORDINATE 
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Select the ordinate point (A), and then specify the ordinate leader endpoint (B). 
 
 
TIP  To select precise ordinate points, use entity snaps. 
 
 
 
Creating leaders and annotations 
Leaders consist of a line or series of lines that connects a feature in a drawing to an annotation. 
Generally, you place an arrowhead at the first point. An annotation, created as dimension text, 
is placed immediately adjacent to the last point. By default, the text placed at the end of the 
leader line consists of the most recent dimension. You can also type an annotation as a single 
line of text. 
 
 
To create a leader and an annotation 
1   Choose Dimensions > Leader. 
 

2   Specify the starting point of the leader. 

3   Specify the endpoint of the leader line segment. 

4   Specify additional leader line segment endpoints. 

5   After you specify the last endpoint, press Enter. 

6   Type the annotation, or press Enter to accept the most recent dimension as the default 
annotation. 

Dimension toolbar    
Command line      DIMLEADER 
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Specify the starting point of the leader (A)        Result. 
and the endpoint of the leader line segment (B). 
 
 
 
 
 

Editing dimensions 

 
You can use grips to edit entity dimensions. You can also edit the dimension text. You can 
rotate dimension lines and dimension text at any angle, and you can reposition the dimension 
text anywhere along the dimension line. 
 
Making dimensions oblique 
Extension lines are normally created at a perpendicular angle to the dimension line. You can 
change the angle of the extension lines, however, so that they tilt relative to the dimension line. 
 
 
To make oblique extension lines 

1   Choose Dimensions > Oblique. 
2    Type o (oblique). 
 

3   Select the linear dimension, and then press Enter. 

4   Type the obliquing angle, and then press Enter. 

Dimension toolbar    
Command line      DIMEDIT 
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Select the dimension to be made oblique (A), and then type   Result. 
the obliquing angle. 
 
 
TIP  To align the oblique angle if you don’t know the exact measurement, use snaps to 
pick two points on the entity. 
 
 
 
Editing dimension text 
You can rotate the text of an existing dimension, move the dimension text to a new position, 
or replace selected dimension text with new text. You can also restore dimension text to its 
original position as defined by the current dimension style. 
 

When you rotate or replace selected text, you specify the change first, and then select one or 
more dimensions to which to apply the change. All the selected dimensions are updated 
simultaneously. 
 
 
To rotate dimension text 
Advanced experience level 
 

1 On the command line, type dimedit. 
2 Type r ( rotate). 
 

3 Type the new dimension text angle, and then press Enter. 

4 Select the dimension to be rotated, and then press Enter. 

Dimension toolbar    
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Select the dimension to be rotated (A), and then              Result.  
type the rotation angle. 
 
 
NOTE The dimension text angle is relative to the dimension line. If the dimension text 
rotation is set to zero, the text angle is defined by the dimension type and the dimen- 
sion style. 
 
 
 
To move dimension text    
Advanced experience level 
 

1   On the command line, type dimtedit. 
 

2 Select the dimension to reposition text. 

3 Select the new text position. 

Dimension toolbar     
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Select the dimension to be moved (A), and then          Result. 
select the new text position (B). 
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To restore dimension text to its home position 
Advanced experience level 
 
1 On the command line, type dimedit. 
2 Type re (restore). 
 

3 Select the dimension text to restore, and then press Enter. 

Dimension toolbar    
 
 
To replace existing dimension text with new text 
Advanced experience level 
 

1   On the command line, type dimedit. 
2   Type e (edit). 
 

3   Type the new dimension text, and then press Enter. 

4   Select the dimension to be replaced, and then press Enter 

Dimension toolbar    
 

 

 

Understanding dimension styles and variables 

 
Dimensions that you insert are created using the current dimension style. You can create, save, 
restore, and delete named dimension styles. 
 
To display information about the current dimension style and compare it with other style 
names, you can use the dimstyle command. 
 

Dimension styles provide a way for you to change various settings that control the appearance 
of dimensions. You can then save those settings for reuse. If you don’t define a dimension 
style before creating dimensions, the program uses the Standard dimension style, which stores 
the default dimension variable settings. Each option in the Dimension Settings dialog box 
relates to a variable that you can set manually. See the online Command Reference for more 
information. 
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To create a dimension style 
1   Choose Dimensions > Style. 
 

2   In the Dimension Style Manager dialog box, click New. 

3   Type the name of the new dimension style, and choose the start style and the used for 
which dimensions. 

4   Click Continue. 

5   In the Dimension Style dialog box, click one of the other tabs, and then change the 
dimension settings as necessary. 

Repeat this step for each tab, as needed. 

6 To end the command, click OK. 

Dimension toolbar    
Command line      DIMSTYLE 

 
 
To select a dimension style 
1   Choose Dimensions > Style. 
2   Select a dimension style from the styles list. 

Dimension toolbar    
Command line      DIMSTYLE 

 
 
To rename a dimension style 
1   Choose Dimensions > Style. 
 

2   In the Styles tab of Dimension Style dialog box, do one of the following: 

•   Double click the required style. 

•   Right click the required style, then choose rename.  

3   Type the new name. 

4   Click Close to exit. 

Dimension toolbar    
Command line      DIMSTYLE 

 
 
To delete a named dimension style 
1   Choose Dimensions > Style. 
 

2   In the Styles tab of Dimension Style dialog box, right-click the required style, then 
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choose delete. 

3   Click Close to close. 

Dimension toolbar    
Command line      DIMSTYLE 
 
To display information about the current style 

1   Choose Dimensions > Style. 

2   In the Dimension Style Manager dialog box, click Compare. 

3   In the Compare and With box, choose your required style at one time, then in the 
following tab, it will show information about the style. 

4   If you want to know the different information between two styles, choose one style in 
Compare box, and choose the other in the With box, you will see difference in the 
following tab. 

5   Click Close to close. 

Dimension toolbar    
Command line      DIMSTYLE 
 
Controlling dimension arrows 
You can control the appearance and size of arrowheads or tick marks placed at the ends of 
dimension lines. Any changes you make affect the current dimension style. The arrowheads 
you choose display in the image tile on the right side of the Dimension Settings dialog box. 
 
You can choose from a number of arrowhead types. You can specify different arrowheads for 
each end of a dimension line and for leader lines. The Starting arrow corresponds to the first 
extension line; the Ending arrow corresponds to the second extension line. Blocks defined in 
the drawing also display in the three Arrowhead lists as user defined arrows. You can use these 
blocks to create and assign your own arrowheads. The Arrow Size value determines the size of 
the arrowhead, measured in drawing units. You can also use tick marks instead of arrowheads. 
 
 
To choose an arrowhead 
1   Choose Dimensions > Style. 
 

2   In the Dimension Style Manager, select the style you wish to change and choose 
Modify. 

3    Click Lines and Arrow tab. 

4   In the 1st Arrowhead or 2st Arrowhead list, click to select the 1st or 2st arrowhead, res-
pecttively. 

5   In the Leader Arrowhead list, click to select a leader arrowhead for leader lines. 

6   Click OK. 
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7   Choose Close to exit. 

Dimension toolbar    
Command line      DIMSTYLE 
 
 
NOTE  You can also specify leader arrow types using the DIMLDRBLK system vari- 
able. 
 
 

A 
B 
C 
D 
E 

 
A  Click to select a starting arrowhead. D  Type or select arrowhead size. 
B  Click to select an ending arrowhead, E  Select mark type, and type or select mark size.
C  Click to select a leader arrowhead. 
. 
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Controlling dimension format 
You can control the way dimension text and arrowheads are placed in relation to the dimen-
sion lines. Any changes you make affect the current dimension style. The image tile on the 
right side of the Dimension Settings dialog box shows the appearance of dimensions based on 
the current dimension style settings. 
 

The program determines whether both dimension text and arrowheads will fit between the ex-
tension lines by comparing the distance between the extension lines to the size of the dimen-
sion text, the size of the arrowheads, and the amount of space required around dimension text. 
The program applies the best fit method based on the available space. If possible, both the 
dimension text and arrowheads are placed between the extension lines. If both will not fit 
between the extension lines, you can determine how text and arrowheads are placed using the 
Fit Method settings on the Dimension Settings dialog box. 
 
                             

 
To format dimensions 
1   Choose Dimensions > Style. 
2   In the Dimension Style Manager, select the style you wish to change and choose 

Modify. 

3   Click Fit tab.  

4   Under Fit options and Text Placement, select an option.  

5   Click OK. 

6   Choose Close to exit. 

Dimension toolbar    
Command line      DIMSTYLE 
 
 
NOTE You can also specify how dimension text and arrows are arranged using the 
DIMATFIT system variable. You can specify how dimension text is moved using the 
DIMTMOVE system variable. 
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F 

A 
B 
C 
D 
E 

G 
H 
I 

J 

K 

 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
A  Click to move either text or arrows between 

extension lines automatically when both text and 
arrows do not fit between the extension lines. 

F   Click to suppress arrows if they don’t’ fit inside the 
extension. 

G  Click to place text beside the dimension line with a 
leader when text isn’t in the default position. B  Click to move arrows between extension lines when 

both text and arrows do not fit between the extension 
lines. 

H  Click to place text above the dimension line with a 
leader connecting the text to the dimension line 
when text isn’t in the default position. C  Click to move arrows between extension lines 

when both text and arrows do not fit between the 
extension lines. 

I  Click to place text above the dimension line without 
a leader when text isn’t in the default position. 

D  Click to move both text and arrows between 
extension lines when both text and arrows do not fit 
between the extension lines. 

J  Click to choose the scale dimension features, you 
can use overall scale for your desired，or you can 
scale dimension to layout. E  Always keep text .between extension lines when both 

text and arrows do not fit between the extension 
lines. 

K  Fine tuning. 

 

 272 



DIMENSION YOUR DRAWING 

Controlling line settings 
You can control settings affecting dimension lines, extension lines, and center marks. Any 
changes you make affect the current dimension style. The image tile on the right side of the 
Dimension Settings dialog box shows the appearance of the dimensions based on the current 
dimension style settings. 

 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 

A  Extend past dimension.                 C  Offset from origin. 
B  Baseline offset. 
 
 
 
To set the color for dimension lines 
1   Choose Dimensions > Style. 
 

2   In the Dimension Style Manager, select the style you wish to change and choose 
Modify. 

3   Click the Lines and Arrows tab. 

4   Make your selections. 

5    Click OK. 

6   Choose Close to exit. 

Dimension toolbar    
Command line      DIMSTYLE 
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I 
H 

G 
F 

E 

D 

C 

B 

A 

J 

 
 
A  Select the dimension line color. F  Select the extension lineweight 
B  Select the dimension lineweight G  Select to prevent the creation of the first and second 

dimension lines. C  Type or select the extend beyond ticks.  
D  Type or select the spacing when using baseline 

dimension. 
H  Type or select the baseline offset distance. 
I   Type or select the offset from origin. 

E  Select to prevent the creation of the first and second 
dimension lines. 

J  Select to prevent the creation of the first and second 
extension lines. E  Select the extension line color 

 
 
Controlling dimension text 
You can control the settings affecting the appearance of dimension text. Any changes you 
make affect the current dimension style. The image tile on the right side of the Dimension 
Settings dialog box shows the appearance of the dimensions based on the current dimension 
style settings. 
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Text between extension lines aligned                   Text between extension lines 
horizontally.                                           aligned with dimension line.  
 
 
To align dimension text with the dimension line 
1   Choose Dimensions > Style. 
 

2   In the Dimension Style Manager, select the style you wish to change and choose 
Modify. 

3   Click the Text tab. 

4   Make your selections. 

5   Click OK. 

6   Choose Close to exit. 

Dimension toolbar    
Command line      DIMSTY

A 
B 

C 

D 
E 

F 
G 

H 

I 

J 

K 
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A  Click to select the text style used for dimension text. G  Click to select or vertical justification of dimension 

text. B  Click to select the dimension text color. 
C  Type or select the text height, measured in drawing 

units 
H  Type or select the offset from dim line. 
I   Select to align text placed horizontally. 

D  Type or select the fraction height scale. J  Select to align text with dimension line. 
E  Click if you want to draw frame around text. K  Select to align text with ISO standard. F  Click to select the horizontal justification of 

dimension text. 
 
Controlling dimension units 
You can determine the appearance and format of the primary and alternate dimension units. 
The image tile on the right side of the Dimension Settings dialog box shows the appearance of 
the dimensions based on the current dimension style settings. 
 

 
Round off distance set to .0100            Round off distance set to 0.2500.   Round off distance set to 1.0000. 
(original dimension before rounding). 
 
 
To round off dimensions 
1   Choose Dimensions > Style. 
 

2   In the Dimension Style Manager, select the style you wish to change and choose 
Modify. 

3   Click the Primary Units tab. 

4   In the Linear Dimension field, type or select the nearest value to which you want to 
round off dimensions. 

5   Click OK. 
6   Choose Close to exit. 

Dimension toolbar    
Command line      DIMSTYLE 
 
 
NOTE You can also specify units for linear dimensions using the DIMLUNIT system 
variable. You can specify fraction formats using the DIMFRAC system variable
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B D 

A 
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A  Select the linear dimension format. 
B  Type or select the number of decimal places you 

want displayed in linear dimension text. 
C  Click to choose the fraction format if you choose 

fraction in the unit format. 
D  Click to choose a decimal separator if you choose 

decimal in the unit format. 
E  Type or select the nearest value to which you want 

to round off linear distance. 
F  Type a prefix or suffix to dimension text. 

G  Select the scale factor in measurement. 
H  Apply the setting of scale factor to layout dimensions 

only. 
I   Select to prevent the inclusion of leading zeros 
when the dimension is less than one foot or the inclusion 
of trailing zeros when the number of inches is zero. 
J  Select the angular dimension format. 
K Type or select the number of decimal places you want 
displayed for angular dimension text. 
L Select whether to suppress leading or trailing zero. 

 
. 

L 

K 

J 

H 

G 

F 

C 

E 
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Adding geometric tolerances 

 
Geometric tolerances indicate the maximum allowable variations in the geometry defined by a 
drawing. ZwCAD draws geometric tolerances using a feature control frame, which is a rec-
tangle divided into compartments. 
 

Each feature control frame consists of at least two compartments. The first compartment con-
tains a geometric tolerance symbol that indicates the geometric characteristic to which the 
tolerance is applied, such as location, orientation, or form. For example, a form tolerance may 
indicate the flatness or roundness of a surface. The geometric tolerance symbols and their 
characteristics are shown in the followingtable. 
 
Geometric tolerance symbols 
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The second compartment contains the tolerance value. When appropriate, the tolerance value 
is preceded by a diameter symbol and followed by a material condition symbol. The material 
conditions apply to features that can vary in size. The material condition symbols and their 
meanings are shown in the following table. 
 
Material conditions 
 

 
 
 
 
 
 
 
 
 

 
The tolerance value can then be followed by primary, secondary, and tertiary datum reference 
letters, along with the material conditions of each datum. Datum reference letters are generally 
used as reference tolerances to one of up to three perpendicular planes from which a measure-
ment is made, although datum reference letters can also indicate an exact point or axis. 

 
 
 
 
 
 
 
               
 
 

 
A  Geometric characteristic symbol. D  Material condition symbol. 
B  Diameter symbol. E  Datum reference. 
C  Tolerance value. 
 . 
. 
 
When two tolerances apply to the same geometry, you can also add a composite tolerance 
consisting of a primary tolerance value followed by a secondary tolerance value. To make a 
tolerance even more specific, it can also contain a projected tolerance consisting of a height 
value followed by a projected tolerance symbol. For example, you can use a projected toler-
ance to indicate the perpendicularity of an embedded part. 
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To add a geometric tolerance 
1   Choose Dimensions > Tolerance. 
 

2   To display the geometric tolerance symbols, on the first line, click the Sym box. 

3   Click to select a geometric tolerance symbol. 

4   Under Tolerance 1, click the Dia. box to add a diameter symbol. 

5   In the field, type the first tolerance value. 

6   To display the material condition symbols, click the other line box in Tolerance 1. 

7   Click to select a material condition. 

8   Under Tolerance 2, repeat steps 4 through 7 to add a secondary tolerance value, if appro-
priate. 

9   Under Datum 1, type the primary datum reference letter. 

10   To display the material condition symbols, click the other line box in Tolerance 2. 

11   Click to select a material condition. 

12   Repeat steps 9 through 11 to add secondary and tertiary datum, if appropriate. 

13   In the second row, repeat steps 2 through 12 to add composite tolerances, if appropriate. 

14   In the Height box, type a projected tolerance zone height value, if appropriate. 

15   To insert a projected tolerance zone symbol, click the Projected Tolerance Zone box, if 
appropriate. 

16   Click OK. 

17   In the drawing, specify the location of the feature frame. 

Dimension toolbar    
Command line      TOLERANCE 
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A 

B 

C 

Q P O N M L K J I H G E 

D 

 
 

A  Use this row to include composite tolerances. K  Click to select the material condition symbol for the 
second tolerance value. B  Type a projected tolerance height value. 

C  Type a datum identifier. L  Type the second tolerance value. 
D  Click to include a projected tolerance symbol. M  Click to include a diameter symbol for the second 

tolerance value. E  Click to select the material condition symbol for 
tertiary data. N  Click to select the material condition symbol for the 

first tolerance value. F  Type the tertiary datum reference letter. 
O  Type the first tolerance value. G  Click to select the material condition symbol for 

secondary datum. P  Click to include a diameter symbol for the first 
tolerance value. H  Type the secondary datum reference letter. 

Q  Click to select a geometric tolerance symbolI   Click to select the material condition symbol for 
primary datum. 

J  Type the primary datum reference letter. 
. 
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Controlling dimension tolerance 
You can create dimensions as either tolerance or limits dimensions. When creating a tolerance 
dimension, you can control the upper and lower tolerance limits as well as the number of deci-
mal places of the dimension text. The image tile on the right side of the Dimension Settings 
dialog box shows the appearance of tolerance and limits dimensions based on the current dim-
ension style settings. 
 

 
 
 
 
 
 
 
 
 
 

Tolerance dimension. Limits dimension. 
 
 
 
To create a tolerance dimension 
1   Choose Dimensions > Style. 
 

2   In the Dimension Style Manager, select the style you wish to change and choose 
Modify. 

3   Click the Tolerances tab. 

4   Make your selections. 

5   Click OK. 

6   Choose Close to exit. 

Dimension toolbar    
Command line      DIMSTYLE 
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I 

H 

A 
B 

C 

D 

E 
F 

G 

 
A  Select a method of tolerance format. 
B  Type or select the number of decimal places you want displayed in tolerance. G  Select the zero suppression for tolerance format. 

F  Select the vertical position. 

C  Type or select the maximum tolerance or upper limit 
value. 

H  Type or select the precision of alternate unit 
tolerance. 

D  Type or select the minimum tolerance or lower limit 
value. 

I   Select the zero suppression for alternate unit 
tolerance.E  Type or select a scale for height. 
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CHAPTER 12 

 

 Controlling alternate dimension units 
You can include alternate dimensions in addition to the primary dimension text. You can also 
determine the appearance and format of the alternate dimensions, including the scale factor 
applied to generate alternate dimensions. The image tile on the right side of the Dimension 
Settings dialog box shows the appearance of the dimensions based on the current dimension 
style settings. 
 

 
Alternate dimension created using a scale factor of 25.4, with an appended suffix. 
 
To create an alternate dimension 
1   Choose Dimensions > Style. 
 

2   In the Dimension Style Manager, select the style you wish to change and choose 
Modify. 

3   Click the Alternate Units tab. 

4   Click the Display Alternate Units check box. 

5   Make your selections. 

6   Click OK. 

7   Choose Close to exit. 

Dimension toolbar    
Command line      DIMSTYLE 
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A  Click to display alternate units. 
B  Click to select the format for alternate dimensions. 
C  Type or select the number of decimal places displayed in alternate dimensions. G  Select the zero suppression 

F  Type a prefix or suffix to be appended to alternate 
dimensions. 

D  Type or select the multiplier for alternate units.  H  Select the placement.
E  Type or select any rounding for alternate 

dimensions. 
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Working with blocks, attributes, 

and external references 
 
 

 
Blocks, attributes, and external references provide mechanisms for managing objects in your 
drawings and for including additional information with the standard drawing objects. With 
blocks, you can combine numerous objects into a single object, and then reuse it, inserting 
multiple copies. With attributes, you can associate text, such as part numbers or prices, with 
blocks, and then extract the text attribute information to a separate file, such as a database, for 
further analysis. With external references, you can link separate reference drawing files to a 
drawing to combine information without adding the contents of the reference drawings to the 
current drawing. If you make changes to the referenced file, all references are updated 
automatically. 
 

This section explains how to: 
 

•   Create, insert, and redefine blocks. 
•   Create, edit, and insert attributes. 
•   Extract attribute data to a separate file. 
•   Attach and work with external references. 
 
 
 
 
Topics in this chapter 
 
 

Working with blocks .............................................................................................287 
Working with attributes ...........................................................................................291 
Working with external references ..............................................................................297 
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Working with blocks 

 
Usually, blocks are several objects combined into one that you can insert into a drawing and 
manipulate as a single object. A block can consist of visible objects such as lines, arcs, and 
circles, as well as visible or invisible data called attributes. Blocks are stored as part of the 
drawing file. 
 

Blocks can help you better organize your work, quickly create and revise drawings, and 
reduce drawing file size. Using blocks, you can create a library of frequently used symbols. 
Then you can insert a symbol as a block rather than redraw the symbol from scratch. 
 
After you create a block from multiple objects, you save it once, which also saves disk space. 
You insert only multiple references to a single block definition. You can change the block 
definition to quickly revise a drawing, and then update all instances of the block. 
 

If you insert a block that contains objects originally drawn on layer 0 and assigned color and 
linetype BYLAYER, it is placed on the current layer and assumes the color and linetype of that 
layer. If you insert a block that contains objects originally drawn on other layers or with 
explicitly specified colors or linetypes, the block retains the original settings. 
 

If you insert a block that contains objects originally assigned color and linetype BYBLOCK, 
and the block itself has the color and linetype BYLAYER, those objects adopt the color and 
linetype of the layer onto which they are inserted. If the block is assigned an explicit color or 
linetype, such as red or dashed, those objects adopt those qualities. 
 
A procedure called nesting occurs when you include other blocks in a new block that you are 
creating. Nesting is useful when you want to combine and include small components, such as 
nuts and bolts, into a larger assembly and you need to insert multiple instances of that 
assembly into an even larger drawing. 
 
Creating blocks 
The tools and commands for creating blocks appear on the Tools toolbar and the Tools menu, 
respectively, when you set the program to the Advanced experience level. You can also use 
the ZwCAD Explorer to create blocks. 
 
You can create blocks in two ways: 
 

•   By saving a block for use within the current drawing only. 
•   By saving the block as a separate drawing file that you can insert into other drawings. 
 
When you create a block, you specify its name, its insertion point, and the objects that compose 
the block. The insertion point is the base point for the block and serves as the reference point 
when you later insert the block into a drawing. 
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To create a block for use within a current drawing 
Advanced experience level 
 
1   Choose Draw > Block > Make. 
2   In the tab, type a name for the block. 
3   Specify the insertion point for the block. 
4   Select the objects that you want in the block, and then press Enter. 

The block is created and exists only in the current drawing. The objects you select are 
removed from the display, because they are now part of the block. 

5   To restore the original objects to the drawing while retaining the new block, click 
retain.. 

Draw toolbar     
Command line   BLOCK 
 
 
NOTE If you frequently restore original objects after you define a block, you can cus- 
tomize the program to add the Undelete command to a menu or toolbar. 
 

 
You can create a block as a separate drawing file that you can insert into other drawings. 
 
To save a block as a separate drawing file 
Advanced experience level 
 
1   On the command line, type wblock. 
2   In the source tab, choose one of the following: 
•   Block This option saves existing block object to a separate drawing file. When prompted, 

type the name of the block(s). 
•   Entity drawing This option immediately saves the entire drawing to a separate drawing 

file. 
•   Objects This option saves those objects you select to a separate drawing file. When 

prompted, specify the insertion point for the block, select the objects for the block. 
3   In destination tab, type the name of the drawing file you want to create and choose the 

saved path. 
 
 
NOTE When saving multiple blocks or saving the entire drawing as a separate draw- 
ing file, the program assigns the 0,0,0 coordinate as the insertion base point. You can 
change the base point by opening the drawing and redefining the block. 
 
 
Inserting blocks 
You can insert blocks and other drawings into the current drawing. When you insert a block, it 
is treated as a single object. When you insert a drawing, it is added to the current drawing as a 
block. You can then insert multiple instances of the block without reloading the original 
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drawing file. If you change the original drawing file, those changes have no effect on the 
current drawing unless you redefine the block by reinserting the changed drawing. 
 

You can also insert blocks from another drawing into the current drawing, using the ZwCAD 
Explorer. Both drawings must be open at the same time to do this. see Chapter 8, “Working 
with the ZwCAD Explorer.” 
 
When you insert a block or drawing, you must specify the insertion point, scale, and rotation 
angle. The block’s insertion point is the reference point specified when you created the block. 
When you insert a drawing as a block, the program takes the specified insertion point as the 
block insertion point. You can change the insertion point, however, by first opening the 
original drawing and redefining the block. 
 
To insert a block 
1   Choose Insert > Block. 
2   In the Insert Block dialog box, under Insert, click Block Name. 
3   In the Block Name box, select the name of the block you want to insert. 
4   Click Insert. 
5   Specify the insertion point for the block. 
6   Specify the x, y, and z scale factors and the rotation angle, or press Enter to accept the 

default values. 

Draw toolbar     
Command line   DDINSERT 
 
To insert an entire drawing into the current drawing 
1   Choose Insert > Block. 
2   In the Insert Block dialog box, under Insert, click From File. 
3   Type the path and the drawing file name, or click Browse to specify the file from the 

Insert Drawing dialog box, and click Open. 
4   Click Insert. 
5   Specify the insertion point for the block. 
6   Specify the x, y, and z scale factors and the rotation angle, or press Enter to accept the 

default values. 

Draw toolbar     
Command line   DDINSERT 
 
 
NOTE You can specify the insertion point, scale factors, and rotation angle in the Insert Block  
 
dialog box before inserting the block. You can also control whether the block is exploded back 
into its original component objects after insertion. Under Positioning, clear the Position Block 
When Inserting check box, and specify the appropriate coordinates. If you want to explode the 
block immediately, select the Explode Upon Insertion check box. 
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A  Click and then enter the path and drawing file name to insert the entire drawing file as a block. 
B  Click to position the block when inserting. 
C  Specify the insertion point, scale factors, and rotation angle before you insert the block (available only when Position 

Block When Inserting is cleared). 
D  Click to explode the block on insertion. 
E  Click to insert the block. 

  
Redefining blocks 
You can redefine all instances of a block within the current drawing. To redefine a block that 
was created in the current drawing, you create a new block using the same name. You can 
update all the blocks in the current drawing by redefining the block. If the block was inserted 
from a separate drawing file that was subsequently updated, reinsert that block to update all 
other instances in the current drawing. 
 
To redefine a block in the current drawing 
Advanced experience level 
 
1   Choose Draw > Block > Make. 
2   Type the name of the block you want to redefine, and then click OK. 
3   Specify the insertion point for the block. 
4   Select the objects for the block, and then press Enter. 
5   Click OK. 
6    In the dialog box of “The block already exists, Do you want to redefine it?”, click YES. 

Draw toolbar     
Command line   BLOCK 
 
The block is immediately redefined, and all instances of the block in the drawing are updated. 
The objects you select for inclusion in the block are removed from the drawing, because they 
are now part of the block. 
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TIP To restore the original objects to the drawing while retaining the new block, type 
undelete or oops. 

 
You can update all instances of a block inserted from a separate drawing by reinsert- ing the 
drawing. 
 
Exploding blocks 
You can explode an inserted block to its original component objects. When you explode a blo- 
ck, only that single instance of the block is affected. The original block definition remains in 
the drawing, and you can still insert additional copies of the original block. If you explode a 
block that contains attributes, the attributes are lost, but the original attribute definition srema- 
in. 
 

Exploding dissociates component objects to their next simplest level of complexity;blocks or 
polylines in a block become blocks or polylines again 
 
To explode a block 

1   Choose Modify > Explode. 
2   Select the block. 
3   Press Enter. 

Modify toolbar     
Command line     EXPLOD 
 
 
 

Working with attributes 

 
An attribute is a particular object that you can save as part of a block definition. Attributes 
consist of textbased data. You can use attributes to track such things as part numbers and 
prices. Attributes have either fixed or variable values. When you insert a block containing 
attributes, the program adds the fixed values to the drawing along with the block, and you are 
prompted to supply any variable values. 
 

After you insert blocks containing attributes, you can extract the attribute information to a 
separate file and then use that information in a spreadsheet or database to produce a parts list or 
bill of materials. You can also use attribute information to track the number of times a 
particular block is inserted into a drawing. 
 

Attributes can be visible or hidden. Hidden attributes are neither displayed nor printed, but the 
information is still stored in the drawing and written to a file when you extract it. 
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Defining attributes 
You add an attribute to a drawing by first defining it and then saving it as part of a block 
definition. To define an attribute, you specify the characteristics of the attribute, including its 
name, prompt, and default value; the location and text format- ting; and optional modes 
(hidden, fixed, validate, and predefined). 
 
To define an attribute 
Advanced experience level 
 
1   Choose Draw > Block > Define Attribute. 
2   In the Define Attribute dialog box, type the name, prompt, and default value. 
3   Under Insert Coordinates, specify the location of the attribute, or click Select to select a 

point in the drawing. 
4   Under Attribute Flags, select the optional attribute modes. 
5   Under Text, specify the text characteristics. 
6   To add the attribute to the drawing, do one of the following: 
•   Click Define to add the attribute and keep the dialog box active so you can define 

another attribute. 
•   Click Define And Exit to add the attribute and end the command 

Command line     DDATTDEF 
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A  Type the name you want to assign to the attribute. 
B  Enter the identifying prompt information 

displayed when you insert a block containing the attribute. 
C  Enter the default or constant value. For variable attributes, the default value is replaced by the actual value when 

you later insert a block containing the attribute. 
D  Specify the x-, y-, and z-coordinates for the attribute insertion point. 
E  Select to create a hidden attribute. 
F  Select to create a fixed-value attribute. 
G  Select to create an attribute whose value must be validated when you later insert a block containing the attribute. 
H  Select to create an attribute whose value is defined and not requested when you later insert a block containing the 

attribute, but that you can edit after the block is inserted. 
I   Click to add the attribute and keep the dialog box 

active so you can define another attribute. 
J  Click to add the attribute and end the command. 
K  Specify the text rotation angle, or click to specify the rotation angle by selecting two points in the drawing. 
L  Specify the text height, or click to specify the height by selecting two points in the drawing. 
M   Choose the text justification. 
N  Choose the text style from those styles already defined in the drawing. 
O  Click to specify the attribute insertion point by selecting a point in the drawing. 
 
 
 
Editing attribute definitions 
You can edit an attribute definition before you associate it with a block and before it 
is saved as part of a block definition. 
 
To edit an attribute definition 
Advanced experience level 
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1   On the command line, type ddedit. 
2   Select the attribute definition text to edit. 
3   Modify the attribute name, prompt string, default value, and other attribute definition 

characteristics. 
4   Click OK. 
 
 
 
Attaching attributes to blocks 
You can attach attributes to a block after you define it and select it as one of the entities to 
include. Include the attributes when the program prompts you for the objects to include in the 
selection set for a block. After the attribute is incorporated into a block, the program prompts 
you each time you insert the block, so you can specify different values for the attributes each 
time you insert it into a new drawing. 
 

Editing attributes attached to blocks 
You can edit the attribute values of a block that has been inserted into a drawing. 
 
To edit an attribute attached to a block 
Advanced experience level 
1   On the command line, type ddatte. 
2   Select the block to edit. 

The Edit Block Attributes dialog box displays all the attributes attached to the block you 
select. 

3   Edit the attribute values as necessary. 
4   Click OK. 
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A  Identifies the name of the block. 
B  Displays the names of all attributes attached to the block.   
C  Click to select attribute. 
D  Type the new value for the selected attribute. 
E  Click to update the attribute values and exit. 
F  Displays the value of each attribute attached to the block. 
G  Displays the prompt for each attribute attached to the block. 
 
 
 
Extracting attribute information 
You can extract attribute information from a drawing and save it to a separate text file for use 
with a database program. You can save the file in any of the following formats: 
•   Comma Delimited Format (CDF) Contains one line for each instance of a block, with 

individual attribute fields separated by commas. Character string fields are enclosed with 
single quotation marks. You must specify a template file when extracting to a CDF file. 

•   Space Delimited Format (SDF) Contains one line for each instance of a block. Each 
attribute field has a fixed length; there are no separators or character string delimiters. 
You must specify a template file when extracting to a SDF file. 

•   Drawing Exchange Format (DXF) Creates a subset of a standard DXF file (a *.dxx file) 
containing all the information about each block, including the insertion 
points, rotation angles, and attribute values. No template file is required. 

 
Before extracting attributes to a CDF or SDF file, you must create a template file. The template 
file is an ASCII text file that specifies the attribute data fields to be written in the extract file. 
Each line of the template file specifies one attribute field. ZwCAD recognizes 15 different 
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fields, which contain elements such as the block name, the x, y, and z mcoordinates of its 
insertion point, the layer on which it is inserted, and so on. You can include any of these fields. 
The template file must include at least one attribute name. 
 

Each line in the template file must start with the field name. Block name and insertion point 
values must begin with BL:. The next nonblank character must be either a C (indicating 
a character string field) or an N (indicating a numeric field). This character is then followed 
by three digits indicating the width of the field (in characters). The final three digits indicate 
the number of decimal places (for numeric fields). In the case of character fields, the last three 
digits must be zeros (000). A typical template file is similar to the one shown here： 

 
 
 
 
 
 
 
 
 
 
 

 
A  Field name. 
B  Block name. Block names must begin with BL:.. 
C  Insertion point. Insertion point values must begin with BL:.. 
D  Attribute tags. 
E  Number of decimal places for numeric fields or 000 for character fields. 
F  Field width for character or numeric fields. 
G  C for character fields; N for numeric fields. 
 
To create a template file 
1   Create a template file using any ASCII text editor (such as Microsoft® Notepad or 

Microsoft®  WordPad) or a word processing program such as Microsoft®  Word. 
2   Include the necessary fields in the template file. 
3   Save the template file in ASCII text format. 
 
To extract attribute information 
1   Choose Tools > Attribute Extraction. 
2   Click Select, specify the objects from which to extract attributes, and then press 

Enter. 
3   Specify the format of the extracted file. 
4   For CDF and SDF formats, specify the template file. 
5   Specify the extract output file. 
6   Click Extract. 
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A  Click to select blocks in the drawing containing attributes you want to extract. 
B  Click to specify the format of the extracted file. 
C  Specify the template file for CDF and SDF extracts. 
D  Specify the extract output file. 
E  Click to extract attributes. 
F  Click to specify the output file using a file dialog box. 
G  Click to specify the template file using a file dialog box. 
H  Indicates the number of blocks with attributes selected for extraction. 
 
 

Working with external references 

 
You can link entire drawings to the current drawing as external references. Unlike inserting a 
drawing as a block, in which you add all the objects from the separate drawing into the current 
drawing, external references attach a pointer to the external file. The objects in the external 
reference appear in the current drawing, but the enti- ties themselves are not added to the 
drawing. Thus, attaching an external reference does not significantly increase the size of the 
current drawing file. 
 

External references provide additional capabilities not available when you insert a drawing as 
a block. When you insert a drawing as a block, the objects are stored in the drawing. Any 
changes you make to the original drawing are not reflected in the drawing in which you 

 297 



 298 

inserted it. When you attach an external reference, however, any changes you make to the 
original drawing file are reflected in the drawings that reference it. These changes appear 
automatically each time you open the drawing containing the external reference. If you know 
that the original drawing was modified, you can reload the external reference anytime you’re 
working on the drawing. 
 
External references are useful for assembling master drawings from component drawings. Use 
external references to coordinate your work with others in a group. External references help 
reduce drawing file size and ensure that you are always working with the most recent version 
of a drawing. 
 

The Xref Manager helps you easily attach and work with external references. 
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A  Click to display a detailed list or hierarchical tree. 
B  Select an external reference to modify its attachment. 
C  Type or click Browse to specify the external reference location. 
D  Click to link a drawing. 
E  Click to completely remove the external reference. 
F  Click to update with changes from the external reference. 
G   Click to remove the external reference, but keep elements and path information for easy reloading. 
H  Click to make the external reference a permanent part of the drawing. 
I   Click to open the source drawing for the external reference. 
 
 
 

 
Attaching external references 
Attaching a separate drawing to the current one creates an external reference. The external 



reference appears in the drawing as a block definition, but the drawing entities are linked 
rather than added to the current drawing. If you modify the linked drawing, the current 
drawing that contains the external reference is updated automatically when you open it, or you 
can reload the external reference manually so it reflects the latest version of the external 
reference. 
 
When you attach an external reference, its layers, linetypes, text styles, and other elements are 
not added to the current drawing. Rather, these elements are also linked from the referenced 
file. 
There are two ways you can attach an external reference: 
 

•   An attachment is an inserted drawing that contains a link to the original file. Attachments 
can themselves contain other, nested reference files. When you attach an external reference, 
any nested references contained in the file also appear in the current drawing. 
•   An overlay is an inserted drawing that contains a link to the original file. Overlays allow 
you to lay a drawing on top of another drawing, similar to the way you work manually with 
transparencies. When a drawing that contains overlaid external references is itself attached or 
overlaid as an external reference in another drawing, 
the overlays do not appear as part of the external reference. Use overlaying when you want to 
see reference geometry in a drawing but you do not need to include that geometry in drawings 
that will be used by others (nested external references). 
 
You can attach as many copies of an external reference file as you want. Each copy can have a 
different position, scale, and rotation angle. 
 
To attach an external reference 
1   Choose Insert > Xref Manager. 
2   Click Attach. 
3   Specify the drawing file to attach as an external reference, and then click Open. 
4   In Reference Type, choose how you want to insert the drawing: 
•   Attachment – inserts a copy of the drawing and includes any other drawings that are exter 

nally referenced within the referenced drawing. 
•   Overlay – lays a copy of a drawing over your original drawing; it does not include any 

nested external references from the externally referenced drawing. 
5   Make any additional selections. 
6   Click OK. 
7   If you marked Specify On Screen for any items, follow the prompts to attach the external 
reference. 

Insert toolbar     
Command line     XREF 
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A  Displays the external reference to attach, or select one from the list. 
B  Click to locate and select a different external reference. 
C  Select to choose the path type. 
D  Click Attachment to link a drawing, including any of its own external references. Click Overlay to link a drawing, 

omitting any of its own nested external references. 
E  Choose to specify the insertion point in the drawing, or enter x, y, and z coordinates. 
F  Choose to specify the scale in the drawing, or enter x, y, and z scale factors. 
G  Choose to specify the rotation angle in the drawing, or enter a rotation angle. 

 
 
Viewing the list of external references 
You can view a list of the external references that are linked to the current drawing two 
different ways using the Xref Manager: 
•   List View displays the external references in a list, which allows you to sort the list of 

references by name, status, size, type, date, or saved path. 
•   Tree View displays a hierarchical representation of the external references and the 

relationships between them. The tree view shows the level of nesting relationships 
of the attached external references. 

 
To view a list of external references 
1   Choose Insert > Xref Manager. 

2 Click List View ( ) or Tree View ( ). 

Insert toolbar     



 301 

Command line     XREF 

 

Opening external references 
From the Xref Manager you can quickly open the source drawing for any external reference. 
This is especially helpful if you are working with nested external references, which you cannot 
bind or detach. From the Xref Manager, open the source drawing, make changes, and then 
save and close the source drawing. When the Xref Manager displays again, simply reload the 
external reference. 
 
To open an external reference 
1   Choose Insert > Xref Manager. 
2   Select the external reference to open. 
3   Click Open. 

Insert toolbar     
Command line    XREF 
 
 
 
Removing external references 
Removing external references from the current drawing is easy with the Xref Manager. You 
can unload an external reference, which keeps some information about the external reference 
in the current drawing for easy reloading later, or you can detach the external reference 
entirely. 
 
When you unload an external reference, you remove it from the current drawing. However, its 
elements, such as layers and linetypes, remain in the drawing and it is still listed in the Xref 
Manager. By detaching an external reference you remove it and all of its elements from the 
current drawing, and it is no longer listed in the Xref Manager. 
 
To unload an external reference 
1   Choose Insert > Xref Manager. 
 

2   Select the external reference to unload. 
3   Click Unload. 

Insert toolbar     
Command line     XREF 
 
To detach an external reference 
1    Choose Insert > Xref Manager. 
 

2   Select the external reference to detach. 
3   Click Detach. 

Insert toolbar     
Command line     XREF 
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NOTE Only the external references that are attached directly to the current drawing 
can be detached; nested external references cannot be detached. 
 
 
Reloading external references 
When you open or print a drawing, any external references in the drawing are updated 
automatically. If a drawing is already open and a referenced drawing is modified, you can 
update the current drawing manually to display the latest version of the referenced drawing. 
You may also want to reload an external reference that has been unloaded temporarily. 
 

To reload an external reference 
1   Choose Insert > Xref Manager. 
2   Select the external reference to reload. 
3   Click Reload. 

Insert toolbar     

Command line     XREF 

 

Changing the path for external references 
If the file associated with an external reference is moved to a different directory or renamed, 
the program displays a message indicating that it cannot load the external reference. You can 
re-establish the link to the file by doing any of the following: 
•   Change the path for the external reference. 
•   Specify additional directories for ZwCAD to search. This is especially helpful 

if you have several external references that have moved to a new directory. 
 
To change the path for a single external reference 
1   Choose Insert > Xref Manager. 
 

2   Select the external reference whose path you want to change. 
3   In Xref Path, do one of the following: 
•   Enter a new filename or location. 
•   Click Browse to locate and select the referenced drawing. ZwCAD reloads the specified 

external reference automatically. 

Insert toolbar     
Command line    XREF 

 
NOTE You cannot recursively reference a drawing from the same original drawing. 
 
 
To change the search paths for all external references in the drawing 
1   Choose Insert > Xref Manager. 
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2   In Additional Xref Search Paths, do one of the following: 
•   Enter a new directory and its path. Separate multiple paths with a semicolon, for example, 

c:\My Drawings;d:\My Drawings\Backup. 
•   Click Browse to locate and select a directory. 
 

ZwCAD searches the specified directories; any found external references are reloaded 
automatically. 

Insert toolbar     
Command line     XREF 
 
Binding external references to drawings 
External references are not part of the drawing. Rather, they are links to an externally 
referenced file. To provide a copy of a drawing containing external references to someone else, 
you must also provide all the external reference files. In addition, the person receiving the 
drawings must either recreate the same paths you used when linking the external references or 
change the paths for the external references. 
 

To provide a copy of a drawing that contains external references, it is often easier to first bind 
the external references to the drawing. Binding the external references makes them a 
permanent part of the drawing, which is similar to inserting a separate drawing as a block. 
 

You can bind external references that are attached directly to the current drawing; you cannot 
bind nested external references. 
 
To bind an existing external reference to a drawing 
1   Choose Insert > Xref Manager. 
 

2   Select the external reference to bind. 
3   Click Bind. 
4   Choose one of the following: 
•   Bind Binds the external reference and creates a unique name for each named object, such 

as a layer or block, that is located in the external reference. For example, a layer named 
Electric in the external reference will be named Xref$0$Electric in the current drawing. 
If the current drawing already has a layer or block with the same name, the name is 
changed incrementally, for example, Xref$1$Electric. 

•   Insert Binds the external reference, but does not change the names of any named objects in 
the external reference. For example, a layer named Electric in the external reference will 
have the same name, Electric, in the current drawing. If the current drawing has a layer 
or block with the same name, the named object in the external reference takes on the 
properties of the named object in the current drawing. 

5   Click OK. 

Insert toolbar     
Command line    XREF 
 
Clipping external references 
When you attach a drawing as an external reference, all of the referenced drawing displays in 



 304 

the current drawing. However, after you attach an external reference, you can define a clipping 
boundary that determines which portion of the referenced drawing is visible or hidden. 
 

You can edit, move, or copy clipped external references the same way you modify unclipped 
external references. The boundary moves with the reference. If an external reference contains 
nested clipped external references, they also appear clipped in the drawing. 
 

 
TIP In addition to clipping external references, you can also partially hide blocks 
using clipping boundaries. 
 
 

 
Example of an external reference clipped using a clipping boundary. The clipping boundary is the rectangle 
in the top window. 
 
 
Adding a clipping boundary 
When you create a clipping boundary, it affects only the display of the referenced drawing; it 
does not affect the original referenced drawing or any referenced geometry. The portion of the 
external reference within the clipping boundary is visible and the remainder of the external 
reference becomes hidden. 
 
To define a rectangular clipping boundary 

1   Choose Modify > Clip > Xref. 
2   Select the external references to clip. If desired, you can also select blocks. 
3   Press Enter. 
4   Press Enter to create a new clipping boundary. 
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5   If prompted, press Enter to delete any existing boundaries. 
6   Choose Rectangular. 
7   Define the first corner of the clipping rectangle. 
8   Define the second corner of the clipping rectangle. 
The selected external references are clipped by the rectangle. 

Reference toolbar   

Command line     XCLIP 

 
TIP You can first select all external references, right click the selection, and then 
select Xref Clip from the shortcut menu. 
 
 
To define a clipping boundary using a polyline 

1   Draw a polyline where you want to clip external references. 
2   Choose Modify > Clip > Xref. 
3   Select the external references to clip. If desired, you can also select blocks. 
4   Press Enter. 
5   Press Enter to create a new clipping boundary. 
6   If prompted, press Enter to delete any existing boundaries. 
7   Choose Select Polyline. 
8   Select the polyline to use as clipping boundary. 

Reference toolbar   

Command line     XCLIP 

 

Turning clipping boundaries on and off 
You can turn xref clipping on or off. When a clipping boundary is turned off, the boundary 
does not display and the entire external reference is visible, provided that the geometry is on a 
layer that is on and thawed. When a clipping boundary is turned off, it still exists and can be 
turned on. However, deleting a clipping boundary is permanent. 
 
To turn clipping boundaries on and off 
1   Choose Modify > Clip > Xref. 
2   Select the desired external references. 
3   Press Enter. 
4   To turn off clipping boundaries, choose Off. To turn on existing clipping bound aries, 

choose On. 
5   Press Enter. 
If you are turning off a clipping boundary, click the clipped portion of the external reference to 
view the previously hidden portion of the referenced drawing. 

Reference toolbar   
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Command line     XCLIP 
 
 
TIP When the XCLIPFRAME system variable is on (set to 1), you can select and print 
the clipping boundary frame. 
 
 
Deleting a clipping boundary 
If you no longer need a clipping boundary for an external reference, you can delete it. 
 
To delete a clipping boundary 

1   Choose Modify > Clip > Xref. 
2   Select the desired external references. 
3   Press Enter. 
4   Choose Delete, and then press Enter. 
5   Click the clipped portion of the external reference. 
The previously hidden portion of the referenced drawing displays. 

Reference toolbar   

Command line     XCLIP 



 
 
Printing drawings 
 

You can print a copy of your drawing exactly as you created it, or you can add formatting and 
specify print controls to change how your drawing looks when it is printed. 

Sometimes you may require multiple printed drawings, each with a different look or layout. 
For example, you may need one printed drawing for a client presentation, along with several 
other variations for production contractors. For each type of 

printed drawing that you require, you can create a layout that defines its characteristics, 
including scale, area to print, print style tables, and more. 

This section explains how to: 

•   Start printing right away. 

•   Set up a drawing to print multiple layouts from paper space on a Layout tab. 

•   Define how you want your drawing to look when it is printed. 

•   Print or plot your drawing. 

 

Topics in this chapter 

 

Getting started printing..........................................................................................308 
Defining layouts for printing .....................................................................................309 
Customizing print options.....................................................................................322 
Printing or plotting your drawing................................................................................341 
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Getting started printing 

 

When you create a drawing, you do most of your work on the Model tab. At any time you can 
print your drawing to see how it looks on paper. It’s easy to get started printing, and then later 
create layouts and custom print settings to enhance your printed output. 

 

To start printing 

1 Choose File > Plot. 

2 Click Print. 

Standard toolbar    

Command line     PLOT 

There are many options that you can set before printing, such as the scale of the drawing, print 
area, print style tables, and more. For details, see “Customizing print options” on page 321 

in this chapter. 

NOTE Type qprint and then press Enter to print the current viewport. The Print dialog 

box is bypassed and the drawing is sent directly to the selected printer. 
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Defining layouts for printing 

 

You can print your drawing directly from the Model tab where you created it, or you can 
create custom layouts for printing on Layout tabs. 

 

When printing from the Model tab, you can print your drawing exactly the way it appears, or 
you can modify the drawing before printing by adding dimensions, a legend, or a title block. 

 

You typically use the Layout tabs for printing if you require multiple print layouts. You may 
also want to use a Layout tab for printing even if you want your drawing printed only one way. 
For example, if you want to include large amounts of text on your printed drawing, you can 
add the text to a Layout tab so it does not clutter your drawing while you work on the Model 
tab. 

 

Understanding layouts 

When you create a drawing, you do most of your work on the Model tab. Each drawing that 
you create can contain numerous layouts that simulate the paper on which 

you will print a copy of the drawing. Each of these layouts is created on a Layout tab. 

 

You can prepare a separate layout for each way you want to print your drawing. The layout 
allows you to organize different views to control which portion of your drawing prints and at 
what scale. 

 

Before you print, you can also include additional objects and layout settings that control how 
your drawing prints. Additional items only appear on the Layout tab, not on the Model tab. For 
example, a layout can contain title blocks, legends, or keynotes 

that print with your model, but do not clutter the screen when you work with your model on 
the Model tab. 



 

Use these general steps to prepare your drawing for printing multiple layouts: 

 

1   On the Model tab, create your drawing. 

2   Create a new layout. You can use an existing Layout1 or Layout2 tab, or you can create a 
new Layout tab. For details about creating a new layout, see “Creating a new layout” on 
page 314 in this chapter. 

3   Create at least one layout viewport on the Layout tab. Use each viewport to help control 
which portion of the drawing prints and at what scale. For details, see “Working with 
layout viewports” on page 317 in this chapter. 

4   Include any additional items that may be required for the specific layout, such as 
dimensions, a legend, or a title block. 

5   Specify additional settings for the layout, such as the scale of the drawing, print area, 
print style tables, and more. For details, see “Customizing print options” on page 321 in 
this chapter. 

6   Print or plot your drawing. For more details, see “Printing or plotting your drawing” on 
page 341 in this chapter. 

 

Understanding paper space and model space 

When you start a drawing session, your initial working area is called model space. Model 
space is an area in which you create two dimensional and three dimensional objects based on 
either the World Coordinate System (WCS) or a user coordinate system (UCS). You view and 
work in model space while using the Model tab. 

 

Your view of this area is a single viewport that fills the screen. You can create additional 
views on the Model tab, called viewports, which can show the same or different two 
dimensional or three dimensional views, all of which are displayed in a tiled manner. You can 
work in only one of these viewports at a time on the Model tab, and you can print only the 
current viewport. 
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Model space with two viewports. 

 

ZwCAD provides an additional work area, called paper space. The contents of paper space 
represent the paper layout of your drawing. In this work area, you can 

create and arrange different views of your model similar to the way you arrange detail drawings 
or orthogonal views of a model on a sheet of paper. You can also add keynotes, annotations, 
borders, title blocks, and other print-related objects in paper space, which reduces clutter when 
you work with your model in model space. 

 

You view and work in paper space while using a Layout tab. Each view, or layout viewport, 
that you create in paper space provides a window of your drawing in model space. You can 
create one layout viewport or several. You can place layout viewports anywhere on the screen; 
their edges can be touching or not; and you can print them all at the same time. 
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You do not need to use paper space to print your drawing, but it offers several advantages: 

•   Print the same drawing with different print settings that you save with each layout, for 
example, printer configuration files, print style tables, lineweight settings, drawing scale, 
and more. 

•   Add print related objects that are not essential to the model itself, such as keynotes or 
annotations, to reduce clutter when you work with your model in model space on the 
Model tab. 

•   For a single layout, create multiple layout viewports that print the model at different 
views and scales. 

 

 

 

 

 

 

 

 

 

 

 

Paper space with layout viewports. 
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Viewing drawings in paper space and model space 

When you work in paper space on a Layout tab, you can still view your drawing in model 
space. First you need to create a layout viewport in paper space; this allows you to view your 
model space objects from paper space. 

Within a layout viewport you can modify the model space objects, but it is often more 
convenient to modify these objects on the Model tab. 

Zooming or panning the drawing in model space or paper space affects the entire drawing, 
unless you use multiple windows or viewports. 

To view a drawing in model space on the Model tab 

Do one of the following: 

•   Click the Model tab. 

•   Right-click the Model/Paper Space toggle in the status bar, and then choose 

Model. 

 

To view a drawing in paper space on a Layout tab 

Do one of the following: 

•   Click one of the Layout tabs. 

•   Type layout and then press Enter. In the prompt box, choose Set. Type a name for the 
layout you want to make current, and then press Enter. 

•   Double click the Model/Paper Space toggle in the status bar. For example, double click 
“Model” or “M:Tab Name” in the status bar to switch to paper space. 

•   While using a Layout tab, type pspace and then press Enter. 

•   While using a Layout tab, double click outside of the layout viewport. 

The first time you switch to a Layout tab, your drawing seems to disappear. This is normal. 
You must create at least one layout viewport to see your model. For details, see “Working 
with layout viewports” on page 317 in this chapter. 



 314 

 

To view a drawing in model space on a Layout tab 

Do one of the following: 

•   Click the desired Layout tab, and then create and view a layout viewport. For more details, 
see “Working with layout viewports” on page 317 in this chapter. 

•   Double-click the Model/Paper Space toggle in the status bar. For example, double click 
“P:Tab Name” in the status bar to switch to model space on the current Layout tab. 

•   Type mspace and then press Enter. 

•   While using a Layout tab, double click inside of the layout viewport. 

 

Creating a new layout 

In ZwCAD, you can create multiple layouts for a single drawing. Each layout represents a 
sheet of paper. For each layout you can specify the print area, print styles, print scale, 
lineweight scale, pen mappings, and add viewports, dimensions, a title block, and other 
geometry specific to the layout. The objects you add to a layout in paper space do not appear 
in model space. 

Each layout requires at least one layout viewport. This viewport displays the drawing’s model 
space objects. 

When you create a new drawing, the drawing automatically contains two default layouts: 
Layout1 and Layout2. You can start by using one of the default layouts, you can create your 
own, or your can create a new layout from another template (.dwt) file, drawing (.dwg) file, or 
drawing interchange (.dxf) file. 

Each drawing can contain up to 255 layouts. 

To create a new layout using the Layout1 or Layout2 tab 

1   Click the Layout1 or Layout2 tab. 

2   Set up at least one layout viewport. For details, see “Working with layout viewports” on 
page 317 in this chapter. 

3   If desired, rename the layout. For details, see “To rename a layout” on page 316 in this 
chapter. 



 

To create a new layout using a new Layout tab 

1   Choose Insert > Layout > New Layout. 

2   Type a unique name for your layout and then press Enter. 

The name can be up to 255 characters in length and can contain letters, numbers, the dollar 
sign ($), hyphen (-), and underscore (_), or any combination. 

3   Set up at least one layout viewport. For details, see “Working with layout viewports” on 
page 317 in this chapter. 

Layout toolbar     

Command line   LAYOUTS 

 

To create a new layout from an existing file 

1   Choose Insert > Layout > Layout from Template. 

2   Select the desired template, drawing, or drawing interchange file that contains the layout 
you want, and then click Open. 

3   Select the layout(s), and then click OK. You can choose multiple layouts by holding 
down Ctrl while selecting layout names. 

Layout toolbar     

Command line   LAYOUTS 

 

Reusing layouts from other files 

Save time by reusing layouts that you have already created. Within the same drawing, you 
may want to make a copy of a layout that contains most of the settings you want, and then 
make changes to the new copy. If you created layouts that you want to use again when you 
create new drawings, you can save the layouts as a drawing template. 
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To make a copy of a layout 

1   Type layout and then press Enter. 

2   On the command line, type Copy. 

3   Type the name of the layout you want to copy, and then press Enter. 

4   Type a name for the new layout, and then press Enter. 

 

To save a layout as a drawing template 

1   Type layout and then press Enter. 

2   On the command line, type Save. 

3   Type the name of the layout that you want to save, and then press Enter. 

4   Specify the file name and location for the template, and then click Save. 

After you save a layout as a template, you can use the template when you create new drawings. 
You can also import the template’s layouts into another drawing. 

 

Managing layouts in a drawing 

You can rename layouts, delete layouts, and view a list of all layouts available in a drawing. 
You can also change the order in which the Layout tabs appear; the Model tab is always 
stationary. 

 

If you want to rename, delete, or reorder a layout when the Layout tabs are hidden, 

you can type layout to make your changes or choose View > Model and Layout Tabs to 
display the tabs. 

 

To rename a layout 
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1   Right click the Layout tab to rename. 

2   Type a new name for the layout. 

3   Click OK. 

The name can be up to 255 characters in length and can contain letters, numbers, the dollar 
sign ($), hyphen (-), and underscore (_), or any combination. 

To delete a layout 

1   Right click the Layout tab to delete. 

2   Click OK to confirm the deletion. 

 

NOTE You cannot delete the Model tab or the last remaining Layout tab. To delete all 

geometry from the Model tab or a Layout tab, first select all geometry and then use 

the Erase command. 

 

To view a list of all layouts 

1   Type layout and then press Enter. 

2   On the command line, type ? to list all layouts. 

3   Type s or press Enter to scroll through the layouts. 

 

Working with layout viewports 

When you begin working in a drawing on the Model tab, it consists of a single view of your 
model. You may have created additional views by dividing the drawing space into multiple 
windows; each window is a separate viewport on the Model tab. 

On a Layout tab, you must create at least one layout viewport to see your model. However, 
you can create multiple layout viewports that display unique views of your model located in 
model space. Each layout viewport functions as a window into your model space drawing. 
You can separately control the view, scale, and contents of each layout viewport. Each layout 
viewport is created as a separate entity that you can move, copy, or delete. 
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Click any layout viewport to make it the current viewport, and then add or modify model 
space objects in that viewport. Any changes you make in one layout viewport are immediately 
visible in the other viewports (if the other layout viewports are displaying that portion of the 
drawing). Zooming or panning in the current viewport affects only that viewport. 

This section focusses on working with layout viewports in paper space on a Layout tab. For 
additional information about viewports in model space, see “Dividing the current window into 
multiple views” on page 114. 

Creating layout viewports 

The first time you switch to a Layout tab, all of your model space objects disappear. You must 
create at least one layout viewport on the Layout tab to see your work. 

You can create layout viewports anywhere inside the drawing area. You can control the 
number of viewports created and the arrangement of the viewports. 

To create layout viewports 

1   On the command line, type mview. 

2   Type fit (Fit To View), Create 2 Viewports, Create 3 Viewports, or Create 4 Viewports, or 
specify two opposing corners to create a custom viewport. 

3   Choose the viewport orientation, type h (horizontal) or v (vertical). 

4   Do one of the following: 

•   To arrange the viewports to fill the current graphic area, type fit to screen. 

•   To fit the viewports within a bounding rectangle, specify the corners of a rectangle. 

 

TIP When you create a layout viewport, the layout viewport border is created on the current 

layer. You can make layout viewport borders invisible by creating a new layer before you 

create layout viewports and then turning off that layer after you create the layout viewports。 

To select a layout viewport’s borders, you must turn that layer back on before you can . 

rearrange or modify the layout viewport. 

 



 

 

 

 

 

 

 

 

 

 

 

You can create a single layout viewport, or you can divide the graphic area into two viewports arranged 

vertically (A) or horizontally (B); three viewports arranged left (C), right (D), above (E), 

below (F), vertically (G), or horizontally (H); or four viewports (I). 

 

Viewing and scaling layout viewports 

If you have created numerous layout viewports, your system performance may be affected. If 
necessary, you can turn a layout viewport on or off. Turning off a layout viewport does not 
delete the viewport or its contents; it simply turns off its display. 

You can also change how you view items within a layout viewport by specifying a scale factor, 
which changes how large or small model space objects appear within the layout viewport. 

To turn layout viewports on or off 

1   Click the desired Layout tab. 

 319 



 320 

2   Type mview and then press Enter. 

3   Type on or off. 

4   Select the edge of the layout viewport to turn on or off, and then press Enter. 

 

To change the layout viewport scale 

1   Choose Modify > Properties. 

2   Select the edge of the layout viewport. 

3   In Scale, enter the scale at which you want to view model space objects from within the 
layout viewport. 

4   Click OK. 

 

To change the scale of model space objects relative to paper space 

1   Click the Model tab. 

2   Click a viewport to make it current. 

3   On the command line, type zoom. 

4   Type the zoom scale factor relative to paper space by appending the suffix xp to the scale 
factor, and then press Enter. 

For example, to increase the scale of the objects in the viewport on the Model tab to twice the 
size of paper space units, type 2xp. To decrease the scale to half the size of paper space units, 
type .5xp. 

 

Modifying layout viewports 

After you create layout viewports, you can modify them as needed. On the Layout tab, you can 
snap to the viewport borders using entity snaps. You can also copy, delete, move, scale, and 
stretch layout viewports as you would any other drawing entity. 
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Modifying a layout viewport on a Layout tab does not affect the model space objects within 
the layout viewport. 

 

To modify layout viewport properties 

1   Click the desired Layout tab. 

2   Choose Modify > Properties. 

3   Select the edge of the layout viewport you want to modify. 

4   Adjust the center point, width, or height of the viewport. 

5   In Scale, enter the scale at which you want to view model space objects from within the 
layout viewport. 

6   Click OK. 

 

NOTE You can select only layout viewports for modification. If you click a viewport 

on the Model tab, it makes that viewport active, not available for modification. 



Customizing print options 

 

Before you print, you can set up many aspects of printing: 

•   Specify paper size and orientation. 

•   Select and configure a printer or plotting device. 

•   Specify the view and scale of a printed drawing, including which portion of a drawing to 
print, the print scale, and the origin of the print area. 

•   Choose whether to print and scale lineweights. 

•   Choose whether to implement print style tables to control colors, pen widths, line types, 
and lineweights. 

•   Open printer configuration (PCP) files; create and save PCP files. 

 

Setting the paper size and orientation 

You can specify a paper size and paper orientation for all drawings. 

 

To select the paper size and orientation 

1 Choose File > Page Setup. 

2 Select the paper size and paper orientation, and then click OK. 

Command line   PSETUP 

You can also adjust the orientation by printing a drawing upside down on the paper. Each 
layout in your drawing can specify whether to print upside down. 
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To print a drawing rotated 90 degree 

1   If necessary, click the desired Layout tab or the Model tab. 

2   Choose File > Plot. 

3   Click the Advanced tab. 

4   Select Rotate 90 degree. 

5   Select Save Changes to Layout, and then click Apply to save your changes. 

Standard toolbar    

Command line     PLOT 

 

Selecting a printer or plotter 

You can specify a printer or plotter to be used when printing any drawing. You can print your 
drawing on any printer or plotter that is compatible with Windows, including raster printers. 

 

To select a printer or plotter 

1 Choose File > Page Setup. 

2 From the Printer Name list, select a printer or plotter, and then click OK. 

Standard toolbar    

Command line     PSETUP 

 

Setting the scale and view 

You can print or plot the entire drawing or a selected portion, depending on which options you 
select in the Print dialog box. You can choose to print what is visible on the screen, or you can 



specify to print an area of the drawing. 

You can control the position of the drawing on the paper by specifying the origin of the print 
area, the location of the lower left corner of the print area, in relation to the lower left corner 
of the paper. The origin is normally set to 0,0, which places the lower left corner of the print 
area as close to the lower left corner of the paper as the printer or plotter will allow. You can 
specify a different origin, however, by specifying different coordinates. 

When you create a drawing, you generally draw objects full-size. When you print the drawing, 
you can specify the scale of the resulting print or let the program adjust the size of the drawing 
to fit the paper. To print the drawing at a specific scale, specify the scale as a ratio of drawing 
units to printed units. 

If you are printing from a Layout tab, the scale and view options you specify can be different 
for each layout that you create. 

 

To automatically scale the drawing for printing 

1   If necessary, click the desired Layout tab or the Model tab. 

2   Choose File > Plot. 

3   Click the Scale/View tab. 

4   To scale the drawing to fit on one printed page, in Print Scale, click Fit print area to size 
of page. 

5   Select Save Changes to Layout, and then click Apply to save your changes. 

Standard toolbar    

Command line     PLOT 

 

To specify the scale factor yourself 

1   If necessary, click the desired Layout tab or the Model tab. 

2   Choose File > Plot. 

3   Click the Scale/View tab. 
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4   In Print Scale, do one of the following: 

•   Select a predefined scale. For example, choose 1:2 if you want 1 printed unit 

(inch or millimeter) to equal 2 drawing units. 

•   Select Custom, and then under User Defined Scale, type the ratio of printed units of 
measure (inches or millimeters) to drawing units. 

5   To specify the printed units of measure, click Inches or Millimeters. 

6   Select Save Changes to Layout, and then click Apply to save your changes. 

Standard toolbar    

Command line     PLOT 

 

To specify a portion of the drawing to print 

1   If necessary, click the desired Layout tab or the Model tab. 

2   Choose File > Plot. 

3   Click the Scale/View tab. 

4   Under Print Area, click one of the following: 

•   Current View – prints the view on the screen. 

•   Saved View – prints the selected saved view. 

•   Extents – prints the area that contains objects in the drawing. 

•   Limits – prints to the limits defined for the layout or drawing. 

•   Window – prints the portion of the drawing contained in the specified window, 
maintaining the aspect ratio of the windowed area to the drawing. 

If you clicked Window, you must specify the window. Under Windowed Print Area, enter the 
diagonal x and y coordinates of the window, or select the area on the screen. 

To print only the area in the window without considering whether there is extra space on the 
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screen, select the Print Only Area Within Specified Window check box. 

5   Under Objects To Print, click one of the following: 

•   All Objects Within Print Area – prints all drawing objects contained within the specified 
print area. 

•   Selected Objects Within Print Area – prints only the objects you select from within the 
specified print area. 

6  Select Save Changes to Layout, and then click Apply to save your changes. 

Standard toolbar    

Command line     PLOT 
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A  Displays either “Model” or the layout name to which 
the print settings apply. 

B  Click to select the area of the drawing that you want 
to print. 

C  Type the x and y coordinates of the two opposing 
corners of the rectangular area to print; or, to 
specify coordinates in the drawing window, click 
Select Print Area. 

D  Select to print the area of the window while ignoring 
the aspect ratio to the remainder of the drawing. 

E  Click to specify drawing units and paper size in 
millimeters or inches. 

F  Specify the custom scale for the print area by typing 
the ratio of drawing units to printed inches or printed 

millimeters. (Available only if Custom is selected for 
Print Scale.) 

G  Select to fit the specified print area to the current 
paper size, select a scale ratio, or select to specify 
your own custom scale in User Defined Scale. 

H  Click to fit print area to size of page. 

I   Click to print only selected objects within the 
specified print area. 

J  Click to print all objects within the specified print 
area. 

K  Select to save the print settings for the model or 
layout. 

I  Select to print using the current print settings or 
using the settings from the last time you printed. 

 

NOTE ZwCAD saves your print settings each time you print. To restore the ZwCAD default 
print settings, click Reset in the Print dialog box. 

 

To specify the print area origin 

1   If necessary, click the desired Layout tab or the Model tab. 

2   Choose File > Plot. 

3   Click the Advanced tab. 

4   Under Origin of Print Area, do one of the following: 

•   To center the specified print area on the printed page, select the Center on Page check box. 

•   To specify an origin for the print area, type the x- and y-coordinates, or click Select 

Origin and then specify a point on the drawing. 
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5 Select Save Changes to Layout, and then click Apply to save your changes. 

Standard toolbar    

Command line     PLOT 

 

Choosing how lineweights print 

If objects are assigned lineweights, you can control whether they print with the assigned 
lineweights. If you turn off lineweight printing, objects print with a default outline. You can 
also control whether lineweights print in proportion to the scale you set on the Scale/View tab. 

Each layout in your drawing can specify whether to print and scale lineweights. 

 

To set lineweight options 

1   If necessary, click the desired Layout tab or the Model tab. 

2   Choose File > Plot. 

3   Click the Advanced tab. 

4   Choose how you want to print lineweights: 

•   Use Entity Lineweight – prints objects with their assigned lineweights. If not selected, 
objects print with a default outline. 

•   Scale Lineweight – prints lineweights in proportion to the scale you set on the 
Scale/View tab. If not selected, lineweights print at their assigned size without 
adjustments for the print scale. (A Layout tab must be active to scale lineweights.) 

5 Select Save Changes to Layout, and then click Apply to save your changes. 

Standard toolbar    

Command line     PLOT 

 



NOTE Print styles can also affect how lineweights print. For details, see the next section. 

 

A  Displays either “Model” or the layout name to which 
the print settings apply. 

H  Select to print objects with their assigned 
lineweights. 

B  Select the header of page. I   Click to rotate 90 degree. 

C  Select the footer of page. J  Type x and y coordinates to specify the origin of the 
print area. 

D  Click to load print settings from a PCP file.  
K  Select to center the print area on the page. 

E  Click to save the current configuration as a PCP. 
L  Select to save the print settings for the model or 

layout. F  Click to print to file. 

G  Select to print lineweights in proportion to the scale 
you set on the Scale/View tab. (A Layout tab must 
be active.) 

M  Select to load print settings from the current layout 
(or model) or the last time you printed.
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NOTE ZwCAD saves your print settings each time you print. To restore the ZwCAD default 
print settings, click Reset in the Print dialog box. 

 

Using print styles 

ZwCAD uses print styles to change the appearance of your printed drawing without modifying 
the actual objects in your drawing. Assigning print styles allows you to customize the color, 
pen width, linetype, and lineweight that are used to print your drawing. 

 

Print styles help you control what your drawing looks like when it is printed. Rather than 
describe what an entity looks like on your screen, print styles describe what an entity will look 
like when you print it. For example, you can map all yellow objects in your drawing to print in 
blue without modifying the actual objects. You could also map all yellow objects to print with 
whatever lineweight, linetype, or pen width that you specify. 

 

Because print styles are saved in print style tables, which are files located on your computer, 
disk, or server, you can reuse them to help eliminate the need to reconfigure your print 
settings each time you print a drawing. For example, you may have multiple clients who have 
their own printing preferences. You can save print styles in 

a named file for each of your clients. You can even share the file with coworkers, or store the 
files on a network to ensure that everyone in your office uses the same standards. 

 

Understanding print style tables 

A print style table is a collection of print styles that allows you to change the appearance of 
your printed drawing without modifying the actual objects in your drawing. Each print style 
table is saved in a file that can be located on your computer, disk, or server. 

 

A drawing can use one type of print style table at a time. There are two types of print style 
tables: 
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•   Color dependent print style tables (CTB) contain a collection of print styles based on each of 
the 255 index colors available in a drawing. True colors and color books are not 
applicable to colordependent print style tables. 

•   Named print style tables (STB) contain a collection of print styles that you define. They can 
vary regardless of color. 

With colo rdependent print style tables, you cannot assign print styles to individual objects or 
layers. To use these print styles, you assign a specific color to an entity or layer. When you 
specify a color dependent print style table at printing time, the entity colors and layer colors map 
to color based print styles in the print style table that you specify. 

 

With named print style tables, you can assign named print styles to individual objects and 
layers. Objects and layers assigned print styles are printed according to the print style table 
that you specify at printing time. If you specify a print style for a specific entity, that print 
style overrides any print style assigned to the layer on which the entity resides. 

Sometimes a named print style assigned to an entity or layer is not located in the print style 
table that is assigned to a layout or drawing. This can happen if the print style has been deleted 
from the named print style table or if you assign a different named print style table to the 
drawing that does not contain the named print style. In this case, the entity is printed using its 
default properties, which is similar to assigning the Normal print style to an entity or layer. If 
you plan on interchanging named print style tables within the same drawing, it’s a good idea to 
coordinate the tables to use the same print style names. 

If a new drawing is based on a template, the new drawing uses the same type of print style 
table as the template. If a new drawing is created without a template, the type of print style 
table is specified in the New Drawing Wizard; by default, the new drawing uses the print style 
table type specified in Tools > Options on the Printing tab. Every drawing is designed to use 
print style tables, but you decide whether to implement them. 

 

Implementing print style tables 

Every drawing is designed to use print style tables, but you decide whether to implement them. 
Even if you use one of the default print style tables available with ZwCAD, using print style 
tables requires planning ahead of time to ensure that your drawing prints as planned. 

For example, a single drawing of a floor plan might require the printing of the following 
drawing sheets: 

•   Main Floor Plan Walls print with thick, black lines. 
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•   Electrical Plan Walls print with normal gray lines, indicating that they are not the focus. 

•   HVAC Plan Walls print with normal gray lines, indicating that they are not the focus. 

•   Roof Plan Walls print with thin, gray lines and a hidden linetype, indicating that they are 
hidden under the roof in a plan view. 

 

In this example, you can create four named print style tables, each containing a print style 
named “WallPstyle”. Each print style table contains its own settings for “WallPstyle” to control 
how the walls print. Assign WallPstyle to either the wall entities or to a wall layer. Then, assign 
a different named print style table each time you print, or create four layouts and assign a 
different print style table to each layout. 

 

Assigning print style tables 

Select a print style table before printing if you want to change how your drawing appears 
when you print it. Print style tables can modify how colors, pen widths, line types, and 
lineweights look when they are printed. 

You can assign print style tables globally for all layouts (including the Model tab), or 
individually for the Model tab or a Layout tab. Assigning a print style table to an individual 
layout allows you to further customize the layouts you use to print a drawing. 

However, assigning different named print style tables to various layouts may result in 
mismatched print style names; a named print style assigned to an object or layer may not be 
located in the assigned print style table at print time. In this case, objects are printed using their 
default properties, which is similar to assigning the Normal print style to an object or layer. 

To assign print style tables 

1   If necessary, click the desired Layout tab, or click the Model tab. 

2   Choose File > Plot. 

3   Click the Advanced tab. 

4   Under Print Style Table (Pen Assignments), select a print style table that you created or 
one of the following: 

•   None — Applies no print style table. Objects print according to their own properties. 
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•   Icad — Uses the default print style table and its color assignments. 

•   Monochrome — Prints all colors as black. 

5   At the prompt, choose Yes to assign the print style table to all layouts in the drawing, 
including the Model tab, or choose No to assign the print style table only to the individual 
layout listed in Layout Name on the Print dialog box. 

6   Select Save Changes to Layout, and then click Apply to save your changes. 

Standard toolbar    

Command line     PLOT 

 

 

NOTE When your drawing was first created it was set up to use either color dependent 

or named print style tables. For details on converting a drawing to use a different type of 

print style table, see “Understanding print style tables” on page 330 in this chapter. 

 

Creating new print style tables 

ZwCAD offers several print style tables to help you get started. If you want to customize your 
print output further, you can create your own print style table. You can create a new print style 
table entirely from scratch, based on ZwCAD registry settings, or by importing a printer 
configuration file (PCP file). 

To create new print style tables 

1   Choose File > Print Styles Manager. 

2   Double click Create a Print Style Table. 

3   Complete the setup wizard. 

On the last wizard page, you can click Print Style Table Editor to set up the print styles for the 
table. For more details about the Print Style Table Editor options, see the next section. 
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Modifying print style tables 

When your drawing was created, it was set up to use color dependent or named print style 
tables. 

Color dependent print style tables (.ctb files) You can modify individual print styles within the 
table, but you cannot add, rename, or delete print styles. Color dependent print style tables 
always have 255 print styles, each named for a specific color. Your changes affect all objects 
and layers assigned that color. 

Named print style tables (.stb files) You can add, modify, rename, and delete individual print 
styles within the table. However, you cannot modify, rename, or delete the Normal print style. 
Your changes affect all objects and layers that are assigned that print style name. 

 

TIP If you can’t remember what type of print style table is assigned to your drawing, 

use the PSTYLEMODE system variable to determine the print style table type. 

 

Each print style within a print style table specifies a color, pen numbers, linetype, and 
lineweight. ZwCAD recognizes additional characteristics for compatibility with AutoCAD 
only, including: dither, grayscale, screening, adaptive, line end style, line join style, and fill 
style. 

 

When specifying print style characteristics, be sure to consider the limitations of your output 
device. 

 

NOTE It is recommended that you only modify print style tables that you have created. 

If you modify a default print style table that came with ZwCAD, you overwrite the 

original information which is then lost. 

 

To modify print style tables 

1   Choose File > Print Styles Manager. 
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2   Double click the print style table you want to modify. 

3   Click the General tab, and then do any of the following: 

•   Enter a new table description. 

•   Select Apply Global Scale Factor to Non ISO Linetypes to apply the scale factor to non ISO 
linetypes used for any print style in the current print style table. This also applies to fill 
patterns, which are not used in ZwCAD, but are recognized for compatibility with 
AutoCAD. 

•   Enter a scale factor to apply to non ISO linetypes used for any print style in the current 
print style table. 

4   Click the Properties tab, and then do any of the following: 

•   Make format changes to a print style by selecting it in the Print Styles list, then make 
color, pen map, linetype, or lineweight changes for the print style. Your changes are 
saved automatically for the selected print style. 

•   Add a new print style by clicking Add Style. Enter a new name, and then click OK. 
Select the options for the print style. (Available for named print styles only.) 

•   Rename a print style by selecting it in the Print Styles list. Single-click the print style 
again, and then enter a new name. (Available for named print styles only.) 

•   Delete a print style by selecting it in the Print Styles list. Click Delete Style. (Available 
for named print styles only.) 

5   Click OK. 

 

Copy, rename, or delete print style tables 

Copy, rename, or delete a print style table just as you would any other file on your computer. 
Regardless of which print style table type your drawing uses, you can use the Print Style 
Manager to manage both color dependent and named print style tables. 

 

To copy, rename, or delete print style tables 

1   Choose File > Print Styles Manager. 
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2   Select a print style table. 

Color dependent print style tables are .ctb files and named print style tables are .stb 
files。 

3   Copy, rename, or delete the print style table just as you would any other file on your 
computer. 

 

Changing a drawing’s print style table type 

When your drawing was created, it was set up to use color-dependent print style tables (.ctb 
files) or named print style tables (.stb files). A drawing can use one type of print style table at 
a time. If necessary, after a drawing is created you can convert the drawing to use the other 
type of print style table. 

If you can’t remember what type of print style table is assigned to your drawing, use the 
PSTYLEMODE system variable to determine the print style table type. 

 

To change a drawing to use named print style tables 

1   If you want to reuse any of the existing print style information, convert your color 
dependent print style tables to named print style tables. For details, see “To convert a 
color-dependent print style table to a named print style table” on page 371 in this chapter. 

2   Open the drawing that uses color dependent print style tables (.ctb files). 

3   Type convertpstyles, and then press Enter. 

4   If you have already converted your individual color dependent print style tables to named 
tables, click OK in the prompt that displays. 

If you have not converted the tables, click Cancel. First use convertctb to convert your 
color dependent print style tables to named tables. If you do not, all of the print style 
information you specified in your drawing will be lost. 

5   Select a named print style table (.stb file) that you want to use with the drawing. 

6   Click Open. 
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NOTE If you have not converted a color-dependent print style table to a named print 

style table, you will be warned that the table you have selected does not contain color 

mapping and the drawing cannot be converted. 

 

To change a drawing to use color-dependent print style tables 

1   Open the drawing that uses named print style tables (.stb files). 

2   Type convertpstyles, and then press Enter. 

3   If you are sure you want to convert the drawing and lose all print style assignments, click 
OK in the prompt that displays. 

If you do not want to lose the print style assignments, click Cancel. 

 

NOTE Converting a drawing to use color-dependent print style tables will remove all 

of the named print style information from objects and layers. However, the named 

print style tables are not deleted from your computer. 

 

Converting print style tables 

You can convert a color dependent print style table to a named print style table. You cannot 
convert a named print style table to a color dependent print style table because color dependent 
tables contain only print styles that are named after the 255 colors to which they map. 

Converting a color dependent print style table to a named print style table can be helpful in the 
following situations: 

•   You don’t want to create a named print style table from scratch. 

•   You want to create a named print style table that has the same settings as a color 
dependent print style table, but with some new print styles or other custom settings. 



•   You want to convert a drawing to use named print style tables and you want to reuse 
most of print styles already defined in a color dependent print style table. 

 

To convert a color dependent print style table to a named print style table 

1   Type convertctb, and then press Enter. 

2   Select the color dependent print style table (.ctb file) that you want to convert. 

3   Click Open. 

4   Enter a name for the new named print style table (.stb file). 

5   Click Save. 

The print styles in the new table are named Style 1, Style 2, and so on. If want to use different 
print style names, rename the print styles before you assign them to objects and layers in your 
drawing. If you rename the print styles after assigning them, they will not match when you 
print your drawing. For information about renaming print styles, see “Modifying print style 
tables” on page 334 in this chapter 

Turning off print style tables 

When you turn off print style tables, objects print according to their own properties. However, 
all of the print style information is saved so you can easily turn on print styles again. Actual 
print style table files are not deleted, and for drawings that use named print style tables, 
objects and layers retain their assigned print styles. 

To turn off print style tables 

1   If necessary, click the desired Layout tab, or click the Model tab. 

2   Choose File > Plot. 

3   Click the Advanced tab. 

4   Under Print Style Table (Pen Assignments), select None. 

5   At the prompt, choose Yes to turn off print style tables for all layouts in the drawing, 
including the Model tab, or choose No to turn off print style tables only for the individual 
layout listed in Layout Name on the Print dialog box. 
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6   Select Save Changes to Layout, and then click Apply to save your changes. 

Standard toolbar    

Command line     PLOT 

 

Reusing print settings 

After you set up print settings for a drawing or layout, you can save them and reuse them 
again using printer configuration files. 

Printer configuration files store the printer information you create for specific drawings or 
layouts, which eliminates the need to completely reconfigure your print settings each time you 
print a drawing. Printer configuration files also allow you to share and reuse print settings 
between different drawings and layouts. 

ZwCAD supports the printer configuration (PCP) file format used by AutoCAD. This feature 
makes it possible to use existing PCP files saved in AutoCAD, as well as to save your ZwCAD 
print configuration settings to a PCP format. 

 

TIP You can convert an AutoCAD PC2 file to PCP format using the Device And Default 

selection feature in the AutoCAD Print dialog box. 

 

The printer configuration files that you specify can be different for each layout that you create. 

 

To save print settings in a PCP file 

1   If necessary, click the desired Layout tab or the Model tab. 

2   Choose File > Plot. 

3   Click the Advanced tab. 

4   Specify the desired print settings. 
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5   Under Printer Configuration File, click Save. 

6   Name the file, and then click Save. 

Standard toolbar    

Command line     PLOT 

 

To assign a PCP file 

1   If necessary, click the desired Layout tab or the Model tab. 

2   Choose File > Plot. 

3   Click the Advanced tab. 

4   Under Printer Configuration File, click Open. 

5   Locate and select the PCP file, and then click Open. 

6   Select Save Changes to Layout, and then click Apply to save your changes. 

Standard toolbar    

Command line     PLOT 

 

PCP files created before ZwCAD contain obsolete PenMap/Width settings that you can 
convert to use with print style tables. Import the PCP file to create a new 

color dependent print style table. For details, see “Creating new print style tables” on page 333 
in this chapter. 

 

TIP It is easy to reuse print settings from the last time you printed. In the Print dialog 

box under Use Settings, choose Previous Print. 



 

Printing or plotting your drawing 

 

After you have configured your drawing and any layouts for printing, you are ready to print. If 
desired, you can preview your page before printing. 

Previewing a drawing before printing 

Viewing a drawing before printing gives you a preview of what your drawing will look like 
when it is printed. This helps you see if there are any changes you want to make before 
actually printing the drawing. 

If you are using print style tables, the preview shows how your drawing will print with the 
assigned print styles. For example, the preview may display different colors or lineweights than 
those used in the drawing because of assigned print styles. 

To preview a drawing before printing 

1   If necessary, click the desired Layout tab or the Model tab. 

2   Choose File > Plot Preview. 

3   After checking the preview image, do one of the following: 

•   To print the drawing, click Print Settings to display the Print dialog box. 

•   To return to the drawing, click Close. 

Standard toolbar    

Command line     PREVIEW
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A B C E F D

A  Click to print the drawing. D   Click to zoom window.  

E   Click to zoom original. B  Click to print the drawing. 

D   Click to close preview. C  Click to zoom. 

 

 

Printing a drawing 

The Print dialog box is organized by tabs into two functional areas: scaling and viewing, and 
advanced printing options. The print setting options available under each tab were described in 
the previous sections. 

 

NOTE You cannot print a rendered image directly to a printer. To print a rendered 

image, you must first save the drawing to a different format and then print it from 

another graphics program. 
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To print a drawing 

1   If necessary, click the desired Layout tab or the Model tab. 

2   Choose File > Plot. 

3   From the Print dialog box, make any adjustments to the settings. 

4   Click Print. 

Standard toolbar    

Command line     PLOT 

 

NOTE Instead of using the print settings you saved with your layout, you can select Previous 

Print in the Use Settings list to print according to the settings used the last time you printed. If 

necessary, you can click Reset to restore the ZwCAD default print settings。 

 

 



 
  
Drawing in three dimensions 
 

 
 
 
 
Paper drawings typically represent two dimensional views of three dimensional objects. With 
ZwCAD, you can create three dimensional models of three dimensional objects. 
 

This section explains how to: 
 

•   View objects in three dimensions. 
•   Create three dimensional objects. 
•   Edit objects in three dimensional space. 
•   Edit three dimensional solids. 
•   Display hidden line and shaded views of three dimensional objects. 
 
The tools and commands for many of the functions described in this section appear 
on the Draw 3D toolbar and the Insert menu, respectively, when you set the program to the 
Advanced experience level. 
 
 
 
 
 
Topics in this chapter 

 
 

Viewing objects in three dimensions..........................................................................345 
Creating three dimensional objects...............................................................................348 
Editing in three dimensions........................................................................................369 
Editing three dimensional solids...............................................................................374 
Hiding, shading, and rendering ...............................................................................385 
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Viewing objects in three dimensions 

 
You can view a ZwCAD drawing from any position in three dimensional space. From any 
selected viewing position, you can add new objects and modify existing objects. You can also 
generate hidden line and shaded views from any viewing position. 
 
Setting the viewing direction 
You view three dimensional drawings by setting the viewing direction. The viewing direction 
establishes the viewing position, the Cartesian coordinate corresponding to the viewpoint 
looking back at the origin point, the 0,0,0 coordinate. When you view a drawing from the 
default viewpoint (0,0,1), you see a plan view of the drawing. 
 
You can change the viewing direction to look at the drawing from a different vantage point or 
to work on a three dimensional model from a different orientation. 
 
To set a new viewing direction 
1   Choose View > 3D Views > Viewpoint Presets. 

2   Click the preset button. 

3   Click the preset view you want to use. 

Command line    SETVPOINT 
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A 

C 

B 

 
 
 
 
 
 
 
 
 
 

 
 
 
 
 

 
A  Click to select a non-axis viewpoint. C  Click to select a viewpoint aligned with an axis.
B  Click to select the previous viewpoint. 
 
 

You can dynamically rotate the viewpoint within the xy plane and relative to the xy plane, and 
you can pan and zoom the drawing. As you change the viewpoint settings, the drawing display 
automatically updates. 
 
To dynamically set a view direction 
1   Choose View- 3D Views – Viewpoint Presets 

2   Click the appropriate tools to dynamically change the viewpoint. 

3   To complete the command, click OK. 
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A  Indicates the current viewpoint. F  Click to zoom out. 
B  Click to pan the drawing. G  Click to zoom in. 
C  Click to display the Preset Viewpoints dialog box. H  Shows the current viewpoint orientation. 
D  Click to update the drawing display whenever you 
click a tool. 

I   Type or select the rotation angle increment. 
J  Click to rotate the view about a predefined axis. 

E  Click to zoom extents. 
 
You can set the current viewing direction to the plan view of the current user coordi- 
nate system (UCS), a previously saved UCS, or the World Coordinate System 
(WCS). 
 
To display a plan view of the current drawing 
1   Choose View > 3D Views > Plan View. 
2   It concludes three plan views: Current UCS, World UCS, Named UCS. 
    Choose one what you want. 
Command line    PLAN 
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Creating three dimensional objects 

 
ZwCAD supports the following types of three dimensional models: 
 

•   Wire frame models, which consist of lines and curves that define the edges of a three 
dimensional object. You can create a wire frame model by drawing lines, arcs, polylines, 
and other two dimensional objects anywhere in three dimensional space. Wire frame 
models have no surfaces; they always appear as outlines. Because you must individually 
draw and position each object that makes up a wire frame model, creating one can be 
exacting and time consuming. 

•   Surface models, which consist of both edges and the surfaces between those edges. 
You can create a surface model by applying elevation and thickness to two dimensional 
planar objects or by using specific three dimensional object creation commands. Surface 
models consist of individual planes forming a faceted, polygonal mesh. 

•   3D solids, which are three dimensional ACIS objects that consist of faces and edges. 3D 
solids appear to have volume and are easier to work with than wire frame and surface 
models. ZwCAD supports viewing and limited editing of 3D solids, including moving, 
rotating and scaling. Additionally, some versions of ZwCAD allow you to create and 
more completely edit 3D solids. 

 

 
Applying elevation and thickness 
By default, the program creates new two dimensional objects with a zero elevation and 
thickness. The easiest way to create a three dimensional object is to change the elevation or 
thickness property of an existing two dimensional object. 
 

The elevation of an object is its z coordinate position in relation to the xy plane in which the 
object is drawn. An elevation of 0 indicates that the object is drawn on the 
xy plane of the current UCS. Positive elevations are above this plane; negative elevations are 
below it. 
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The thickness of an object is the distance it is extruded above or below its elevation. A positive 
thickness extrudes the object upward in the positive z direction of the object; a negative 
thickness extrudes it downward in the negative z direction. The thickness is applied uniformly 
to the entire object. You can extrude any two dimensional object into a three dimensional 
object by changing the thickness of the object to a nonzero value. For example, a circle 
becomes a cylinder, a line becomes a three dimensional plane, and a rectangle becomes a box. 
 

 
 
 
 
 
 
 
 
 
 
Two-dimensional objects.          Two-dimensional objects with thickness added. 
 

You can create three dimensional objects using any of the following methods: 
 

•   Draw two dimensional objects in three dimensional space. 
•   Convert two dimensional planar objects into three dimensional objects by applying 

elevation and thickness. 
•   Convert two dimensional planar objects into three dimensional objects by revolving or 

extruding. 
•   Create three dimensional objects such as boxes, cylinders, cones, domes, spheres, and 

wedges. 
 

 
NOTE Three dimensional solids are drawn as true solids with versions of ZwCAD 
that support three dimensional ACIS solids. Three dimensional solids that you can 
create include: box, cone, cylinder, dish, dome, pyramid, sphere, torus, and wedge. 
 

 
You can change the default elevation and thickness values to create new objects with an 
elevation and thickness already applied. 
 
To set the current elevation 
1   On the command line, type elev. 
2   Specify the New Current Value For Elevation, and then press Enter. 
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To set the current thickness 
1   On the command line, type thickness. 
 

2   Specify the New Current Value For Thickness, and then press Enter. 
 
To set the current elevation and thickness using a dialog box 
1   Choose Tools > Draft Settings. 
 

2   Click the 3D Settings tab. 
3   To change the current thickness, in the Current 3D Thickness box, type a new thickness 

value or click the arrows to select a new thickness. 
5   To change the current elevation, in the Current 3D Elevation box, type a new elvation 

value or click the arrows to select a new elevation. 
6   Click OK. 
Command line    SETTINGS 

 
 

A 

B 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
A  Type or select the current three dimensional thickness. 
B  Type or select the current three dimensional elevation. 
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Creating three dimensional faces 
You can create a three dimensional face, which consists of a section of a plane in three 
dimensional space. You define a three dimensional face by specifying the x,y,z coordinates of 
three or more corners. After you specify the fourth point, the program continues to prompt you 
for additional faces by alternating prompts for the third point and fourth point to allow you to 
build a complex three dimensional object. Each three or four sided plane is created as a 
separate three dimensional face object. 
 
To create a three dimensional face 
Advanced experience level 
 
1   Choose Draw > Surfaces > 3D face. 
2   Specify the first point of the three dimensional face. 
3   Specify the second, third, and fourth points. 
4   Specify the third and fourth points for additional faces. 
5   To complete the command, press Enter. 

Surface toolbar    
Command line    3DFACE 
 
 
 
TIP Any or all edges of a three dimensional face can be invisible to allow you to more 
accurately model objects with holes in them. As the program prompts you for the cor- 
ner points, in the prompt box, choose Invisible Edge to make the next edge invisible. 
 
 
 
 
 
 
 
 
 
 
 
 
An example of a three dimensional model created using three dimensional faces. 
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Creating rectangular meshes 
You can create a three dimensional rectangular mesh consisting of four sided polygons. You 
determine the size of the mesh by specifying the number of vertices along the primary (M-
direction) and secondary (N direction) mesh axes and then specifying the coordinates for each 
vertex. 
 
To create a rectangular mesh 
Advanced experience level 
 
1   Choose Draw > Surfaces > 3D Mesh. 
2   Specify the number of vertices along the primary mesh axis. 
3   Specify the number of vertices along the secondary mesh axis. 
4   Specify the coordinates for each vertex. 

Specifying the coordinates for the last vertex completes the mesh and ends the command. 

Surface toolbar     
Command line     3DMESH 
 
 
TIP Although creating rectangular meshes manually can be exacting, they are useful 
for representing complex surfaces such as three dimensional terrain models. The 
Mesh tool is most useful when combined with scripts or LISP programs that mathe- 
matically calculate the coordinates of the vertices. 
 
 
 
 
 
 
 
 
 
 
 
 
 
An example of a three dimensional terrain model created using rectangular meshes. 
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Creating polyface meshes 
You can create a polygon mesh consisting of faces connecting three or more vertices. You first 
determine the coordinates of each vertex and then define each face by entering the vertex 
numbers for all the vertices of that face. As you create each face, you 
can control the visibility and color of each edge and assign each edge to specific layers. 
 
To create a polyface mesh 
Advanced experience level 
 
1   On the command line, type pface. 
2   Specify the coordinates of each vertex. 

After each vertex that you specify, the next vertex number is displayed, and you are 
prompted for the coordinates of the vertex. Specify the coordinates, and then press Enter. 
Continue to specify the coordinates for each numbered vertex. 

3   To finish specifying vertex coordinates, press Enter. 
4   Specify the vertex numbers that define the first face. 

You specify the face by entering the vertex numbers that were defined when you 
specified coordinates in step 2. Each face can be composed of three or more numbered 
vertices. 

5   To finish defining the first face, press Enter. 
6   Specify the next face by entering its vertex numbers. 
7   To complete the command, press Enter. 
 
 
TIP To make an edge invisible, type the vertex number as a negative value. 
 
 
Creating ruled surface meshes 
You can create a ruled surface, which is a three-dimensional polygon mesh that approximates 
the surface between two existing objects. You select the two objects that define the ruled 
surface. These objects can be arcs, circles, lines, points, or polylines. 
 
To create a ruled surface mesh 
Advanced experience level 
 
1   Choose Draw > Surfaces > Ruled Surface. 
2   Select the first defining object. 
3   Select the second defining object. 

Surface toolbar      
Command line     RULESURF 
 



 
 
 
 
 
 
 

Select the first (A) and second (B) defining objects. The resulting ruled surface mesh. 
 

 
 
TIP To control the density of the mesh, change the values for the Number of M Direc- 
tion Surfaces. Choose Settings > Draft Settings, and then click the 3D Settings 
tab. Under Surface Settings, change the Number Of M Direction Surfaces value. 
 
 
Creating extruded surface meshes 
You can create an extruded surface, which is a three dimensional polygon mesh that 
approximates the surface generated by extruding a path curve along a direction vector. You 
select the two objects that define the path curve and direction vector. The length of the 
direction vector determines the distance the path curve is moved along the direction vector. 
The extruded object can be an arc, circle, line, or polyline. You can choose a line or open 
polyline as the direction vector. The resulting mesh consists of a series of parallel polygonal 
planes running along the specified path. 
 
To create an extruded surface mesh 
Advanced experience level 
1   Choose Draw > Surfaces > Tabulated Surface. 
2   Select the object to extrude. 
3   Select the extrusion path. 

Surface toolbar      
Command line     TABSURF 
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Select the object to extrude (A) and the extrusion path (B).      The resulting extruded surface mesh. 
 

 
 
TIP To control the density of the mesh, change the values for the Number of M Direc- 
tion Surfaces. Choose Settings > Draft Settings, and then click the 3D Settings 
tab. Under Surface Settings, change the Number Of M Direction Surfaces. 
 
 

 
NOTE An extruded mesh is different from an extruded solid. If you want to extrude an 
object and convert it to a three dimensional solid, use the Extrude command. 
 
 
Creating revolved surface meshes 
You can create a surface of revolution, which is a three dimensional polygon mesh that 
approximates the surface generated by rotating a two dimensional profile around 
an axis. You select the two objects that define the profile and the axis. You also specify the 
starting angle and the number of degrees to revolve the profile. 
 

Revolving the profile 360 degrees creates a closed three dimensional mesh. The Number Of M 
Direction Surfaces value determines the mesh density (the number of mesh segments) in the M 
direction (around the axis of revolution). The N Direction Mesh Density value determines the 
mesh density (the number of mesh segments) in the N direction (along the axis of revolution). 



To create a revolved surface mesh 
Advanced experience level 
 
1   Choose Draw > Surfaces > Revolved Surface. 
2   Select the object to revolve. 
3   Select the object to be used as the axis of revolution. 
4   Specify the starting angle. 
5   Specify the number of degrees to revolve the object. 

Surface toolbar      
Command line     REVSURF 

 
 

 
 

 
 
 
 
 
 
 
 

Select the object to be revolved (A) and the            The resulting revolved surface 
axis of revolution (B).                              mesh. 
 
 
 
TIP To control the density of the mesh, change the values for the Number of M Direc- 
tion Surfaces. Choose Settings > Draft Settings, and then click the 3D Settings 
tab. Under Surface Settings, change the Number Of M Direction Surfaces. 

. 
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Creating edge defined Coons surface patch meshes 
You can create a surface called a Coons surface patch, a mesh connecting four edges. You 
select the objects that define the edges. Edge objects can be arcs, lines, or polylines. The four 
edge objects must form a closed loop and share endpoints. A 
patch is a bicubic surface (one curve extends in the M direction and the other in the 
N direction) interpolated between the four adjoining edges. You can select the edges in any 
order. The first edge you select determines the M direction of the mesh. 
 
To create an edge defined Coons surface patch mesh 
Advanced experience level 
 
1   Choose Draw > Surfaces > Edge Surface. 
2   Select the first edge. 
3   Select the second, third, and fourth edges. 

Surface toolbar      
Command line     EDGESURF 
 

 
 
 
 
 
 
 
 

Select the objects to be used as the four              The resulting Coons surface patch mesh. 
edges (A, B, C, and D). 
 
 
TIP To control the density of the mesh, change the values for the Number of M Direction 
Surfaces. Choose Settings > Draft Settings, and then click the 3D Settings tab. Under Surface 
Settings, change the Number Of M Direction Surfaces 
 
..
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Creating boxes 
You can create rectangular boxes, or cubes. A box consists of six rectangular surface planes. 
The base of the box is always parallel with the xy plane of the current UCS. You position the 
box by specifying either a corner or the center of the box. You determine the size of the box by 
either specifying a second corner and the height; defining the box to be a cube and then 
providing its length; or specifying the length, width, and height. 
 

 
NOTE  The box is created as a three dimensional ACIS solid. 
 
 
To create a box 
1   Choose Draw > Solids > Box. 
2   Specify the first corner of the base. 
3   Specify the opposite corner of the base. 
4   Specify the height. 

Solids toolbar      
Command line     BOX 
 

 
 
 
 
 
 
 

 
 

 
First corner of the base (A), the opposite corner of the base (B), and the height (C). 
 
To create a box as a three dimensional surface 
 
To create a box as a surface instead of as a solid, the procedure is similar. 
 

1   Choose Draw > Surfaces > 3D Surface. 
2   On the command line, type box. 
3   Specify the first corner of the base. 
4   Specify the opposite corner of the base. 
5   Specify the height. 

Surfaces toolbar      
Command line      AI_BOX
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Creating wedges 
 
You can create three dimensional wedges consisting of five surface planes. The base of the 
wedge is always parallel with the xy plane of the current UCS with the sloped face opposite 
the first corner. The height is always parallel with the z axis. You position the wedge by 
specifying either a corner or the center of the wedge. You determine the size of the wedge by 
either specifying a second corner and the height; defining the wedge based on a cube having a 
given length; or specifying the length, width, and height. 
 
 
NOTE  The wedge is created as a three dimensional ACIS solid. 
 
 
To create a wedge 
1   Choose Draw > Solids > Wedge. 
2   Specify the first corner of the base. 
3   Specify the opposite corner of the base. 
4   Specify the height. 

Solids toolbar      
Command line     WEDGE 
 

 
 
 
 
 
 
 
 

First corner of the base (A), the opposite corner of the base (B), and the height (C). 
 
To create a wedge as a three dimensional surface 
 

To create a wedge as a surface instead of as a solid, the procedure is similar. 
1   Choose Draw > Surfaces > 3D Surface. 
2   On the command line, type wedge. 
3   Specify the first corner of the base. 
4   Specify the opposite corner of the base. 
5   Specify the height. 

Surfaces toolbar      
Command line      AI_WEDGE



 
Creating cones 
You can create three dimensional cones defined by a circular base and tapering to a point 
perpendicular to the base. The base of the cone is always parallel with the xy plane of the 
current UCS; the height of the cone is always parallel with the z axis. 
You position the cone by specifying the center of the base. You determine the size of the cone 
by specifying either the radius or the diameter of the base and the height. 
 

 
NOTE  The cone is created as a three dimensional ACIS solid. 
 
 
To create a cone 
1   Choose Draw > Solids > Cone. 
2   Specify the center of the base of the cone. 
3   Specify the radius or diameter. 
4   Specify the height. 

Solids toolbar      
Command line     CONE 
 

 
 
 
 
 
 
 
 

Center of the base (A), the radius of the base (B), and the height (C). 
 
To create a cone as a three dimensional surface 
 
To create a cone as a surface instead of as a solid, the procedure is similar. 
1   Choose Draw > Surfaces > 3D Surface. 
2   On the command line, type cone. 
3   Specify the center of the base of the cone. 
4   Specify the radius or diameter. 
5   Specify the height. 

Surfaces toolbar      
Command line      AI_CONE 
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Creating pyramids 
You can create tetrahedrons (three sided pyramids) or four-sided pyramids. The sides of the 
resulting pyramid can meet at a point (the apex) or can form a three or four edged top. The 
sides of a four sided pyramid can also meet along a ridge defined by two points. The base of 
the pyramid is always parallel with the xy plane of the current UCS. You position the pyramid 
by specifying a corner of the base. You determine the size of the pyramid by specifying the 
base points and either the apex, the corners of the top surface, or the endpoints of the ridge. 
 
 

 
NOTE  The tetrahedron and pyramid are created as three dimensional ACIS solids. 
 
 
Creating cylinders 
You can create cylinders defined by a circular base. The base of a cylinder is always parallel 
with the xy plane of the current UCS; the height of a cylinder is always parallel with the z axis. 
You position a cylinder by specifying the center of the base. You determine the size of a 
cylinder by specifying either the radius or diameter of the base and the height. 
 

 
NOTE  The cylinder is created as a three dimensional ACIS solid. 
 
 
To create a cylinder 
1   Choose Draw > Solids > Cone. 
 

2   Specify the center of the base of the cylinder. 
3   Specify the radius or diameter. 
4   Specify the height. 

Solids toolbar       
Command line     CYLINDER 

 

 
 
 
 
 

 
 
 
 

Center of the base (A), radius of the base (B), and the height (C). 
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To create a cylinder as a three dimensional surface 
 

To create a cylinder as a surface instead of as a solid, the procedure is similar. 
 
1   Choose Draw > Surfaces > 3D Surface. 
2    On the command line, type cylinder. 
 

3   Specify the center, radius, and height as described previously. 
Command line      3D 
 
Creating spheres 
You can create spheres. The latitude lines of a sphere are always parallel with the xy plane of 
the current UCS; the central axis is always parallel with the z axis. You position a sphere by 
specifying its center point. You determine the size of a sphere by specifying either its radius or 
its diameter. 
 

 
NOTE  The sphere is created as a three dimensional ACIS solid. 
 
 
To create a sphere 
1   Choose Draw > Solids > Sphere. 
 

2   Specify the center of the sphere. 
3   Specify the radius or diameter. 

Solids toolbar       
Command line     SPHERE 
 

 
 
 
 
 
 
 
 

 
Center (A) and radius (B) of the sphere.            The resulting sphere.  
 
To create a sphere as a three dimensional surface 
To create a sphere as a surface instead of as a solid, the procedure is similar. 
 
1   Choose Draw > Surfaces > 3D Surface. 
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2   On the command line, type sphere. 
 

3   Specify the center of the sphere. 
4   Specify the radius or diameter. 
5   Specify the number of longitudinal sections that are perpendicular to the xy plane. 
6   Specify the number of latitudinal sections that are parallel to the xy plane. 

Surfaces toolbar      
Command line      AI_SPHERE 
 
 
Creating dishes 
You can create a three dimensional dish. The latitude lines of a dish are always parallel with 
the xy plane of the current UCS; the central axis is always parallel with the z axis. You 
position a dish by specifying its center point. You determine the size of a dish by specifying 
either its radius or its diameter. 
 

 
NOTE  The dish is created as a three dimensional ACIS solid. 
 
 
To create a dish as a three dimensional surface 
To create a dish as a surface instead of as a solid, the procedure is similar. 
 
1   Choose Draw > Surfaces > 3D Surface. 
2    On the command line, type dish. 
 

3   Specify the center and radius or diameter as described previously. 

Surfaces toolbar      
Command line      AI_DISH 
 
Creating domes 
You can create a three dimensional dome. The latitude lines of a dome are always parallel 
with the xy plane of the current UCS; the central axis is always parallel with the z axis. You 
position a dome by specifying its center point. You determine the size of a dome by specifying 
either its radius or its diameter. 
 

 
NOTE  The dome is created as a three dimensional ACIS solid. 
 
 
To create a dome as a three dimensional surface 
To create a dome as a surface instead of as a solid, the procedure is similar. 
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1   Choose Draw > Surfaces > 3D Surface. 
2    On the command line, type dome. 
3   Specify the center and radius or diameter as described previously. 

Surfaces toolbar      
Command line      AI_DOME 
 
Creating torus 
You can create a three dimensional donut or ring shaped object known as a torus. The diameter 
of a ring is always parallel with the xy plane of the current UCS. A torus is constructed by 
revolving a circle about a line drawn in the plane of the circle and parallel with the z axis of 
the current UCS. You position a torus by specifying its center point. You determine the size of 
a torus by specifying its overall diameter or radius 
and the diameter or radius of the tube (the circle being revolved). 
 

 
NOTE  The torus is created as a three dimensional ACIS solid. 
 
 
To create a torus 
1   Choose Draw > Solids > Torus. 
2   Specify the center of the whole torus. 
3   Specify the radius or diameter of the whole torus. 
4   Specify the radius or diameter of the body of the torus. 

Solids toolbar       
Command line     TORUS 

 
 

  
 
 
 
 
 
 
 

Center (A) and radius of the whole torus (B), and the radius of the body (C). 
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To create a torus as a three dimensional surface 
 

To create a torus as a surface instead of as a solid, the procedure is similar. 
 
1   Choose Draw > Surfaces > 3D Surface. 
2    On the command line, type torus. 
3   Specify the center of the whole torus. 
4   Specify the radius or diameter of the whole torus. 
5   Specify the radius or diameter of the body of the torus. 
6   Specify the number of longitudinal sections that are perpendicular to the xy plane. 
7   Specify the number of latitudinal sections that are parallel to the xy plane. 

Surfaces toolbar      
Command line      AI_TORUS 

 
Creating regions 
You can convert a closed object into a two dimensional region. After you create a region, you 
can modify it using the various three dimensional tools. For example, you can create a region 
from a square, and then extrude the square to create a three dimensional cube. 
 

You can create regions from closed objects, such as polylines, polygons, circles, ellipses, 
closed splines, and donuts. 
 

Creating regions typically has no visible effect on a drawing. However, if the original object 
had a width or lineweight, that information is lost when you create the region. 
 
To create a region 
1   On the command line, type region. 
2   Select the objects to create the region. 
3   Press Enter. 
The command bar displays a message that describes how many regions were created. 
 
Creating extruded solids 
You can create three dimensional solids by extruding closed objects, such as polylines, 
polygons, circles, ellipses, closed splines, donuts, and regions. You can extrude the object 
along a selected path, or you can specify its height and taper angle. 
 
To create an extruded solid 
1   Choose Draw > Solids > Extrude. 
2   Select the object to extrude. 
3   Select the extrusion path, or specify the height. 

Solids toolbar       
Command line     EXTRUDE 
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Select the object to extrude (A) and the            The resulting extruded surface mesh. 
extrusion Path (B).  
 

 
 

 
Creating revolved solids 
 

You can create three dimensional solids by revolving closed objects, such as polylines, 
polygons, circles, ellipses, and regions. You can revolve the object about a defined axis, line, 
polyline, or two points. 
 
To create a revolved solid 
1   Choose Draw > Solids > Revolve. 
2   Select the object to revolve. 
3   Do one of the following to define the axis of revolution: 
•   Specify a start point and an end point. 
•   Type o and press Enter to select an object that determines the axis. 
•   Type x and press Enter to select the x axis. 
•   Type y and press Enter to select the y axis. 
4    Specify the angle of revolution. 

Solids toolbar       
Command line     REVOLVE 
 

 
 
 
 
 
 
 



 
 
 
 
 
 
 
 
 

Select the object to revolve (A) and the axis (B) about        The resulting revolved solid. 
which to revolve it., followed by the angle of revolution. 

 
 
 
Creating composite solids 
You can create composite three dimensional solids by combining, subtracting, and finding the 
intersection of two or more solids. 
 
To combine solids 
1   Choose Modify > Solids Editing > Union. 
2   Select the objects to combine. 

Solids Editing toolbar       
Command line            UNION 

 
 
 

 
 
 
 
 
 

Select the objects to combine (A and B).     The resulting combined solid.  

 
To subtract solids 
1   Choose Modify > Solids Editing > Subtract. 
2   Select the objects to subtract from one another. 

Solids Editing toolbar       
Command line            SUBTRACT 
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Select the objects to subtract (A and B).  The resulting solid.  
 

To intersect solids 
1   Choose Modify > Solids Editing > Intersect. 
2   Select the objects to intersect. 

Solids Editing toolbar       
Command line            INTERSECT 
 

 
 
 
 
 
 
 
 
 
Select the objects to combine (A and B).    The resulting combined solid.  
 



Editing in three dimensions 

 
You can copy, move, rotate, array, mirror, and align two dimensional and three dimensional 
objects in both two dimensional and three dimensional space. You can also change and edit 
properties of three dimensional objects much like you change and edit properties for two 
dimensional objects. When you modify three dimensional objects in two dimensional space, 
you modify the object in relation to the current UCS. 

 
Rotating in three dimensions 
You can rotate selected objects about a specified axis in three dimensional space. 
You select the objects to rotate and then define the axis of rotation either by specifying two 
points; selecting an existing object; aligning the axis with the x, y, or z axis of the current UCS; 
or aligning the axis with the current view. 
 
To rotate an object about an axis in three dimensions 
1   Choose Modify > 3D Operation > Rotate 3D. 
 

2   Select the objects to rotate, and then press Enter. 
3   Choose from one of the following options: Object, Last, View, Xaxis, Yaxis, Zaxis. 
4   Specify the rotation angle. 
5   Specify the reference angle. 
Command line       ROTATE3D 

 

 
 
 
 
 
 
 
 
 
 
 

Select the objects to rotate (A), specify the endpoints      Result after rotating the objects. .        
of the axis of rotation (B and C), and then specify the 
 rotation angle (D). 
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Arraying in three dimensions 
You can copy selected objects and arrange them in a three dimensional rectangular or polar 
(circular) pattern. For a rectangular array, you control the number of copies in the array by 
specifying the number of rows and columns and the number of levels. You also specify the 
distance between each. For a polar array, you specify the axis around which to array the 
objects, the number of copies of the objects to create, and the angle subtended by the resulting 
array. 
 
To create a three dimensional rectangular array 
1   Choose Modify > 3D Operation > 3D Array. 
2   Select the objects, and then press Enter. 
3   In the prompt box, choose Rectangular. 
4   Type the number of rows in the array. 
5   Type the number of columns. 
6   Type the number of levels. 
7   Specify the vertical distance between the rows. 
8   Specify the horizontal distance between the columns. 
9   Specify the depth between the levels. 
Command line       3DARRAY 

 
 
 

 
 
 
 
 
 
 
 
 
 
 

 
To create a three dimensional rectangular array, select the object to copy (A), type the 
number of rows, columns, and levels, and then specify the distance between each row (B), column (C), 
and level (D). 
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To create a three dimensional polar array 
1   Choose Modify > 3D Operation > 3D Array. 
2   Select the objects, and then press Enter. 
3   In the prompt box, choose Polar. 
4   Type the number of copies to make, including the original selection set. 
5   Specify the angle the array is to fill, from 0 to 360 degrees. 

The default setting for the angle is 360 degrees. Positive values create the array in 
a counterclockwise direction; negative values create the array in a clockwise direction. 

6   In the prompt box, choose one of the following: 
•   Yes Rotate Objects to rotate objects as they are arrayed. 
•   No Do Not Rotate to retain the original orientation of each copy as it is arrayed. 
7   Specify the center point of the array. 
8   Specify a second point along the central axis of the array. 
Command line       3DARRAY 

 
 
 
 
 
 
 

 
 
 
 
 
 

To create a three dimensional polar array, select the object to copy (A), type the number of copies to make, 
specify the angle the array is to fill (B), and then specify the center point of the array (C) and a second point along the 
central axis of the array (D). 
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Mirroring in three dimensions 
You can create a mirror image of selected objects in three dimensional space. You mirror the 
objects about a mirror plane that you define by either specifying three points; selecting an 
existing two dimensional planar object; aligning the plane parallel with the xy, yz, or xz plane 
of the current UCS; or aligning the plane with the current view. You can delete or retain the 
original objects. 
 
To mirror an object about a three dimensional plane 
1   Choose Modify > 3D Operation > Mirror 3D. 
2   Select the objects, and then press Enter. 
3   In the prompt box, choose 3 Points, or press Enter to select the default. 
4   Specify the first point on the mirror plane. 
5   Specify the second and third points on the plane. 
6   In the prompt box, choose one of the following: 
•   Yes Delete Objects to delete the original objects. 
•   No Keep Objects to retain the original objects. 
Command line       MIRROR3D 

 
 
 
 

 
 
 
 
 
 
 

Select the object to mirror (A), and then specify      The resulting mirrored object.   
the first point (B), second point (C), and third 
point (D) defining the mirror plane. 
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Aligning in three dimensions 
You can align selected objects with other objects in three dimensional space. You select the 
objects you want to align, and specify one, two or three pairs of points to align the selected 
objects. 
 
To align an object an object with another 
1   Choose Modify > 3D Operation > Align. 
2   Select the objects, and then press Enter. 
3   Specify the first source point. 
4   Specify the first destination point 
5   Specify additional source and destination points if desired (up to three pairs). 
Command line       ALIGN 
 

 
 
 

  
 

 
 
 
 

 
 

Select the objects to align, and then specify the        The resulting mirrored object. 
first source point (A), the first destination point 
(B), the second destination point (C), and the second  
destination point (D). You can specify up to three pairs 
 of source/destination points. 
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Editing three dimensional solids 

 
You can edit three dimensional solids in several unique ways, including: chamfer, fillet, 
section, and slice. You can also modify individual faces and edges of solids, as well as imprint, 
separate, shell, and check solids. 
 
You can edit three dimensional ACIS solids, including: boxes, cones, cylinders, dishes, domes, 
pyramids, spheres, tori, and wedges. 
 
Chamfering and filleting solids 
You can chamfer or fillet a three dimensional solid much like you chamfer or fillet a two-
dimensional object. 
 
To chamfer a solid 
1   Choose Modify > Chamfer. 
2   Select the edge of the base surface to chamfer. (One of two surfaces adjacent to the 

selected edge will be highlighted.) 
3   Do one of the following: 
•   To select a different surface, type n and press Enter. 
•   To use the current surface, press Enter. 
4   Specify the base surface distance (measured from the selected edge to the base surface). 
5   Specify the adjacent surface distance (measured from the selected edge to the adjacent 

surface). 
6   Do one of the following: 
•   Specify the edges to chamfer. 
•   To select all edges around the base surface, type l and press Enter. 

Modify toolbar       
Command line       CHAMFER 
 
To fillet a solid 
1   Choose Modify > Fillet. 
2   Select the edge of the solid to fillet. 
3   Specify the fillet radius. 
4   Select additional edges to fillet, and press Enter to fillet 

Modify toolbar       
Command line      FILLET 
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Sectioning and slicing solids 
 

You can section or slice a three dimensional solid, region, or body (typically a sheet). 
 
When you section a solid, you obtain an “inside view” by creating a cross-section through the 
solid as a region or block. When you section a region or body, the resulting intersections are 
curves. 
 

When you slice a solid, region, or body, you create a new object by cutting the original object 
and removing a specific side. 
 
To section an object 
1   Choose Draw > Solids > Section. 
2   Select the objects to cross section. 
3   Do one of the following: 
•   Specify three points to define the cross section plane. (The first point defines the origin, 

while the second point defines the x axis and the third point defines the y axis.) 
•   Type o and press Enter to select an object that defines the cross sectional plane. 
•   Specify an axis by typing the appropriate letter and pressing Enter. 

Solids toolbar       
Command line      SECTION 
 
To slice an object 
1   Choose Draw > Solids > Slice. 
2   Select the objects to slice. 
3   Do one of the following: 
•   Specify three points to define the cross section plane. (The first point defines the origin, 

while the second point defines the x axis and the third point defines the y axis.) 
•   Type o and press Enter to select an object that defines the cross sectional plane. 
•   Specify an axis by typing the appropriate letter and pressing Enter. 
4   Specify which side to retain, or type b to retain both sides. 

Solids toolbar       
Command line      SLICE 
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Modifying faces 
You can edit three dimension solids by extruding, moving, rotating, offsetting, tapering, 
deleting, or copying individual faces. You can also change the color of individual faces. 
 
To extrude a solid face 
1   Choose Modify > Solids Editing > Extrude Faces. 
2   Select the object with the face you want to extrude. 
3   Select the face(s) to extrude, and press Enter. 
4   Do one of the following: 
•   Specify the height of extrusion. 
•   Type p and press Enter to select a path for extrusion. 
5    If you specified a height, specify a taper angle. 

Solids Editing toolbar       
 

 
 
 
 
 
 
 
 
 
 
 

Select the object to extrude, and then specify the       The resulting object with the face 
face(s) to extrude (A), and the height of extrusion     offset to position (B). 
 or path. 
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To move a solid face 
1   Choose Modify > Solids Editing > Move Faces. 
2   Select the object with the face you want to move. 
3   Select the face(s) to move, and press Enter. 
4   Specify a base point. 
5   Specify an end point. 

Solids Editing toolbar       
 

 
 

 
 
 
 
 
 
 
 
 
 

Select the object, and then specify the          The resulting object with the face moved 
face(s) to move (A), the base point (B),          to the new position. 
and the end point (C). 
 
 
To rotate a solid face 
1   Choose Modify > Solids Editing > Rotate Faces. 
2   Select the object with the face you want to rotate. 
3   Select the face(s) to rotate, and press Enter. 
4   Specify a base point. 
5   Specify another point on the rotation axis. 
6   Specify the rotation angle. 

Solids Editing toolbar       
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Select the object, and then specify the face(s) to      The resulting object with the face 
rotate (A), the base point (B), a second point on       tapered to position (D). 
the rotation axis (C), and a rotation angle. 
 
To offset a solid face 
1   Choose Modify > Solids Editing > Offset Faces. 
2   Select the object with the face you want to offset. 
3   Select the face(s) to offset, and press Enter. 
4   Specify an offset distance. 

Solids Editing toolbar       
 

 
 
 
 
 
 
 
 
 
 
 

Select the object, and then specify the face(s) to    The resulting object with the face offset 
offset (A) and the distance to offset.                to position (B). 
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To taper a solid face 
1   Choose Modify > Solids Editing > Taper Faces. 
2   Select the object with the face you want to taper. 
3   Select the face(s) to taper, and press Enter. 
4   Specify a base point. 
5   Specify another point along the axis. 
6   Specify a taper angle. 

Solids Editing toolbar      
. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Select the object, and then specify the face(s) to     The resulting object with the face tapered to 
taper (A), a base point, a second point along the      position (D). 
taper axis, and a taper angle 
 
 
 
To delete a solid face 
1   Choose Modify > Solids Editing > Delete Face. 
2   Select the object with the face you want to delete. 
3   Select the face(s) to delete, and press Enter. 

Solids Editing toolbar       
 
 
 
 
 
 
 



 
 
 
 
 
 
 
 
 
 
 
 
 
Select the object, and then specify the face(s) to     The resulting object with the face deleted. 
delete (A). 
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To copy a solid face 
1   Choose Modify > Solids Editing > Copy Faces. 
2   Select the object with the face you want to copy. 
3   Select the face(s) to copy, and press Enter. 
4   Specify a base point. 
5   Specify an end point. 

Solids Editing toolbar       
 
 
 
 
 
 
 
 
 
 
 
Select the object, and then specify the face(s) to    The resulting object with the 
copy (A), the base point (B), and the end point       with the face copied. 
(C). 
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To color a face 
1   Choose Modify > Solids Editing > Color Face. 
2   Select the object with the face you want to color. 
3   Select the face(s) to color, and press Enter. 
4   Specify a color. 

Solids Editing toolbar       
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Select the object, and then specify the face(s) to          The resulting object with the face colored. 
color (A). 

 
Modifying edges 
In addition to modifying faces of solids, you can modify individual edges. You can copy 
individual edges or change the color of individual edges. 
 
To copy an edge 
1   Choose Modify > Solids Editing > Copy Edge. 
2   Select the object with the edge you want to copy. 
3   Select the edge(s) to copy, and press Enter. 
4   Specify a base point. 
5   Specify an end point. 

Solids Editing toolbar       
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Select the object, and then specify the edge(s) to        The resulting object with the edge copied. 
copy (A), the base point (B), and the end point 
(C). 
 
To color an edge 
1    Choose Modify > Solids Editing > Color Edges. 
2   Select the object with the edge you want to color. 
3   Select the edge(s) to color, and press Enter. 
4   Specify a color. 

Solids Editing toolbar       

 
Imprinting solids 
You can modify the face of a solid by imprinting another object on it. For example, you can 
imprint a line, arc, or polyline onto the face of a box. 
 
To imprint a solid object 
1   Choose Modify > Solids Editing > Imprint. 
2   Select the solid object you want to imprint. 
3   Select the object you want to imprint on the solid. 

Solids Editing toolbar       
 

 
Separating solids 
You can separate solids that have been combined. After you separate them, they are separated 
into individual solids. 
 
To separate solids 
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1   Choose Modify > Solids Editing > Separate. 
2   Select the solid you want to separate. 

Solids Editing toolbar       
 
 
Shelling solids 
 

You can create a shell or a hollow thin wall from your 3D solid object. ZwCAD 
offsets existing faces to create new faces. 
 
To shell a solid 
1   Choose Modify > Solids Editing > Shell. 
2   Select the object you want to shell. 
3   Remove any faces you don’t want to include. 
4   Specify an offset distance. 

Solids Editing toolbar       
 
 
 
 
 
 
 
 
 
 
 
 

 Select the object, and then select faces to            The resulting shelled object 
remove (A) and (B), then specify an offset 
distance. 
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Cleaning solids 
 

You can remove redundant edges or vertices from solids when they are not needed. 
 
To clean a solid 
1   Choose Modify > Solids Editing > Clean. 
2   Select the object you want to clean. 

Solids Editing toolbar       
 
 
Checking solids 
 

You can check whether a selected object is a valid three dimensional ACIS solid. If it 
is a valid 3D solid, you can modify the object using the 3D solid editing commands; if not, you 
cannot edit the object using these commands. 
 
To check a solid 
1   Choose Modify > Solids Editing > Check. 
2   Select the objects to check. 

Solids Editing toolbar       
 
 
 

Hiding, shading, and rendering 

 
As you create three dimensional objects, the program displays both wire frame and surface 
models in wire frame view, which makes it difficult to visualize your three dimensional 
models. To better visualize the model, you can remove all the lines that are hidden behind 
other objects or surfaces when seen from the current viewpoint. 
 

Shading goes a step further by removing hidden lines and then assigning flat colors to the 
visible surfaces, making them appear solid. Shaded images are useful when you want to 
quickly visualize your model as a solid object, though they lack depth and definition. 
 

Rendering provides an even more realistic image of your model, complete with light sources, 
shadows, surface material properties, and reflections, giving your model a photo realistic look. 
As shown in the following illustrations, when you render a model, the program removes 
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hidden lines and then shades the surfaces as though they were illuminated from imaginary light 
sources. 

 
 
 
Creating hidden line images 
Creating a hidden line view of your drawing removes all the lines that are hidden behind other 
surfaces when seen from your vantage point. When you remove hidden lines or shade a model, 
the program treats the objects differently, depending on how you created them. Wire frame 
models always appear transparent, because they have no surfaces. Surface models appear 
filled, with surfaces applied to all visible sides. 
 
To create a hidden-line image 
Choose View > Rendering > Hide. 

Render toolbar       
Command line      HIDE 
 
 
 
 
 
 
 
 
Before creating a hidden line image.      After removing hidden lines.  

 
Creating shaded images 
Creating a shaded image of your drawing removes hidden lines and then applies shading to 
the visible surfaces based on their object color. Because they are intended to provide a quick 
visualization, shaded images do not have a light source and use continuous colors across 
surfaces, causing them to appear flat and unrealistic. 
 
 



 
To create a shaded image 
Choose View > Rendering > Shade. 

Render toolbar       
Command line      SHADE 
 
To control the appearance of the shaded image, choose Settings > Drawing Settings, and then 
click the 3D Settings tab and select the options you want. You can shade the surfaces and 
edges of the model in four ways: 
•   Faces shaded; edges not highlighted. 
•   Faces shaded; edges highlighted in the background color. 
•   Faces filled in the background color; edges drawn using the object color (similar to 

a hidden line view). 
•   Faces filled using the object color; edges highlighted in the background color. 
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Working with other programs 
 

 
 
 
 
ZwCAD offers great flexibility in its capability to be used with other programs. You can 
include a ZwCAD drawing in a Microsoft® Word document or insert a Microsoft®  Excel 
spreadsheet containing a parts list into an ZwCAD drawing. To include ZwCAD drawings in 
other programs and documents from other programs in ZwCAD drawings, you either link or 
embed them. You can also save ZwCAD drawings in other file formats that can be used 
directly with other programs or send ZwCAD drawings to coworkers via email. 
 

This section explains how to: 
 

•   Save and view snapshots. 

•   Use raster images in your drawings. 

•   Use object linking and embedding. 

•   Export ZwCAD drawings to other file formats. 

•   Send drawing files via email. 

•   Use ZwCAD with the Internet. 
 
 
 
 
 
 
 
 
Topics in this chapter 
 

Saving and viewing snapshots.................................................................................389 
Using raster images in a drawing..............................................................................390 
Using data from other programs in ZwCAD drawings ..................................................395 
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Using ZwCAD with the Internet...............................................................................407 
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Saving and viewing snapshots 

 
You can save snapshots of a drawing to view later. A snapshot saves the current drawing in 
either *.emf, *.wmf, or *.sld format exactly as it appears on the screen. A snapshot is not a 
drawing file. You cannot edit or print the snapshot; you can only view it. 
 

You can use snapshots in the following ways: 
 

•   Make presentations by showing snapshots of your drawings. 

•   Reference a snapshot of a drawing while working on a different drawing. 

•   Present a number of snapshots as a slide show by using scripts. 
 
When you view a snapshot, it temporarily replaces the current drawing. When you refresh the 
display of the current drawing (by redrawing, panning, zooming, minimizing, maximizing, or 
tiling), the snapshot image disappears, and you are returned to the current drawing. 
 
You create a snapshot by saving the current view as a snapshot. A snapshot does not include 
any entities on layers that are not currently visible. The contents of the snap shot also depend 
on the current drawing space. In model space, the snapshot shows only the current viewport. 
In paper space, the snapshot contains all visible viewports. 
 
To create a snapshot 
1   Choose Tools > Make Snapshot. 
 

2   In the Create Snapshot dialog box, specify the name of the snapshot file you want to 
create. 

3   From the Files Of Types list, choose either *.emf, *.wmf, or *.sld. 

4   Click Save. 

Command line   MSLIDE 
 
 
The current drawing remains on the screen, and the snapshot is saved to the directory that you 
specify. You can view previously saved snapshots, and you can also view snapshots created 
using AutoCAD. 
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To view a snapshot 
1   Choose Tools > View Snapshot. 
 

2   In the View Snapshot dialog box, specify the name of the snapshot file you want to view. 

3   Click Open. 

ZwCAD displays the snapshot in the current drawing window. 

Command line   VSNAPSHOT 

 

 

Using raster images in a drawing 

 
You can modify and view raster images directly inside of ZwCAD. You can load, edit, and 
modify multiple images as overlays or underlays to your ZwCAD drawings. The raster images 
can be selected through ZwCAD commands or by selecting the raster image frame. 
 
Attaching raster images 
You can attach raster images to a drawing. 
 
To attach a raster image 

1   Choose Insert > Raster Image. 
 

2   Specify a file to attach, and then click OK. 

3   In the Raster Insert dialog box, specify the position, scale, rotation, and then click OK. 

4   Specify an insertion point. 

5   Specify a scale. 

 
Command line   IMAGEATTACH 
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Modifying raster images 
You can modify a raster image by changing its brightness, contrast, fade, size, rotation, or 
quality. You can also determine whether image frames display and print. 
 

You can use other ZwCAD commands for typical modifications, such as Delete, Move, Layer, 
and more. 
 
To adjust the brightness, contrast, fade, size, or rotation of an image 
1   Choose Insert > Image Management. 
 

2   Select an image. 

3   In the Adjust Image area, adjust the settings by using the slide bars or by entering an 
exact number. The image preview shows how your changes will affect the image when you 
click OK. 
 
TIP If you want to restore the parameters to those of the original image, click 
Reset. 
 

 
4   In the Size area, enter new width (X) and height (Y) drawing units. Mark Keep Aspect if 
you want the width and height to change together to retain the image’s aspect ratio. 

5   In the Rotation area, enter how many degrees to rotate the image to the left. 

6   Click OK. 

Insert toolbar     

Command line   IMAGE 
 
To change the quality of all images in a drawing 
1   Choose Modify > Object > Image > Quality. 
 

2   Do one of the following: 

•   Type high to use high quality images. 

•   Type draft to use draft quality images, which require smaller amounts of system 
resources. 
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To turn image frames on or off for all images 
1   Choose Modify > Object > Image > Frame 
 

2   Do one of the following to toggle frames off and on: 

•   Type on to display and print frames for all images in a drawing. 

•   Type off to hide all frames on the screen and during printing. 
 
Clipping raster images 
You can clip raster images so that only a portion of the image is visible in a drawing. The 
visible portion can be in the shape of any rectangle or polygon. 
 

Image clipping can be turned on an off. If you turn off clipping for an image, the entire image 
is visible provided that the image is on a layer that is on and thawed. The clipping information 
is retained however, and you can turn clipping back on at any time. 
 

If you delete clipping from an image, the clipping is removed permanently but the image itself 
remains in the drawing. 
 
To clip an image in the shape of a rectangle 
1   Choose Modify > Clip > Image 
 

2   Select the edge of the image you want to clip. 

3   If prompted, type new to create a new clipping boundary. 

4   Choose Rectangle. 

5   Define the first corner of the clipping rectangle. 

6   Define the second corner of the clipping rectangle. 

The selected image is clipped so that only the interior of the rectangle is visible. 
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To clip an image in the shape of a polygon 
1   Choose Modify > Clip > Image 
 

2   Select the edge of the image you want to clip. 

3   If prompted, type new to create a new clipping boundary. 

4   Choose Polygon. 

5   Select the points for the polygon, and then press Enter when the polygon is complete. 

The selected image is clipped so only the interior of the polygon is visible. 
 
To turn clipping on or off for an image 
1   Choose Modify > Clip > Image 
 

2   Select the edge of the image for which you want to turn clipping on or off. 

3   Type on or off. 
 
To remove clipping from an image 
1   Choose Modify > Clip > Image 

2   Select the edge of the image for which you want to remove clipping. 

3   Type delete. 
 
Unloading and reloading raster images 
If you find that including a raster image affects system performance, you can unload it so only 
the image frame displays to mark its location. If you want an unloaded raster image to print, 
reload it before printing. You may also want to reload an image if the original file contains 
new content. 



To unload and reload a raster image 
1   Choose Insert > Image Management. 
 

2   Select the file you want to unload or reload. 

3   Do one of the following: 

•   To unload the image so only its outer edge displays, click Unload. 

•   To reload the image so its contents display and print, click Reload. 

Insert toolbar     

Command line   IMAGE 

 
Changing the path for raster images 
If the file associated with a raster image is renamed or moved to a different directory, the pro-
gram displays a message indicating that it cannot load the image. You can reestablish the link 
to the file by changing the path for the image. 
 
To change the path for a raster image 
1   Choose Insert > Image Management. 
 

2   Select the desired file. 

3   Click the [...] button. 

4   Select the file with its new name or in its new location, and then click Open. 

5   Click Set Path. 

Insert toolbar     

Command line   IMAGE 
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Using data from other programs in ZwCAD drawings 

 
You can include data from other programs in ZwCAD drawings by using either embedding or 
linking. The method you choose depends on the type of object or file you want to include in 
your ZwCAD drawing and what you want to do with it after it is there. 
 
Embedding objects into drawings 
Embed an object into your ZwCAD drawing when you want to keep all the data you work 
with in one file or if you want to transfer the file to other computers. You can embed data 
from programs that support object linking and embedding. 
 

For example, if you want to distribute data about a department’s computer equipment along 
with an ZwCAD drawing of the department’s floor plan, you can embed a Microsoft®  Excel 
spreadsheet into the floor plan. 
 

When you embed data from another program, ZwCAD becomes the container for that data. 
The object embedded in the ZwCAD drawing becomes part of the ZwCAD file. When you 
edit the data, you open its program from within the ZwCAD drawing. 
 

Any changes you make to the embedded data exist only in the ZwCAD drawing, so it is not 
necessary to keep that data in a separate file. If the data does exist in a separate file, the 
original file does not change when you modify the embedded object in ZwCAD. Also, 
changes to the original file do not affect the embedded object in the ZwCAD drawing. 
 
To embed another program’s object into an ZwCAD drawing 

1   Open the file that contains the data you want. 

2   In the file, select the data you want to embed in the ZwCAD drawing. 

3   Choose that program’s command to place data on the Clipboard. Usually, you choose 

Edit > Copy. 

4   In the ZwCAD window, display the drawing in which you want to embed the object. 

5   Choose Edit > Paste, or click the Paste tool ( ) on the Standard toolbar. 
The data on the Clipboard is pasted into the drawing as an embedded object. The object 
appears in the center of the view, but you can select and move it by moving the cursor. 
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To embed an object from an existing file within ZwCAD 
1   Choose Insert > OLE object. 
 

2   In the Insert Object dialog box, click Create From File. 

3   Specify the file by doing one of the following: 

•   Type a path and file name in the File box. 

•   Click Browse to select a file. 
 

4   Select Display As Icon if you want that program’s icon to appear in the drawing instead 
of the data. 

5   Click OK. 
Command line   INSETOBJ 

The first page of the file appears in the ZwCAD drawing, unless you chose to display it as an 
icon. You can select the object and drag to reposition it. 
 
To create a new embedded object from within ZwCAD 
1   Choose Insert > OLE object. 
 

2   In the Insert Object dialog box, click Create New. 

3   From the Object Type list, select the type of object you want to create, and then click OK. 

The program for creating that object opens within ZwCAD. If the program is compatible with 
ActiveX, it opens in place (within the other program) in the ZwCAD drawing; otherwise, the 
program opens in its full window. 

4   Create the object in the other program. 

5   If the program is running within the other document (in place), click anywhere outside 
the embedded object to close the program. 

If the program is running in its full window, choose File > Exit. 
Command line   INSETOBJ 
 
Linking objects to drawings 
If another program supports ActiveX, you can link its data to ZwCAD drawings. Use linking 
when you want to include the same data in many files. When you update the data, all links to 
other files reflect the changes. 
 

For example, if you created your company logo in an ActiveX compatible drawing program, 
and you want to include it in the title block of every drawing you create with ZwCAD, you 
can link it to each ZwCAD drawing. When you change the original logo in the drawing pro-
gram, the ZwCAD drawing updates automatically. 
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When you link data from another program, the ZwCAD drawing stores only a reference to the 
location of the file in which you created the data. You link data from a saved file, so ZwCAD 
can find the data and display it. 
 

Because linking adds only a reference to a file, the data does not significantly increase the file 
size of the ZwCAD drawing. However, links require some maintenance. If you move any of 
the linked files, you need to update the links. In addition, if you want to transport linked data, 
you must include all linked files. 
 

You can update a linked object automatically every time you open the drawing, or you can do 
so only when you specify. Anytime a link is updated, changes made to the object in its original 
file also appear in the ZwCAD drawing, and the changes also appear in the original file if they 
were made through ZwCAD. 
 
To link a file to an ZwCAD drawing 
1   Save the original file. 

Because a link consists of a reference to the original file, you must save the file before you can 
link to it. 

2   In the original file, select the data you want in the ZwCAD drawing. 

3   Choose that program’s command to place data on the Clipboard. Usually, you choose 

Edit > Copy. 

4   Display the ZwCAD drawing to which you want to link the file. 

5   In ZwCAD, choose Edit > Paste Special. 

6   In the Paste Special dialog box, select Paste Link. 

7   Click OK. 
 
To create a linked object from within ZwCAD 

1   Display the ZwCAD drawing in which you want to display the linked object. 

•   Choose Insert > OLE object 

•   Type insertobj and then press Enter. 
 

2   In the Insert Object dialog box, click Create From File. 

3   Specify the file by doing one of the following: 

•   Type a path and file name in the File box. 

•   Click Browse to select the file using a file dialog box. 
 

4   Select the Link check box. 

5   Select Display As Icon if you want that program’s icon to appear in the drawing instead 
of the data. 

6   Click OK. 

The first page appears in the ZwCAD drawing, unless you chose to display it as an icon. To 
reposition the object, select and drag it. 
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Editing an embedded or linked object from within ZwCAD 
You can modify an embedded or linked object in its original program from within ZwCAD. 
When you modify an embedded object, you change the object only in ZwCAD, not its original 
file (if you pasted the object from an existing file). When you modify a linked file, however, 
you open and change the original file. 
 

Most programs include a submenu of actions you can perform on an embedded or linked 
ActiveX object. Usually, the commands for editing ActiveX objects are Edit and Open. If the 
object is embedded and its program supports inplace editing, the Edit command opens the 
object in place. The Open command opens the object in the full program window. In ZwCAD, 
this command appears at the bottom of the Edit menu. 
 
To edit an embedded or linked object 
•   In the ZwCAD drawing, double click the object. 

If the object is embedded and the program in which you created the object supports in-place 
editing, the object opens in place. 
 

If the object is linked, or if its program does not support inplace editing, the other program 
opens in its full window and displays the object. 
 
Importing files created in other formats 
You can import the following files: 
 

•   Drawing Exchange Format files with a .dxf file extension. This file type is an ASCII or 
binary description of a drawing file. 

•   Design Web Format files with a .dwf file extension. DWF™ files are used to distribute a 
drawing for others to view in a Web browser, review, and edit using free Autodesk®  software 
and tools. 

•   Drawing templates with a .dwt file extension. This file type contains predefined settings 
that you can reuse when you create new drawings. 

•   Three dimensional entities saved with an .sat file extension. This file type contains three 
dimensional ACIS solids saved as an .sat file. 



Importing a DXF, DWF, or DWT file 
Importing DXF files, two dimensional DWF files, and DWT files is similar to opening a 
standard drawing file. 
 
To import a DXF, DWF, or DWT file 

1   Choose File > Open. 
 

2   Choose the folder that contains the drawing. 

3    In Files of Type, choose the type of drawing you want to import. 

4   Choose the file you want to open. 

5   Click Open. 

Standard toolbar     

Command line      OPEN 
 
Importing an ACIS file 
An ACIS file contains three dimensional solids, regions, or bodies that are saved as an 
ASCII .sat file. 
 
To import an ACIS file 

1   Choose Insert > ACIS file. 
 

2   Choose the directory containing the SAT file. 

3   Choose the SAT file you want to open. 

4   Click Open. 
Command line      ACISIN 
 
 

Using ZwCAD data in other program 

You can use any of the following methods to include ZwCAD data in a document created in 
another program: 

•   Embedding 

•   Linking 

•   Dragging 

•   Exporting 

•   Emailing 
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The method you choose depends on the capabilities of the other program and how you want to 
work with the ZwCAD data after you’ve placed it in the other document. 
 

 
NOTE Each method except exporting uses ActiveX to integrate data from different 
programs. With ActiveX, you can open ZwCAD drawings from within the other 
program to modify the ZwCAD drawings. 
 
 
Embedding drawings 
When you embed an ZwCAD drawing, it becomes part of the other program’s document file. 
When you edit the drawing, you edit only the version that is embedded in the other document. 
 

Embedding is useful when you don’t want to maintain a link to the ZwCAD drawing for the 
data you include in the other document. Edits made to the new drawing do not affect the ori-
ginal drawing. To transfer the file to other computers, you can transfer all the data in one file, 
but embedded objects increase the file size. 
 
From within a document in a program that supports ActiveX, such as Microsoft® Word, you 
can either create a new embedded ZwCAD drawing or embed an existing ZwCAD drawing. 
 
To create an ZwCAD drawing in another document 
1   In the document, choose Insert > OLE Object (or the equivalent command for that 
program). 

2   In the dialog box, click the options for creating a new file. 

3   Under Object Type, choose ZwCAD Drawing, and then click OK. 

4   Create the ZwCAD drawing. 

5   If ZwCAD is running in its own window, choose File > Exit. 

If ZwCAD is running within the other document (in place), click somewhere in the document 
outside the ZwCAD drawing to close ZwCAD. 

6   To edit the ZwCAD drawing from within the document, double-click the drawing. 
 
 
TIP You can also embed an existing ZwCAD drawing from within another document. 
Follow step 1 in the preceding procedure, and then click the option for creating an ob- 
ject from an existing file. 
 
 
To embed selected ZwCAD entities 

1   In ZwCAD, select the entities you want to embed. 

2   Choose Edit > Copy (or press Ctrl+C). 

3   Open the document in which you want to embed the entities. 
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4   Choose Edit > Paste (or the equivalent command). 
 
To embed an entire ZwCAD drawing 

1   Open the document in which you want to embed the drawing. 

2   Choose Insert > OLE Object. 

3   Click Create From File. 

4   Click Browse, and then choose the file you want to embed. 

5   Click Insert, and then click OK. 
 
Editing an embedded ZwCAD object in place 
In many ActiveX compatible programs you can edit an embedded ZwCAD object without 
leaving the program (or container application). This is called inplace editing. A different set of 
ZwCAD menus and toolbars temporarily replaces most of the menus and controls in the active 
window while you edit the ZwCAD object. 
 
To edit an embedded ZwCAD object in place 
1   In the container application, double click the embedded ZwCAD object. A different set of 

ZwCAD menus and controls appears. 

2   Edit the ZwCAD drawing. 

3   Click anywhere outside the drawing window to exit the inplace editing controls. 
 
Linking drawings 
When you link an ZwCAD drawing to another document, the other document contains only a 
reference to the ZwCAD drawing file, rather than the actual drawing. You link data in a saved 
ZwCAD file so that the other program can find the data and display it. 
 
Linking works well when you want to include the same ZwCAD data in more than one docu-
ment. When you update the data, you need update it in only one location. The versions that are 
linked to other documents reflect the changes automatically. 
 
Linking an ZwCAD file to another document does not increase the file size the way embed-
ding an ZwCAD object does. However, links require more maintenance. To transport the data, 
you must make sure to transfer all linked files to the other computer. 
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To link an ZwCAD file to another document 
1   Open the drawing you want to link. 
 
NOTE Because a link is a reference to a file, you can link only files that are saved to a 
location on a disk. If you haven’t saved the drawing you want to link, choose File > Save. 
 
2   In the other program, open the document in which you want to include the ZwCAD 
drawing. 

3   Choose that program’s command for inserting objects. 

In Microsoft®  Office programs, choose Insert > Object. In the Object dialog box, click the 
Create From File tab. Specify the name of the drawing file you want to link. Select the Link 
To File check box, and then click OK. The drawing appears in the document, with a link to the 
original ZwCAD file. 

 
Dragging ZwCAD drawings into other programs 
If the other program in which you want to include ZwCAD drawings is compatible with Act-
iveX, an alternative to pasting drawings with menu commands is to drag drawing file icons 
from Windows Explorer into the other document. Dragging and dropping drawings does not 
use the Clipboard, so data on the Clipboard is not 
affected. 
 
When you drag an ZwCAD drawing file from Windows Explorer, you link or embed the 
entire drawing in the other document. When you drag the file, the cursor changes in response 
to the action you take. 
 
How the cursor changes 
Cursor appearance Action 

                       Drag to embed the selected file to the other 
                   document.. 
 
                          Cannot drop drawings in that document. 
 

 
 
TIP Before you drag a drawing, position the Windows Explorer window and the other 
program’s window so you can see the file icon and the document in which you want 
to drop it. 
 
 
To drag and embed drawings into another document 

•   Select the icon for the drawing file, and then drag the drawing into the document. 
 
 



 
Exporting drawings 
You can save or export ZwCAD drawings in a number of different formats for use with other 
programs. When you save a drawing in a different format, the program saves all the entities in 
the drawing to the new file. Or, you can choose which entities are included in the new file. 

 
Export formats 

 
You can also export ACIS solids, regions, and surfaces to an ASCII file (*.sat) that you can 
use in other programs. 
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Exporting to a DWG, DXF, BMP, EMF, WMF,  or SVG file 
Exporting to a file is similar to saving a standard drawing file. 
 
To export a drawing to a DWG, DXF, BMP, EMF, WMF, or SVG file 
1   Choose File > Export 
 

2   In the Export Drawing As File dialog box, under Save As Type, choose the file format. 

3   Specify the name of the file you want to create. 

4   Click Save. 

5   If the selection prompt box displays, choose the entity selection method, and then create 
the selection set. 

6   When you have finished selecting entities, press Enter. 
Command line      EXPORT 
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Exporting to a DWF file 
DWF files allow you to publish your drawings so they can be viewed on the Internet using a 
Web browser. ZwCAD exports your drawing to a Design Web Format (.dwf) file, which can 
be viewed in a Web browser if Autodesk® DWF Viewer is also installed on the computer. 
DWF Viewer is a free tool from Autodesk®. 
 
You can export your drawing to a 2D DWF file or a 3D DWF file. 2D DWF files have smaller 
file sizes, but cannot be viewed in three dimensions. 3D DWF files can be viewed in three 
dimensions using the Autodesk® DWF Viewer, but have larger file sizes. 
 
To export a drawing to a 2D DWF file 
1   Choose File > Export 
 

2   In Save As Type, choose Design Web Format (dwf). 

3   Specify the name of the file you want to create. 

4   Click Save. 

5   Choose how you want to export: 

•   DWF File Version — Choose the DWF file version you want. Version 4.2 can export 
entities on the Model tab only (no layouts). Version 5.5 can export the current layout only. 
Version 6.0 can export the current layout or all layouts. 

•   DWF File Format — Choose the desired file format. Compressed binary files have a 
smaller file size than uncompressed binary files. ASCII files have the largest file size. 

•   Layout to Export — Choose whether to export the current layout only, or all layouts in 
the drawing. 

6   Click OK. 

7   Choose the entity selection method, and then create a selection set that contains the 
entities you want to export. 

8   When you have finished selecting entities, press Enter. 
 
Command line      EXPORT 



 
Exporting to an ACIS file 
You can export ACIS entities such as surfaces, regions, and solids to an ACIS file in ASCII 
(SAT) format. 
 
To export an ACIS file 

1   On the command line, type acisout. 
 

2   Select the ACIS entities you want to save. 

3   Specify the name of the file you want to create. 

4   Click Save. 
 
Sending drawings through email 
You can send an ZwCAD drawing to another user via email. ZwCAD is compatible with 
email programs that support the Messaging Application Program Interface (MAPI) protocol. 
 
To include a drawing file in an email message 
1   While the drawing file is open, choose File > Send Mail. 

If your mail program is not already running, it starts; a new email message containing the 
ZwCAD icon and file name appears. 

2   Address the email, type a message, and send the email message as you would any other 
message. 
 
To view an ZwCAD file sent by email 
•   Open the email message, and then double click the ZwCAD icon. 
 
NOTE ZwCAD software must be installed on the computer used to open drawings 
in email. 
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Using ZwCAD with the Internet 

 
You can use ZwCAD to access the Internet and exchange drawing information and perform 
other tasks, including: 

•   Add hyperlinks to a drawing. 

•   Publish drawings to the Internet. 

•   Drag drawings (.dwg files) directly from a Web site into ZwCAD. 

•   Access the Internet during a drawing session. 
 
 
NOTE You will need Internet Explorer Version 5.0 or later and access to the Internet 
to fully use these features. 
 
 
Add hyperlinks to a drawing 
 

In your ZwCAD drawings, you can include hyperlinks, which are pointers that take you to 
another location, such as a Web address or a file on a particular computer. You can attach a 
hyperlink to any entity in your drawing. Then, when you select that entity, you can open the 
link and jump to the specific Web address or file location. You can create absolute hyperlinks, 
which store the full path to a file, or relative hyperlinks, which store a partial path relative to a 
base folder or a Uniform Resource Locator (URL). 
 

 
NOTE To open files associated with hyperlinks, the PICKFIRST system variable must 
be set to On. 
 
 
To create a hyperlink 
1   Type hyperlink and then press Enter. 

2   Select an entity or entities that you would like to associate with a hyperlink; then press 
Enter to display the Edit Hyperlink dialog box. 

3   Do one of the following: 

•   Click Browse to specify a file. 

•   In the Link to File or URL box, type a Web address. 
 

4   If you want to use a common path for all hyperlinks in the drawing, select the Use relative 
path for hyperlinks check box. Relative paths provide flexibility if you move files to a differ-
rent folder, since you can change multiple hyperlink paths at once, rather than change them all 
individually. 
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5   Click OK to close the Edit Hyperlink dialog box. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
NOTE The HYPERLINKBASE system variable defines the relative path used for all hyperlinks 
in the current drawing. To use the default drawing path, leave the value blank by entering a 
period ("."). 
 
 
To remove a hyperlink 

1   Type hyperlink and then press Enter. 

2   Select an entity or entities with a hyperlink; then press Enter to display the Edit Hyper-
link dialog box. 

3   Click Remove Link. 

4   Click OK to close the Edit Hyperlink dialog box. 
 
To access a hyperlink 

1   Select an entity with a hyperlink. 

2   Right click anywhere in the drawing area. 

3   In the pop up menu, choose Open Link. 
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Publishing drawings to the Internet 
You can publish your drawings so they can be viewed on the Internet using a Web browser. 
ZwCAD exports your drawing to a Design Web Format (.dwf) file, which can be viewed in a 
Web browser if DWF Viewer is also installed on the computer. DWF Viewer is a free tool 
from Autodesk®. 
 

For details about creating a DWF file, see “Exporting to a DWF file” on page 447 in this 
chapter. 
 
Inserting drawings from a Web site 
Some Web sites are configured to allow you to drag drawings from the Web site directly into 
your drawing. You can drag and drop drawings from any Web site that supports the Auto-
desk®  I drop® technology. 
 
To insert a drawing from a Web site 

1   Open your Web browser. 

2   Navigate to a Web site that supports Autodesk®  I drop. 

3   Position the Web browser and ZwCAD windows so they are both visible. 

4   Click the drawing in your Web browser and drag it to your drawing in ZwCAD. The 

drawing file is downloaded and inserted into your drawing in ZwCAD. 
 
Accessing the ZwCAD Web site during a drawing session 
In addition to using hyperlinks to access the Internet, you can access a company Web site at 
any time. At the Web site, you can obtain company information as well as product information 
and news. 
 
To access the ZwCAD Web site 

1   Choose Tools > ZwCAD on the web. 
 

2   Navigate to the section of your choice on the ZwCAD Web site. 
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Customizing ZwCAD 
 

 
 
 
 
You can customize ZwCAD in a number of ways. For example, you can change the appear-
ance of many aspects of the program and modify the existing menus and toolbars or create new 
ones. This section explains how to: 

•   Set the program’s preferences. 

•   Customize menus and toolbars. 

•   Customize the keyboard. 

•   Create aliases for frequently used commands. 

•   Customize entities. 

•   Create and use scripts. 

•   Use add on programs with ZwCAD. 

•   Use a digitizer tablet for menu selection and calibrated drawing. 
 
 
 
 
 
Topics in this chapter 
 
 

Setting and changing options .................................................................................. 411 
Customizing menus .............................................................................................423 
Customizing toolbars ...........................................................................................430 
Customizing the keyboard ....................................................................................438 
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Using a digitizer tablet .........................................................................................451 
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Setting and changing options 

 
You can change many of the options that control the program’s behavior and appearance, such 
as setting the experience level, specifying file paths and default files, and configuring display 
features. 
 
Changing the options on the Open and Save tab 
In the Options dialog box, the open and save tab contains settings for experience level and 
save options. You can also set VBA security. 

 

File Save Controls settings related to saving a file in AutoCAD. 

•   Default file format on The file format selected for this option is the default format that all 

drawings are saved as when you use SAVE, SAVEAS, and QSAVE. 

•   Save a Thumbnail Preview Image Displays an image of the drawing in the Preview area of 
the Select File dialog box. 

•   Incremental Save Percentage Sets the percentage of potentially wasted space in a drawing 
file. When the specified percentage is reached, ZwCAD performs a full save instead of an 
incremental save. Full saves eliminate wasted space. If you set Incremental Save Percentage 
to 0, every save is a full save. 

 
File Safety Precautions Assists in avoiding data loss and in detecting errors. 

•   Automatic Save Saves your drawing automatically at the intervals you specify. 
      Minutes Between Saves: Specifies how often the drawing is saved when using Automatic 

Save. 
•   Create Backup Copy with Each Save Specifies whether a backup copy of a drawing is 

created when you save the drawing. 
•   Maintain a Log File Writes the contents of the text window to a log file. To specify the 

location and name of the log file, use the Files tab in the Options dialog box. 
•   File Extension for Temporary Files Specifies a unique extension for the current user to 

identify temporary files in a network environment. The default extension is .ac$. 
 

Setting the experience level You can control which menus and tools are available by setting 
the experience level. You can choose from the following experience levels: 

•   Beginner Menus and toolbars display only basic commands. 

•   Intermediate Menus and toolbars display most two dimensional entity creation and 
modifycation commands. 
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•   Advanced Menus and toolbars display all available commands. 
 
 
 

External References (Xrefs) Controls the settings that relate to editing and loading external 
references. 
•   Demand Load Xrefs Controls demand loading of xrefs. Demand loading improves 

performance by loading only the parts of the referenced drawing needed to regenerate the 
current drawing. 

    Disabled: Turns off demand loading. 
    Enabled: Turns on demand loading and improves AutoCAD performance. Select the Enabled 

setting to enhance the loading process when working with clipped xrefs that contain a spatial 
or layer index. When this option is selected, other users cannot edit the file while it is being 
referenced. 

    Enabled with Copy: Turns on demand loading but uses a copy of the referenced drawing. 
Other users can edit the original drawing. 

•   Retain Changes to Xref Layers Saves changes to layer properties and states for xref-
dependent layers. When the drawing is reloaded, the properties currently assigned to xref-
dependent layers are retained. This setting is saved in the drawing. 

•   Allow Other Users to Refedit Current Drawing Determines whether the current drawing file 
can be edited in place if it is being referenced by another drawing or multiple drawings. This 
setting is saved in the drawing. 

 
To change the options on the Open and Save tab 
1   Choose Tools > Options. 
 

2   Click the Open and Save tab. 

3   Choose the command which you want. 

4   When you have finished, click OK. 
Command line   OPTIONS 
 
 
Changing the options on the Files tab 
You can specify locations for various file types such as those used for drawings, fonts, and 
menus in the Options dialog box on the Files tab. You can even specify multiple paths for the 
same file type. In addition, you can change the names of the default system files that are used 
for functions such as font mapping and error logging. 
 
Specifying the user paths 
You can enter paths to your ZwCAD directories by typing them into a Location field in the 
Options dialog box. This feature includes directories for drawings, fonts, help, external 
references, menus, hatch patterns, blocks, print style tables, print output files, temporary files, 
templates, and color books. ZwCAD searches directories for support files in the following 
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order: 

•   The ZwCAD program directory. 

•   The current drawing directory. 

•   The Windows search path. 

•   The search path specified in the Options dialog box. 
 
You can enter multiple paths for each item. If, for example, the Drawings item has more than 
one directory associated with it, you can specify multiple paths by separating them with a 
semicolon. ZwCAD searches the directories in the order in which they are listed. 
 
To specify a user path 

1   Choose Tools > Options. 
 

2   Click the Files tab. 

3   Under Location, click the item in the User Paths list whose path you want to specify, and 
type the path. 

If you do not know the path or directory name, click Browse, and then browse to the 
location of the directory you want. 

4 When you have finished, click OK. 
Command line   OPTIONS 
 
 
Changing the default system files 
You can change the default system files, including the log file, default template, alternate font, 
and font mapping file. 
 
To change a default system file 

1   Choose Tools > Options. 
 

2   Click the Files tab. 

3   In the lower half of the dialog box, under File, double click the file name for the default 
system file you want to change, and type in a new file name. 

If you don’t know the file name, click Browse, and then browse to the location of the file 
you want. 

4   Type a new name. 

5   When you have finished, click OK. 
Command line   OPTIONS 

 
 



Changing the options on the Display tab 
In the Options dialog box, the Display tab contains settings for displaying the command bar, 
ZwCAD window, menus, and real time view rotation. 
 

Window Elements   
•   Display Scroll Bars in Drawing Window Displays scroll bars at the bottom and right sides 

of the drawing area. 
•   Display Screen Menu Displays the screen menu on the right side of the drawing area. The 

ZwCAD screen menu font is controlled by the Windows system font settings. If you use the 
ZwCAD screen menu, you should set the Windows system font setting to a font and font size 
that fits the screen menu size restrictions. 

•   Use large buttons for toolbars Displays the buttons for 32*30 pixel format, the default value 
is 15*16 pixel.  

•   Graphics screen Displays color dialog box, to assign the color of elements in the main 
application window. 

 
Display Resolution Controls the quality of the display of objects. If you set high values to improve 
display quality, the impact on performance is significant. 
•   Arc and Circle Smoothness Controls the smoothness of circles, arcs, and ellipses. A higher 

number produces smoother objects, but ZwCAD requires more time to regenerate, pan, and 
zoom the objects. You can improve performance by setting this option to a low value such as 
100 for drawing, and increasing the value for rendering. The valid range is 1 to 20,000. The 
default setting is 1000. This setting is saved in the drawing. To change the default for new 
drawings, consider specifying this setting in the template files on which you base your new 
drawings. 

•   Segments in a Polyline Curve Sets the number of line segments to be generated for each 
polyline curve. The higher the number, the greater the performance impact. Set this option to 
a low value such as 4 to optimize performance for drawing. Values range from –32767 to 
32767. The default setting is 8. This setting is saved in the drawing. 

•   Rendered Object Smoothness Controls the smoothness of shaded and rendered curved 
solids. ZwCAD multiplies the value you enter for Rendered Object Smoothness by the value 
you enter for Arc and Circle Smoothness to determine how to display solid objects. To 
improve performance, set Rendered Object Smoothness to 1 or less when drawing. A higher 
number decreases display performance and increases rendering time. The valid range is 0.01 
to 10. The default setting is 0.5.  

•   Contour Lines per Surface Sets the number of contour lines per surface on objects. A higher 
number decreases display performance and increases rendering time. The valid range is 0 to 
2047. The default setting is 4. 

 
Crosschairs color You can control how the crosshairs display. To help you differentiate the x, 
y, and z axes, a different color is assigned to each. You can change the default axes colors to 
any color you want. In addition, you can specify the size of the crosshairs display, enable 
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grips attraction for the cursor, and you can elect to use cross hairs as the default pointer shape. 
 
Display Performance Controls display settings that affect ZwCAD performance. 
•   Pan and Zoom with Raster and OLE Controls the display of raster images and OLE objects 

when you use Realtime PAN and ZOOM. 
•   Highlight Raster Image Frame Only Controls the display of raster images during selection. If 

this option is selected, only the frame of the raster image is highlighted when selected. 
•   Apply Solid Fill Displays solid fills in objects. You must regenerate the drawing for this 

setting to take effect. 
•   Show Text Boundary Frame Only Displays the frames for text objects instead of displaying 

the text objects. After you select or clear this option, you must use REGEN to update the 
display. 

•   Show Silhouettes in Wireframe Controls whether silhouette curves of 3D solid objects are 
displayed as wireframes. This option also controls whether mesh is drawn or suppressed 
when a 3D solid object is hidden. 

•   Reference Edit Fading Intensity Specifies the fading intensity value for objects during in 
place reference editing. With in place reference editing, you can edit a block reference or 
external reference from within the current drawing. 

 
To change the options on the Display tab 
1   Choose Tools > Options. 
 

2   Click the Display tab. 

3   Select the options you want. 

4   When you have finished, click OK. 
Command line   OPTIONS 
 
 
 
 
 
 
Changing the options on the Drafting tab 
 
In the Options dialog box, the Drafting tab Specifies a number of general editing options.  

SmartSnap Settings Controls settings that relate to the visual aids, called SmartSnaps, that are 
displayed when you use object snaps. When the cursor, or aperture box, is on an object, you can 
press  to cycle through all the snap points available for that object. TAB
•   Enable Smartsnap Click to use smartsnap setting.  
•   Display SmartSnap Tooltip Controls the display of the SmartSnap tooltip. The tooltip is a 

label that describes which part of the object you are snapping to. 
•   Display Marker Controls the display of the SmartSnap marker. The marker is a geometric 
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symbol that is displayed when the crosshairs move over a snap point. 
•   Display snap marker in all views Controls the display of the SmartSnap marker in all views. 
•   Display SmartSnap Aperture Box Controls the display of the SmartSnap aperture box. The 

aperture box is a box that appears inside the crosshairs when you snap to an object. 
•   Show snap cursor decoration Controls the display of the SmartSnap cursor decoration. 
•   SmartSnap Marker Color Specifies the color of the SmartSnap marker. 
•   SmartSnap Marker Size Sets the display size for the SmartSnap marker. 
 
Object Snap Options Specifies options for object snaps. 
•    Ignore Hatch Objects Specifies that object snaps ignore hatch patterns when object snapping 

is turned on. 
 
SmartTrack Settings  
•   Display Polar Tracking Vector Displays a vector along specified angles when polar tracking 

is on. With polar tracking, you can draw lines along angles. Polar angles are 90 degree 
divisors, such as 45, 30, and 15 degrees. 

•   Display Full-Screen Tracking Vector Controls the display of tracking vectors. Tracking 
vectors are construction lines from which you can draw objects at specific angles or in 
specific relationships to other objects. 

•   Display SmartTrack Tooltip Controls the display of the AutoTrack tooltip. The tooltip is a 
label that displays the tracking coordinates. 

    
Alignment Point Acquisition Controls the method of displaying alignment vectors in a drawing. 
•   Automatic Displays tracking vectors automatically when the aperture moves over an object 

snap. 
•   Shift to Acquire Displays tracking vectors when you press SHIFT and move the aperture 

over an object snap. 
 
Aperture Size Sets the display size for the SmartSnap aperture. When Display SmartSnap Aperture 
Box is selected, the aperture box is displayed in the center of the crosshairs when you snap to an 
object. The aperture size determines how close to a snap point you can be before the magnet locks 
the aperture box to the snap point. Values range from 1 to 50 pixels. 
 
To change the options on the Drafting tab 
1   Choose Tools > Options. 
 

2   Click the Drafting tab. 

3   Select the options you want. 

4   When you have finished, click OK. 
Command line   OPTIONS 
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Changing the options on the Selection tab 
 
In the Options dialog box, the Selection tab sets options for selecting objects.  

Pickbox Size Controls the display size of the ZwCAD pickbox. The pickbox is the object selection 
tool that appears in editing commands. 
Selection Modes Controls settings that relate to object selection methods. 
•   Noun/Verb Selection Allows you to select an object before starting a command. The 

command affects the previously selected object or objects. 
•   Use Shift to Add to Selection Adds an object to or removes it from the selection set when 

you press SHIFT and select an object. To clear a selection set quickly, draw a selection 
window in a blank area of the drawing. 

•   Press and Drag Draws a selection window by selecting a point and dragging the pointing 
device to a second point. If this option is cleared, you can draw a selection window by 
selecting two separate points with the pointing device. 

•   Implied Windowing Initiates the drawing of a selection window when you select a point 
outside an object. 

•   Object Grouping Selects all objects in a group when you select one object in that group. 
•   Associative Hatch Determines which objects are selected when you select an associative 

hatch. If this option is selected, boundary objects are also selected when you select an 
associative hatch. 

 
Grip Size Controls the display size of ZwCAD grips. 
 
Grips Controls the settings that relate to grips. Grips are small squares displayed on an object after 
it has been selected. 
•   Grip Color Determines the color of a selected grip. 
•   Enable Grips Displays grips on an object when you select it. You can edit an object with 

grips by selecting a grip and using the shortcut menu.  
•   Enable Grips within Blocks Controls how grips are displayed on a block after you select it. If 

this option is selected, ZwCAD displays all grips for each object in the block. If this option is 
cleared, ZwCAD displays one grip located at the insertion point of the block. 

•   Enable Grip Tips Displays grip specific tips when the cursor hovers over a grip on a custom 
object that supports grip tips. 

•   Object Selection Limit for Display of Grips Suppresses the display of grips when the initial 
selection set includes more than the specified number of objects. The valid range is 1 to 
32,767. The default setting is 100. 

 
To change the options on the Selection tab 
1   Choose Tools > Options. 
 

2   Click the selection tab. 

3   Select the options you want. 
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4   When you have finished, click OK. 
Command line   OPTIONS 
 
 
Changing the options on the User Preference tab 
 
In the Options dialog box, the user prefernce tab controls options that optimize the way you work. 
 
Windows Standard Behavior Controls keystroke and right click behavior. 
•   Shortcut Menus in Drawing Area Displays a shortcut menu in the drawing area when you 

right click the pointing device. If this option is cleared, AutoCAD interprets right click as 
ENTER. 

•   Right Click Customization Displays the Right click Customization dialog box. This dialog 
box provides further definition for the Shortcut Menus in Drawing Area option. 

 
Drag and Drop Scale Controls the default scale for dragging objects into a drawing using 
DesignCenter or I drop. 
•   Source Content Units Sets the units ZwCAD uses for an object being inserted into the 

current drawing when no insert units are specified with the INSUNITS system variables. 
•   Target Drawing Units Sets the units ZwCAD uses in the current drawing when no insert units 

are specified with the INSUNITS system variables 
 
Priority for Coordinate Data Entry Controls how ZwCAD responds to input of coordinate data. 
•   Running Object Snap Specifies that running object snaps override coordinate entry at all 

times. You can also select this option by setting OSNAPCOORD to 0. 
•   Keyboard Entry Specifies that coordinate entry overrides running object snaps at all times. 

You can also select this option by setting OSNAPCOORD to 1. 
•   Keyboard Entry Except Scripts Specifies that coordinate entry overrides running object 

snaps, except in scripts. You can also select this option by setting OSNAPCOORD to 2. 
 

Lineweight Settings Displays the lineweight settings dialog box. Use this dialog box to set 
lineweight options, such as display properties and defaults, and also to set the current lineweight. 

To change the options on the User Preference tab 
1   Choose Tools > Options. 
 

2   Click the user preference tab. 

3   Select the options you want. 

4   When you have finished, click OK. 
Command line   OPTIONS 
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Changing the options on the Profiles tab 
ZwCAD allows you to customize the settings that control your drawing environment, and then 
save and restore those settings in a profile. For example, if you prefer working with custom 
menus and toolbars, you can save these settings as your own profile. 
 

Profiles can be helpful if you have multiple users with different preferences, or if you are a 
single user who works on various projects that require unique settings. You can even export 
your profile and bring it with you when you work on a different computer. 
 
Understanding the settings saved in profiles 
Profiles save many settings that control the drawing environment. Once you start using a pro-
file, it automatically tracks and stores changes that you make to your drawing environment. 
 

Some settings are saved immediately, but some require that you exit ZwCAD and then start 
ZwCAD again. This is because profiles save settings from your computer’s registry and some 
settings are only saved to the registry when you exit ZwCAD. 
Settings saved in profiles 
Setting Location                       When saved 
 
Toolbar setting                 Tools > Customize >Toolbars tab         Exit and restart of ZwCAD 
Menu setting                   Tools > Customize >Menu tab            Immediately 
Keyboard settings             Tools > Customize >Keyboard tab         Immediately 
Alias settings                 Tools > Customize > Alias tab             Immediately 
Window elements on/off           View >Display> Command Bar             Exit and restart of ZwCAD 

status andtherivairous          View > Display> Model and Layout Tabs 

settings                       View > Display> Scroll Bars 

                                View > Display> Status Bar 
Tablet configurations           Settings > Tablet                       Immediately 
User paths                   Tools > Options, Paths/Files tab           Immediately 
System variables              Typed in command bar                  Varies — some saved immediately 

and some upon exit and restart of 

ZwCAD 
 
Creating profiles 
Create profiles if you want to save your custom drawing environment settings. This can be 
helpful if you have two or more drawing environments that you use regularly. 
 
When you create a new profile, the current drawing environment settings are automatically 
saved with the new profile. 



 420 

To create a profile 
1   Choose Tools > Options. 
 

2   Click the Profiles tab. 

3   Click Create. 

4   Enter a name, a description (optional), and then click OK. 

5   In the Options dialog box, click OK. 

6   Make changes to your drawing environment. 
Command line   OPTIONS 

ZwCAD automatically saves the settings to the new profile. 
 
NOTE In some cases, for example, with toolbars, you need to exit and restart Intelli- 
CAD before the settings are saved with the profile. This is because profiles save set- 
tings from your computer’s registry and some settings are only saved to the registry 
when you exit ZwCAD. 
 
 
 
 
 

 
Loading a profile 
While you work in ZwCAD, you can load the custom settings of any profile. The current 
profile when you exit ZwCAD is automatically loaded when you start ZwCAD again. 
 
To load a profile 
1   Choose Tools > Options. 
 

2   Click the Profiles tab. 

3   Select the desired profile. 

4   Click Set Current. 
Command line   OPTIONS 
 
Restoring the default settings 
At any time you can return to the default drawing environment settings that were installed 
with ZwCAD. 
 

If the Default profile is unchanged, simply load it to restore the default settings. If the Default 
profile is deleted or changed, reset an existing profile (one that you no longer need) to replace 
its contents with the default settings. 
 
To restore default settings using an unchanged Default profile 

1   Choose Tools > Options. 
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2   Click the Profiles tab. 

3   Select the Default profile. 

4   Click Set Current. 

Command line   OPTIONS 
 
To restore default settings without using the Default profile 
 
NOTE Resetting a profile erases all of the profile’s custom settings. Do this only if you 
are certain you no longer need the selected profile. 
 

 
1   Choose Tools > Options. 
 

2   Click the Profiles tab. 

3   Select a profile that you no longer need; all of it’s custom settings will be erased. 

If necessary, create or copy a profile to use for restoring the default settings. 

4 Click Reset. 

Command line   OPTIONS 
 
Managing profiles 
Once you start using profiles, you may need to rename, copy, or delete them. Copying a 
profile is a quick way to create a new profile based on an existing profile. 
 
To rename a profile 
1   Choose Tools > Options. 
 

2   Click the Profiles tab. 

3   Select the profile you want to rename. 

4   Click Rename. 

5   Make any necessary changes to the name or description, and then click OK. 

Command line   OPTIONS 
 
To copy a profile 
1   Choose Tools > Options. 
 

2   Click the Profiles tab. 

3   Select the profile you want to copy. 

4   Click Copy. 

5   Enter a new name, a description (optional), and then click OK. 

Command line   OPTIONS 
 
 



To delete a profile 
1   Choose Tools > Options. 
 

2   Click the Profiles tab. 

3   Select the profile you want to delete. 

4   Click Delete. 

Command line   OPTIONS 

 

Working with profiles on multiple computers 
If you use multiple computers and you like to work with our own drawing environment 
settings, save time by bringing your profile with you. 
 

On your computer, export your profile to an .arg file. Bring the file with you to the other 
computer using a disk, E-mail, network, or some other method. When you start working at 
another computer, simply open and load your profile instead of recreating your preferred 
drawing environment. 
 
To export a profile to a file 
1   Choose Tools > Options. 
 

2   Click the Profiles tab. 

3   Select the profile to export. 

4   Click Export. 

5   Specify a location and name for the exported file, and then click Save. 

Command line   OPTIONS 
 
To open a profile from a file 
1   Choose Tools > Options. 
 

2   Click the Profiles tab. 

3   Click Import. 

4   Locate and select the profile (.arg file), and then click Open. 

5   Make any necessary changes to the name or description, and then click OK. 

6   (Optional) To load the imported profile, select it, and then click Set Current. 

Command line   OPTIONS 
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Customizing menus 

 
 
You can customize a current menu and save your changes as an ZwCAD menu file. You can 
also load both existing ZwCAD (*.icm) and AutoCAD (*.mnu, *.mns) menu files. You cus-
tommize menus using the Customize dialog box. 
 
To display the Customize dialog box 

Choose Tools > Customize > Menus. 
 

Command line   menuload 
 

D

A 

B 

C 

E F 

G 

H 

I 

J 

 
A  To make a menu item current, choose it from the list. 
B  Contains the command string assigned to the 
current menu item. 
C  Contains the text displayed in the status bar for the 
current menu item. 
D  Click to import an existing menu file from another 
source. 
E  Click to save the current menu to a different location. 
F  Click to reset the current menu, rejecting any 

changes you have made. 
G  Click to display the Options dialog box for further 
customization options. 
H  Click to add the selected command to the current 
menu item. 
I   Click to rename the current menu item. 
J  Click to insert a Menu Item, a Menu Sub Item, a 

Spacer, or Context Menu Item, or a Context Menu 
Sub Item. 
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Understanding menu compatibility 
MNU files are menu files created by all AutoCAD releases, and MNS files are included in 
AutoCAD Releases 13, 14, and 2000. ZwCAD reads both file formats, even when menu 
macros include AutoLISP code. This feature allows you to continue using your existing 
AutoCAD menus. 
 
ZwCAD support of specific sections in AutoCAD MNU and MNS files 
Menu section                  Definition ZwCAD support  

***POP0                     Cursor menu Supported  
 

***POPn                     Pull down menus Supported 
  

***AUXn                     Auxiliary menus Not supported  
 

***BUTTONn                 Button menus Not supported 
   

***ICON                     Icon menus Not supported 
  

***SCREEN                  Screen menus Not supported 
  

***TABLETn                 Tablet menus Not supported 

  
To see how ZwCAD reads AutoCAD menu source files 
1   Type menu and then press Enter. 

2   Under Files Of Type, select AutoCAD Menu File (mnu). 

3   In the Open Menu dialog box, go to the AutoCAD Support folder and select the 
Acad.mnu file (or Acad.mns for Releases 13, 14, and 2000). 

4   To load the AutoCAD menu file into ZwCAD, click Open. 

The ZwCAD menu bar now looks identical to the AutoCAD menu bar. 

5   To see how it works, choose a few commands from the menu bar, such as File > Open or 
Draw > Line. 

6   To restore ZwCAD to its default menu, choose Tools > Customize, and then click the 
Menus tab and click Reset. 

7   To restore the ZwCAD default toolbars, choose Tools > Customize, and then click the 
Toolbars tab and click Reset. 
 
Creating new menus and commands 
You can create a new menu by inserting a menu item at the top level of the Menu Tree. Then 
you can add commands to the new menu item. You can also add submenus and modify 
existing menu names and commands by adding, deleting, and rearranging them. 

 

 
NOTE A green bullet in front of a menu item or command indicates that the menu item 
or command is available for you to use at the experience level you have set. A red bul- 
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let in front of a menu item or command indicates that the menu item or command is not 
available for you to use at the experience level you have set. To change your experience 
level, choose Tools > Options. 
 
 
To create a new menu 

1   Choose Tools > Customize >Menu. 

2   In the Menu Tree, select the menu name above which you want to add a new menu. 

3   Choose Insert > Menu Item. 

4   Type a name for the new pull down menu, and then press Enter. 

5   Click Close. 

Command line    CUSTOMIZE 
 
To see the new menu, you must perform the following steps for adding a command to the menu. 
 
To add a command to a menu 
1   Choose Tools > Customize >Menu. 

2   In the Menu Tree, select the menu to which you want to add the new command. 

3   Choose Insert > Menu Sub Item. 

4   Type a name for the new command, and then press Enter. 

5   Assign a command string to the command you added by doing one of the following: 

•   In the Available Commands list, choose the command, and then click Add Command. 

•   In the Command box, type the command string, and then click Add Command. 
 

6   In the Help String box, type the text to be displayed in the status bar when the cursor is 
positioned over the new command. 

7   To add another command, repeat steps 3 through 7. 

8   When you have finished, click Close. 

Command line    CUSTOMIZE 
 
 
 
TIP When you type a name for a new command, you can specify an access key by inclu- 
ding an ampersand (&) immediately preceding the letter you want to use as the access 
key. Be sure not to assign the same access key to more than one menu or command 
within a menu. For example, if you add a command named Quick Line to the Insert 
menu, including an ampersand immediately preceding the letter Q causes that letter 
to appear underlined in the menu. You can then select that command by displaying the  
menu and pressing the Q key. 
 
 
To rename a menu item 



 426 

1   Choose Tools > Customize >Menu. 

2   In the Menu Tree, select the menu item you want to rename. 

3   Click Rename. 

4   Type a new name for the menu item by typing over the highlighted name, and then press 
Enter. 

5   Click Close. 

Command line    CUSTOMIZE 
 
To delete a menu item 
1   Choose Tools > Customize >Menu. 

2   In the Menu Tree, select the menu item you want to delete. 

3   Click Delete. 

4   In the Confirmation dialog box, click Yes to delete the menu item. 

5   Click Close. 

Command line    CUSTOMIZE 
 
 
NOTE Deleting a menu item that has sub items below it in the Menu Tree also deletes 
all those sub items. 
 
 
Setting the experience levels for menus 
You can set the experience levels for menu items you create, and you can change the 
experience levels for existing commands. 
 
To set the experience levels for a command 
1   Choose Tools > Customize >Menu. 

2   In the Menu Tree, select the command. 

3   Click Options. 

4   In the Menu Customization Options dialog box, under Experience Level, select the 
experience levels that you want for the command. 

5   Click OK. 

6   Click Close. 

Command line    CUSTOMIZE 
 
 
NOTE Select all the experience levels above the lowest level you want to use. Com- 
mands appear in the menu only at the experience levels you specify. If you select 
Intermediate without also selecting Advanced, the commands will appear only when 
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you set the experience level to Intermediate. 
 
 
Saving menu files 
ZwCAD automatically saves any changes you make to the current menu. You can also create 
and save your custom menus. The program automatically saves all menu files with the *.icm 
file extension. 
 
To save the current menu to a file 
1   Choose Tools > Customize >Menu. 

2   Click Export. 

3   In the Select Menu File dialog box, specify the directory and file name you want to use to 
save the menu file. 

4   Click Save. 

5   Click Close. 

Command line    CUSTOMIZE 
 
 
NOTE Saving a menu does not save any toolbars that you created or modified. 
 
 
 
Loading menu files 
You can replace the current menu file with other custom menus. The program loads both 
AutoCAD (*.mnu, *.mns) and ZwCAD (*.icm) menu files. 
 
To load a menu file 
1   Choose Tools > Customize >Menu. 

2   Click Import. 

3   From the Files Of Type list, choose either *.icm, *.mnu, or *.mns. 

4   Select the menu to load. 

5   Click Open. 

6   Click Close. 

Command line    CUSTOMIZE 
 
 
NOTE Loading a new menu replaces only the menu. It does not replace any custom 
 
toolbars you may have defined. 
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Creating custom shortcut menus 
With ZwCAD, you can create a custom shortcut menu for commands you want to use frequ-
ently. You access the shortcut menu by holding down the Shift key and clicking the right 
mouse button or by clicking the mouse wheel (if you have one). Using any ASCII text editor, 
you construct the menu to conform to the Custom shortcut menu syntax and definitions as 
shown here: 
 
***MENUGROUP=group_name 

***POP0 

**menu_name 

[menu_name] 

ID_item_name [item_string]command 
 
***HELPSTRINGS ID_item_name[help_string] 

 

 
Shortcut menu syntax and explanations 

Item Explanation 
group_name Menu group name.  

menu_name                                           Shortcut menu name. 

item_name                                           Menu item name. 

 

Shortcut menu syntax and explanations 

Item Explanation 
 
item_string Menu item string (typically, the command name). The menu 
                                         item string appears in the shortcut menu. To specify an  
                                          access key for a command, insert an ampersand (&) 
                                 immediately before the letter you want to use as the access 
                                 key. Do not assign the same access key to more than one 
                                          command. 
Command                                  Command string. Begin the command string with "^C^C" 

(e.g., ̂ C^C_LINE) 
help_string                                 Help string. The text in the help string appears in the status 

bar when you place the cursor over the menu item. 
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To create a custom shortcut menu 
The following example describes how to build a custom menu that includes line, hatch, dtext, 
circle, and erase commands. 
 
1   Open any ASCII text editor. 

2   Type the following characters exactly as shown here: 
 
***MENUGROUP=example 

***POP0 

**ZwCAD 

[ZwCAD] 

ID_Line [Line]^C^C_line ID_Hatch [Hatch]^C^C_hatch ID_Dtext [Dtext]^C^C_dtext ID_0 

[Circle Rad]^C^C_circle ID_Erase [erase]^C^C_erase 

***HELPSTRINGS 

ID_LINE [Draws a line] 

ID_HATCH [Fills an enclosed area with a nonassociative hatch pattern] ID_DTEXT 

[Displays text on screen as it is entered] 

ID_CIRCLE [Creates a circle] 

ID_ERASE [Removes objects from a drawing] 
 

 
To use the custom shortcut menu 
1   Open ZwCAD. 
2   Choose Tools > Customize >Menu. 

3   Click Import. 

4   Select the custom shortcut menu file. 

5   Select the Append To Current Menu check box, and then click Open. 

If you don’t select this box, the custom shortcut menu deletes all current menus. 

6   Click Close. 

7   Select an entity in your drawing, and then hold down Shift and click the right mouse 
button. 

8   Click the shortcut command that you want. 

Command line    CUSTOMIZE 

 
To restore the shortcut menu defaults 
1   Choose Tools > Customize >Menu. 
 

2   Click Reset. 

Command line    CUSTOMIZE 
3   Save the file as example.mnu to the ZwCAD 6.1 folder.



Customizing toolbars 

 
 
ZwCAD provides toolbars so that you can access frequently used commands. You can cus-
tommize these toolbars by adding or removing tools or by rearranging the organization of 
tools. You can also create custom toolbars. Toolbars are saved as integral parts of the program. 
Although you cannot export custom toolbars for use by others, you can load toolbars created 
as part of AutoCAD menus. You customize toolbars using the Customize dialog box and 
clicking the Toolbars tab. 
 
To display the Customize dialog box 
1   Choose Tools > Customize > Toolbars. 

2   Customize the toolbars using the procedures that follow the illustration here. 

Command line    CUSTOMIZE 

 
 
 

A 

B 

C 

D 

E 
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A  The Categories list shows available toolbar 

categories. 
B  Contains the string displayed as a ToolTip for the 

current tool. 
C  Contains the text displayed in the status bar for the 

current tool. 
D  Contains the command string assigned to the 
current tool. 
E  Displays the available tools for the selected 
category. 

 
Creating a new toolbar 
You can create a new toolbar by dragging a tool from the Customize dialog box and dropping 
it anywhere except on another toolbar. ZwCAD immediately creates a new toolbar and assigns 
it a default name. Then you can add tools to the new toolbar. You can also add, delete, or mo-
dify tools on any existing toolbar. 
 

When you create a toolbar using tools from the Buttons area of the Customize dialog box, the 
ToolTip, Help String, and Command fields are filled in automatically with default information. 
You can edit this information for each tool. 
 
To create a new toolbar 
1   Choose Tools > Customize > Toolbars. 

2   In the Categories list, choose a category to display its associated tools. 

3   Click and drag a tool outside the Customize dialog box and onto an open area of the 
screen. 

4   Modify the ToolTip, Help String, and Command fields as needed. 
5   Click Close. 
Command line    CUSTOMIZE 
 
To add a tool to a toolbar 
Make sure the toolbar you want to modify is visible. 
1   Choose Tools > Customize > Toolbars. 

2   In the Categories list, choose a category to display its associated tools. 

3   Click and drag a tool onto the toolbar. 

4   Modify the ToolTip, Help String, and Command fields as needed. 

5   To add another tool, repeat steps 4 through 6. 

6   Click Close. 

Command line    CUSTOMIZE 
 
To delete a tool from a toolbar 
Make sure the toolbar you want to modify is visible. 
1   Choose Tools > Customize > Toolbars. 
 



2   Click the Toolbars tab. 

3   Drag the tool you want to delete off of the toolbar. 

4   Click Close. 

Command line    CUSTOMIZE 
 
To add space between tools on a toolbar 
Make sure the toolbar you want to modify is visible. 
1   Choose Tools > Customize > Toolbars. 

2   On the toolbar, drag the tool away from the tool beside it. 

To avoid accidentally deleting a tool, do not drag a tool more than halfway past the edge of 
the toolbar. 

3   Click Close. 
Command line    CUSTOMIZE 
 

Naming toolbars 
When you create a toolbar, the program assigns it an arbitrary name, such as ToolBar1, 
ToolBar2, and so on. The toolbar name is displayed on the title bar when the toolbar is 
floating. You can rename a toolbar at any time. 
 

In the Select Toolbars dialog box, you can rename toolbars, turn the display of toolbars on and 
off, choose to display large or small tools, choose to display toolbar tools in color or black and 
white, and control the display of ToolTips. 
 
To rename a toolbar 
1   Choose View > Toolbars. 
 

2   From the Toolbars list, choose the toolbar that you want to rename. 

3   In the Toolbar Name field, replace the current name with the new toolbar name. 

4   Click OK. 

Command line    TBCONFIG 
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E 

F 

A 

B 

C 

D 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
A  Select to display a toolbar. 
B  Choose the toolbar that you want to rename. 
C  Type a new name. 
D  Select to display large tools; clear to display small tools. 
E  Select to display ToolTips; clear to not display 
ToolTips. 
F  Click to  
customize the toolbars.  
 
 
 
Setting the experience levels for tools 
You can set the experience levels for toolbar tools you create, and you can change the experi-
ence levels for existing tools. 
 
To set the experience levels for a tool 
1   Choose Tools > Customize > Toolbars. 

2   Go outside the Customize dialog box to a toolbar, and click a tool to select it. 

3   Go back to the Customize dialog box, and click Options. 

4   Under User Level, select the experience levels you want for that tool. 

5   Click OK. 

6   Click Close. 

Command line    CUSTOMIZE 
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NOTE Select all the experience levels above the lowest level you want to use. Tools 
appear in toolbars only at the experience levels you specify. If you select Intermediate  
without also selecting Advanced, the tool will appear only when you set the experience  
level to Intermediate. 
 
Creating custom toolbar tools 
ZwCAD provides tools for most of the available ZwCAD commands. These tools appear on 
the Toolbars tab of the Customize dialog box. You can also create your own custom tools and 
incorporate them into your custom toolbars. To add a custom tool to a toolbar, you must first 
add one of the program’s standard tools and then replace it on the toolbar with your custom 
tool. 
 

You create custom tools as bitmap (*.bmp) files using any paint or illustration program cap-
able of saving to a bitmap. Because you can configure toolbars to display either large or small 
tools and to display tools either in color or monochrome, create four different versions of each 
custom tool. Create custom tools using the following dimensions: 

•   Small tools: 16 x 15 pixels. 

•   Large tools: 24 x 22 pixels. 
 
 
NOTE If you attempt to use bitmaps that do not match these dimensions, the program 
will stretch or shrink (rather than crop) the bitmaps to fit the specified size. The 
resulting tools may not appear as originally intended. 
 
 
To add a custom tool to a toolbar 
Make sure the toolbar you want to modify is visible. 
1   Choose Tools > Customize > Toolbars. 

3   Go outside the Customize dialog box to a toolbar, and click a tool in the toolbar to select 
it. 

4   Go back to the Customize dialog box, and click Options. 

5   In the Toolbar Customization Options dialog box, under Button Bitmaps, click the browse 
tool (indicated by an ellipsis) adjacent to the Small, Color Button list to display the 
Select Bitmap dialog box. 

6   Select the bitmap you want to use for the small color tool. 

7   Click Open. 

8   Repeat steps 5 through 7 for the Large Color Button, Small Black and White Button, and 
Large Black and White Button versions of your custom tool. 

9   When you have finished, click OK. 
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10   Click Close. 

Command line    CUSTOMIZE 

 
The Toolbar Customization Options dialog box.  
 
 
Importing toolbars 
Toolbars are saved as integral parts of ZwCAD. In ZwCAD, you can load toolbars created as 
part of AutoCAD (*.mnu, *.mns) menus. Importing an AutoCAD menu file from the Toolbars 
tab of the Customize dialog box loads only the toolbar section of the menu file. 
To import a menu file 
1   Choose Tools > Customize > Toolbars. 

2   Click Import.  

3   Select the menu you want to load. 

4   Click Open. 

5   Click Close. 

Command line    CUSTOMIZE 

 
NOTE Importing an AutoCAD menu file from the Toolbars tab of the Customize dia- 
log box replaces any custom toolbars you may have defined. Importing the menu file 
in this way, however, does not affect the current menu.



 
Creating toolbars that you can share as files 
With ZwCAD, you can manually create toolbars that you can share as files with other Zw 
CAD users. You create the toolbar files using any ASCII text editor and the toolbar syntax and 
definitions shown here: 
 
***MENUGROUP=group_name 

 
***TOOLBARS 

**toolbar_name 

ID_toolbar_name [_Toolbar ("toolbar_name", orient, visible, xval, yval, 

rows)] 

ID_button_name [_Button ("button_name", id_small, id_large)]command 

 
***HELPSTRINGS 

ID_button_name [help_string] 

 
Toolbar syntax and explanations 

Item Explanation 

group_name                                   Menu group name 

toolbar_name                                Toolbar name. 

orient                                       Orientation. Select Floating, Top, Bottom, Left, and Right 

(not case sensitive). 

visible                                      Visibility. Select Show or Hide (not case sensitive). 

xval                                        x coordinate, designated in pixels from left edge of screen. 

Suggested value: 200. 

yval                                        y coordinate, designated in pixels from top edge of screen. 

Suggested value: 200. 

rows                                        Number of rows. 

button_name                                 Tool name. Appears as a ToolTip when user places 

cursor over button 

id_small                                     Name of small (16 x 15 pixels) icon bitmap (BMP) file. 

This file must be located in the ZwCAD 6.1 folder. 

id_large                                     Name of large (24 x 22 pixels) icon bitmap (BMP) file. 

This file must be located in the ZwCAD 6.1 folder. 

command                                   Command string (Example: ^C^C_LINE). 

help_string                                   Help string. Appears in the status bar when cursor passes 

over the button 
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To create a toolbar that you can share 
1   Open any ASCII text editor. 

2   Type the following characters exactly as shown here: 
 
***MENUGROUP=example 

 
***TOOLBARS 

**NewDraw 

ID_ NewDraw [_Toolbar("NewDraw ", _Bottom, _Show, 200, 200, 1)] ID_Line_0 

[_Button("Line", Iline.bmp, IL_line.bmp)]^C^C_line ID_Hatch [_Button("Hatch", 

Ihatch.bmp, IL_hatch.bmp)]^C^C_hatch ID_Dtext [_Button("Dtext", Idtext.bmp, 

IL_dtext.bmp)]^C^C_dtext ID__0 [_Button("Circle Rad", Icirad.bmp, 

IL_cirad.bmp)]^C^Ccircle; ID_Erase [_Button("Erase", Ierase.bmp, 

IL_erase.bmp)]^C^Cerase; 

 
***HELPSTRINGS 

ID_Line_0 [Creates straight line segments] 

ID_Hatch [Fills an enclosed area with a nonassociative hatch pattern] ID_Dtext 

[Displays text on screen as it is entered] 

ID__0 [Allows user to draw a circle with a radius value] ID_Erase [Removes objects 

from a drawing] 

3   Save the file to the ZwCAD folder with a *.mnu extension. 
 
 
To copy an existing toolbar 
Make sure the toolbar you want to copy is visible. 
1   Choose Tools > Customize > Toolbars. 

2   Go outside the Customize dialog box and select a tool on the existing toolbar that you 
want to copy. 

3   Copy the information from the ToolTip, Help String, and Command boxes and paste it 
into the corresponding lines in the text file. 

4   Save the file to the ZwCAD folder with a *.mnu extension. 

Command line    CUSTOMIZE 

 
To open the toolbar file on another computer 
1   Copy the toolbar (MNU) file and all related custom bitmap (*.bmp) files to the 
ZwCAD folder on the other computer. 

2   Open ZwCAD. 

3   Do one of the following: 
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•   Choose Tools > Customize. 

•   Type customize and press Enter. 
 

4   Click the Toolbars tab. 

5   Click Import. 

6   Select the new toolbar file. 

7   Select the Append To Current Menu check box, and then click Open. 

If you don’t select this box, the custom shortcut menu deletes all current menus. 

8   Click Close. 
 
To restore the toolbar defaults 
1   Choose Tools > Customize > Toolbars. 
 

2   Click Reset. 

Command line    CUSTOMIZE 

 

 

Customizing the keyboard 

 
 
ZwCAD provides keyboard shortcuts so you can access frequently used commands. You can 
customize these shortcuts and add new shortcuts using the Customize dialog box. 
 
To customize the keyboard 
1    Choose Tools > Customize > Keyboard. 

3   To define a new shortcut key, enter the shortcut in the Press New Shortcut Key box. 

4   To define a new command string, enter the command string in the Command box. 

5   To import an existing keyboard shortcut file, click Import. 

6   To save a keyboard shortcut to a file, click Export. 

7   To add a command selected in the Available Commands pane to the shortcuts, click Add 
Command. 

8   To insert a new keyboard shortcut, click New. 

Command line    CUSTOMIZE 

 
 



 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Creating a keyboard shortcut 
You can assign macros to special keys and certain combinations of keys to create a keyboard 
shortcut. A macro consists of one or more commands that are displayed on the status bar as 
follows: 

•   A single command, such as QSAVE. 

•   A command with options, such as ARC;\A;\\. 

•   More than one command, such as ^C^C^CZOOM;E;QSAVE;QPRINT. 
 

Keyboard shortcuts are more powerful than aliases. An alias lets you abbreviate a single com-
mand name; a keyboard shortcut contains one or more macros. To activate a macro, you press 
the shortcut key; you do not need to press Enter as you do with an alias. A shortcut consists of 
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the following keys: 

•   The function and the cursor control keys, as well as alphanumeric keys pressed in combi-
nation with the Ctrl, Alt, and Shift keys. The Shift key must be used in conjunction with the 
Ctrl, Alt, and/or function keys. 

•   Alphanumeric keys are those labeled A through Z and 1 though 0. 

•   The cursor keys are the up, down, left, and right arrows and the Page Up, Page Down, 
Home, End, Insert, and Delete keys. 

•   The function keys are those labeled F1 through F12. 
 
To create a keyboard shortcut 
1   Choose Tools > Customize > Keyboard. 

2   Click New. 

3   In the Press New Shortcut Key field, press Alt+A. The program adds Alt+A to its list of 

Defined Keys. 

4   In the Available Commands list, select Arc Center Start Angle. 

5   Click Add Command. 

The program adds the command to the Command field and enters the complete syntax for you: 

^C^C^_CARC;C;\ \A; 

6   To save your changes and close the dialog box, click Close. 

7   To activate the Arc command with the center, start, and angle options, press Alt+A. 

Command line    CUSTOMIZE 

 
To redefine an existing keyboard shortcut 
1   Choose Tools > Customize > Keyboard. 

2   In the Defined Keys list, select the shortcut you want to change. 

3   In the Command field, change the command string assigned to the keyboard shortcut by 
doing one of the following: 

•   Use the text cursor to delete the current command string, choose a new command in the 
Available Commands list, and then click Add Command. 

•   Edit the command string in the Command field. 
 

4 Click Close. 

Command line    CUSTOMIZE 

 
To delete an existing keyboard shortcut 
1   Choose Tools > Customize > Keyboard. 



2   In the Defined Keys list, select the shortcut you want to delete. 

3   Click Delete. 

4   Click Close. 

Command line    CUSTOMIZE 

 

Saving keyboard shortcut files 
ZwCAD automatically saves any changes you make to the current keyboard shortcuts. You 
can also create and save your own keyboard shortcut files. The program saves keyboard 
shortcut files with the *.ick file extension. 
 
To save the current keyboard shortcuts to a file 
1   Choose Tools > Customize > Keyboard. 

2   Click Export. 

3   Specify the directory and file name you want to use to save the keyboard shortcut file. 

4   Click Save. 

5   Click Close. 

Command line    CUSTOMIZE 

 
Loading keyboard shortcut files 
You can replace the current keyboard shortcut file with other custom keyboard shortcut files. 
 
To load a keyboard shortcut file 
1   Choose Tools > Customize > Keyboard. 

2   Click Import. 

3   Select the file to load. 

4   Click Open. 

5   Click Close. 
 

Command line    CUSTOMIZE 
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Creating aliases 

 
ZwCAD provides aliases for many commands. You can use aliases to issue frequently used 
commands by entering one or two letters rather than the entire command name. 
 

The program also uses aliases to maintain command name compatibility with AutoCAD. You 
can use the same aliases and keyboard shortcuts used by AutoCAD. In addition, ZwCAD has 
enhanced several AutoCAD commands. For example, ZwCAD added two useful options to 
the rectangle command: you can draw a rectangle as a square, and you can rotate a rectangle 
at an angle. 
 

You can customize aliases, and you can add new aliases. You customize aliases using the 
Customize dialog box. 
 
 
 
To display the Customize dialog box 
Choose Tools > Customize > Aliases. 

Command line    CUSTOMIZE 

 

A 

B C 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
A  Shows aliases already defined. 
B  Contains the current alias. 
C  Displays the command assigned to the current 
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Creating, redefining, and deleting aliases 
To create a new command alias, you first define the alias and then assign it one of the available 
ZwCAD commands. 
 
To create a new alias 
1   Choose Tools > Customize > Aliases. 

2   Click New. 

3   In the Alias field, type the new alias. 

4   In the Available Commands list, select the command you want to assign to the alias. 

5   Click Assign. 

6   Click Close. 

Command line    CUSTOMIZE 

 
To redefine an existing alias 
1   Choose Tools > Customize > Aliases. 

2   In the Aliases list, select the alias you want to change. 

3   In the Available Commands list, select the command you want to assign to the alias. 

4   Click Assign. 

5   Click Close. 

Command line    CUSTOMIZE 

 
 
To delete an existing alias 
1   Choose Tools > Customize > Aliases. 
 

2   Click the Aliases tab. 

3   In the Aliases list, select the alias you want to delete. 

4   Click Delete. 

5   Click Close. 

Command line    CUSTOMIZE 

 
 
Saving alias files 
ZwCAD automatically saves any changes you make to the current aliases. You can also create 
and save your own alias files. The program saves alias files with the *.ica file extension. You 
can also save alias files for use with AutoCAD by saving the files with the *.pgp file extension. 
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To save the current aliases to a file 
1   Choose Tools > Customize > Aliases. 

2   Click Export. 

3   From the Save As Type list, choose either *.ica or *.pgp. 

4   Specify the directory and file name you want to use to save the alias file. 

5   Click Save. 

6   Click Close. 

Command line    CUSTOMIZE 

 
Loading alias files 
You can replace the current alias file with other custom alias files. The program loads both 
AutoCAD (*.pgp) and ZwCAD (*.ica) alias files. 
 
To load an alias file 
1   Choose Tools > Customize > Aliases. 

2   Click Import. 

3   From the Files Of Type list, choose either *.ica or *.pgp. 

4   Select the alias file to load. 

5   Click Open. 

6   Click Close. 

Command line    CUSTOMIZE 

 
 
 

Creating and replaying scripts 

 
 
ZwCAD can record anything you type on the keyboard and any points you select in a drawing. 
You can save all of these actions to a script file (with the *.scr extension) and then repeat them 
by replaying the script. You can use scripts for successively repeating commands, showing 
snapshots in a slide show, or batch printing. You can also load and run script files created for 
use with AutoCAD. 
 

ZwCAD supports most AutoCAD customization files, including menus, script files, and LISP 



routines. ZwCAD uses compatible linetypes, hatch patterns, units translation, and command 
aliases, but you can also substitute your own files for these. This feature allows you to continue 
to work with your favorite customized drafting environment. 
 

A script is a form of text file. A script file contains one line of text or other data for each act-
ion. For example, when you type a command and press Enter, it is recorded on a line in the 
script file. When you select a point in a drawing, the coordinate of that point is recorded on a 
line in the script file. You can also create script files outside ZwCAD using a text editor (such 
as Microsoft® Notepad or Microsoft® WordPad) or a word processing program (such as Micro-
soft® Word) that saves the file in ASCII format. The file type and extension must be .scr. 
 
Script files can contain comments. Any line that begins with a semicolon is considered a com-
ment. The program ignores these lines when replaying the script. The Undo feature reverses 
the last command performed by the script. 
 
ZwCAD improves on scripts, AutoLISP, and ADS by providing additional functions. For 
scripts, ZwCAD includes a Script Recorder that records both command line entries and screen 
picks you make with your mouse. 
 
After you activate the Script Recorder, every keyboard entry you make and any points you 
select in a drawing are recorded until you stop the Script Recorder. You can play back your 
script at any time. 
 

 
CAUTION The Script Recorder does not record your use of toolbars, menus, or dialog 
boxes. Using these elements while recording a script causes unpredictable results. 
 
 
To record a script 
1   Choose Tools > Record Script. 
 

2   Specify the name of the script file you want to create. 

3   Click Save. 

4   Type commands on the keyboard. 

The Script Recorder records all keyboard entries and all points you select in the drawing, 

saving everything to the script file. 

Command line    RECSCRIPT 
 
To stop recording 
Choose Tools > Stop Script. 

Command line   STOPSCRIPT 

 
To replay a script 
1   Choose Tools > Run Script. 

2   In the Run Script dialog box, specify the name of the script file you want to run. 
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3   Click Open. 

The program immediately runs the script, performing all the actions originally recorded. 

Command line   SCRIPT 

 
To append to a script 
1   Choose Tools > Record Script. 
 

2   In the Record Script dialog box, select the Append To Script check box. 

3   Select the existing script file to append. 

4   Click Save. 

5   Click Yes to the prompt asking whether you want to replace the existing script. 

6   Repeat the procedure to enter additional commands and steps. 

Command line    RECSCRIPT 
 
 
TIP To invoke a script automatically when you load ZwCAD, in Windows Explorer, 
double click a script file. 
 
 
 

Programming ZwCAD 

 
 
Another way you can customize ZwCAD is to add custom programs written in any of several 
programming languages that run within ZwCAD, including the following: 

•   LISP 

•   Visual Basic for Applications (VBA) 

•   ADS 
 
In ZwCAD, you can run many programs originally created for use with AutoCAD. Specifically, 
you can use programs written entirely in AutoLISP with no modification. In addition, you can 
run many ADS programs originally written for use with AutoCAD after first recompiling them 
using the ZwCAD run time libraries. Many AutoCAD third party programs are compatible 
with ZwCAD. 
 

 
NOTE For information about programming for ZwCAD, see the online Help for the 
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ZwCAD Developer’s Reference. 
 
 
Using LISP routines 
ZwCAD supports the LISP programming language and is compatible with AutoLISP, the 
implementation of the LISP language in AutoCAD. This means that you can load and run any 
AutoLISP program written for use with AutoCAD. 
 
To load a LISP routine 
Advanced experience level 
 

1   Choose Tools > Load Application. 
 

2   In the Load Application Files dialog box, click Add File. 

3   Select the LISP file that you want to load, and then click Open. 

4   Click OK. 

Command line    APPLOAD 

E 

G 

H 

A B 

C 

D 

F 

 
A  Lists the names of LISP and SDS files already. F   Click to add a file to startup suite. 

B  Click to add a LISP or SDS file name to the list. G   Click to startup suite. 

C  Click to remove the highlighted file name from the 
list. 

H  Select to save the current list to the icadload.dfs file 
when you click Load, Unload, or OK.

D  Click to load the highlighted file. 
E  Click to unload the highlighted file. 
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TIP You can also load a LISP routine by typing (load “d:/path/routine.lsp”) in the 
command bar (you must include the parentheses and the quotation marks), where d:/ 
path is the drive and path where the LISP routine is located on your computer, and 
routine.lsp is the LISP routine file name. 
  
 
To run a LISP routine 
Advanced experience level 
 

1   Choose Tools > Load Application. 
 

2 In the Load Application Files dialog box, choose the routine you want to run (make sure 

that it is the only one selected), and then click Load. 

Command line    APPLOAD 

 
Some LISP routines are created in such a way that you can run them by simply typing the name 
of the routine, or by typing a keyword, directly in the command bar. If nothing happens when 
you attempt to run the LISP routine from within the Load Application Files dialog box, turn 
on the display of the command bar or Prompt History window by choosing View > Command 
Bar or View > Prompt History Window, and look for an entry that is similar to the following: 
 
Loading D:\path\routine.lsp 
 
C:KEYWORD 
 
where D:\path\routine.lsp is the complete drive, path, and file name of the LISP routine. You 
may need to scroll back several lines in the command bar or Prompt History window to find the 
lines indicating where the LISP routine was loaded. You can run the LISP routine by typing 
the name of the routine or keyword appearing after the C drive designation. 
 
For example, if you loaded a LISP routine named drawbox.lsp and see the designation C: 
DRAWBOX in the command bar or Prompt History window, you can run the LISP routine by 
typing drawbox in the command bar. 
 
Using ADS applications 
To write AutoCAD applications in C or C++, Autodesk®  uses the ADS (AutoCAD Develop-
ment System). This is an API (applications programming interface) that provides a library to 
access AutoCAD-specific functions and drawing data. 
 
The equivalent in ZwCAD is called SDS™, the Solutions Development System™. SDS is a 
C/C++ language interface compatible with the ADS interface in AutoCAD. Like scripts and 
AutoLISP, you can run your existing ADS applications in ZwCAD. Simply recompile the 
source code using the SDS libraries provided on the ZwCAD CD ROM, or, if you use an 



AutoCAD program written by a third- party vendor, contact that vendor for the ZwCAD ver-
sion. 
 

ZwCAD provides the Sds.H file, which redefines ADS function names to their SDS equivalents. 
SDS supports the AutoCAD dialog control language (DCL), which is used by ADS to define 
the look of a dialog box. You can use all DCL files unmodified within SDS. 
 
 
Understanding ADS compatibility 
The primary difference between ADS and SDS is that all SDS functions have an sds_ prefix, 
and ADS functions have a variety of prefixes, such as ads_, acad_, and acrx_. The exception is 
dialog related SDS functions, which have a dlg_ prefix. ZwCAD accepts either prefix. Other 
differences include the additional SDS functions listed in the following table. 
 
SDS functions with no ADS equivalent 

 
Some ADS functions are not supported in SDS, including: ads__msize, ads_ssgetx, 
ads_ssnamex, ads_tablet, ads_ssGetKwordCallbackPtr, ads_ssGetOtherCallbackPtr, and 
adsw_acadDocWnd. 
 
For more information 

•   Read the online documentation for SDS functions. 
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•   See the \ZwCAD 6.1\Api\Sds folder, which contains the SDS include, header, and library 
files. 
•   See the \ZwCAD 6.1\Api\Dcl folder, which contains the core DCL files. 
 
 
 
 
Using DCL with ZwCAD 
ZwCAD completely supports the AutoCAD DCL (dialog control language). DCL is used by 
AutoLISP functions to define the look of dialog boxes. You can use all DCL files unmodified 
within ZwCAD. 
 
Using VBA 
ZwCAD can be customized using Visual Basic for Applications (VBA) through an integrated 
interface, available from the ZwCAD menu. ZwCAD features a broad range of objects, giving 
you the power to write your own custom applications that can run within ZwCAD. 
 
To run a VBA macro 
Advanced experience level 
 

1   Choose Tools > Macros > Macros. 
 

2   In the Run ZwCAD VBA Macro dialog box, enter the name of an existing VBA macro, 
and then click Run. 

You can also create, delete, and edit VBA macros from this dialog box. 

Command line    VBARUN 

 
To edit a VBA macro 
Advanced experience level 
 

1   Choose Tools > Macros > Visual Basic Editor. 
 

2 Use the Visual Basic Editor to write or debug VBA macros. 

Command line    VBA 

 
For more information 

•   Read the online documentation for VBA, available both from the VBA Editor Help and 
from the ZwCAD Help. 

•   Many publications are available that explain how to program in Visual Basic and how to 
use VBA. 
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Using a digitizer tablet 

 
ZwCAD supports tablets compatible with the TabletWorks driver and has its own tablet over-
lay. For instructions on installing the tablet driver and using the buttons on your pointing de-
vice, refer to your hardware documentation. 
 

Three options are available with the Tablet command: 
 

•   Configure Maps the tablet overlay to the tablet itself. Configure the tablet if you plan to 
select ZwCAD tools from the tablet overlay. 

•   Calibrate Maps points on the tablet, in absolute coordinates, to points on a drawing. 
Calibrate the tablet if you intend to digitize points. This process is convenient for tracing 
paper drawings. 

•   Tablet ON/OFF Turns tablet calibration (digitizer mode) on and off. Use this to switch 
between tool selection and digitizer input. To use the tablet for tool selection, tablet 
mode must be turned off. 

 
Configuring the tablet 
Before you begin to configure the tablet, slip the tablet overlay underneath the tablet’s plastic 
cover, and align it in accordance with the directions for your tablet. If your tablet does not 
have a plastic cover, align the overlay holes with the pegs on your tablet. 
 
ZwCAD provides a default configuration for tablets measuring 12" by 12". If you choose to 
accept the default, be sure to verify that the commands in the grid are activated correctly. If 
the default alignment does not work for your tablet, you’ll need to begin the configuration 
process again and align the tablet yourself. 
 
To configure the tablet for menu input 
1   Choose Tools > Tablet > Configure. 
 

2   In response to the prompt to align the tablet, do one of the following: 

•   If your tablet is 12" by 12", type No to accept the default alignment and conclude the 
configuration process. 

•   To align the tablet yourself, type Yes, and then continue with step 3. 
3   Click the tablet pointer on the upper left alignment point of the overlay (). 
4   Click the tablet pointer on the lower left alignment point of the overlay (). 
5   Click the tablet pointer on the lower right alignment point of the overlay (). 

6   Click the tablet pointer on the lower left alignment point of the Workspace area of the 
overlay (). 



7   Click the tablet pointer on the upper right alignment of the Workspace area of the overlay 
(). 
Command line    TABLET 

 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
  
Click points in the order shown to configure your tablet for menu input. 
 
To turn tablet mode on or off 
Do one of the following: 

•   Choose Tools > Tablet > On (or Off). 

•   Type tablet, choose On or Off, and then press Enter. 

•   Press the F4 key to toggle tablet mode on or off. 

•   On the status bar, double click TABLET to turn tablet mode on or off. 
 
Calibrating the tablet 
You must specify at least two points for tablet calibration. However, the more points you 
specify, the more accurate the transformation between the tablet and the screen points. Speci-
fying additional points is particularly useful if you plan to trace a paper drawing that is not 
orthogonal, such as an aerial photograph. 
 
Understanding transformation types 
Depending on the number of points specified, you have a choice of transformation types to 
use, along with the type recommended for ZwCAD. 
 

Transformation refers to the calculation of the points on the screen that correspond to points 
you digitize on the tablet. 

•   Orthogonal Preserves all angles between lines, preserves all relative distances, and, in 
general, preserves shapes. If you specify only two points, an orthogonal transformation 
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is automatically generated. The orthogonal transformation type yields the most precise 
mapping between the digitized points on the tablet and the corresponding points on the 
screen. 

•   Affine Preserves parallel lines, but not necessarily the angles between intersecting lines. 
If you specified three points, ZwCAD can no longer represent this mapping as an exact 
ortho gonal transformation. Therefore, you have a choice of an exact affine 
transformation or a “best fit” orthogonal transformation. 

•   Projective Does not preserve parallel lines or angles. If you specify exactly four points, 
you have a choice of an exact projective transformation or a “best fit” orthogonal or 
affine transformation. 

 
Recommended and “best fit” transformation types 

  
 
Choose the recommended type unless you know it will not be appropriate for what you are 
digitizing. The most appropriate type is not always the one with the least error; for example, 
you might digitize three points and select the orthogonal transformation, even though the 
affine transformation would yield a closer representation of your calibration entries. 
 

 
Digitizing by selecting points (1, 2, 3, and 4) on the tablet.   Corresponding screen coordinates:  
                                             1  Coordinate specification X0, Y0, Z0 
                                             2  Coordinate specification X0, Y5, Z0 

3  Coordinate specification X5, Y5, Z 0 
                                             4  Coordinate specification X5, Y0, Z0 
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To calibrate your tablet for digitizing points 
1   Choose Tools > Tablet > Calibrate. 
 

2   Click a point on the tablet to define as the first calibration point. 

3   Specify a point within the ZwCAD drawing window to correspond to the point you 
digitized on the tablet, or enter coordinate values in the command bar. 

4   Click a point on the tablet to define as the second calibration point. 

Specify a point within the ZwCAD drawing window to correspond to the point you digitized 
on the tablet, or enter coordinate values in the command bar. To specify more than the two 
points required, click a point on the tablet to define as the third calibration point. You can 
enter up to 10 points. 

5 Choose the transformation type, and then press Enter. 

Command line    TABLET 

 
 
Customizing the tablet interface 
You can customize the digitizer tablet interface by using the LISP commands integrated with 
ZwCAD, even if you are not familiar with LISP. For instructions, see “Customizing the Tablet 
Interface” in the ZwCAD online Help. 



 
 

Glossary 
 
 
 
 
 
 
 
2D  Two dimensional locations defined by x and y coordinates. 
 
3D  Three dimensional locations defined by x, y, and z coordinates. 
 
3D DWF  Acronym for Three Dimensional Design Web Format, which is a type of file that 
can be viewed in three dimensions using a Web browser, if Autodesk® DWF Viewer is also 
installed on the computer. 
 
3D solids  Three dimensional ACIS entity. 

 
absolute coordinates  Coordinates defined in relation to the origin point of the current 
user coordinate system. See also coordinate system, coordinates, origin, relative 
coordinates, user coordinate system, and World Coordinate System. 
 

ActiveX  A mechanism for exchanging information between different programs where by a 
copy of a source document is embedded or a pointer to a source document is linked to a target 
document. See also embed and link. 
 
acute angles  Angles of fewer than 90 degrees. 
 
alias  An abbreviation or alternative word for an ZwCAD command. 
 
aligned dimension  A dimension aligned parallel to an entity or measuring the distance 
between two points at any angle. 
 

angle  The difference in direction between two nonparallel linear entities, measured in 
degrees or radians. 
 

angular dimension  A dimension measuring the angle between two lines or sub- tended 
by an arc. 
 

angular unit  The unit of measurement for angles. Angular units can be measured in decimal 
degrees, degrees/minutes/seconds, grads, and radians. 
 
annotation  Any text, dimensions, tolerances, or notes added to a drawing. 
 
ANSI  Acronym for American National Standards Institute. In the context of text, a standard 
character set defined by ANSI used in computer aided drafting. 
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arc  A segment of a circle or ellipse. 
 
area  Measurement of a planar region or the calculated space within an entity. 
 
array  Multiple copies of selected entities in a circular or rectangular pattern. 
 
ASCII  Acronym for American Standard Code for Information Interchange, a commonly used 
system for assigning numbers to printable alphanumeric characters, punctuation, and symbols. 
 

attribute  A component of a block containing specific text or numeric information. You can 
copy the information contained in an attribute from the drawing to an external database. 
 

attribute definition  An entity composed of a name, prompt for information, display 
characteristics, and default text that, when incorporated into a block, creates an attribute when 
the block is inserted into a drawing. 
 

attribute name  Text that identifies an attribute within a block. 
 
attribute text  The text containing an attribute’s information within a block. 
 
B spline curve  See spline. 
 
base point  A point on an entity that serves as its reference or insertion point. A point of 
reference when specifying relative distances. 
 
baseline  The line on which text characters appear to sit. The descenders of individual 
characters drop below the baseline. 
 
baseline dimension  Multiple parallel dimensions measured from the same baseline origin. 
 

bind  To convert an externally referenced drawing into a standard block definition. 
 
blips  Temporary screen markers displayed in a drawing when you select a point. Also 
called marker blips. 
 

block  One or more entities grouped together to create a single entity. See also nested block. 
 
block definition  The name, base point, and entities grouped together when creating a block. 
 
boundary polyline  A selected area bounded by a single closed entity or by multiple entities 
that intersect. 
 

BYBLOCK  A property whereby an entity inherits the color, linetype, lineweight, or print 
style of any block that contains it. 
 

BYLAYER  A property whereby an entity inherits the color, linetype, lineweight, or print 
style of its associated layer. 
 
CAD  Acronym for computer aided design. 
 
Cartesian coordinates  Coordinates defined using three perpendicular axes (x, y, and z) 
to define locations in three dimensional space. See also cylindrical coordinates, polar 
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coordinates, and spherical coordinates. 
 

center line  A line used to indicate the center of a circle or an arc, usually consisting of a 
center mark and lines extending slightly beyond the diameter of the circle or the arc. 
 

center mark  A cross marking the center of a circle or an arc. 
chamfer  A beveled edge between two lines. 
 
chord  A line connecting two points on a circle or an arc. 
 
circumference  The measurement of the distance around a circle. 
 
closed  A condition whereby the start point and endpoint of an entity are the same. 
 
color-dependent print style table  A collection of print styles that determine how entities 
print according to their assigned color. See print style table. 
 

comma-delimited  Data that is separated by a comma to represent the end of a field. 
 
command bar  A dockable window in which you type ZwCAD commands and view 
prompts and other program messages. 
 

cone  A three dimensional entity where a vertex exists above or below the circular shape and 
where a surface has been applied between the vertex and the circular shape. 
 

contiguous  Connected, unbroken, or uninterrupted. Entities that share the same 
endpoint. 

continued dimension  A dimension measured from the previous extension line of an 
existing dimension, resulting in two or more dimensions positioned end to end. 
 

control point  A point used to define a spline. 
 
Coons patch  A surface interpolated among three or four boundary curves. 
 
coordinate filter  A function that extracts individual x, y, and z coordinate values from 
different points to create a new composite point. 
 

coordinate system  A system of points that represents the drawing space in relation to an 
origin (0,0,0) and a set of axes that intersect at the origin. In two dimensions, the x and y axes 
represent horizontal and vertical directions, respectively. In three dimensions, the z axis 
represents locations above and below the two dimensional xy plane. Locations in the drawing 
can be represented using two dimensional and three dimensional rectangular (Cartesian) 
coordinates, two dimensional polar coordinates, three dimensional polar (cylindrical) 
coordinates, and three dimensional spherical coordinates. See also polar coordinates, relative 
coordinates, spherical coordinates, user coordinate system, and World Coordinate 
System. 
 

coordinates  A set of values that determines a location in two dimensional or three 
dimensional space. See also absolute coordinates, Cartesian coordinates, polar coordinates, 
relative coordinates, and spherical coordinates. 
 

coplanar  Lying within the same plane. 
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crosshairs  A cursor that consists of two or three lines that intersect at the cursor location. 
 
crosshatch  To fill an area with a pattern of evenly spaced perpendicular lines. See also 
hatch. 
 

crossing circle  An entity selection method that selects entities contained within or crossing 
the boundary of a circular selection window. 
 

crossing polygon  An entity selection method that selects entities contained within or 
crossing the boundary of a polygon selection window. 
 

crossing window  An entity selection method that selects entities contained within or 
crossing the boundary of a rectangular selection window. 
 

cube  A boxed, three dimensional, geometric shape where length, width, and height are equal. 
 
cursor  The insertion point symbol on the screen. The appearance of the cursor changes 
based on the current task. 
 

curve  A smooth, continuous path made up of linear and arc segments. Curve types include 
arcs, splines, circles, and ellipses. 
 

cylindrical coordinates  Coordinates describing a point in three dimensional space based on 
its distance from the origin, its angle in the xy plane, and its z coordinate value. See also polar 
coordinates and spherical coordinates. 
 
datum line dimensioning  See ordinate dimension. 
 
default  An initial or predefined setting. 
 
detach  To remove an external reference from a drawing. See also external refer- ence. 
 

diameter  The distance across a circle or sphere. 
 
digitizer tablet  A hardware input device that incorporates an electronic pad and a handheld 
pointer similar to a mouse. A digitizer tablet serves two purposes: (1) You can select tools from 
paper representations attached to the pad (called an overlay), providing access to all tools at 
once while freeing your screen space; and (2) you can input digital points into the computer 
that correspond to points on a paper drawing, photograph, or blueprint attached to the pad. 
 
dimension  A measurement, as in height or width. In the context of drafting, a set of lines, 
arrowheads, and text used to indicate a measurement. 
 

dimension style  A named group of dimension variable settings that determines the 
appearance of the dimension. You can save multiple dimension styles for reuse. 
 

dimension text  The measurement value. Dimension text can include prefixes, suf fixes, 
tolerances, and other annotations. 
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dimension text rotation  The angle in degrees between the x axis and the dimension text 
baseline. 
 
dimension tolerance  A value specifying the allowed variation of a dimension (+ or – n). 
 
dish  The lower half of a sphere. See also dome. 
 
displacement point  The point to which a base, or reference, point will be relocated when 
moving or copying entities. 
 

distance  The measure of space between two points. 
 
dock  To position a toolbar or the command bar at the edge of the drawing window, where it 
locks into place. See also float. 
 

dome  The upper half of a sphere. See also dish. 
 
donut  A filled circle or flat ring created as a polyline. 
drawing extents  See extents. 
 
drawing limits  See limits. 
 
drawing unit  The linear measurement system used in a drawing. The user determines what 
a drawing unit represents, such as one inch, one centimeter, one foot, or one meter. 
 

DWF  Acronym for Design Web Format, a file format for viewing drawings in a Web browser 
and distributing for review using free Autodesk®  software and tools. 
 

.dwg  A standard format used by CAD programs to store drawing files. 
 
.dwt  A standard format used by CAD programs to store drawing templates, which are 
drawings that contain predefined settings that you can use when creating a new drawing. 
See also template. 
 

DXF  Acronym for Drawing Exchange Format, a standard ASCII or binary file format for 
importing and exporting files between most CAD programs. 
 
elevation  The z value measured from the xy plane. Positive values are above the xy plane; 
negative values are below the xy plane. 
 

embed  A technique for exchanging information between different programs whereby a 
copy of the source document is stored in the target document. See also ActiveX and link. 
 

EMF  Acronym for Enhanced Metafile, a file format with the type and extension of .emf. It is 
a native internal file format of Windows 98. EMF supports both raster and vector information 
and 24-bit RGB color. Most Windows based programs support this format. 
 
endpoint  The point at which a line or curve ends. 
 
entity  Any single basic item in a drawing. Entities include arcs, attributes, blocks, circles, 
dimensions, ellipses, elliptical arcs, infinite lines, lines, polylines, rays, and text. 
 

entity data  Any of a variety of additional information, such as text, numbers, and 
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distances, that can be attached to drawing entities. 
 

entity snap  A technique for accurately locating and specifying key geometric points on 
entities, such as endpoints and midpoints of lines, and center points and tangents of arcs and 
circles. 
 
entity snap override  To disable or change an entity snap mode for a single input. See also 
entity snap and running entity snap. 
 
Esnap  See entity snap. 
 
explode  The conversion of a complex entity into its basic entities. 
 
extension lines  Lines extending away from an entity being dimensioned so that you can 
place the dimension line away from the entity. Also called projection lines. 
 

extents  The smallest rectangle that can contain all the entities in a drawing. Infinite lines and 
rays do not affect a drawing’s extents. See also limits. 
 

external reference  A drawing that is linked to another drawing. 
 
extrude  The process of converting a two dimensional entity into a three dimen sional 
entity by stretching (extruding) the two dimensional entity along a straight path. Changing 
the thickness of a two dimensional entity effectively extrudes it along its z axis. See also 
tabulated surface. 

 
face  A planar surface defined by three or four points. 
 
fence  An entity-selection method that selects entities crossing a multisegmented line. 
 

fillet  An arc that smoothly connects the end of one line to another. 
 
float  To position a toolbar or the command bar away from the edges of the drawing window 
where it can be moved independently. See also dock. 
 

freeze  To suppress the display of, and ignore the entities on, a specified layer when 
regenerating a drawing, thus accelerating the display of the drawing. See also thaw. 
 
grid  An adjustable, regularly spaced pattern of dots on the screen, used as an aid in drawing 
and aligning entities. The grid is not printed. 
 

grip  A small square displayed at key positions on an entity when the entity is selected 
that can be used to modify the entity by clicking and dragging. 
 
halfwidth  The distance from the center of a wide polyline to its edge. 
 
hatch  To fill a selected area either with lines, crosshatching, or a hatch pattern. See also 
crosshatch. 
 
hatch pattern  A pattern, often representing a material such as steel, wood, or sand, for 
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filling selected areas. 
 

hidden-line removal  A visualization technique in which all lines that are hidden behind 
other entities or surfaces from your viewpoint are clipped or removed, giving the image the 
appearance of a solid entity. 
 

horizontal dimension  A linear dimension measuring a horizontal distance. 

 
infinite line  A line extending infinitely in both directions. 
 
insertion point  The point where you place an entity into a particular space. A reference 
point by which an entity is inserted in a drawing. 
 

intersection  The point where two entities meet or cross. 
 
isometric drawing  A drawing aligned with an isometric plane. 
 
isometric plane  One of three planes representing the left, right, or top sides of an 
implied three dimensional, orthogonal entity. Snap and grid points are aligned with the 
plane to constrain drawings. 
layer  The computer equivalent of overlays used in manual drafting. A tool by which drawing 
components can be organized into related sets, such as plumbing, framing, and electrical 
systems of a house, each being drawn on its own layer. 
 

layout  Similar to a sheet of paper, a representation of how a drawing will look when printed. 
 

layout viewport  A window in a Layout tab (paper space) that displays all or a portion of a 
drawing’s model space entities. See also paper space and model space. 
 

leader  A line leading from a feature of a drawing to an annotation. 
 
limits  The user defined boundary of a drawing, defined by its lower left and upper right 
corner coordinates. See also extents. 
 

limits tolerance  Dimension text in which the measured dimension is replaced by the largest 
and smallest dimensions allowed, with the upper limit displayed above the lower limit. See 
also tolerance and variance tolerance. 
 

linetype  The appearance of a line, defined as a solid (continuous) line or as a pattern of 
dashes, dots, and blank spaces. 
 

lineweight  The width of a line, defined in millimeters or inches. 
 
link  A technique for exchanging information between different programs whereby the 
target document maintains a pointer to the original source document. Any changes to the 
source document are reflected in all target documents containing links to the source. See also 
ActiveX and embed. 
LISP  Acronym for List Processing Language, a computer language invented in the late 
1950s by John McCarthy for use in artificial intelligence. Because it is interpreted rather than 
compiled, and is relatively straightforward, it is a convenient language for users to write 
routines to extend the set of commands and functionality of ZwCAD. 
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lock  Prevents unauthorized access to drawing layers. 

 
M direction  In a polygon mesh, the direction from the first to the second row. See also N 
direction. 
 

macro  In menus and toolbars, several commands grouped together as one. AlsoVisual Basic 
for Applications code. 
 
major axis  The longest distance across an ellipse, from one end to the other. See also 
minor axis. 
 

marker blips  Temporary screen markers displayed in a drawing when you select a point. 
Also called blips. 
 

MDI  Acronym for multiple-document interface. See multiple document interface. 
 
mesh  A set of connected polygon faces approximating a curved surface. 
 
minor axis  The shortest distance across an ellipse, from one side to the other. See also 
major axis. 
 

mirror  To create a reverse image copy of selected entities by reflecting the entities 
symmetrically about a line or plane. 
 

model space  The primary drawing area in which you create entities. See also paper space. 
 

multiple-document interface  The ability to view and work with different drawings 
simultaneously. 
 
N direction  In a polygon mesh, the direction from the first to the second column. See also 
M direction. 
 
named print style table  A collection of print styles that determine how entities print 
according to the print styles you create and assign to entities and layers. See print style 
table. 
 

named view  A saved view that can be recalled at a later time by specifying its name. 
 
nested block  A block contained as part of the definition of another block. See also block. 
 
nonassociative hatch  A hatch that is not associated with or linked to an entity. 

 
oblique  Geometric lines or planes that are not parallel or perpendicular. 
 
offset  See parallel. 
 
OLE  Acronym for Object Linking and Embedding. See ActiveX. 
ordinate dimension  A measurement of the horizontal (x ordinate) or vertical (y ordinate) 
distance from an established reference base point or datum. 
 

origin  The intersection point of the coordinate system axes. In a Cartesian coordinate 
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system, the origin is the point at which the x, y, and z axes intersect (the 0,0,0 coordinate). 
 

orthogonal  Having perpendicular slopes or tangents at the point of intersection. 
 
orthogonal mode (ortho)  A drawing mode in which the entity creation is constrained to 
parallel the horizontal and vertical axes relative to the current snap angle. 
 

orthographic projection  A drafting technique by which a three dimensional item is 
described in two dimensions by showing it from various directions, most commonly front, top, 
and side views. 
 
outside circle  An entity selection method that selects entities falling completely outside 
a circular selection window. 
 

outside polygon  An entity selection method that selects entities falling completely outside 
a polygon selection window. 
 

outside window  An entity selection method that selects entities falling completely outside 
a rectangular selection window. 
 
pan  To shift the displayed view of a drawing without changing the magnification. See also 
zoom. 
 
paper space  A two dimensional work area similar to a sheet of paper, in which you can 
arrange different views of your model as layout viewports. See also model space. 
 

parallel  Two or more coplanar lines that never intersect one another. 
 
parallel dimension  See baseline dimension. 
 
PDF  Acronym for Portable Document Format. PDF files can be viewed using Adobe® 
Acrobat Reader, which is free software that users can download; they can also be viewed, 
reviewed, and edited using Adobe® Acrobat. 
 

perimeter  The distance around the boundary of an entity. 
 
perpendicular  Entities at right angles to one another. 
 
planar  Entities whose extents are situated entirely within a plane. 
 
plane  Two dimensional surface. 
 
plan view  A view of the drawing from above, looking down the z axis perpendicular to the xy 
plane of the current UCS. 
 

point  A location in space specified by its x, y, and z coordinates. A drawing entity consisting 
of a single x,y,z coordinate location and represented by one of several symbols. 
point filter  See coordinate filter. 
 
polar array  Multiple copies of selected entities in a circular pattern. 
 
polar coordinates  Coordinates describing a two dimensional point on a two dimensional 
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plane based on the point’s distance from the origin and its angle in the plane. See also 
Cartesian coordinates, coordinates, cylindrical coordinates, relative coordinates, and 
spherical coordinates. 
 

polygon  A closed single entity with three or more sides. 
 
polyline  A drawing entity composed of one or more connected line or arc segments treated 
as a single entity. 
 

print style  A collection of settings, including color, pen width, linetype, and lineweight, 
that determine how a drawing looks when it is printed. See print style table. 
 

print style table  A collection of print styles that you can assign to the Model tab or to a 
Layout tab. Print style tables change how a drawing looks when you print it without modifying 
the actual entities. See print style. 
 

profile  File that contains your preferred drawing environment settings. 
 
projection lines  See extension lines. 
 
prompt box  A list of options displayed when a command or tool provides several choices. 
 

Prompt History window  A window containing a history of the most recent commands 
and prompts issued since you started the current session of ZwCAD. 
 
quadrant  One fourth of a circle, arc, or ellipse entity. In the context of entity snaps, the 
option that snaps to points on a circle, arc, or ellipse at each quadrant. 

 
radial dimension  A dimension that measures the radius of a circle or arc. 
 
radian  A unit of angular measurement; 360 degrees equals 6.283185 or 2pi radians. 
 
radius  The distance from the center of a circle or sphere to its periphery. 
 
ray  A line that starts at a designated point and runs infinitely. 
 
ray tracing  A visualization technique in which rays from imaginary light sources are traced 
as they refract off the surfaces of a model, determining where shadows fall and how reflections 
on shiny materials such as metal and glass appear. 
 

rectangle  A four sided, closed entity whereby opposite sides are equal in length. 
 
rectangular array  Multiple copies of selected entities in a rectangular pattern consisting of 
a specified number of columns and rows. 
 

redo  To reverse the effect of previous undo commands. See also undo. 
 
redraw  To quickly update or refresh the drawing screen display. See also regenerate. 

 
regenerate  To update or refresh the drawing screen display by recalculating the drawing 
from its database. See also redraw. 
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region  A two dimensional closed, surfaced, planar boundary. 
 
relative coordinates  Coordinates expressed in relation to a previous coordinate. See also 
absolute coordinates. 
 
render  A visualization technique in which all surfaces of a model are shaded as though 
they were illuminated from an imaginary light source located behind you as you face the 
screen. Rendered images are photo realistic, having depth, shadow, reflection, and texture. 
 

revolve  Creating a three dimensional surface entity by rotating a two dimensional profile 
around an axis. 
 

right hand rule  A visual aid for remembering the relative directions of the positive x, y, and 
z axes of a Cartesian coordinate system and the positive rotation direction about an axis. 
 

rotate  To change the orientation of an entity, without modifying it, by repositioning it 
equidistant from, but at a new angle with respect to, a point or axis. 
 
rotation angle  The angle by which an entity is displaced from its original location when 
rotating it about a point or axis. 
 

rubber-band line  A ghosted image line that stretches dynamically on the screen with the 
movement of the cursor. The line extends between a fixed point and the cursor position to 
provide dynamic feedback. 
 

ruled surface  A three dimensional polygon mesh that approximates a smooth surface 
between two entities. 
 

running entity snap  Setting an entity snap so that it continues for subsequent selections. See 
also entity snap and entity snap override. 
 
scale  To resize an entity. To draw according to the proportions of an entity. 
 
script  A set of commands stored in an ASCII script file and replayed in sequence by running 
the script. 
 
SDS  Acronym for Solutions Development System, a C programming interface for 
developing specialized programs to run inside ZwCAD. 
 

segment  Any part of an entity bounded by two points. 
 
selection set  One or more drawing entities selected on which one can operate as a single 
unit. 
 

shade  To fill planar entities with solid colors for easier visualization. 
 
snap angle  The angle around which the snap grid is rotated. 
snap grid  An invisible grid that locks entity creation to a specified alignment and snap 
increment when Snap is enabled. 

snap resolution  The spacing between points on the snap grid. 
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snapshot  A raster representation of the current view of one’s drawing. 
 
spherical coordinates  Coordinates describing a point in three-dimensional space based 
on its distance from the origin, its angle in the xy plane, and its angle up from the xy plane. 
See also Cartesian coordinates, coordinates, cylindrical coordinates, and polar 
coordinates. 
 

spline  A curve generated along the path of three or more control points. The curve passes 
through the start point and endpoint, but does not necessarily pass through the intermediate 
control points. 
 

status bar  The bar at the bottom of the ZwCAD window that displays information about 
the selected command or tool as well as the cursor coordinates, the name of the current layer, 
mode settings, and other information about drawing settings. 
 
surface model  A three-dimensional model consisting of both edges and the surfaces 
between those edges. See also wireframe model. 
 

surface of revolution  A three-dimensional polygon mesh that approximates the surface 
generated by rotating a two-dimensional profile around an axis. 
 

SVG  An acronym for Scalable Vector Graphic, which is a file format for working with 
interactive graphics, including a Web development language. 
 

system variable  A setting or value that stores operating environment and command 
information (such as the drawing limits or global linetype scale factor). 
 
tabulated surface  A three-dimensional polygon mesh that approximates the surface 
generated by extruding a curve along a vector. See also extrude. 
 

tangent  A line that passes through a single point on a curve. 
 
template  A drawing with preset layers, linetypes, and other settings (and entities) that can 
be used as the basis for creating a new drawing. Templates are saved with a .dwt file extension. 
 
text style  A named, saved collection of format settings that determines the appearance of 
text. 
 
thaw  To redisplay a layer that was frozen. See also freeze. 
 
thickness  An entity’s depth, as measured along its z-axis. The distance an entity is extruded 
above or below its elevation. See also elevation and extrude. 
through point  In creating a parallel entity, a point through which the new entity passes. 
 

tolerance  Dimension text indicating how much the actual dimension of a manufactured 
component can vary from the specified dimension. See also limits tolerance and variance 
tolerance. 
 
tolerance command  A command that creates a feature control frame used in mechanical 
geometric dimensioning and tolerancing. 
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toolbar  A collection of tools arranged on a palette that can be moved and resized 
anywhere on the screen. 
 

torus  A donut-shaped, three-dimensional entity. 
 
transparent command  A command started while another command is already active. 
You can use a command transparently by preceding it with an apostrophe. 
 

true color  Colors defined using 24 bit color. There are more than 16 million true colors 
from which you can choose. 
 
UCS  Acronym for user coordinate system. See user coordinate system. 
 
UCS icon  A user coordinate system icon that shows the orientation of the coordinate axes, the 
location of the coordinate system origin, and the viewing direction relative to the xy plane. 
 
undo  To reverse the effect of previous commands. See also redo. 
 
unit  See drawing unit. 
 
unlock  Free access to layers in a drawing that would be otherwise locked, thus prohibiting 
them from being viewed or edited by another user. 
 

user coordinate system  A Cartesian coordinate system with origins and orientation 
defined by the user. See also World Coordinate System. 
 
variance tolerance  Dimension text in which a plus/minus value is appended to the specified 
dimension to indicate how much the actual dimension of a manufactured component can vary 
from the specified dimension. See also limits tolerance and tolerance. 
 

VBA  Acronym for Visual Basic for Applications, a macro programming language 
embedded in programs that allows the user to customize the program. 
 

vector  A means of describing a displacement using magnitude and orientation. For example, 
you can create a line entity, or move an entity, by specifying an initial point, a direction, and a 
distance. 
 
vertex  The point of intersection of the sides of an angle. The start points or end- points of 
a line or arc segment in a polyline. 
 

vertical dimension  A linear dimension measuring a vertical distance. 
 
view  A representation of a drawing or portion of a drawing from a specific view point in 
three-dimensional space. 
 

viewpoint  A location in three-dimensional space for viewing one’s drafting. 
 
viewport  A window that displays all or a portion of a drawing’s model space entities while in 
model space on the Model tab. See also model space and paper space. 
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viewport configuration  A named arrangement of windows that can be saved and restored. 
 

WCS  Acronym for World Coordinate System. See World Coordinate System. 
 
wedge  A three-dimensional entity that resembles a box divided along one side from one 
corner to the opposite corner; for example, a doorstop or a ramp. 
 

window circle  An entity-selection method that selects entities contained entirely within a 
circular selection window. 
 

window inside  An entity-selection method that selects entities contained entirely within a 
rectangular selection window. 
 

window polygon  An entity selection method that selects entities contained entirely within a 
polygon selection window. 
 

wipeout  An entity that displays with the current background color, so the details behind 
it do not display or print. 
 

wire-frame model  A three-dimensional model consisting of lines and curves that define 
the edges of a three-dimensional entity. See also surface model. 
 

WMF  Acronym for Windows metafile, a format containing vector and color informa- tion to 
render entities. 
 

World Coordinate System  The fixed Cartesian coordinate system used as the basis for 
defining other coordinate systems. See also user coordinate system. 
 
xref  See external reference. 
 

zoom  To increase or decrease the magnification of the display of a drawing. See also pan. 
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